Linux-client 20.04 will einfach nicht werden

Liebe Liste,
beim Versuch, einen eigenen 20.04-Client gemäß der Doku zu erstellen scheitern wir immer am linuxmuster-linuxclient7 setup. Anbei die Bildschirmausgabe. In Zeile 80 tritt eine erstes Problem auf ( Uid could not be found!), dem wir nicht auf die Spur kommen. Am Ende wird die Samba-Gruppe „Domain Users“ nicht gefunden, auf dem Server ist diese aber vorhanden.
Hat jemand dieses Problem schon mal gelöst?
Danke für Eure tolle Unterstützung
Markus

hier die Bildchirmausgabe:

Creating backup of local data...
Removing cache files...
Passwort für global-admin@LINUXMUSTER.XYZ.DE: 
[INFO] #### linuxmuster-linuxclient7 setup ####
[INFO] Cleaning sssd cache.
[INFO] Stopping sssd
[INFO] Deleting old kerberos tickets.
[INFO] Cleaning / leaving all domain joins
[INFO] * linuxmuster.XYZ.DE
[INFO] -> Done!
[INFO] Deleting krb5.keytab if it exists ... 
[INFO] Deleting old CA certificate if it exists ... 
[INFO] * Deleting linuxmuster.XYZ.DE.pem
[INFO] Deleting /etc/linuxmuster-linuxclient7/network.conf if exists ...
[INFO] Trying to discover available domains...
[INFO] Using first discovered domain linuxmuster.XYZ.DE
[INFO] Preparing network configuration
[INFO] Writing new network Configuration
[INFO] Deleting obsolete files
[INFO] * /etc/profile.d/99-linuxmuster.sh
[INFO] * /etc/sudoers.d/linuxmuster
[INFO] * /etc/profile.d/linuxmuster-proxy.sh/etc/bash_completion.d/99-linuxmuster-client-adsso.sh
[INFO] * /etc/profile.d/99-linuxmuster-client-adsso.sh
[INFO] * /etc/sudoers.d/linuxmuster-client-adsso
[INFO] * /usr/sbin/linuxmuster-client-adsso
[INFO] * /usr/sbin/linuxmuster-client-adsso-print-logs
[INFO] * /etc/systemd/system/linuxmuster-client-adsso.service
[INFO] * /home/linuxadmin/.config/autostart/linuxmuster-client-adsso-autostart.desktop
[INFO] * /etc/cups/client.conf
[INFO] * /usr/share/linuxmuster-linuxclient7/templates/linuxmuster-client-adsso.service
[INFO] * /usr/share/linuxmuster-linuxclient7/templates/linuxmuster-client-adsso-autostart.desktop
[INFO] Deleting obsolete directories
[INFO] * /etc/linuxmuster-client
[INFO] * /etc/linuxmuster-client-adsso
[INFO] * /usr/share/linuxmuster-client-adsso
[INFO] Applying all configuration templates:
[INFO] * greeter.dconf-defaults ...
[DEBUG] -> to /etc/gdm3/greeter.dconf-defaults
[INFO] * timesyncd.conf ...
[DEBUG] -> to /etc/systemd/timesyncd.conf
[INFO] * nsswitch.conf ...
[DEBUG] -> to /etc/nsswitch.conf
[INFO] * krb5.conf ...
[DEBUG] -> to /etc/krb5.conf
[INFO] * cifs.spnego.conf ...
[DEBUG] -> to /etc/request-key.d/cifs.spnego.conf
[INFO] * pam_mount.conf.xml ...
[DEBUG] -> to /etc/security/pam_mount.conf.xml
[INFO] * smb.conf ...
[DEBUG] -> to /etc/samba/smb.conf
[INFO] * lightdm.conf ...
[DEBUG] -> to /etc/lightdm/lightdm.conf.d/50-linuxmuster.conf
[INFO] * linuxmuster-linuxclient7.desktop ...
[DEBUG] -> to /home/linuxadmin/.config/autostart/linuxmuster-linuxclient7-autostart.desktop
[INFO] * linuxmuster-linuxclient7.service ...
[DEBUG] -> to /etc/systemd/system/linuxmuster-linuxclient7.service
[INFO] * common-session ...
[DEBUG] -> to /etc/pam.d/common-session
[INFO] Reloading systemctl ... 
[INFO] Updating pam configuration ... 
[INFO] Raloading systctl daemon
[INFO] Enabling services:
[INFO] * linuxmuster-linuxclient7
[INFO] * smbd
[INFO] * nmbd
[INFO] * sssd
[INFO] Restarting services:
[INFO] * smbd
[INFO] * nmbd
[INFO] * systemd-timesyncd

[INFO] #### Joining domain linuxmuster.XYZ.DE ####


[INFO] Successfully pulled kerberos ticket.
[INFO] Now trying to join the Domain:
[INFO] It looks like the domain was joined successfully.
[INFO] Installing server ca certificate ... 
[DEBUG] Calculating mountpoint of //linuxmuster.XYZ.DE/sysvol
[WARNING] Uid could not be found! Continuing anyway!
[DEBUG] Trying to mount //linuxmuster.XYZ.DE/sysvol to /srv/samba/global-admin/sysvol
[DEBUG] * Creating directory...
[DEBUG] * Executing mount.cifs -o file_mode=0700,dir_mode=0700,sec=krb5,nodev,nosuid,mfsymlinks,nobrl,vers=3.0,user=global-admin,domain=LINUXMUSTER.XYZ.DE '//linuxmuster.XYZ.DE/sysvol' '/srv/samba/global-admin/sysvol' 2>/dev/null 
[DEBUG] * Trying to mount...
[DEBUG] * Success!
[INFO] Copying CA certificate from server to client!
[INFO] === Trying to unmount all shares of user global-admin ===
[INFO] Mount basedir /home/global-admin/media does not exist -> nothing to unmount
[INFO] * Trying to unmount /srv/samba/global-admin/sysvol...
[INFO] * Deleting /srv/samba/global-admin/sysvol...
[INFO] Deleting /srv/samba/global-admin...
[INFO] ===> Finished unmounting all shares of user global-admin ===
[INFO] Adjusting sssd.conf
[INFO] Writing new Configuration
[INFO] Restarting sssd
[INFO] Testing if the domain join actually works
[INFO] * Checking if the group "domain users" exists
[ERROR] The "domain users" group does not exists! Users wont be able to log in!
[ERROR] This is sometimes related to /etc/nsswitch.conf.

================================================================================
The setup FAILED, see previous errors!
Plase check your configuration and try again.
================================================================================

Hi Markus,

Ist der Rechner in der devices.csv und stimmt der Hostname?

VG, Dorian

Hallo,

was steht den auf dem Client in der /etc/hosts Datei?
Und was steht auf dem Server in der /etc/hosts Datei?

LG

Holger

Lieber Dorian, lieber Holger,
in den genannten Dateien scheint alles „normal“:

linuxmuster-linuxclient7 status ergibt:

[INFO] #### linuxmuster-linuxclient7 status ####
[INFO] Linuxmuster-linuxclient7 is setup!
[INFO] Testing if domain is joined...
[INFO] Checking joined domains

[INFO] Joined domains:
[INFO] * linuxmuster.XYZgymnasium.de

[INFO] Testing if the domain join actually works
[INFO] * Checking if the group "domain users" exists
[ERROR] The "domain users" group does not exists! Users wont be able to log in!
[ERROR] This is sometimes related to /etc/nsswitch.conf.


================================================================================
This Computer is joined to a domain but it was not possible to authenticate to the domain controller.
There is an error with your domain join!
This happens when you reboot the client without creating an image.
Please try to re-join the domain using 'linuxmuster-linuxclient7 setup'.
================================================================================

Auf dem Client:

nsswitch.conf:

#
# WARNING! All changes to this file will be overwritten by linuxmuster-linuxclient7 setup and upgrade!
#

passwd:         files systemd sss
group:          files systemd sss
shadow:         files sss
gshadow:        files

hosts:          files mdns4_minimal [NOTFOUND=return] dns
networks:       files

protocols:      db files
services:       db files sss
ethers:         db files
rpc:            db files

netgroup:       nis sss
sudoers:        files sss
automount:      sss

hostname:

bgn01.linuxmuster.XYZgymnasium.de

hosts:

127.0.0.1	localhost
127.0.1.1	bgn01 bgn01.linuxmuster.XYZgymnasium.de

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

auf dem Server:

nsswitch.conf:

# modified by linuxmuster-setup at 20210408153016
# /etc/nsswitch.conf
#
# thomas@linuxmuster.net
# 20160902
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat winbind
group:          compat winbind
shadow:         compat winbind
gshadow:        files

hosts:          files dns
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis

hostname:

servus.linuxmuster.XYZgymnasium.de

hosts:

# modified by linuxmuster-prepare at 20210408153016
# /etc/hosts
#
# thomas@linuxmuster.net
# 20160902
#

127.0.0.1       localhost
10.64.1.1        servus.linuxmuster.XYZgymnasium.de        servus

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Der Client ist mit Ubuntu 20.04 mate installiert, Displaymanager ist gdm3. Im übrigen bekommen wir mit dem Ubuntu2004 Muster-Image das gleiche Ergebnis.
Der Teufel ist ein Eichhörnchen…
Viele Grüße
markus

Hmm … eigentlich sieht alles ganz gut aus …
Das Problem scheint zu sein, dass sssd nicht richtig die Gruppen kontroliert.
Ist es ein frischer client?

Vg, Dorian

Hallo,

erzähl doch mal ein wenig zum Server.
Wurde der frisch aufgesetzt? (linuxmuster-setup gemacht?)
Wurde schon mal
sophomorix-school --gpo-create default-school
ausgeführt?
Wie sieht den die Zeile des Clients in der /etc/linuxmuster/sophomorix/default-school/devices.csv aus?
Gibt es Clients die an der Domäne funktionieren (also mit anderen Betriebsystemen).

LG

Holger

Liebe ListenGurus,
mieses Wetter, viel Zeit zum Rechnerknechten.
Client und Server sind „frisch“, linuxmuster-setup ist gelaufen.
Den Befehl „sophomorix-school --gpo-create default-school“ haben wir gerade probiert, läuft ohne Fehler durch, keine Veränderung.
Der Eintrag in der devices.csv lautet:

r88;bgn01;bu2004;FC:08:4A:D7:37:51;10.64.88.1;;;;classroom-teachercomputer;;1;;;;;

Ein sophomorix-check bring dies:

Command line::
Hmmh. do not know what to do with option info
Option json is a modifier option
Option verbose is a modifier option
* forcing info mode
Option combinations successfully checked
OK: SophomorixSchemaVersion 1 matches required Version 1
#### Reading /usr/share/sophomorix/devel/sophomorix.ini                       ####
#### Distro-check: Ubuntu 18.04 is OK                                         ####
#### Reading /etc/samba/smb.conf                                              ####
#### Reading /usr/lib/linuxmuster-webui/etc/default-ui-permissions.ini        ####
#### Parsing: net conf list                                                   ####
#### Asking domain passwordsettings from samba                                ####
#### Reading /etc/linuxmuster/sophomorix/sophomorix.conf                      ####
#### Reading /etc/linuxmuster/sophomorix/default-school/school.conf           ####
#### 0 ERRORS, 0 WARNINGS -> let's go                                         ####
#### Creating lock in /var/lib/sophomorix/lock/sophomorix.lock                ####
#### /usr/sbin/sophomorix-check started ...                                   ####
#### Cleaning up last check                                                   ####
Encoding extrastudents.csv: UTF8 (ENCODING=UTF8,*_FORCE=FALSE, *_CHECKED=UTF8)
Encoding students.csv: UTF8 (ENCODING=UTF8,*_FORCE=FALSE, *_CHECKED=UTF8)
Encoding teachers.csv: UTF8 (ENCODING=UTF8,*_FORCE=FALSE, *_CHECKED=UTF8)
#### Reading injected lines ...                                               ####
#### 0 ERRORS, 0 WARNINGS -> let's go                                         ####
#### Searching AD for users ...                                               ####
#### Query AD (begin)                                                         ####
#### Query AD (end)                                                           ####

#### ### School default-school: Matching lines in files to users in AD ...    ####
#### unidMATCH: 4 CHECKED in default-school, MATCH: 0, NOMATCH: 4, NOunid: 0  ####
#### exactMATCH: 4 CHECKED in default-school, MATCH: 3, NOMATCH: 1            ####
#### approxMATCH: 1 CHECKED in default-school, MATCH: 0                       ####
#### approxMATCH: 1 CHECKED in default-school, MATCH: 0                       ####
#### approxMATCH: 1 CHECKED in default-school, MATCH: 0                       ####
#### approxMATCH: 1 CHECKED in default-school, MATCH: 0                       ####
#### ## School default-school ... Done!                                       ####
#### Removing lock in /var/lib/sophomorix/lock/sophomorix.lock                ####
#### /usr/sbin/sophomorix-check terminated regularly                          ####
Calling console printout
LOG       : /usr/sbin/sophomorix-check terminated regularly                   
##### Overview of what can be done:
     1 users can be added in sophomorix.add                              
     0 users can be updated in sophomorix.update                         
     0 users can be killed in sophomorix.kill                            
     4 users are not to be changed in sophomorix.nochange                
     0 users with errors in sophomorix.error          

Auch wenn ich mit Samba noch auf Kriegsfuß stehe, wundere ich mich doch über den Missmatch von Usern in sophomorix-Files und der AD bei unidMATCHH und exactMATCH. Verstehe ich nicht, muss auch nichts zu bedeuten haben.
@Holger: Was meinst Du mit „anderem Betriebssystem“? :innocent: Wir haben aus Verzweiflung einen Rechner mit Win10-Krampf drangehängt, um das Samba-Geraffel mal in einer Gui anzuschauen. Sieht alles so aus, wie in der Doku.
Mit der Windows-Möhre können wir uns an der AD anmelden und haben Zugriff auf die Netzlaufwerke, mit den Linux-Clients mit lokaler Anmeldung als linuxadmin ist nur Zugriff auf Netzlaufwerke, aber keine Anmeldung an der AD möglich.
So nebenbei: der lokal (!) angemeldete linuxadmin kann die Dateien auf allen teachers-Verzeichnissen lesen und schreiben.
So langsam denken wir daran, den Server nochmal komplett neu zu machen. Das Wetter soll ja mies bleiben…
Viele Grüße
Markus

Hallo!

Vergleiche doch mal bitte dir Uhrzeiten zwischen Server und deinem Linuxclient.

Beste Grüße

Thorsten

Hi,

Noch was:
Gibts auffällige logs im systemctl status sssd?

VG, Dorian

Liebe Mitdenker,
„date“ unterscheidet sich auf dem Server und dem Client um wenige Sekunden.
@dorian: was wäre denn auffällig? anbei ein Bildschirmschuss:

● sssd.service - System Security Services Daemon
     Loaded: loaded (/lib/systemd/system/sssd.service; enabled; vendor preset: enabled)
    Drop-In: /etc/systemd/system/sssd.service.d
             └─override.conf
     Active: active (running) since Wed 2021-08-04 13:30:04 CEST; 59s ago
   Main PID: 17823 (sssd)
      Tasks: 4 (limit: 9276)
     Memory: 42.5M
     CGroup: /system.slice/sssd.service
             ├─17823 /usr/sbin/sssd -i --logger=files
             ├─17847 /usr/libexec/sssd/sssd_be --domain linuxmuster.xyzgymnasium.de --uid 0 --gid 0 --logger=files
             ├─17848 /usr/libexec/sssd/sssd_nss --uid 0 --gid 0 --logger=files
             └─17849 /usr/libexec/sssd/sssd_pam --uid 0 --gid 0 --logger=files

Aug 04 13:30:03 bgn01.linuxmuster.xyzgymnasium.de systemd[1]: Starting System Security Services Daemon...
Aug 04 13:30:03 bgn01.linuxmuster.xyzgymnasium.de sssd[17823]: Starting up
Aug 04 13:30:03 bgn01.linuxmuster.xyzgymnasium.de sssd_be[17847]: Starting up
Aug 04 13:30:03 bgn01.linuxmuster.xyzgymnasium.de sssd_nss[17848]: Starting up
Aug 04 13:30:03 bgn01.linuxmuster.xyzgymnasium.de sssd_pam[17849]: Starting up
Aug 04 13:30:04 bgn01.linuxmuster.xyzgymnasium.de systemd[1]: Started System Security Services Daemon.

Frustrierend ist, dass alles augenscheinlich korrekt ist, es aber dennoch nicht funzt. Eine prächtige Fehlermeldung ist schon was Schönes…
VG
markus

Apropos Fehlermeldung: auf dem Client bringt ein „sudo -i“ folgende Ausgabe

linuxadmin@bgn01:~$ sudo -i
[sudo] Passwort für linuxadmin: 
(pam_mount.c:365): pam_mount 2.16: entering auth stage
[INFO] ====== onLogin started ======
id: »BGN01$“: Einen solchen Benutzer gibt es nicht
[WARNING] Exception when querying groups of user BGN01$, it probaply does not exist
[INFO] ==== This Client is not joined to any domain, exiting ====
[INFO] ======> onLogin end ====
root@bgn01:~# 

Das erscheint wir jedoch normal, da der Client ja nicht an der AD angemeldet ist. Oder liege ich da falsch?
VG markus

Hallo,

… wenn das alles so seltsam ist, dann denken wir doch mal in eine andere Richtung, zum Beispiel: Sonderzeichen im global-admin Passwort.
Das wird ja für den DOmainjoin verwendet: wenn da Server und Client eine andere Ansicht über das Sonderzeichen haben, dann kann das schon mal lustig werden.

Also mal das global admin Passwort ändern am Server.
Dann CLient booten und die /etc/krb5key.tab löschen.
Dann nochmal
linuxmuster-linuxclient7 --setup aufrufen.
Danach rebooten und Image erstellen: vor der Imageerstellung die
/srv/linbo/.cloop.macct Datei löschenoder wegbewegen.

LG

Hogler

Lieber Holger,
danke für Deinen „Ferienkurs“. Wir haben nur Groß- und Kleinbuchstaben und Zahlen im PW des global-admin. Mit „Passwort ändern am Server“ meinst Du in der Schulkonsole - auf dem Server gibt es diesen Benutzer nicht. Trotztdem probiert: no success!
Eine .macct - datei haben wir weder für das eigene noch für das Muster-Image. Ich dachte, die wird erst mit der Aufnahme in die Domain angelegt - woher soll er sonst die credentials bekommen? Bisher ist ein join in die AD aber nicht gelungen.
In der Ausgabe von „linuxmuster-linuxclient7 setup“ kommt immer diese Warnung:

[WARNING] Uid could not be found! Continuing anyway!

Welche Uid sucht er denn da und findet sie nicht?
Aber wir machen das wie der skript: Continuing anyway!
LG markus

Hallo Markus,

bitte versuch mal die Domänenaufnahme mit dem default cloop in deinem Netz:

LG

Holger

Die vom global-admin. Aber die kann er an der Stelle gar nicht finden, die Meldung ist nicht relevant.
Kannst du bitte den Inhalt von der /etc/sssd/sssd.conf posten?

VG, Dorian

Hallo!
Ich hale hier mal fest, was ich an obigem Image noch verändert habe:

erstmal alles machen, was in README steht

zudem:

  • einen passenden key nach /srv/linbo/linuxmuster-client/ubuntu2004/common/root/.ssh/authorized-keys legen
  • /srv/linbo/linuxmuster-client/ubuntu2004/common/etc/linuxmuster-client angepasst
  • /srv/linbo/linuxmuster-client/ubuntu2004/common/etc/ssh/sshd_config anpassen (die server-IP)

meine persönlichen Änderungen:

  • sed -i s#//#//10.16.1.7:3142/# /etc/apt/sources.list #Apt-Cacher eintragen
  • ich musste außerdem noch
sudo apt -o Acquire::AllowInsecureRepositories=true -o Acquire::AllowDowngradeToInsecureRepositories=true update

ausführen, damit apt update geht, das suse-Repo hab ich nicht zum Laufen gekriegt und auskommentiert.

  • sudo apt install net-tools emacs parole xine-ui qreator geeqie ttf-mscorefonts-installer texlive-music texlive-pstricks texlive-latex-extra libdvd-pkg libdvdread7 policykit-1 policykit-1-gnome libavcodec-extra pinta keepassxc
  • visudo und dann ALL ALL=(ALL:ALL) ALL
  • Veracrypt installieren (deb)
  • greenfoot, bluej, scenebuilder, filius neueste versionen (deb)
  • Dateimanager Einstellugnen: ansicht: Listenansicht, Papierkorb alle 3
    Einstellungen → Datenschutz: Dateichronik aus, Papierkorb leeren, Bildschirmschoner anpassen
  • LO unter Laden/Speichern->Allgemein die Option „Druckeinstellungen mit dem Dokument laden“ deaktivieren
  • LO Online-Update aus (ist gar nicht installiert…)
  • ggf hier schauen für alternative Toolbars: https://libreofficehelp.com/change-libreoffice-default-look-and-feel/
  • cups browse abschalten (aus: Automatische Druckerinstallation unter 20.04 abschalten - #2 von Sven):
    in /etc/avahi/avahi-daemon.conf jeweils use-ipv4=no und use-ipv6=no und dann service avahi-daemon restart
  • Tastenkürzel (Terminal, Global) einrichten
  • firefox standardsuchmaschine duckduckgo o.ä (war schon eingesetellt) und letzte Sitzung wiederherstellen
  • Neues linuxadmin-Passwort (wird aber von irgendetwas wieder auf Muster! zurückgesetzt, muss ich noch prüfen)
  • evtl /etc/cups/client.conf mit ServerName 10.16.1.1 erstellen
  • /Downloads und /Dokuments auf 777-Rechte gesetzt, könnte man aber auch so machen:
for dir in Dokumente Musik Bilder Videos Downloads
do
  rmdir $HOME/$dir 2> /dev/null
  mkdir "$SERVERHOME/$dir" 2> /dev/null
  ln -sfn "$SERVERHOME/$dir" "$HOME/$dir"
done
  • tipp10, Master PDF Editor (Update aus)

  • Lesezeichen Schulkonsole, Wiki, OwnCloud, Moodle, MRBS (ohne Datum!!!), Druckauftröge, Firewall, BelWü-Mail
    Proxy-Einstellungen: localhost, 127.0.0.1, server, 10.16.0.0/16, 172.16.0.0/16, owncloud.eichendorff-gymnasium.de

  • pdfjam

  • Ubuntu Fehlerberichte weg: /etc/default/apport den Wert der Variablen enabled von 1 auf 0 setzen. (odi)
    Bildschirm sprerren aus, zeitgeist (Datenschutz/Privatsphäre) prüfen.
    FlashPrint 4.4.0 (https://www.flashforge.com/download-center)

  • shutdown aktivieren, Post siehe Ubuntu automatisch herunterfahren - #14 von maxEG

  • „usersettings.conf“ Programm-Einstellungen verlinken, dazu das hier editieren:
    /var/lib/samba/sysvol/lmn.eichendorff-gymnasium.de/scripts/default-school/custom/linux/logon.sh

LG
Max

Super Liste, Max! Kann ich gut gebrauchen.
In dem Zsh. hätte ich noch zwei Fragen

  1. Bei mir macht LO nach jedem Druckauftrag, der Drucker hat brav und flott gedruckt, eine Denkpause (20-30s). Weiß jemand, wie ich ihm das abgewöhnen kann? An der Einstellung „Druckeinstellungen mit dem Dokument laden“ liegts wohl nicht…
  2. Wenn man den Login-Namen mit einem Großbuchstaben beginnt, dann werden die Shares und Drucker nicht gemountet. Dazu gibts bestimmt auch ein Script, der den Username in lower case ändert, nachdem man ihn eingegeben hat…?!
    Ich haben den Client von Grundauf neu erstellt, nicht Holgers Vorlage verwendet.

LG
Daniel

Hallo zusammen,

wenn ich mir die Liste von Max anschaue, daran denke, was in Holgers (oder Dominiks) Client schon an Arbeit drin steckt, komme ich immer mehr zu dem Schluss, dass von linuxmuster.net ganz offiziell ein default-cloop mit den Basisanwendungen angeboten werden sollte.

  • Durch eine einheitliche Grundlage ließe sich viel Arbeit vermeiden.

  • Wahrscheinlich ließen sich Fehler schneller analysieren und beheben.

  • Die Diskussion um zusätzliche Erweiterungen, Programme, Features wäre strukturierter.

… um nur einige Vorteile zu nennen.

Viele Grüße

Wilfried

2 Like

Hi Max,

Danke für deine Ausführungen :smiley:

Ein paar Fragen/Hinweise hab ich aber noch:

Was genau hast du hier angepasst? Und warum?

Das ist eigentlich nicht vorgesehen, Drucker sollten per GPO installiert werden.

Kleiner Hinweis hierzu:
Mit sudo rechten kann man u.a. auf die Server shares von anderen angemeldeten Benutzern zugreifen.

Was genu fügst du in die logon.sh ein? Würde sicher auch Anderen helfen.

VG, Dorian

Hi Wilfried,

Die Diskussion zieht sich jetzt schon sehr lange. Und wie bisher immer ist meine Antwort:
Wir haben im Moment niemanden, der die Ressourcen dazu hat, sowas zu entwickeln und zu betreuen.
Wenn du das machen magst, kannst du das gerne tun.

Und genau weil es keinen Maintainer für sowas gibt, haben wir eben den alternativen Weg dokumentiert, weil der für uns keine zusätzliche Arbeit bedeutet. Und das wird auch so bleiben, esseidenn jemand „neues“ nimmt sich der Sache an.

VG, Dorian