Automatisches Einbinden des Home-Verzeichnisses

nextcloud

#1

Halo zusammen,

in unserem Wiki steht noch, dass jeder Nutzer sein Home-Verzeichnis selbst einbinden muss (http://www.linuxmuster.net/wiki/anwenderwiki:owncloud:owncloud5#einbinden_des_home_funktioniert_nun). Dies lässt sich vom Admin mittlerweile einstellen. Unter Einstellung -> Verwaltung -> Externe Speicher können für alle Nutzer externe Speicher angelegt werden. Die Zugangsdaten werden von der Anmeldung in Nextcloud übernommen.


Für das Home-Verzeichnis des Nutzers kann die Variable $user verwendet werden. Zwar werden fehlerhafte Einstellungen durch das rote Kästchen angezeigt, die Konfiguration funktioniert aber. Jeder Nutzer, der sich anmeldet, hat damit automatisch seine Verzeichnisse eingebunden.

Viele Grüße
Dominik


#2

Hallo Dominik,

… verlockend.
Wäre schon sehr schön, aber: die nextcloud muss dafür in Grün stehen …
oder die Firewall den sambaport an den Server weiterleiten…

Ich teste das mal mit meinen in Rot stehenden Nextcloud Installationen.
Port wird dann nur für die IP freigegeben.

LG

Holger


#3

Hallo Dominik,

vielen Dank für den Tipp. Das werde ich direkt ausprobieren - nur der Port muss noch von BelWue freigeschalten werden, da die Nextcloud bei uns extern gehostet ist. Wenn das wie gewünscht klappt, wäre das für unsere Nextcloud genial!
viele Grüße
Manuel


#4

Hallo Manuel,

wir haben unsere Nextcloud auch bei Belwue.
Leider installiert Belwue SMB / CIFS nicht…
Daher ist ein Einbinden der Homes leider nicht möglich.
Falls du doch eine Möglichkeit findest, wäre ich sehr daran interessiert ;-).
Viele Grüße
Jürgen


#5

Hallo,

wir haben unsere Nextcloud auch bei Belwue.
Leider installiert Belwue SMB / CIFS nicht…
Daher ist ein Einbinden der Homes leider nicht möglich.
Falls du doch eine Möglichkeit findest, wäre ich sehr daran interessiert
;-).

… wie soll das gehen?
Ein SMB/CIFS Share durch das Internet hindurch mounten?
Seid ihr sicher, dass das eine gute Idee ist?

Wie macht die Nextcloud das den?

LG

Holger


#6

Hej,

Die Idee ist nicht schlechter, als deinen Samba Port nach rot mit IP Beschränkung aufzumachen - genau genommen isses dasselbe. Je nach Konfiguration der Firewall kann man das wohl schon riskieren.

Nextcloud benötigt aber natürlich die Samba Client Tools auf seinem Server, um auf Samba Freigaben zugreifen zu könne, und wenn die beim Belwue Server nicht installiert sind, guckst du halt in die Röhre.

Aber hej, ihr dürft das nicht so komfortabel machen, sonst will die Ella ja gar niemand mehr benutzen mit ihrem “Hinsurfen ist sicher Konzept”. :joy::joy:

VG

Frank


#7

Hallo Jürgen,
mit der Portfreischaltung bei BelWue hatte ich mich wohl falsch ausgedrückt. Da unser Schulinternet über BelWue läuft muss der Port von BelWue auf dem Modem/BelWue-Router freigegeben werden, damit ich da von außen dran kommen.
Die Nextcloud läuft auf einem Server, der unter meiner vollen Kontrolle ist. Da konnte ich also dem Dienst leicht nachinstallieren.
viele Grüße
Manuel


#9

Hallo zusammen,

das Freigeben der SMB-Freigabe nach außen habe ich eigentlich in der Dokumentation 6.2.0 gelesen:

http://docs.linuxmuster.net/de/basiskurs/basiskurs/security-remote-access.html#freigegebene-dienste-nutzen

Es muss wohl der Port 139 sein (und nicht, wie von mir bisher gedacht, der Port 445).

Allerdings würde ich den Port aus Sicherheitsgründen nur für die Nextcloud-IP freigeben. So wie den LDAP-Port auch.

Ich warte noch auf die Portfreischaltung vol BelWue auf dem Modem/Router und dann werde ich berichten.

viele Grüße
Manuel


#10

Bei mir funktioniert das leider nur mit den Tauschverzeichnissen :frowning:
Bei “Home” kommt als fehlermeldung immer: “Es ist ein Fehler mit folgender Meldung aufgetreten:Leere Antwort vom Server erhalten.”

Gibt es irgendwo log-files, die mehr infos liefern?

Grüßle

Markus


#11

Hai,

Man kann in der config.php die NC nndrn debuggen Modus versetzen (Option musste mal im Handbuch gucken) und dann loggt die.NC standartmäßig ziemlich ausführlich nach nextcloud.log oder so - im Datenverzeichnis.

VG
Frank

Nachtrag: Linkservice…

https://docs.nextcloud.com/server/13/developer_manual/general/debugging.html#


#12

Hallo Frank!

Danke für die schnelle Hilfe, hat aber leider nichts gebracht.

Ich logfile taucht folgende Pasage auf:
“Couldn’t stat
smb://10.16.1.1/4417050c-c798-1033-949e-557b3da2045c/: Does not
exist at
/var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/NativeState.php#168”

Bei einem anderen Benutzer steht statt 4417050c… etwas anderes.

Ist das eine samba-ID? Hab ich bei der LDAP-Einbindung was verbuchselt??

Die Tauchverzeichnisse gehen problemlos, auch wenn jeder Benutzer seinen
SMB-Speicher selber einrichtet geht’s.

Für Hilfe wäre ich sehr dankbar.

Grüßle

Markus


#13

Hallo Markus,

das Problem hatte ich zu Beginn auch. Es liegt daran, dass nextcloud die Benutzer nicht mit ihren Nutzernamen abspeichert, sondern mit diesen kryptischen Namen (4417050c-c798-1033-949e-557b3da2045c). Geh mal auf die Benutzerübersicht in Nextcloud als Admin. Da solltest du es sehen.

Um es zu fixen, gehe in den LDAP-Bereich in der Admin-Verwaltung und passe die Reiter Fortgeschritten und Experte folgendermaßen an:


Unter Umständen musst du zunächst die LDAP-Benutzernamenzuordnun über den Button löschen.

Viele Grüße
Dominik


#14

Hallo Dominic,

Unter Umständen musst du zunächst die LDAP-Benutzernamenzuordnun über
den Button löschen.

meine “frühen” NUtzer haben auch noch die Benutzerkennung aus owncloud
und nicht den cn.

Wenn ich die Benutzerkennung lösche (wovor ich bisher zurückgeschreckt
bin), verlieren die user dann ihre Datenanbindung in der nextcloud?
Also erscheinen sie in der nextcloud als neue Nutzer?
Oder bekommt die nextcloud das hin: dass sie die neue Benutzerkennung
für die alten Daten verwendet?

LG

Holger


#15

Hallo Holger,

habe ich bisher nicht ausprobiert. Aber unter https://ocloud.de/doc/admin/lang/de/configuration_user/user_auth_ldap.html ist zu lesen, dass davon in Produktivumgebungen dringend abgeraten wird.

Viele Grüße
Dominik


#16

Hallo Dominik,

habe ich bisher nicht ausprobiert. Aber unter
https://ocloud.de/doc/admin/lang/de/configuration_user/user_auth_ldap.html
ist zu lesen, dass davon in Produktivumgebungen dringend abgeraten wird.

… ja: ich dachte auch, dass ich da mal sowas gelesen hatte …
normalerweise bin ich ja eher unerschrocken, es mußte also einen
deutlichen Hinweis auf zu erwartende Probleme geben …

Somit sei dies eine Warnung an Markus.

LG

Holger


#17

Hat funktioniert! Super! DANKE!!!


#18

Hallo,

und was ist mit den Daten und Shares der bereits angelegten Nutzer passiert? Was genau hast du gemacht? Einstellungen angepasst und Zuordnung gelöscht, nur die Einstellungen angepasst?

VG

Frank


#19

Danke für die Warnung, aber der nextcloud-server läuft im Moment nur zum testen - noch keine “Produktivumgebung”
Ich werde nextcloud jetzt nochmal neu aufspielen und dann von Anfang an alles so einstellen wie von Dominik beschrieben.

Hab aber noch zwei andere (Luxux-)Probleme:

  1. In nextcloud tauchen unter Benutzer auch alle PCs auf (Examaccount…) und noch viel mehr. Kann man das mit LDAP filtern, so dass nur Lehrer und Schüler Benutzer sind?
  2. Die Nutzer sollen auf dem Nextcloud-Server so gut wie nichts speichern können. Sie haben ja Zugriff auf Home_auf_Server und da ist genug Platz. Kann man ein quota für alle Benutzer setzen? Ich seh da nur die Möglichkeit für jeden einzelnen Benutzer, aber das wird viel Arbeit :slight_smile:

Grüßle


#20

Wir binden die meisten Shares über sftp ein. Auf diese Weise spart man sich das Bauchgrummeln smb nach rot zu öffnen.

Das war aus irgendwelchen Gründen für Tauschen_Projekte nicht so komfortabel. Daher habe ich letztlich die VM mit einem NIC in Grün und mit einem anderen in Rot gehängt. Doch wieder Bauchgrummeln.
Gruß
Frithjof


#21

Hallo Markus,
so sehen unsere LDAP-Server-Einstellungen aus. Ich habe die Benutzer zusätzlich auf die Lehrer beschränkt (zweites Bild), aber davor wurden nur Lehrer und Schüler angezeigt. Vielleicht liegt es an “ou=accounts”?
viele Grüße
Manuel