Nextcloud: Automatisches Einbinden des Home-Verzeichnisses (lmn v7)

Hallo Dominik
Deine hier gepostete Lösung ist schon älter – und sie funktioniert hier nicht mit v7. Ich habe Nextcloud 17.0.3 installiert und habe ebenfalls das Problem, dass die Freigaben zwar funktionieren, doch der Zugriff auf „Home_auf_Server“ nur mit der Meldung

Fehler beim Einbinden des externen Speichers Es ist ein Fehler mit folgender Meldung aufgetreten:Leere Antwort vom Server erhalten. Do you want to review mount point config in admin settings page?

quittiert wird, wähend alle anderen Freigaben wie „Tausch_Kollegium“ oder „Meine_Klassen“ ohne Probleme funktionieren.

Unter Nextcloud habe ich nachgesehen: Mein Verzeichnis hat dort keinen kryptischen Namen sondern lautet genauso wie mein Login. Wenn ich die von dir genannten Einträge unter Experte eintrage, kann ich mich als LDAP-User gar nicht mehr anmelden.
Vermutlich hat sich in der Zwischenzeit wieder etwas geändert – nur was?
Schönen Gruß,
Michael

Noch ein Tipp am Ende: Man kann die komplette LDAP-Konfiguration der Nextcloud auch so erhalten:

cd /var/www/html/nextcloud/
sudo -u www-data /usr/bin/php occ ldap:show-config

… nochmal ein Nachtrag bzw eine Idee zu der Frage:

Hier kann man nachlesen, wie die Einstellungen unter Experte gedacht sind.
https://docs.nextcloud.com/server/stable/admin_manual/configuration_user/user_auth_ldap.html?highlight=ldap#expert-settings

Da steht auch Changes will affect only newly mapped LDAP users.

Nun habe ich mich aber bereits mit meinem Login angemeldet und das User-Verzeichnis für meinen Login wurde unter .../nextclouddata/<username> auch bereits angelegt. Es reicht vermutlich nicht aus, dieses user-Verzeichnis einfach zu löschen – stattdessen müssen vermutlich auch alle Einträge in der nextcloud-DB gelöscht werden, um alle Spuren des „falschen Logins“ zu tilgen??? Hat das mal jemand gemacht?

Ich nehme an, dass das nachträgliche Ändern der Optionen unter Experte auch erklären dürfte, warum man sich dann gar nicht mehr anmelden kann??

Ach ja: Es geht übrigens weiterhin die ganze Zeit um v7 bei meiner Frage. Der Anfang dieses Threads ist alt und der bezog sich nur auf v6.x …

Hallo Michael!

Darum habe ich das mal in einen neuen Thread verschoben.

Beste Grüße

Thorsten

Hallo Michael,
bist Du weitergekommen mit der Einbindung der Home und Tauschverzeichnisse in die Nextcloud? Ich hätte daran großes Interesse. Wir haben aktuell gar keine Möglichkeit, von außen an die „richtigen“ Homeverzeichnisse ranzukommen, es geht bei uns auch um V7.

Gruß, Andreas

Hallo Andreas.
Leider ist es weiterhin so, dass die Tausch_Ordner problemlos eingebunden werden, wohingegen es bei Home_auf_Server Probleme gibt.
Hier sieht das so aus:
Direkt nach dem Anmelden erscheint:
Screenshot_20200225_081357

Kurz darauf wird Home_auf_Server zwar hinzugefügt – bleibt aber „rot“ hinterlegt:
Screenshot_20200225_081417

Wenn man den Ordner anklickt, erscheint:

Warum es bei den anderen Ordner problemlos klappt aber hier nicht, weiß ich bisher nicht.
Unsere v7 läuft aber auch noch nicht produktiv…
Vielleicht hat jemand anderes einen guten Tipp?

Schöne Grüße,
Michael

Hallo Michael,

das Einbinden der Homes klappt bei uns. Welche Settings brauchst Du, dann schau ich bei uns mal nach und schicke Dir die Einstellungen.

LG,
Jochen

Vermutlich alles unter „Externe Speicher“??
Sooo falsch kann das eigentlich nicht sein, was da bisher steht:


Ich habe beides ausprobiert: SFTP und SMB/CIFS – beides klappt nicht.

Hallo Michael,

wir haben da SMB / CIFS anstatt SFTP:

LG,
Jochen

Hi Jochen.
Steht bei dir „Anmeldedaten in Datenbank speichern“ oder „… in Sitzung speichern“?
(Wobei ich nicht glaube, dass es daran scheitert. Hier sind zudem die Icons vorne alle rot – bei dir immerhin gelb)
Schönen Gruß,
Michael

Hallo Michael,

hier ist „Anmeldedaten in Datenbank speichern“ eingetragen.

LG,
Jochen

@jochen : Vielen Dank. Nur, weil ich selbst auch immer wieder mal was verwechsele - ihr verwendet Linuxmuster 7?

Hallo @andreas72,

ja, wir verwenden lmn v7.

LG,
Jochen

1 Like

Hallo Jochen – ich habe es so eingestellt wie bei dir aber es bleibt dabei. Alle anderen Shares funktionieren; nur Home_auf_Server nicht. Ich vermute weiterhin, dass es mit o.g. Link zusammenhängt: Changes will affect only newly mapped LDAP users. ?!

Könntest Du das nicht leicht ausprobieren , indem Du einen neuen Nutzer auf dem Schulserver anlegst und dich mit diesem dann neu an der Nextcloud anmeldest?

Bei uns war das anfangs das Problem. Beim Einbinden des Homes wird ja einfach $user mit dem Benutzernamen ersetzt. Wenn dieser Benutzername der kryptische nextcloud-interne Name ist, kann das nicht funktionieren.

Wir nutzen 6.2 musste man in den Experteneinstellungen von Nextcloud Attribut für interne Benutzernamen: auf uid setzen. Bei der lmn7 mag es anders sein.

Da bei uns noch nicht viel passiert war, war es unkritisch, danach unten LDAP-Benutzernamenzuordnung löschen zu wählen.

Dann lief alles wie gewünscht.

Hallo Thomas,

Ja, daran habe ich auch schon gedacht – das ist aber nicht der Fall. Ich habe auf dem Nextcloud-Server nachgesehen. Unter nextclouddata finde ich einen Ordner, der genauso heißt wie mein Login.

Auch das habe ich schon gemacht … hat das Problem ebenfalls nicht gelöst. Ich muss es nochmal als „neuer“ User versuchen — wobei ich den Zugang natürlich auch gerne für meinen eigenen Login nutzen möchte…
Schönen Gruß,
Michael

Hast Du mal direkt in die Datenbank geschaut - ich bin nicht sicher, ob die Daten unter nextclouddata wirklich die „internen Nutzernamen“ wiederspiegeln.

Da könntest du Recht haben …

mysql -u root -p
show databases;
use nextcloud;
show tables;
SELECT * FROM `oc_ldap_user_mapping`;
oder auch begrenzt: 
SELECT * FROM `oc_ldap_user_mapping` limit 10;

zeigt es an…

Die Tabelle ist so aufgebaut:

+---------------------------------------------------------------------------------------------------+--------------------------------------+--------------------------------------+
| ldap_dn                                                                                           | owncloud_name                        | directory_uuid                       |
+-----------------------------------------------------------------------------------------+--------------------------------------+------------------------------------------------+
| cn=<login>,ou=10a,ou=students,ou=default-school,ou=schools,dc=linuxmuster,dc=meine-domain,dc=de   | 0037D595-9EEF-48E4-2ABCD-2398B9315B | 0037D595-9EEF-48E4-2ABCD-2398B9315B   |

In der Tabelle oc_users hingegen steht nur der Admin aber kein LDAP-User. Aber in der Tabelle oc_accounts könnte auch noch etwas stehen:

| uid                                                      | data 
 ^^^^ Da steht nicht der Kurzname!                           bla bla