Clients melden sich Offline / dhcpretry

Ich versuche gerade relativ aktuelle Lenovo-ThinkCentre mit
Linbo ins Netz einzubinden. Leider bekomme ich beim Start
übers Netz nach einem “erfolgreichen” Linbo-Start immer
die Meldung, dass der Client Offline ist.
In der Vergngenheit war das über den dhcpretry=10 Parameter in
der Start.conf.xxx zu lösen - bei der neuen Version (6.2 + Linbo 2.3)
geht das anscheinend nicht mehr. Es wird ja anscheinend auch keine
pxelinux.cfg/xxx mehr erstellt, wenn man einen Workstation Import macht.
Seltsamerweise schafft es der eine oder andere Client von Zeit zu Zeit,
dass er sich nach dem Boot online präsentiert.
Wo kann man den Parameter jetzt einstellen - falls es an meinem evtl.
zu langsamen Netz im Haus liegt?

Hallo Wolfgang,

https://www.linuxmuster.net/wiki/dokumentation:handbuch:linbo:configuration.pxeboot

Ich meine es muss jetzt in diese Datei eingetragen werden. Danach ist ein
import_workstations nötig.

Gruß

Alois

Am 30. Dezember 2016 um 11:35 schrieb Wolfgang Höfer <
noreply@linuxmuster.net>:

hallo wolfgang und alois,
wenn ich richtig geschaut habe, zeigt der link von alois auf die alte pxelinux.cfg - beschreibung.
die beschreibung der hardwaregruppen liegt jetzt in /var/linbo/boot/grub.
auch hier kann _managed by linuxmuster.net _ entfernt werden, wenn man das selber managen möchte.

vg wolfgang

p.s. schön in der neuen wohnstube

Hallo,

https://www.linuxmuster.net/wiki/dokumentation:handbuch:linbo:configuration.pxeboot

Ich meine es muss jetzt in diese Datei eingetragen werden. Danach ist ein
import_workstations nötig.

das bezieht sich noch immer auf linbo <2.3, da es um die pxelinux.cfg
geht, die in linbo 2.3 nicht mehr verwendet wird.
Die korrekte Stelle ist die start.conf. im Kopf
KernelOptions = dhcpretry=10
ein import_workstations bewegt den Eintrag in die richtige Datei:
/var/linbo/boot/<gruppe>.cfg

… solange in dieser Datei niemand die Zeile

## Managed by linuxmuster

gelöscht hat.

VIele Grüße

Holger

1 Like

Danke, werde ich testen, wenn ich wieder in die Schule komme …
Es wäre fein, wenn Linbo auch das "nach 18:00 alle 30min reboot"
Feature hätte, dann könnte man auch “offline-Clients” eine weitere Chance
geben, ohne jedes Mal in die Schule fahren zu müssen :slight_smile:

Viele Grüße und noch ein gutes 2017 an alle

Wolfgang

Hier nochmal explizit in der Doku:

http://docs.linuxmuster.net/de/latest/release-information/linbo.html#boot-konfiguration-mit-grub

VG, Tobias

Hatte auch das Offline-Problem.
Nun läufts - Vielen Dank auch von meiner Seite.

sorry, der nächste neue PC hat doch wieder das Problem.
Wir wissen also immer noch nicht woran es nun liegt.
vg matthias

Hallo Matthias,

Läuft, während der Client bootet vielleicht eine Übertragung des Image mit Multicast? Wenn das der Fall ist stehen bei mir auch viele Rechner im Offline. Das starten des Betriebsssystems ist aber trotzdem möglich. Nur synchronisieren geht aus dem Offline nicht.

Gruß

Alois

Hallo Alois,

sorry ich glaube es war in diesem Fall nur ein defektes Patchkabel.
Bin gespannt was die nächsten Tage zeigen…

Viele Grüße
Matthias

Hallo Holger,

seitdem ich einen 3Com-Switch durch einen Unifi-Switch ersetzt habe, gibt es einige Rechner mit dem “Linbo-offline-Syndrom”. Meine Frage:Direkt nach “## Managed by linuxmuster” stehen ja die Einträge für die Bootregeln. Diese Einträge sind bei mir bei fast jeder Hardwaregruppe verschieden. Würden diese modifizierten Einträge durch den import_workstations auch überschrieben? Und wenn ja, wo kann ich dann “dhcpretry=10” dauerhaft unterbringen?

Viele Grüße
Wilfried

Hallo Wilfried,

bei mir steht das hier:

# LINBO start.conf Beispiel mit
# Windows 7 auf Partition 1 (NTFS)
# Ubuntu Lucid 10.4 auf Partition 2
# Swap auf Partition 3
#
# Cache auf Partition 5
# Festplatte 160G

[LINBO]                  # globale Konfiguration
SystemType = bios
KernelOptions = dhcpretry=9

Gruß

Alois

Hallo Wilfried,

seitdem ich einen 3Com-Switch durch einen Unifi-Switch ersetzt habe,
gibt es einige Rechner mit dem “Linbo-offline-Syndrom”. Meine
Frage:Direkt nach “## Managed by linuxmuster” stehen ja die Einträge für
die Bootregeln. Diese Einträge sind bei mir bei fast jeder
Hardwaregruppe verschieden. Würden diese modifizierten Einträge durch
den import_workstations auch überschrieben? Und wenn ja, wo kann ich
dann “dhcpretry=10” dauerhaft unterbringen?

wie Alois schreibt: du kannst die Booteinträge in der grub.cfg durch
import_workstations setzen lassen.
Dann muss die ### managed by linuxmuster Zeile unverändert bleiben.
Gewünschte Parameter kommen in die kernelOptions Zeile
Ein Import trägt sie in die grub.cfg
Beim nächsten boot des Clients bemerkt er die Änderung, schreibt sie auf
die Platte und bootet neu, bevor die Oberfläche kommt (das ist normal).

LG

Holger

Hallo Alois und Holger,

ich hatte den Eintrag ### managed by linuxmuster … in der grub.cfg entfernt, damit Änderungen erhalten bleiben. Nachdem ich den dhcpretry-Eintrag in der start.conf eingefügt habe, musste ich vor dem import_workstations den Eintrag ### managed by linuxmuster … ergänzen, damit die dhcpretry-Sache in die grub.cfg geschrieben werden konnte. Danach habe ich meine anderen Änderungen wieder vorgenommen und die Zeile ### managed by linuxmuster … wieder entfernt, damit beim nächsten import_workstations nichts verändert wird.
Vielleicht etwas umständlich, aber es funktioniert und alle clients bekommen jetzt ihre IP.

Viele Grüße
Wilfried

Wir haben hier auch an einigen Rechnern das OFFLINE-Problem. Allerdings schon vor der Rechneraufnahme. Wie bzw. wo kann ich die per default ausgelieferte start.conf mit dem dhcpretry-Wert versehen?
Grüsse Tobias

Hallo liebe Community,

unser Lieferant hat mir Fujitsu Lifebooks A357 mit einem Realtek-Chip geliefert und ich vermute, dass die Treiber hier ein Problem machen. Ich hatte schon den dhcp-retry hochgeschraubt. Dennoch bleibt der Linbo-Client (2.3.51.-0) offline.
#Hat jemand einen Tipp, wie ich nur mit der Console herausfinden kann, ob und #welcher Netzwerkkartentreiber hier benutzt wird?

Update: es ist ein Realtek RTL8111/8168/8411 Gigabit Ethernet rev. 15.
Kerneltreiber Linux Mint: r8169
Kernelmodule: r8169

Über hilfreiche Tipps würde ich mich freuen.

Hallo lieber Henning ,
In den meisten Fällen ist der Client nicht offline, sondern man sieht nur die Bildschirmausgabe nicht .
Du solltest einmal mit linbo-ss versuchen, auf den Client zu kommen. Wenn das funktioniert, ist dein Client nicht offline, sondern die Bildschirmausgabe ist aufgrund des kernel mode settings nicht möglich. Bitte sieh einmal in diesem Forum mit dem Stichwort nomodeset nach, was dann zu tun ist, meistens brauchst du nur den Kernel Parameter in der start.conf.
Liebe Grüße
Christoph

Vorsicht Typo!

linbo-ssh

Beste Grüße

Thorsten

Uups…
Danke für die Berichtigung😳!
Gruß Christoph

Der Client hat laut ifconfig an der Console keine IP bekommen.
Deshalb wird linbo-ssh auch nicht funktionieren.

Ich versuche es etwas deutlicher zu erklären:

Es ist ein nagelneuer Laptop ohne Betriebssystem. Darauf wird ein Xenial-Client installiert. Ich starte also den Laptop und über PXE bekommt er auch eine Verbindung. Jetzt startet Linbo und er bekommt keine IP mehr und zeigt mir euch keine IP mit ifconfig an.

Kann ich sonst noch etwas testen?