Benutzer erhalten nicht das linuxadmin-Profil


#1

ich habe einen leoclient 2 installiert, der gut funktioniert, wenn der linuxadmin oder der linuxuser angemeldet ist.
Wenn sich aber ein anderer Benutzer anmeldet, erhält dieser nur das Standardprofil von Ubuntu.
Ich brauche eine Anleitung mit der auch ein linux-Laie klar kommt. Wer kann mir da helfen, oder hilfreiche Links mitteilen?

Gruß
Jürgen


#2

Hallo Jürgen,

Dein Fall ist mir nicht ganz klar. Bitte schildere es nochmal etwas genauer. Zum Beispiel folgendes habe ich mich gefragt:
Hast vor der Installation von leoclient2 einen Linuxclient gehabt, bei dem die Profilzuweisung für Domänenbenutzer funktioniert hat?
Hast Du danach den leoclient2 darauf installiert und seit dem das Problem mit der Profilzuweisung für Domänenbenutzer?

Gruß
Stefan


#3

Hallo Stefan,
danke dir für deine Antwort.
Den Leoclient habe ich im letzten Schuljahr installiert, zunächst als Linuxclient aus einem vorkonfigurierten xenial-cloop. Bei einer Fortbildung in Leonberg habe ich dann die VirtualBox und ein virtuelles win7 eingerichtet.
Seither habe ich an dem Client nichts mehr gemacht, weil wir bis dahin nur langsame PCs mit konventioneller Festplatte und max. 4 GB Ram hatten. Bei dem besagten Notebook hatte ich allerdings eine SSD eingebaut. Jetzt wurden bei uns Notebooks mit 8 GB Ram und SSDs angeschafft, deshalb habe ich den Rechner wieder aktiviert und möchte das Image dieses Rechners auf die neuen übertragen.
Vermutlich hatte ich bei dem Rechner die Anmeldung eines Domänenbenutzers noch gar nicht ausprobiert, ich weiß das schon nicht mehr.
Was ich schon überprüft habe: Das Home des Linuxadmin ist leer. Danach habe ich in der Datei /etc/linuxmuster-client/auth/config den Werts der Variablen AUTOCOINFIGURE_LDAP auf NO gesetzt.
danach habe ich den Befehl “sudo dpkg-reconfigure linuxmuster-client-auth” ausgeführt. Hier bin ich mir aber nicht sicher welche Werte ich einsetzen muss, bzw. wo ich nachsehen kann, welche Werte das in meinem Fall sind.

Ich hoffe diese Infos sind das, was du noch brauchst, um mir vielleicht auf die Sprünge zu helfen. Danke für deine Mühe.

Gruß
Jürgen


#4

Hallo Jürgen,

Vermutlich hatte ich bei dem Rechner die Anmeldung eines
Domänenbenutzers noch gar nicht ausprobiert, ich weiß das schon nicht mehr.
Was ich schon überprüft habe: Das Home des Linuxadmin ist leer. Danach
habe ich in der Datei /etc/linuxmuster-client/auth/config den Werts der
Variablen AUTOCOINFIGURE_LDAP auf NO gesetzt.
danach habe ich den Befehl “sudo dpkg-reconfigure
linuxmuster-client-auth” ausgeführt. Hier bin ich mir aber nicht sicher
welche Werte ich einsetzen muss, bzw. wo ich nachsehen kann, welche
Werte das in meinem Fall sind.

die Domäne liest du aus der /etc/hosts auf dem Server ab.
Da steht z.B.
server.liuxmuster.lokal
Dann wird das zu
dc=linuxmuster.dc=lokal

LDAP Version ist v3

LG

Holger


#5

Hallo Holger,
danke für die schnelle Antwort.
Müsste es dann funktionieren? Oder muss ich sonst noch etwas machen?

Gruß
Jürgen


#6

Hallo Holger,
ich habe das gemacht. Allerdings hat ein normaler Benutzer immer noch das Ubuntu-Profil.

In /etc/hosts steht:
“127.0.0.1 localhost.localdomain localhost
141.10.86.194 bmc.paedml-linux.lokal bmc
10.96.1.1 server.paedml-linux.lokal serever”

habe eingegeben:
10.96.1.1
“dc=paedml-linux,dc=lokal“

Danach habe ich den Client neu gestartet und ein Image erzeugt.
Wo liegt der Fehler?

Gruß
Jürgen


#7

Hallo Jürgen,

ich habe das gemacht. Allerdings hat ein normaler Benutzer immer noch
das Ubuntu-Profil.

In /etc/hosts steht:
“127.0.0.1 localhost.localdomain localhost
141.10.86.194 bmc.paedml-linux.lokal bmc
10.96.1.1 server.paedml-linux.lokal serever”

habe eingegeben:
10.96.1.1
“dc=paedml-linux,dc=lokal“

Danach habe ich den Client neu gestartet und ein Image erzeugt.
Wo liegt der Fehler?

das was ich geschrieben habe hat mit dem Profil nichts zutun: da geht es
nur um die Domänenanmeldung.
… jetzt wo ich den Tread noch mal gelesen habe, war das aber garnicht
dein Problem, sondern die Übernahme des Profils.

Das funktioniert nur im default.cloop automatisch: verwendest du dieses?
Wenn nicht, dann mußt du die linuxmuster-client Pakete von Hand
nachinstallieren und Einrichten (also nicht nur linuxmuster-client-auth)

LG

Holger


#8

Hallo Holger,

kann man auf dem Client nachsehen, ob es der Default-cloop ist? Ich weiß
nicht mehr, welches cloop ich verwendet habe.

Falls ich die Linuxmuster-Client-Pakete nachinstallieren muss, ist es
dafür notwendig, dass der Client mit dem Server verbunden ist? Ich frage
deshalb, weil ich den Client hier zu Hause habe, aber hier ist er
natürlich nicht mit dem Server verbunden.

Wo finde ich die aktuelle Anleitung zur Installation der
Linuxmuster-Client Pakete.

Gruß
Jürgen


#9

Hallo Jürgen,

schau mal auf dem vorhandenen Client nach, ob es die Verzeichnisse
/etc/Linuxmuster-client/
gibt.
Ist da auch ein UNterordner profile ?
Schick uns mal den Inhalt der /etc/linuxmuster-client/profile/profile.conf

Derzeit nehme ich an, dass ein
chown -R linuxadmin:linuxadmin /home/linuxadmin
das Problem beheben wird.

LG

Holger


#10

Hallo Holger,

vielen Dank für deine Mühe und die schnellen Antworten.

Ja, die Verzeichnisse gibt es, der Inhalt der Datei
/etc/linuxmuster-client/profile/profile.conf

sieht so aus:

" # verbose logging true/false, default: true
LOGGING=true
" # Profile user, default “linuxadmin"
PROFILE_USER=“linuxadmin”
” # Name of “Own Docs"
OWNDOCSFOLDER=”"
" # Additional options for the rsync command used for
" # syncing the template users profile to the
" # logged in user. Profile can be cleaned up on every login
" # by adding
RSYNC_OPTIONS="–force --delete"
RSYNC_OPTIONS="–force --delete --links"
" # Configdir: Where all *.conf files for the profile packag reside
CONFDIR=/etc/linuxmuster-client/profile

(Die Anführungszeichen vor den Rauten sind von mir.)

Was beantwortet diese Datei für dich?

Viele Grüße
Jürgen


#11

Hallo Jürgen,

RSYNC_OPTIONS="–force --delete"
RSYNC_OPTIONS="–force --delete --links"

sind die bei dir beide einkommentiert?
Das sollte nicht sein.
Mach mal ein #
vor die Obere Zeile der beiden und starte den Client neu.

Hab ich das richtig, dass der Login der Domänennutzer funktioniert, sie
aber nicht das linuxadmin Profil bekommen?

Es sei darauf hingewiesen, dass sie, je nach dem wie man es einstellt,
nicht alles vom linuxadmin bekommen: nur wenn sie “es” noch nicht haben.
Was genau kommt den nicht an von deinen Änderungen?
Und was steht in /etc/linuxmuster-client/profile/usersettings.conf und
usersettings-opt.conf

LG

Holger


#12

Hallo Holger,

in den Dateien findet sich:

usersettings.conf:
firefox:.mozilla/firefox/uknhxyfe.default

usersettings-opt.conf:
libreoffice:.config/libreoffice
ALL:ALL

Gruß
Jürgen


#13

Hallo Holger, hallo alle anderen,

leider ist mein Problem immer noch nicht gelöst.

Was genau kommt denn nicht an von deinen Änderungen?

Die Icons im Starter sind nicht die selben, und auf dem Desktop taucht der Leo-Virt-Starter und das Icon “für Homes auf Server” nicht auf. Außerdem wird nicht automatisch in die “eigenen Dateien” abgespeichert.

Außerdem habe ich die neuesten Updates für dern Linuxclient installiert, aber da gibt es wohl auch ein Problem, dass dann zwar die Anmedung am Client durchgeführt werden kann, aber danach erscheint nur noch ein dunkler Hintergrund und der Mauszeiger, aber sonst nichts, man kann auch nichts mehr machen als dern Rechner durch langes Drücken des Schalters abzuwürgen. Dieses Problem wurde im Forum auch schon von jemand anderem beschrieben (siehe: Ubuntuclient funktioniert nach update nicht mehr richtig).
Deshalb habe ich das davor vorhandene Image wieder verwendet.
Ich wäre sehr froh, wenn jemand noch gute Tipps für mich hätte.
Viele Grüße
Jürgen


#14

Hallo Jürgen,

bitte stell mal sicher, dass im Home des linuxadmins im Unterverzeichnis
Home_auf_Server nichts ist.
Also als linuxadmin
ls -al /home/linuxadmin/Home_auf_Server/

nur
.
und

angezeigt wird.

Wenn nicht: alles darin befindliche Löschen: das spuckt einem gehörig in
die Suppe.

Danach noch mal testen

LG

Holger


#15

Hallo Holger,

so sieht die Ausgabe aus:

root@g9r009pc44:/home/linuxadmin# ls -al /home/linuxadmin/Home_auf_Server/
insgesamt 8
drwx–x--x 2 linuxadmin linuxadmin 4096 Feb 28 11:02 .
drwxr-xr-x 19 linuxadmin linuxadmin 4096 Feb 28 10:42 …
root@g9r009pc44:/home/linuxadmin#

Was bedeutet “insgesmt 8” ?

Gruß
Jürgen


#16

Hallo Jürgen,

insgesamt 8 bedeutet, dass dieses Verzeichnis insgesamt 8kiB auf dem Datenträger belegt.
(4096 Byte + 4096 Byte = 8192 Byte = 8 kiB)

Das ist das (in Zweierpotenzen gerechnete) “Kibibyte”, das Pendant zum (in Zehnerpotenzen gerechnete) Kilobyte)…

LGJ


#17

Hallo,

insgesamt 8 bedeutet, dass dieses Verzeichnis insgesamt 8kiB auf dem
Datenträger belegt.
(4096 Byte + 4096 Byte = 8192 Byte = 8 kiB)

Das ist das (in Zweierpotenzen gerechnete) “Kibibyte”, das Pendant zum
(in Zehnerpotenzen gerechnete) Kilobyte)…

… und wenn sie außen Braun aber innen Grün sind, dann sind das kiwibyte :slight_smile:

… jetzt aber noch zum Problem:
OK, das Verzeichnis ist leer: schonmal gut.
Dann schau mal nach, ob die Partition genügend Platz und inodes hat:
df -h
und
df -i

Wenn das OK ist, dann bügeln wir das Home des linuxadmin mittels (als
linuxadmin im Terminal):
cd /
sudo su
chown linuxadmin:linuxadmin -R /home/linuxadmin

Dann Image erstellen und nochmal an einem anderen Rechner zurückspielen
und testen.

LG

Holger


#18

Hallo Holger,

Die Ergebnise von …>

root@g9r009pc72:/home/linuxadmin# df -h
Dateisystem Größe Benutzt Verf. Verw% Eingehängt auf
udev 3,7G 0 3,7G 0% /dev
tmpfs 742M 9,7M 732M 2% /run
/dev/sda1 19G 15G 3,3G 82% /
tmpfs 3,7G 204K 3,7G 1% /dev/shm
tmpfs 5,0M 4,0K 5,0M 1% /run/lock
tmpfs 3,7G 0 3,7G 0% /sys/fs/cgroup
/dev/sda3 38G 48M 36G 1% /var/virtual
cgmfs 100K 0 100K 0% /run/cgmanager/fs
tmpfs 742M 4,0K 742M 1% /run/user/109
tmpfs 742M 56K 742M 1% /run/user/1000

root@g9r009pc72:/home/linuxadmin# df -i
Dateisystem Inodes IBenutzt IFrei IUse% Eingehängt auf
udev 944346 536 943810 1% /dev
tmpfs 949194 811 948383 1% /run
/dev/sda1 1250928 221782 1029146 18% /
tmpfs 949194 7 949187 1% /dev/shm
tmpfs 949194 4 949190 1% /run/lock
tmpfs 949194 18 949176 1% /sys/fs/cgroup
/dev/sda3 2501856 12 2501844 1% /var/virtual
cgmfs 949194 14 949180 1% /run/cgmanager/fs
tmpfs 949194 29 949165 1% /run/user/1000
root@g9r009pc72:/home/linuxadmin#

sehen so aus. Ist das so ok?

Gruß
Jürgen


#19

Hallo zusammen,

seid ihr hier weitergekommen? Habe eben selbiges Problem festgestellt, als mir ein Referendar erzählte, dass er offenbar nicht das Standard-Profil bekommt. Alle, die vorher schon mal an dem alten trusty-Rechner angemeldet waren, haben das richtige Profil. die obigen Hinweise habe ich ebenfalls bereits erfolglos ausprobiert… seltsam das …

Viele Grüße

Christian


#20

Hallo zusammen,

ist das eventuell das gleiche Problem, das auch hier schonmal diskutiert wurde?

Hier mal ein paar Screenshots:

So sollte es bei unserem Client aussehen:
Profilproblem_Icons_richtig

Aber es sieht so aus:

Und im Benutzer-Wechseln-Menü (das es auch nicht geben sollte) tauchen alle vorher angemeldeten Benutzer auf:
Profilproblem_Menue_falsch

Erst kürzlich habe ich das auch wieder beobachtet, aber leider versäumt, mir den Füllstand der Platte usw. anzusehen (war halt im Unterricht, wo man dann leider doch nicht so viel Zeit für die Diagnose hat). Nach einem sync-Start war alles wieder i.O.

Ich habe das Gefühl, dass es sporadisch dann auftritt, wenn auch das Netz etwas “wackelig” ist, kann mir aber (noch) nicht so ganz erklären, woran es dann liegt.

Viele Grüße

Andreas


Home leer nach login