BBB Fehler beim aktivieren von Mikrofon Fehler 1007

Hallo Community,
seit einer Woche versuche ich BBB zum laufen zu bekommen. Erst hatt ich einen internen Server installiert, diesen habe ich nicht zum laufen bekommen weil ich das Root Zertifikat unserer internen Zertifizierungsstelle nicht in das Docker Image bekommen habe. Jetzt habe ich einen Server installiert mit externer Domain und öffentlichem Zertifikat, dort läuft jetzt alles soweit außer dass ich den Fehler 1007 beim auswählen von „Mit Mikrofon“ erhalte. Langsam bin ich wirklich am verzweifeln, ich muss dazu sagen dass der Server ( Ubuntu 16.04) als VM in der DMZ steht und von außen per NAT angesprochen wird. Ich habe alle Empfehlungen auf er BBB Seite konfiguriert ( Beispiel: https://docs.bigbluebutton.org/2.2/configure-firewall.html)

Kann mir vielleicht einer sagen in welches LOG ich genauer schauen muss um diesen 1007 Fehler besser eingrenzen zu können.

Ich danke schon mal für jede Antwort.

VG

Ich kann Dir zwar Deine Frage nicht beantworten, aber ich würde meiner Schulleitung was husten - der virtuelle Server performt wahrscheinlich sowieso nicht gut, jeder billige Vierkern aus der Hetzner Serverbörse wäre besser. Ist denn Deine Arbeitszeit nichts wert? Eine Woche frickeln für etwas, das man für 30€/Monat + 30 min entspannter Arbeit haben kann?

1 Like

Volle Zustimmung, den Hetznerserver hast Du in einer halben Stunde, keine Stromkosten und direkt im Internet. Und wenn Dir den jemand hackt, weil BBB jede Menge Angriffspunkte dafuer hat, sei’s drum. Zuruecksetzen, Skript durchlaufen lassen, neue Keys in Moodle rein und fertig.
Keine Einrichtungskosten, monatlich kuendbar.
Gruss Harry

Hallo,

Zertifizierungsstelle nicht in das Docker Image bekommen habe. Jetzt
habe ich einen Server installiert mit externer Domain und öffentlichem
Zertifikat, dort läuft jetzt alles soweit außer dass ich den Fehler 1007
beim auswählen von „Mit Mikrofon“ erhalte.

den Fehler hatte ich am Anfang auch sporadisch, weil ich zuerst meine
BBB Server virtualisiert installiert habe.

Seit ich dedizierte Server mit 16.04 verwende ist das nicht mehr
aufgetreten.

Der Grund ist auch nachvollziehbar: freeswitch ist eine
echtzeitanwendung: das braucht eine korrekte RealTimeClock: und die hast
du in einer virtualisierten Umgebung nicht unbedingt.
Also klappt es meistens, aber eben nicht immer.

LG

Holger

Ich gebe euch ja teilweise recht, ich habe ja jetzt auch nicht 1 Woche nur BBB versucht zum laufen zu bekommen, habe immer mal wieder dran gearbeitet, muss ja auch immer mal warten wenn unser Dienstleister eine Konfiguration durchführt. Wir haben halt eine VMWare Umgebung im RZ mit öffentlichen IP-Adressen, ich habe ca 5 Linux Webserver am laufen, Moodle oder andere Projekte die ohne Probleme laufen, ich dachte wieso soll nicht auch BBB laufen, ich bekomme das auch hin, es dauert halt etwas länger als sonst. Es nervt halt weil man nicht genau sagen wo es jetzt hängt, am Server ? an der Firewall ? lauf Dienstleister sind die Ports die für BBB benötigt werden, freigeschaltet.

Es ist ja „nur noch“ das Audio was nicht funktioniert.

Welchen Server bzw welche Art würdest du da bei Hetzner nehmen ?
Der mc50 kostet 60 Euro im Monat, ich habe sicherlich schon 3 tage voll dran gearbeitet, bedeutet der Server wäre schon lange bezahtl gewesen , sogar noch 150 Euro übrigt. Wenn ich es aber über unsere Umgebung zum laufen bekomme, wird es dann die Jahre immer günstiger.

Denke die meisten hier haben die Intel Core i7-4770-Variante mit 32GByte RAM von hier:
https://www.hetzner.de/sb

Preise pendeln taeglich zwischen 25 und 30€/Monat, weiss der Teufel wieso - Boerse halt.
Euer vmware-Gedoehns in der Schule in Ehren, irgendwie ist draussen aber schon geiler.
Und mit 1GBit/s symmetrisch duerftet ihr in der Schule auch nicht angebunden sein, oder?

Gruss Harry

Sau cool, die Boerse kannte ich gar nicht. Also die VMWare Umgebung ist schon auch performant, alle anderen Projekte laufen ja auch super. BBB und NAT ist halt nicht so schön.

Die Server Börse von Hetzner hat auch mir gut getan. Wir hätten auch noch VMs in der Schule frei, doch bei Hetzner habe ich 1GBit/s symetrisch.

Beim ersten Aufsetzen hat nur die Namensauflösung über den DNS nicht gestimmt, da habe ich auch einige Stunden verbraten.
Kaum hat die Namensauflösung geklappt hat auch die Installation super funktioniert. Die meiste Zeit habe ich nebenbei mein Buch weitergelesen.
Nach insg. 2 Stunden war der Server betriebsbereit.
Noch die Anbindung an den LDAP und den Port in der Firewall öffnen und die Kollegen können loslegen.
Ich habe bisher 3 kurze Schulungen gegeben, also die Knöpfe gezeigt.
Als Lehrer ging es am besten mit Chrome oder Opera, denn damit können auch eigene Tabs (mit Video oder Homepages) geteilt werden.
Also 30€ für i7 4770 gibt es gerade aktuell mit 32GB Ram

Grüßle
Ralf

TURN-Server hast Du eingepflegt? Vielleicht (!) wuerde das was bringen.

Nein noch nicht, habe heute angefangen zu Lesen (https://docs.bigbluebutton.org/2.2/setup-turn-server.html)und dann gesehen was alles konfiguriert werden muss, habe dann einfach den Tab geschlossen weil ich keine Lust hatte weiterzulesen :slight_smile:

Du kannst den von Linuxmuster nehmen, ein eigener laesst sich auf dem BBB-Server nicht betreiben, da Port 443 schon belegt ist.
Ich glaube allerdings, dass der nur vor boesen Firewalls zuhause schuetzt und nicht wenn Euer NAT da nicht alles durchreicht.

Nach vielen Tests in den letzten Tagen habe ich endlich die optimale, einfache Lösung für diesen „Fehler 1007“ gefunden:

systemctl restart docker

Wenn manuelle Änderungen an einigen Dateien vorgenommen wurden, sollten einige BBB Dienste neu gestartet werden, und danach auch wieder Docker:

systemctl restart bbb-web
systemctl restart bbb-webrtc-sfu
systemctl restart freeswitch
systemctl restart docker

Danach sollte alles fehlerfrei laufen!

Aufgrund des Updates von BBB hatte ich gestern Nacht wieder mit diesem Fehler 1007 gekämpft.
Alles habe ich durchgeschaut, Änderungen analysiert usw. Um dann nach vielen Stunden festzustellen, dass ich die überschriebene Konfiguration für meinen eigenen STUN/TURN-Servern nicht korrigiert hatte. Alte Konfiguration wieder verwendet, bbb-conf --restart ausgeführt und schwupps war kein Fehler mehr da.

Hallo Joachim,

ich möchte mal generell eine Frage in den Raum hier werfen. Den Update-Fehler habe ich definitiv mehr als 10 mal in diversen Foren gelesen.

Und jetzt folgt meine Frage: Werden diese Fehlermeldungen und unsere Lösungen an das Entwicklerteam weitergemeldet, so dass in den nächsten Tagen ggf. die Verbesserungen in das Update eingebaut werden können?

Ich denke nicht, dass wir die Fehler hier ausbügeln müssen. Zwar handelt es sich um OpenSource, wenn wir aber hier mit Performanzproblemen zu kämpfen haben, dann können wir OpenSource auch nicht weg von den Globalplayers bewerben. Dann ist OpenSource schlichtweg zu schlecht.

LG
Marcus

Hallo Marcus,

Ich fuerchte Du hast die Idee hinter Open Source nicht wirklich verstanden, Du selbst bist in der Lage die Fehler direkt an die Entwickler zu melden, Du brauchst hier niemanden zu fragen und „wir“ brauchen auch keine Fehler auszubuegeln, die Entscheidung fuer Open Source ist eine bewusste und deshalb ist „Open Source“ auch nicht schlichtweg zu schlecht.
Open Source sind nicht die Anderen sondern wir mit diesen.
Du kannst auf Github „issues“ aufmachen, die Fehler beschreiben und verfolgen ob diese gefixt werden bzw. wieso niemand diese fixen will bzw. kann.


Das sind 1200 offen und 3800 closed.

Wenn Du am Sourcecode mitarbeiten kannst/willst, kannst Du auch versuchen eigene Aenderungen in den Entwicklerzweig zu bringen, Stichwort pull request.

Gruss Harry

Hallo Harry,

natürlich lebt OpenSource von uns. Jedoch sind viele fitter im Programmieren als ich, jedoch werden immer wieder die gleichen Fehler gepostet, die dann doch irgendwann mal gefixt werden sollten.

Ich kämpfe schon die ganze Zeit für OpenSource an meiner Schule da
a) Sourcesicher
b) Kostensparend
c) einfach besser weil unabhängiger.

Daher möchte ich grundsätzlich OpenSource nicht schlecht reden, im Gegenteil, jedoch bin ich nicht der coding-Mensch, der einfach mal kurz an die Entwickler professionell schreiben oder in GitHub einfach mal so was reintragen kann, weil mir schlichtweg die Fähigkeiten dazu (noch) fehlen.

Da sich die OpenSource-Gemeinde mehr als über Gebühr für ihre Projekte einsetzt, ist mir bekannt und bewusst.

Daher, ja, ich würde gern wenn ich könnte, ich kann aber nicht und bin daher von euch Profis abhängig, die das so mal kurz aus dem Ärmel schütteln und gleich ne Lösung parat haben.

Herzliche Grüße
Marcus

Die meisten Fehler schlagen auch im Entwicklerforum bei Google Groups auf, im Userforum auch und im Setupforum:
https://groups.google.com/forum/#!forum/bigbluebutton-dev
https://groups.google.com/forum/#!forum/bigbluebutton-users
https://groups.google.com/forum/#!forum/bigbluebutton-setup

Da sind die Entwickler auch dabei, auch auf Github mit beeindruckender Geduld.

Gruss Harry