Winprosa: externe Kurswahlerfassung

Hej,
ja, sorry. War unpräzise :wink:

Dieses Mal noch lmn6.2…
Grüße
Michael

Hej,

Habs vorhin nochmal versucht. Bei uns bekommen Projekt-Tauschverzeichnisse die Berechtigung 644. Wenn die Infos vom Thread-Anfang stimmen, kann das eigentlich nicht mehr funktionieren.


Ich scheitere jetzt am Anlegen und Mounten des Shares. Wäre toll, wenn jemand meinen Fehler findet… Vorweg: Es ist geht um einen Ubuntu 16.04-Client unter LMN 6.2 :wink:

Also: Ich habe nun - wie oben beschrieben - das Folgende share auf dem Server in /etc/samba/smb.conf.shares eingetragen

[kurswahl]
   comment = WinProsa Kurswahl
   path = /home/samba/kw
   guest ok = no
   writeable = yes
   force create mode = 0666
   force directory mode = 0777

Das Verzeichnis /home/samba/kw auf dem Server gehört administrator:teachers
Dann habe ich mit sudo service smbd restart den samba-deamon neu gestartet.

Auf dem Clienten habe ich in /etc/security/pam_mount.conf.xml das hier am Ende eingetragen:

<volume options="rw,nosuid,nodev" user="*" mountpoint="/home/samba/kw" path="kurswahl" server="10.32.1.1" fstype="cifs" />

Hätte nun naiv gehofft, dass das so klappt… Pustekuchen.
Das Einbinden klappt schon nicht… Entsprechend kann ich auch gar nicht feststellen, ob das Share richtig angelegt ist…

Wie macht man denn das richtig?
Bitte um Hilfe. Danke und Grüße
Michael

Hallo Michael!

Wem gehört das Verzeichnis /home/share/kw? Vergleiche das mal mit dem restlichen Inhalt.

Ersetze mal

 writable = yes 

durch

 write list = @domadmins, @teachers 

Beste Grüße

Thorsten

Hej,

das Share-Verzeichnis heißt /home/samba/kw und gehört auf dem Server administrator:teachers

Irgendwas mache ich aber grundlegend falsch… Egal. Die Ferien waren zu voll für diese Baustelle.
Ich habe es nun wie @ironiemix mit einem eigenen Benutzer gelöst über das Tauschverzeichnis gelöst.

Nächstes Jahr dann elegant…

Danke trotzdem fürs Mitdenken!
Grüße
Michael

Hallo Michael,

Wem gehört das Verzeichnis /home/share/kw?

das Share-Verzeichnis heißt |/home/samba/kw| und gehört auf dem Server
administrator:teachers

vorsicht: beim Zugriff via samba gibt es auch noch die ACLs zwischen
Client und Dateisystem.

LG

Holger