Windows 10 fordert SMB2

Hallo Forum,

wir installieren gerade Windows 10 mit der aktuellsten DVD. Beim Versuch der Domäne beizutreten, oder ein Netzlaufwerk zu verbinden kommt die im Bild dargestellte Fehlermeldung

Weiss wer wie man das korrigieren kann?

Ich habe schon nach der Fehlermeldung gegoogelt, aber keine brauchbaren Lösungen gefunden.

Gruß

Alois

Hallo Alois,

ich kenne nur diesen BUG von Windows 10 1709:

Such mal nach Registry Einträgen, die SMB1 wieder aktivieren.
… wobei ich dachte, dass wir SMB2 verwenden …

Ansonsten: älteres Windows installieren und updaten.

LG

Holger

schau mal, was Thomas für ein testing paket schrieb.
Wenn du das machst, schließt du aber die clients aus, die SMB2 nicht können.

Vielleicht hilft dir das, Tobias

Hallo Alois,

SMB kann nachinstalliert werden.

0

Grüße

1 Like

Hallo,

der Vollständigkeit halber: Ich habe ein Xubuntu 17.10 Image laufen, das will auch zwingend SMB2 sehen, sonst mountet es die Shares nicht. Man kann aber auch dort eben entweder den Server auf SMB2 tackern oder am Client SMB1 erzwingen - ich schau nachher noch in mein linuxmuster-shares Paket, was genau dafür nötig war.

VG

Frank

Hallo an alle die geantwortet haben.

Vielen Dank

Gruß

Alois

Hallo zusammen,
vielleicht bin ich etwas langsam im begreifen aber ich habe das gleiche Problem, kann aber an euren Antworten nicht lesen, wie ich smb2 aktivieren odee installieren kann. Ich sehe immer nur smb1?
was muss ich machen, um SMB2 zu bekommen?
Diese Windows Support Antworten mit dieser riesigen Registry Bearbeitung sind mir zu hoch.
Gibt es nichts einfacheres, um smb2 zu bekommen?
Vielen Dank im Voraus

Hallo,
wir verwenden zwar keine Windows-clients in der Schule, hatten das Problem aber auch bei der Anbindung der Netzlaufwerke privater Rechner mit Win10 per vpn. Wir konnten smb2 nicht Aktivieren bevor wir nicht auf dem Server die aktuellsten Patches aufgespielt hatten. Erst damit führte der Eintrag der Zeile

max protocol = SMB2

in der Datei /etc/samba/smb.conf.global nicht mehr zu einer Fehlermeldung bei der Kontrolle durch den Befehl testparm. Nach einem “service smbd restart” kann sich windows dann per smb2 verbinden.

Beste Grüße,
Björn

Hier muss man aber aufpassen dass man das nicht mehr bei Samba 4 / W10 tun sollte (=> LMLv7)
eher umgekehrt SAMBA mitteilen nur noch ab SMBv2 zu sprechen,
Stefan Kania empfiehlt in seinem aktuellen Samba 4 Buch hier den Eintrag in die smb.conf:
Listing 22.3 Deaktivieren alter SMB-Versionen:
client ipc min protocol = smb2_10
client min protocol = smb2_10

Und hier muss per se im besten Fall unter W10 gar nichts geändert werden.

Grüße,
gerd