Unregelmäßige LDAPS-Anmeldeprobleme mit Ubuntu 16.04-Clients


#1

Liebes Forum,
ich habe zur Zeit das Problem, dass es massive Probleme mit der LDAPS-Anmeldung bei den (Ubuntu 16.04-) Clients gibt. Mittelweile ist das Problem so groß, dass ein normaler Unterricht im Computerraum teilweise nicht mehr möglich ist, weil sich die Schüler nicht anmelden können.
In einem gezielten Test habe ich jetzt festgestellt, dass es bei einem gleichzeitigen Anmeldeversuch an ca. 8 verschiedenen Ubuntu1604-Clients mit verschiedenen Nutzern zu deutlichen Problemen kommt. Melden sich die Personen nacheinander an, so gibt es keine Probleme.
Dadurch tritt das Problem vor allem dann auf, wenn beide Computerräume gleichzeitig in Betrieb sind.
Das Problem trat allerdings vor ca. einem halben Jahr noch nicht auf, auch wenn beide Räume in Betrieb waren.
Ich habe innerhalb des letzten halben Jahres viele Rechner von Ubuntu 12.04 auf Ubuntu 16.04 umgestellt.
Daher sehe ich folgende mögliche Ursachen:

  1. die deutlich erhöhte Anzahl an Ubuntu 16.04 Rechnern
  2. Updates vom Server
  3. Updates der Firewall (Update von Core 102 auf Core 110 mit DNSSEC-Problemen von 105 auf 106 …)
    Eine Kollegin hat einen Screenshot einer Fehlermeldung eines missglückten Versuchs gemacht,
    ein Schülerpasswort zu ändern, um so das Anmeldeproblem für diesen Schüler zu lösen,
    den ich dieser Meldung anhänge. (Ist vermutlich ein anderes Problem?)
    Außerdem bekomme ich vom System folgende Fehlermeldungen:

Sep 18 10:42:11 server CRON[10295]: pam_ldap: ldap_result Timed out
Sep 18 10:44:01 server CRON[10345]: pam_ldap: ldap_result Can’t contact LDAP server
Sep 18 10:44:01 server CRON[10345]: pam_ldap: reconnecting to LDAP server…

Das fängt plörtzlich an und geht so für mehrere Stunden.
Dann hört es plötzlich wieder auf.


Hat jemand eine Idee, wie ich die Fehlerursache herausfinden kann oder hat jemand ähnliche Probleme gehabt?
Schönen Gruß,
Sebastian


Freezes nach Clientupdate
#2

Hallo Sebastian,

vor einem Jahr (da bin ich bei uns komplett auf 16.04 umgestiegen) hatte ich ähnliche Symptome bei der Useranmeldung, wobei deine Fehlermeldungen nicht ganz identisch sind. Ein Versuch wäre es aber wert:

In /etc/default/slapd des Servers habe ich folgende Zeile hinzugefügt:
ulimit -n 8192

Das erhöht das Filelimit des slapd von 1024 auf 8192.

Nach einem /etc/init.d/slapd restart lief es dann bei mir wieder.

Grüße,
Stefan


SchuKo verweigert Anmeldung (Timeout ohne Meldung?)
#3

Hallo Stefan,

vielen Dank für den Tipp!

Ich habe es mal eingetragen und warte ab, ob es das Problem behebt.

Schönen Gruß,

Sebastian


#4

Hallo Stefan,

ich wollte nochmal bestätigen, dass die Änderung das Problem tatsächlich behoben hat!

Herzlichen Dank für die schnelle und effiziente Hilfe!

Schönen Gruß,

S.Funke


#5

Danke! Seit dem Upgrade auf 6.2 vor kurzem hatte ich auch diese Probleme, mit folgenden Fehlermeldungen in /var/log/syslog:

Apr  9 08:51:53 server slapd[1613]: warning: cannot open /etc/hosts.allow: Too many open files
Apr  9 08:51:53 server slapd[1613]: warning: cannot open /etc/hosts.deny: Too many open files

Das von @lessi vorgeschlagene Vorgehen hat das Problem gelöst.

Vielleicht sollte das an irgendeiner Stelle in die Doku?

Viele Grüße

Andreas