Ubuntu mit GRUB booten: UUID falsch

Hallo zusammen,
ich möchte weiterhin mein Image für die Leih-Laptops verbessern. Hierfür würde ich gerne nicht Ubutnu über LINBO booten, sondern direkt über GRUB. Das geht schneller und in 99% der fälle sind die Laptops eh nicht am Netzwerk angeschlossen.
Dafür habe ich wie in der Doku beschrieben auf dem Server in /srv/linbo/boot/grub eine entsprechende GRUPPE.cfg hinterlegt. Beim Booten erscheint dann auch der „Linbo“-GRUB:

Wähle ich auf dem Laptop, auf dem das Image erstellt wurde, „Ubuntu (Start)“ klappt alles. Wähle ich diesen Eintrag auf einem anderen PC, auf dem das Image ausgerollt wurde erscheint der systemeigene Grub:

Wähle ich hier nun „Ubuntu“ wird (zurecht) gemeckert, dass die Platten-UUID nicht gefunden wird, die in der /boot/grub/grub.cfg des Images steht. Aus dem LINBO heraus kann ich ich Ubuntu booten und wenn ich ein update-grub ausführe wird auch die neue UUID in die grub.cfg geschrieben und alles funktioniert wieder wie gewünscht…

Wie kann ich dem Problem Herr werden? Muss ich die UUID per Postsync-Skript ändern? Kann man in die grub.cfg statt UUIDs auch /dev/xxxx schreiben?

Ich dokumentiere nach wie vor mein Vorgehen. Wenn ich fertig bin schreibe ich hierzu auch gerne einen Artikel für die Doku :wink:

Danke euch wieder und liebe Grüße,
Leo

Hi,

an deiner Stelle würde ich UUIDs deaktivieren:

und noch

  • Die Datei /etc/initramfs-tools/conf.d/resume erstellen und RESUME=none oder wenn man Suspend-To-Disk haben möchte RESUME=/dev/sdaX die SWAP Partition eintragen
  • danach sudo update-initramfs -u

vG

Hallo Stefan,
danke für deinen Link. Diese Anweisungen hatte ich befolgt. Habe auch noch einmal alles überprüft und in der start.conf steht auch das in dem Post befolgt:
Kernel = /boot/vmlinuz
Initrd = /boot/initrd.img
Aber leider bleibt das Geschehen wie oben beschrieben. Wenn ich im LINBO Start-Menue „Ubuntu (Start)“ wähle wird der lokale GRUB geladen und hier erscheint dann die Fehlermeldung…
Muss ich in der /srv/linbo/boot/grub/gruppe.cfg noch was anpassen?
Liebe Grüße, Leo

Hi Leo,

wenn du weiterhin noch Probleme mit den UUIDs hast, musst du einen oder mehrere Schritte vergessen haben :slight_smile:

Auf dem Server:

  • in der start.conf:
Kernel = /boot/vmlinuz
Initrd = /boot/initrd.img
  • wenn du die start.conf geändert hast, immer linuxmuster-import-devices aufrufen. Erst danach die /srv/linbo/grub/gruppe.cfg ändern (falls du vorher Änderungen vorgenommen hast, die Zeile ### managed by linuxmuster.net ### wiederherstellen und noch mal linuxmuster-import-devices aufrufen.

Auf dem Client:

  • /etc/default/grubGRUB_DISABLE_LINUX_UUID=true
  • /etc/fstab → UUIDs ersetzen mit /dev/sdaX
  • danach sudo update-grub
  • Die Datei /etc/initramfs-tools/conf.d/resume erstellen und RESUME=none oder wenn man Suspend-To-Disk haben möchte RESUME=/dev/sdaX die SWAP Partition eintragen
  • danach sudo update-initramfs -u

vG Stephan

1 Like

Hallo Stephan,
(künftig immer mit ph) :wink:
DANKE!!! Ich habe ganz früh die gruppe.cfg-Datei selbst bearbeitet und das „managed by“ raus genommen. Nun funktioniert alles! Vielen Dank!
Zum Verständnis: Die Client-Sachen hatte ich alle erledigt, aber vermutlich die Kernel- und Initrd-Parameter geändert, nachdem ich schon das „managed by“ aus der gruppe.cfg-Datei genommen hatte - sprich das linuxmuster-import-devices das nicht mehr in der cfg-Datei ändern konnte?

Liebe Grüße,
Leo

Hi Leo,

Ja, sobald du das mit managed by... änderst, pack linuxmuster-import-devices die Datei nicht mehr an.

vG

Hallo Leo,

Zum Verständnis: Die Client-Sachen hatte ich alle erledigt, aber
vermutlich die Kernel- und Initrd-Parameter geändert, nachdem ich schon
das „managed by“ aus der gruppe.cfg-Datei genommen hatte - sprich das
linuxmuster-import-devices das nicht mehr in der cfg-Datei ändern konnte?

ja.
Wenn man an der start.conf was ändert bei den KernelAppend oder den
Pfaden im Betriebsystembereich, dann kommt die Änderung nicht mehr in
der grub.cfg der Gruppe an, wenn das managed by raus ist.
Deswegen empfehle ich immer das managed by nicht zu löschen, dondern die
Zeile um ein NOT zu ergänzen, also NOT managed by, dann wird sie auch
nciht gemanaged, aber man kann jederzeit das NOT wieder löschen udn sie
wird neu geschrieben (beim import).
und dann bekommt man das auch schnell wieder rein.

LG

Holger

super danke…