Testing-Pakete für 6.2

#1

Hallo!

Im babo62-testing Repo ist linuxmuster-linbo 2.3.27 verfügbar. Es enthält i.W. Fixes und Verbesserungen bzgl. Windows- und MSOffice-Aktivierung:

  • fixed 64bit msoffice reactivation (issue #72).
  • restore activation tokens even if no keys are provided (issue #75).
  • don’t delete custom files in C:\linuxmuster-win on windows partition anymore (issue #74).
  • added experimental msoffice 2016 reactivation support (issue #73).
  • added experimental windows 10 reactivation support (issue #71).

Da muss also noch einiges getestet werden. Bei mir mit Win7 und MSOffice 2013 hats funktioniert.

Viel Spaß
Thomas

Linbo, 2teGrafikkarte Nvidia 610 - kein Linbo-Anmeldebildschirm sichtbar
Windows 10 Aktivierung wird nicht auf den Server kopiert
Aktivierung Office 2010
Linbo 2.3.26-0 macht probleme
#2

Moin!

linuxmuster-linbo 2.3.28 ist nun im babo62-testing-Repo mit folgenden
Änderungen:

  • Update auf Kernel 4.9.50.
  • Im 64bit-Kernel sind die Framebuffer-Treiber jetzt modularisiert und
    für mehr Graka-Typen verfügbar.

VG, Thomas

#3

Hallo!

im babo62-testing-Repo ist linuxmuster-linbo 2.3.29 verfügbar:

  • Unterstützung von Partitionslabeln, das Problem von wegen Wechselmedien geänderten Device-Pfaden sollte damit in den Griff zu kriegen sein (Details siehe Anleitung).
  • Framebuffer-Grafik-Fixes.
  • Git-Details

VG, Thomas

Trotz postsync funktioniert der Start von Lenovo-Clients nicht
Trotz postsync funktioniert der Start von Lenovo-Clients nicht
Linbo 2.3.26-0 macht probleme
#4

Hallo Thomas,

was bedeutet -c vs. -p hinter linbo-remote?

Danke und Gruß,
Jochen

#5

Hallo Jochen,

[jochen] jochen https://ask.linuxmuster.net/u/jochen
22. Oktober

Hallo Thomas,

was bedeutet -c vs. -p hinter linbo-remote?

man kann
linbo-remote -p label …
oder
linbo-remote -c label …
angeben.
S.a. linbo-remote --help

Viele Grüße
Thomas

#6

Hallo Thomas,
Wir wollen das heute ausprobieren, noch zwei Fragen zur Anwendeung:

  • müssen die label vor dessen Verwendung zuerst noch mit dem beschriebenen Befehl neu gesetzt werden oder ist das seit linbo 2.3.0 automatisch der Fall? In unseren start.conf’s wurden die Label ab dem Moment, ab dem es diese Option gab, bereits eingepflegt.
  • diese Label enstprechen den Angaben, die ich auf der Linbo-Konsole per
 ls -al /dev/disk/by-label/

auslesen kann, ist das richitg?

Vielen Dank für die Arbeit u.a. am WE!

Grüße,
gerd

#7

Hallo Gerd,

Thomas weiß es besser, aber vielleicht hilft dir ja auch meine Einschätzung.

Wir wollen das heute ausprobieren, noch zwei Fragen zur Anwendeung:

  • müssen die label vor dessen Verwendung zuerst noch mit dem
    beschriebenen Befehl neu gesetzt werden oder ist das seit linbo
    2.3.0 automatisch der Fall? In unseren start.conf’s wurden die Label
    ab dem Moment, ab dem es diese Option gab, bereits eingepflegt.
  • diese Label enstprechen den Angaben, die ich auf der Linbo-Konsole per

ls -al /dev/disk/by-label/|

auslesen kann, ist das richitg?

wenn ihr das Label verwendet, seit es das gibt, dann hat jeder Client
den ihr seit dem mit linbo formatiert habt, das richtige Label schon so
gesetzt, wie es das neue linbo zum booten dann verwendet.

Wenn du sicher gehen willst, dann formatier die Cleints vorher.

LG

Holger

Win10, linbo und NVMe PCIe SSDs
#8

Hallo!

[baumhof] baumhof https://ask.linuxmuster.net/u/baumhof Vize-Präsident
23. Oktober

Hallo Gerd,

Thomas weiß es besser, aber vielleicht hilft dir ja auch meine
Einschätzung.

Wir wollen das heute ausprobieren, noch zwei Fragen zur Anwendeung:

  * müssen die label vor dessen Verwendung zuerst noch mit dem
    beschriebenen Befehl neu gesetzt werden oder ist das seit linbo
    2.3.0 automatisch der Fall? In unseren start.conf’s wurden die
    Label
    ab dem Moment, ab dem es diese Option gab, bereits eingepflegt.
  * diese Label enstprechen den Angaben, die ich auf der
    Linbo-Konsole per

    ls -al /dev/disk/by-label/|

auslesen kann, ist das richitg?

wenn ihr das Label verwendet, seit es das gibt, dann hat jeder Client
den ihr seit dem mit linbo formatiert habt, das richtige Label schon so
gesetzt, wie es das neue linbo zum booten dann verwendet.

Wenn du sicher gehen willst, dann formatier die Cleints vorher.

Wenn die Label unter /dev/disk/by-label/ aufgelistet sind, ist alles gut.
Ansonsten müssen die erst in die start.conf eingetragen und dann mit
linbo-remote gesetzt werden.

VG, Thomas

Linbo 2.3.26-0 macht probleme
#9

Hallo Holger, Hallo Thomas,

Ja, kann das gesagte jetzt auch bestätigen, bei uns waren doch nicht alle mit Label versehen, nach dem Nachtragen in der start.conf.hwg und Neuformatierung der Cients konnten wir das Vorhandensein der Label mit obigem Befehl in der Linbo Konsole prüfen.
Wir sind noch nicht bei allen Problemfällen durch, bei den ersten Tests war das Problem der vertauschten Mountpoints nicht mehr da, hier sind die Clients also fehlerfrei durch gebootet.

Grüße,
gerd

#10

Hallo!

linuxmuster-linbo 2.3.30 korrigiert einen Fehler in der Cachedevice-Erkennung während des Bootvorgangs.

VG, Thomas

#11

Moin!

linuxmuster-linbo 2.3.31 und linuxmuster-base 6.2.9 setzen die Unterstützung von Dateisystemlabeln jetzt vollständig um.
Beachtet dazu bitte den aktualisierten Wiki-Artikel.

Außderdem in testing:
eine neue Version (9.1.24lts2-0+ta1) von postgresql 9.1. Major-Version bleibt bei 9.1, deshalb unkritisch. Trotzdem habe ich es zur Sicherheit erstmal in testing eingestellt. Benutzer anlegen, Schuko-Authentifizierung hat hier geklappt. Versetzen noch nicht getestet.

Enthält Patches für:
CVE-2017-7547 [1] [2]
CVE-2017-7546 [3] [4]
CVE-2017-7486 [5] [6]

Zitat von Herrn Alteholz dazu:
“Wie schon angekündigt ist das ein Versionssprung von 9.1.23-0ubuntu0.12.04 auf 9.1.24lts2-0+ta1, welches von Credativ gepflegt wird. Daher bitte genau prüfen ob nach der Installation noch alles so funktioniert wie vorher.
Insbesondere falls Sie einen Datenbank-Cluster mit User Passwörtern zur Authentifizierung und/oder leere Passwörter erlauben möchten, sollten Sie einen Blick in die release notes[7] werfen.”

[1] https://security-tracker.debian.org/tracker/CVE-2017-7547
[2] https://people.canonical.com/~ubuntu-security/cve/2017/CVE-2017-7547.html
[3] https://security-tracker.debian.org/tracker/CVE-2017-7546
[4] https://people.canonical.com/~ubuntu-security/cve/2017/CVE-2017-7546.html
[5] https://security-tracker.debian.org/tracker/CVE-2017-7486
[6] https://people.canonical.com/~ubuntu-security/cve/2017/CVE-2017-7486.html
[7] https://github.com/credativ/postgresql-lts/releases

Viele Grüße
Thomas

Aktualisierungen für 6.2
Linbo 2.3.26-0 macht probleme
#12

Bump! Bevor ich die Pakete ins stable Repo schiebe, sollte außer mir das noch jemand getestet haben. (sic!)

VG, Thomas

#13

Hallo Thomas,

das hat hier in meiner Testumgebung funktioniert.

Gruß

Alois

#14

Hallo,

ich hab jetzt 2.3.31 produktiv in meiner Schule laufen.
Alle Rechner mit (integrierter) radeon GPU haben keine grafische linbo
Oberfläche mehr gezeigt und somit nicht mehr funktioniert.
Alle anderen gingen als wäre nichts passiert.

Das Problem kannman so beheben:

in der start.conf.
folgenden Eintrag machen:

KernelOptions = modprobe.blacklist=radeon

Oder zu den vorherigen Einträgen in der KernelOptions
modprobe.blacklist=radeon dazu schreiben.

Danach ein import_workstations
Dabei muss natürlich die Zeile

# ### managed by linuxmuster

in der /var/linbo/boot/grub/.cfg
intakt sein.

Hat man dort anpassungen, stellt man die Zeile wieder her, macht einen
import und verkrüppelt die Zeile wieder und macht seine Änderungen
wieder rein.

LG

Holger

#15

siehst du das als fix an? Ich sehe das eher als workaround an mit der Hoffnung verknüpft, dass es ein Kernel mit Lösung des Problems gibt.
Oder siehst du das anders?
VG, Tobias

#16

Hallo Tobias,

siehst du das als fix an? Ich sehe das eher als workaround an mit der
Hoffnung verknüpft, dass es ein Kernel mit Lösung des Problems gibt.
Oder siehst du das anders?

ja: wäre auch mein Wunsch, dass das wieder “einfach so” funktioniert.

Aber: die kernel werden immer komplexer und sie unterstützen immer mehr
Hardware: da kommt sowas schon mal vor.
Insofern freue ich mich, dass ich nun einen Mechanismus genauer kenne,
mit dem ich solche Probleme an gehen kann.

Ich weiß halt nicht, ob neuere 4.9er Kernel das Problem nicht mehr
haben: dann wäre es ja nicht so dramatisch: einfach neues linbo mit
neuerem kernel bauen.
Aber deswegen auf 4.10 oder noch neuer zu gehen fände ich übertrieben:
das würde wieder nochmehr testing nach sich ziehen.

LG

Holger