NextCloud Update auf 20.0.7 - Fehler bei PDF?

Hat schon wer das Update auf 20.0.7 gemacht? Evtl besser warten, hier gibt es einen Fehler mit dem Öffnen von PDF, wenn sie in einem öffentlich geteilten Ordner sind. Nur als Datei verlinkt ist kein Problem.

Wer es hat und testen kann, ob das überall so ist:
Ordner anlegen, eine PDF drin ablegen.
Ordner als öffentlichen Link teilen
Ordner über öff. Link öffnen und auf PDF klicken
Sollte aufgehen, bei mir kommt nur eine Fehlermeldung.

Hallo @hmt,

jepp, bei mir das gleiche. Hab den Test auf meiner privaten Nextcloud versucht und es ist direkt so wie du es sagst. Fehlermeldung ist „Invalid or corrupted PDF file“

LG
Marcus

Könnte aber auch am integrierten pdf-Reader liegen. Geht man auf mehr Details, dann steht da

PDF.js v2.4.456 (build: 228a591c)
Message: Invalid PDF structure.

Ggf. müssten wir auf ein Update des pdf-Readers warten.

LG
Marcus

Das wird der mitgelieferte pdf.js Viewer sein.

Interessant,
der Fehler wäre mir nie aufgefallen. Aber wenn man sich genau an die Anleitung hält, taucht er auf. Da man die Datei aber herunterladen kann, finde ich das nicht so dramatisch.

Hej, ich bin nach dem update auf die 20.0.9 auch in den pdf-Fehler gerannt - allerdings nicht bei öffentlichen Links, sondern bei pdfs, die auf einem SMB-Share liegen.
Dieses Problem kommt wohl nicht vom pdf-viewer, sondern von der icewind smb library - und die Menschen berichten, dass er bis NC 21 besteht (Siehe hier oder hier).

Lohnt sich also vielleicht, danach zu schauen.
Letztlich hat dieser Workaround für mich funktioniert: Nextcloud - NativeReadStream excess data will be lost - Subbrsach :+1:

Grüße
Michael

Hey,

eine gute Nachricht: Im Release Nextcloud 21.0.2 wird auch der ICEWIND/SMB-Client auf die Version 3.1.4 aktualisiert. Und damit scheinen die Probleme behoben zu sein. Bislang konnte ich alle PDF wieder öffnen und auch beim Download gabs keine Fehler mehr.

Gruß
Thomas

1 Like

20.0.10 kriegt auch 3.1.4 von icewind/smb, siehe hier: Changelog – Nextcloud

ich habe aber erst ein update auf 20.0.9 angeboten bekommen…

1 Like

Hi Tobias,
das ist seltsam, ich habe schon seit etwa 2 Wochen 21.0.1 angeboten bekommen und das auch gemacht.
Jetzt bekomme ich 21.0.2 angeboten, das führt er aber nicht durch, ich bekomme gesagt, ich hätte die aktuelle Version…
Current version is 21.0.1.

Update to Nextcloud 21.0.2 available. (channel: "stable")
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-21.0.2.zip
Open changelog ↗

Steps that will be executed:
[✔] Check for expected files
[✔] Check for write permissions
[✔] Create backup
[✔] Downloading
[✔] Verify integrity
[✔] Extracting
[✔] Enable maintenance mode
[✔] Replace entry points
[✔] Delete old files
[✔] Move new files in place
[✔] Done

Continue update? [y/N] y

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[✔] Check for expected files
[✔] Check for write permissions
[✔] Create backup
[✔] Downloading
[✔] Verify integrity
[✔] Extracting
[✔] Enable maintenance mode
[✔] Replace entry points
[✔] Delete old files
[✔] Move new files in place
[✔] Done

Update of code successful.

Should the "occ upgrade" command be executed? [Y/n] Y
Nextcloud is already latest version

LG
Max

Hej,
wann man bei Nextcloud was angeboten bekommt - ich checks nicht. Ich habe ja am Freitag den Workaround eingepflegt - heute habe ich von 20.0.9 auf 20.0.10 upgedatet.
NC 21 - kriege ich noch nicht.
Ich kann aber bestätigen: In 20.0.10 funktionieren die pdf auf Sambashares wieder.
Grüße
Michael

Hallo,

die Update-Strategie von Nextcloud ist ziemlich undurchsichtig. Ich habe 3 Instanzen auf 2 Servern laufen. Eine von zwei Instanzen auf Server 1 durfte ich schon vor Wochen auf 21.0.1 heben, die anderen beiden sind noch auf 20.0.9 . Vor vier Tagen kam dann die Info die beiden auf 20.0.10 updaten zu dürfen. Die Version auf Server 2 habe ich auf 20.0.10 problemlos angehoben. Gleich danach durch erneutes Prüfen im Backend durfte ich laut Anzeige auf 21.0.1 updaten. Bekommen habe ich aber auch Version 21.0.2 . Allerdings zum ersten Mal seit Version 14 mit richtig schwer wiegenden Problemen. Einige normal und schnell zu lösen, andere schwerwiegend und eines unlösbar aber unproblematisch für mich.

Wichtig ist, dass Version 21 mindestens PHP7.3 für die Nutzung von occ und cron benötigt. Da ein occ db:add-missing-indices notwendig wird, ist man mit Ubuntu 18.04 aufgeschmissen, da hier nur PHP7.2 drin ist. Bei mir glücklicherweise ein leicht zu lösendes Problem, da ich über ein Repository immer alle aktuellen PHP-Versionen auf Ubuntu 18.04 pflege und habe. Da alle Webservices über PHP-FPM laufen eigentlich auch kein Problem, da dabei das System-PHP auf 7.2 bleiben konnte - bis jetzt.
Über „update-alternatives --config php“ schnell die Standard PHP-Version für manuelle Nutzung auf PHP7.3 angehoben und das Problem war gelöst. Ich bin zwar kein Freund davon, die in der Ubuntu Version vorgesehene Standard-PHP zu überschreiben, aber ohne geht es mit Nextcloud 21 nicht weiter und bisher sind keine Probleme mit anderen Systemen aufgetaucht.
Schwerwiegender war jedoch, dass das Update dazu geführt hat, dass ich einen kompletten Speicherüberlauf hatte und der ganze Server in die Knie gegangen ist und fast unnutzbar wurde. Der notwendige Shutdown über ssh hat fast 15min gedauert, aber glücklicherweise geklappt.
Problem war hier die Nutzung von APCu in Nextcloud. Ich habe jetzt in allen PHP-Versionen auf meinem Server in die apcu.ini unter /etc/php/7.X/mods-available

apc.enable_cli = 1

angefügt. Alternativ geht das natürlich auch über die php.ini. Davon bin ich aber kein Freund, da ein mögliches Update der php.ini bei Ubuntu oder über das Repository mich dann zwingt meine manuellen Änderungen in die neue php.ini zu übernehmen. Deshalb kommen individuelle Anpassungen bei mir nie in die php.ini.
Da ich zur Speicherproblematik noch weitere Lösungen gefunden habe, habe ich diese auch gleich umgesetzt.
In die Nextcloud config.php habe ich

‚loglevel‘ => 2,
‚debug‘ => ‚false‘,

eingebaut. Beides soll zwar Standard sein, aber es schadet nicht. Deshalb habe ich es lieber eingetragen, statt den ganzen Server noch einmal in die Unbrauchbarkeit zu treiben.

Ein Problem lässt sich trotz extrem langer Nachforschung in unzähligen Foren bei mir nicht lösen. Nextcloud läuft bei mir unter aktuellem nginx und PHP8.0. Ich bekomme im Backend die Warnungen:

  • Dein Web-Server ist nicht richtig eingerichtet um „/.well-known/webfinger“ aufzulösen. Weitere Informationen findest Du in der Dokumentation.

  • Dein Web-Server ist nicht richtig eingerichtet um „/.well-known/nodeinfo“ aufzulösen. Weitere Informationen findest Du in der Dokumentation.

nicht weg, egal, was ich im vhost probiert habe. Ich nutze die App Social aber nicht, von daher habe ich mich schweren Herzens mit den Warnungen angefreundet und verzichte auf den grünen Haken.

Fazit:
Nextcloud Hub 21 ist zwar wünschenswert und ein weiterer Meilenstein, aber bei mir war dies seit Ewigkeiten, das erste Update, welches enorme Probleme mit sich gebracht hat und nicht nur Nextcloud sondern diesmal den ganzen Server in die Knie gezwungen hat.

VG
Steffen

2 Like

Hallo Steffen,
danke für die Zusammenfassung. Sollte vllt. in einen eigenen Thread
→ Update auf 21 ?

VG, Tobias

„normal“ war mal so, dass wenn man „Production“ ausgewählt hatte (das heißt jetzt „stabil“), dann wurde die nächste Major Version über die Weboberfläche erst zur Auswahl gestellt, wenn die zweite Teil-Version released war.
Wie schnell danach die Server upgedatet werden/worden ist immernoch irgendwie zufälllig oder eben lastverteilt geplant.

VG, Tobias

Hallo,

ich hab gestern Nacht auch mal das Update von 20.0.9 auf 20.0.10 (unproblematisch: keien Nacharbeiten) und dann auf 21 gemacht.

Dabei hatte ich genau den selben Spaß wie Steffen (Danke für deine Hinweise :slight_smile: ).
Hier jetzt meine Erfahrungen:

  1. nach dem Update soll man (wie so oft) den Befehl: sudo -u www-data php /var/www/owncloud/occ db:add-missing-indices
    ausführen: der dazu gestartete php Prozess wird von meinem Server nach ca. 10 Minuten gekillt, weil der SPeicher überläuft … Ich hab dann (nach ecosia Recherche) in der config.php der nextcloud die memcachezeile auskommentiert:
//  'memcache.local' => '\\OC\\Memcache\\APCu',

Dann lief das durch.

  1. Also blieben noch die immer wiederkehrenden well-known nörgeleien.
    Da hab ich (gefühlt) nach jedem major Update dran rumgebastelt.
    Meine Gedanken dazu:
  • es muss die rewriteengine von apache2 eingeschaltet sein. Also muss in der enabled-site drin stehen:
    AllowOverride All
    für das nextcloud Directory
  • dann muss man den Weg auspfriemeln den eine https Anfrage nimmt.
    Bei mir: https/meinesite/owncloud
    Mein Webroot: /var/www/
    Meine NC liegt in /var/www/owncloud/ (Historisch bedingt).
    Aber: meine site Definition hat eine permanente rewrite Regel: alles was auf /var/www/ zugreifen will, wird automatisch rewritten zu /var/www/owncloud/.
    Damit gil die .htaccess Datei im /var/www/owncloud/ Verzeichnis.
    Und damit sind meine Einträge darin
  RewriteRule ^\.well-known/carddav /owncloud/remote.php/dav/ [R=301,L]
  RewriteRule ^\.well-known/caldav /owncloud/remote.php/dav/ [R=301,L]
  RewriteRule ^\.well-known/webfinger /owncloud/index.php/.well-known/webfinger [R=301,L]
  RewriteRule ^\.well-known/nodeinfo /owncloud/index.php/.well-known/nodeinfo [R=301,L]

Das killt die Meldungen zu carddav und caldav, aber nicht zu webfinger und nodeinfo.
Damit die weg gehen, hab ich in meiner site Definition in /etc/apache2/sites-enabled/default-httpsirgendwasdingens noch drin stehen:

Redirect 301 /.well-known/carddav /owncloud/remote.php/dav
Redirect 301 /.well-known/caldav /owncloud/remote.php/dav
Redirect 301 /.well-known/webfinger /owncloud/index.php/.well-known/webfinger
Redirect 301 /.well-known/nodeinfo /owncloud/index.php/.well-known/nodeinfo

Das ist im globalen Bereich der sitedefinition: also nicht im owncloud Directory Bereich und es steht innerhalb des IfModule

Nach einem service apache2 restart waren die well-known (und sie sind mir „well-known“ diese Probleme) endlich weg.
Fast perfekt … aber, es gibt ja noch
3) „Dem Modul php-imagick fehlt die SVG-Unterstützung. Für eine bessere Kompatibilität wird empfohlen, es zu installieren.“
Da findet ecosia den Hinweis, man solle
apt install libmagickcore-6.q16-6-extra
machen: schade, war schon installiert. purge und reinstall hat auch nciht geholfen.
Jetzt gehe ich mal diesem Tread nach: hoffentlich hilft es:

LG

Holger

Hallo,

das SVG Problem hab ich nun auch behoben.

 apt purge php-imagick imagemagick
 apt install php-imagick imagemagick
a2enmod proxy_fcgi setenvif
a2enconf php7.4-fpm
systemctl reload apache2

LG

Holger

PS: … vergessen zu erwähnen: vor dem Upgrade auf nc 21 hab ich meinen Server von 18.04 auf 20.04 upgegradet per do-releas-upgrade

Hallo Holger,

zur Ergänzung: Bei mir wurde noch eine „Telefonangabe“ verlangt.

Einfach in /var/www/nextcloud/config/config.php

‚default_phone_region‘ =>‚DE‘,

einfügen.

Viele Grüße

Wilfried

Hallo Wilfried,

ja, genau.
Das hatte ich auch gemacht.
Man hätte sich natürlich gewünscht, dass die einfach in die Fehlerbeschreibung reinschreiben, was da in die config.php soll (und dass es darein muss) … aber naja: man hat ja immer viel zu wünschen …

LG

Holger

Hallo,

schon wirklich krass und völlig nebulös, wie das mit dem Erhalten der Updates bei NC läuft.
Über den Updater bekomme ich noch immer weder bei meiner privaten NC noch bei der der Schule NC 21 angeboten - installiert ist jedweils 20.0.10

Klar könnte ich den Umweg über manuellen Download gehen, aber dann hat man mit den ganzen Apps noch mehr Arbeit, weil man die alle auch manuell runterladen muss.

Also bleibt halt erst mal NC 20.

Viele Grüße
Steffen

Hallo Steffen,

bei mir wurde zunächst ein „Zwischenschritt“ als Update angeboten, ich weiß aber nicht mehr welcher. Nachdem ich dieses installiert hatte, kam direkt danach NC 21.

Viele Grüße

Wilfried

Hallo Wilfried,

ich habe ja auch auf 20.0.10 geupdatet und dann kam aber selbst bach dem x-ten Reload, es sei alles aktuell, also eben nix mit „es gibt 21.x“

Viele Grüße
Steffen