Nextcloud: Einbinden eines SMB / CIFS

#1

Hallo,

ich habe auf einem Ubuntu 18.04 eine Nextcloud 15 (neu) installiert. Die Cloud an sich und die LDAP-Anbindung funktioniert.
Das Einbinden der Home- und Tauschverzeichnisse hingegen funktioniert nicht.

  1. Nextcloud steht in orange
  2. Die Pakete libsmbclient, php-smbclient und smbclient sind installiert.
  3. Der IPFire ist so konfiguriert, das der Nextcloud-Server auf allen Ports auf alle Netze zugreifen darf (nur um hier Probleme auszuschließen)
  4. Auf der Konsole des Nextcloud-Servers kann ich mit
smbclient -N -L 10.16.1.1

alle shares auflisten lassen und mit

smbclient //10.16.1.1/ich -U ich

durch mein Home-Verzeichnis navigieren.
Ergo: die Firewall kann also nicht die Ursache sein, oder?

Einstellungen in der Nextcloud als Admin:

Externer Speicher: SMB / CIFS
Authentifizierung: Anmeldedaten in Sitzung speichern
Host: 10.16.1.1
Share: /shares
Entfernter Unterordner: leer
Domain: leer
Verfügbar für teachers(group)

Anmelden als Lehrer ich (wie in der Konsole): funktioniert nicht.

Was ich auch probiert habe: Nutzer dürfen selber externe Speicher einbinden und dann als Lehrer ich

Externer Speicher: SMB / CIFS
Authentifizierung: Anmeldedaten in Sitzung speichern bzw. alternative: Benutzername und PAsswort
Host: 10.16.1.1
Share: /shares bzw. /ich
Entfernter Unterordner: leer
Domain: leer

Auch kein Erfolg.

Hat jemand noch eine Idee?

Grüße,
Sven

#2

Hallo Sven,

Ich habe das gleiche Problem, und es geht noch einen Schritt weiter : ich kann zwar kein Lehrer-Share mounten, aber es funktioniert mit einem Schüler-Share in Nextcloud.

Ich habe es bei unserer letzten Tagung in Karlsruhe mit andere Admins angeschaut ( bei den es klappt ), wir haben alle Einstellungen ausprobiert, leider erfolglos.

Ich habe wirklich keine Ahnung, warum es scheitert, und dazu gibt es auch keine Fehlermeldung …
Es hilft dir nicht weiter, aber zumindest bist du nicht allein …

Gruß

Arnaud

#3

Hallo Arnaud,

ich habe das Problem für mich gelöst, ich hoffe, dass es dir auch hilft. Mit folgenden Einstellungen funktioniert es bei mir:

Tauschverzeichnisse:

Externer Speicher: SMB/CIFS
Authentifizierung: Anmeldedaten in Sitzung speichern
Host: 10.16.1.1
Share: /
Entfernter Unterorder: shares
Domain: meinDomäne

Home:

Externer Speicher: SMB/CIFS
Authentifizierung: Anmeldedaten in Sitzung speichern
Host: 10.16.1.1
Share: /
Entfernter Unterorder: $user
Domain: meinDomäne

Geändert habe ich also drei Dinge:

  • Als Share das Wurzelverzeichnis „/” angegeben
  • Unterordner genutzt
  • Domäne eingetragen

Grüße,
Sven

#4

Ja, vielen Dank :slight_smile:
Anscheinend hatte ich eine Kombination vergessen.

Gruß

Arnaud

#5

Hi Sven, hi Arnaud,
setting bei mir gleich: cloud in orange.
Folgendes funktioniert bei mir bei Admin

Externer Speicher: SMB/CIFS
Authentifizierung: Anmeldedaten in Sitzung speichern
Host: 10.16.1.1
Share: /$user
Entfernter Unterordner: 
Domain:
Verfügbar für teachers(group)

Der User muss (und kann) bei mir dann kein Share mehr einbinden.
Und es funktioniert so.

Vg, Tobias

#6

FYI: Ab NC 16 soll es folgendes geben:

Variablen für externen Speicher (LDAP stellt ‘$home’ bereit)

Finde das nicht in den changlogs, sondern nur hier:
grafik