Neues Linbo startet nicht auf alter Hardware

#1

Hallo,
Ich habe zwei Handvoll Toshiba-Notebooks, die dieses Schuljahr unsynchronisiert auf Medienwagen eingesetzt wurden. Nun würde ich die Geräte gerne einer neuen Verwendung zuführen.

Leider bleibt das neue Linbo hängen (direkt nach der Linbo-ASCII-Art und der Versionsangabe "starting version 237 - vgl Bild.)

Das alte Linbo (2.3.22-0) startet dagegen problemfrei durch.

In bin da leider total unbedarft, wie ich da nun vorgehe. Weiß nicht mal, was ich tun oder testen könnte…
Bitte um Hilfe. Grüße
Michael

#2

Hallo Michael,

welche Netzwerkkarten sind in den Rechnern verbaut? Es gibt Netzwerkkarten die nicht mit Linbo zusammen funktionieren, weil erforderliche Spezifikationen nicht eingehalten wurden.

Es gibt in solchen Fällen die Möglichkeit Linbo per bootfähigen Stick auf die Festplatte zu bringen. Das ISO-Image liegt auf dem Server unter /var/linbo/linbo.iso.

Gruß

Alois

#3

Hallo Alois,
Das ist zwar eine Atheros-Karte (mit denen gab es m.W. tatsächlich manchmal Probleme), aber die Geräte haben ja mit dem alten Linbo hervorragend funktioniert.

Zudem: Ich habe schon vom Linbo-Stick gestartet und auch da komme ich nicht bis in den Linbo-Screen. Auch nach Boot vom Stick bleibt Linbo nach der Ausgabe “Initializing Hardware…” stehen.

Bin gerade das Notebook nochmal gestartet und bin dabei über eine komische Bildschirmausgabe gestolpert.

Kann das sein, dass das mit grub zusammenhängt? Warum lädt der denn linbo64 und linbofs64?
Früher, als das noch mit pxelinux.cfg gemacht wurde, war da nix mit 64… Damals stand da:

LABEL linbo
KERNEL linbo
APPEND initrd=linbofs.lz vga=788 quiet splash 

Und das hat funktioniert…

Hier bin ich mit meinem Latein aber schon ziemlich am Ende und stochere im Nebel… Kann das die richtige Spur sein?

#4

Hallo Michael,

hast du es schon mit der Kernel-Option nomodeset in der start.conf versucht?

Andreas

#5

Hallo @sedding,

teste einfach mal die 32-bit Version.

Grüße
Manfred

#6

Hallo Michael,

haben die Dinger AMD Grafikkarten?
Mach mal folgenden Kernelparameter in die start.conf.
modprobe.blacklist=radeon

Bei mir ist das
KernelOptions = quiet splash modprobe.blacklist=radeon

Dann änderst du die /var/linbo/boot/grub/.cfg
wieder so, dass

 # ### managed by linuxmuster.net ### 

drin steht

und dann machst du
import_workstations

Danach Client booten und schauen, ob linbos Grafische Oberfläche erscheint.

LG

Holger

#7

Lieber Michael,

ich häng mich mal dran, da ich das Problem selbst hatte und damals dann das las:

Das Problem lässt sich also vermutlich mit der von Holger vorgeschlagenen Weise lösen.
Achtung: Ohne den Eintrag

# ### managed by linuxmuster.net ### 

wie von Holger vorgeschlagen ändert ein import_workstation die grub.cfg nicht ab (!)
Daher ist das wichtig, auch die Reihenfolge !

Viele Erfolg,
Christoph G.

#8

Vielen Dank an alle Mitdenker und Holger / Christoph für die richtige Lösung!
Habe das gestern ausprobiert und ja - es lag an den Grafiktreibern.

Grüße und ein schönes Wochenende
Michael