LINBO -> NVME wird nicht erkannt

Hallo Zusammen,
ich möchte aktuell an einer LMN7.0 ein HP 250 G8 mittels Linbo „betanken“.
Das Problem ist allerdings, dass in Linbo die NVME nicht erkannt wird (obwohl in start.conf hinterlegt, dass es eine NVMe sein soll).

Das Gerät besitzt einen Intel i5-1135 sowie eine Hynx NVME (genauen Typ kann ich nachreichen wenn notwendig).

~ # lspci -k
00:17.0 Class 0880: 8086:09ab
00:08.0 Class 0880: 8086:9a11
00:15.1 Class 0c80: 8086:a0e9
00:1f.0 Class 0601: 8086:a082
02:00.0 Class 0280: 10ec:c822
00:1d.1 Class 0604: 8086:a0b1 pcieport
00:04.0 Class 1180: 8086:9a03
00:16.0 Class 0780: 8086:a0e0
01:00.0 Class 0200: 10ec:8168 r8169
00:1f.5 Class 0c80: 8086:a0a4
00:1e.0 Class 0780: 8086:a0a8
00:1f.3 Class 0401: 8086:a0c8
00:00.0 Class 0600: 8086:9a14
00:15.0 Class 0c80: 8086:a0e8
00:1d.0 Class 0604: 8086:a0b0 pcieport
00:0e.0 Class 0104: 8086:9a0b
00:1e.3 Class 0c80: 8086:a0ab
00:14.2 Class 0500: 8086:a0ef
00:02.0 Class 0300: 8086:9a49
00:14.0 Class 0c03: 8086:a0ed xhci_hcd
00:1f.4 Class 0c05: 8086:a0a3 i801_smbus
~ # ls /dev
bus input random tty11 tty20 tty3 tty39 tty48 tty57 tty9 vcsu2
char kmem rtc tty12 tty21 tty30 tty4 tty49 tty58 urandom vga_arbiter
console kmsg rtc0 tty13 tty22 tty31 tty40 tty5 tty59 vcs vmci
core lightnvm stderr tty14 tty23 tty32 tty41 tty50 tty6 vcs1 zero
cpu mem stdin tty15 tty24 tty33 tty42 tty51 tty60 vcs2
cpu_dma_latency null stdout tty16 tty25 tty34 tty43 tty52 tty61 vcsa
fb0 port tty tty17 tty26 tty35 tty44 tty53 tty62 vcsa1
fd psaux tty0 tty18 tty27 tty36 tty45 tty54 tty63 vcsa2
full ptmx tty1 tty19 tty28 tty37 tty46 tty55 tty7 vcsu
fuse pts tty10 tty2 tty29 tty38 tty47 tty56 tty8 vcsu1
~ # fdisk -l
~ #

Auch fdisk zeigt keine NVMe an.

Ich vermute, dass die Ursache im Intel Optane / VMD-Controller liegt. Hier kenne ich das Problem auch von anderen Herstellern. Dort kann man den „VMD Controller“ im BIOS deaktivieren. - nur leider - kann ich es bei diesen HPs nicht deaktivieren.

  • Ubuntu 20.04 von Stick lässt sich problemlos booten. Dort kann man auf die NVMe zugreifen. Habe Sie auch mal „genullt“, schuf aber keine Abhilfe.
  • Folgende Kernel-Optionen schufen keine abhilfe:
    nvme_load=YES nvme_core.default_ps_max_latency_us=0

Hat jemand noch eine Idee, was man machen könnte, damit Linbo die NVME erkennt?
Gibt es alternative möglichkeiten, wie ich die Notebooks sonst in Linbo/die LMN aufnehmen kann?

Hallo,

welche linbo Version wird den verwendet?

Bisher hab ich noch nicht erlebt, dass eine nvme nicht erkannt wurde…

LG

Holger

Hallo Holger,
root@server:/srv/samba/schools/default-school/teachers/testlehrer# apt list --installed | grep linbo

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

linuxmuster-linbo-common7/lmn7,now 2.4.3-4 all [Installiert,automatisch]
linuxmuster-linbo7/lmn7,now 2.4.3-4 all [Installiert,automatisch]

es wird Linbo 2.4.3-4 verwendet.
Timo

Hallo Timo,

schau mal hier, vielleicht hilft das:

LG

Holger

Hallo Holger,
eine Option um den VMD-Controller im BIOS zu deaktivieren hat das Notebook leider nicht. War auch meine erste Vermutung. Laut HP-Support, hat das Gerät keinen VMD-Controller - ich dachte aber, der muss vorhanden sein bei Intel Optane (bin aber nicht sicher)

danke schon mal,
Timo

Hallo Holger,
hast du vielleicht sonst eine Idee, wie ich die Geräte mit Linbo austatten könnte? Gibt es ggf. alternative Möglichkeiten um die Geräte in die LMN aufzunehmen?
Oder hast du noch andere Ideen, was ich machen könnte das die NVMe von Linbo erkannt wird?
Timo

Hallo Timo,

sehe ich das richtig, dass das Problem ist, dass der Controler im properitären Optane Modus betrieben wird und die SSD deswegen nicht ansprechbar ist.
Der Modus ist im BIOS nicht umschaltbar.

Zwei Wege sehe ich an dieser Stelle:

  1. neustes BIOS einspielen und Daumen drücken,d ass das KOnfigurierbar wird
  2. neustes linbo 4.0.0rc5 probieren mit neuerem kernel

Das 4er Linbo läuft bei mir und bei Thomas schon produktiv. Es ist kein „rund neu erfundenes“ linbo, es werden nur ein paar Sachen anders geregelt: es gibt ein neues Image Format (qcow2 statt cloop) was man bedenken muss, weil das neue linbo nur noch qcow2 schreiben will beim Image erstellen. Man muss dann also vor dem ersten Image erstellen in der start.conf den Namen der Imagedatei von …cloop in …qcow2 ändern.
Und linbo legt nun die Images nicht mehr in /srv/linbo/ ab sondern in /srv/linbo/images//

Einzige weitere Option wäre: nochmal suchen ob es nicht doch einen kernelappendswitch gibt, der optane zugänglich macht.

LG

Holger