Linbo Hardware-Init bei Mini-PC (dig. schwarzes Brett) schlägt fehl

hi,
totaler lm7 beginner, bitte dies bei antworten zu berücksichtigen. kann clients und router richtig eintragen in schulkonsole und opensense für einbindung ins system. ein mini-pc hängt sich aber auf, es steht noch linbo initialising hardware. in schulkonsole bei pxe eingetragen: kein pxe. ist die sophomorix-rolle von bedeutung? hatte hier schon lehrer-pc und thin-client.
das gerät meldet beim booten yukon pxe 6.65… pc ist von 2013:
AMDTMA4-3310MX

hat hier jemand tipps für weiteres vorgehen?

gruß
h.

Hallo Hendrik,

totaler lm7 beginner, bitte dies bei antworten zu berücksichtigen. kann
clients und router richtig eintragen in schulkonsole und opensense

wieso in opnsense?
Wo trägst du da einen Clinet ein?

für
einbindung ins system. ein mini-pc hängt sich aber auf, es steht noch
linbo initialising hardware. in schulkonsole bei pxe eingetragen: kein
pxe. ist die sophomorix-rolle von bedeutung? hatte hier schon lehrer-pc
und thin-client.
das gerät meldet beim booten yukon pxe 6.65… pc ist von 2013:
AMDTMA4-3310MX

hat hier jemand tipps für weiteres vorgehen?

das ist einfach: du hast ja dazu geschrieben, dass es ein AMD ist: also
eine AMD GraKa: da startet die linbo Oberfläche nicht.
Der Cleint hat sich nicht aufgehängt: der läuft wunderbar.
Du erreichst ihn auch per linbo-remote
oder
linbo-ssh

Willst du auch die GUI am Client, dann mußt du in die
start.conf. in der er ist, folgende Änderung machen:
aus:
KernelOptions = quiet splash
machst du
KernelOptions = quiet splash modprobe.blacklist=radeon

Danach
linuxmuster-import-devices

Wenn du dann den Client startetst, dann funktioniert er.

Das geht natürlich erst, wenn er am Server schon aufgenommen ist.
Ist er das noch nicht, dann boote ihn per PXE und drück auf Pause, wenn
die MAC Adresse da steht.
Die nimmst du und trägst sie in die
/etc/linuxmuster/sophomorix/default-school/devices.csv ein, gefolgt von
obigem import-devices Befehl.
Danach gibt es die start.conf.

LG

Holger

Danke. Soweit verstanden, wo finde ich die start.conf? Gibt es mehrere?
Die MAC steht schon im Server. In der Opensense habe ich in einer schon angelegten noproxy Gruppe die mit der MAC verbundene IP eingetragen.

Hallo Hendrik,

Die findest Du auf dem Server unter /srv/linbo, Du kannst die Einstellungen aber auch in der WebUI unter Linbo vornehmen.

Viele Grüße,
Jochen

hi jochen und holger
also, ich glaube ich verstehe hier manches verhalten garnicht. die fakten nochmal:
-das schwarze brett (im folgenden sb abgekürzt) soll kein linbo bekommen, deshalb „no-pxe“

  • mac-adresse und vergebene ip mehrfach gecheckt.
  • in /srv/linbo finde ich für jeden pxe-client eine start-conf, also für das sb keine
  • in der devices.csv lautet der eintrag:
    aula;vertretungsplan-aula;nopxe;1C:5A:3E:EC:4C:47;10.0.251.1;;;;staffcomputer;;0;;;;;
  • wenn das sb bootet, meldet sich aber trotzdem linbo…?? muss man hier ins bios von der kiste und pxe abschalten? könnte das der grund sein? das ist leider eine riesenkiste an der wand, komme ich nicht ran. könnte man irgend eine .conf von einem anderen pxe-client kopieren, die änderung machen um dem sb unterjubeln?

übrigens verzweifle ich am anderen schwarzen brett (wlan über fritzbox, win7), das bekommt durch irgend ein skript oder einen geplanten dienst alle 5min eine netzwerkeinstellung untergejubelt, so dass meine händische konfig überschrieben wird. :-/

Hallo Hendrik,

Falls Du eine Alternative suchst, kann ich Dir Porteus Kiosk nahelegen. Das ist ein kostenloses Kiosk-OS, welches man per Wizard konfigurieren kann, so dass ein Vollbildbrowser nur eine Webseite angezeigt und sonst nix gemacht werden kann.
Falls Du aber die originale Software des Boardherstellers zur Anzeige von Bildschirminhalten benötigst, reicht Porteus alleine nicht aus, da die Webseitenanzeige von dem Viewer der originalen Software des Boardherstellers aufbereitet wird. Es gibt aber viele alternative Ansätze, um proprietäre Anzeigesoftware los zu werden. Bei mir läuft das mittlerweile so, dass WebUntis in der Verwaltung eh eingesetzt wird und das dann die Vertretungsplananzeige als Webseite aufbereitet. Ein Display mit der Funktion eine Webseite anzeigen zu können, zeigt diese dann an.

Such mal im Forum hier nach ‚porteus‘, dann findest Du ein bisschen was dazu und auch andern Ansätzen, z.B:

Gruß
Stefan

P.S: Bei mir läuft die Mensa-Online-Buchung seit vielen Jahren problemlos auf drei solchen Porteus-Clients (noch mit 32bit). Das einzige Problem ist mittlerweile, das das Display von 2 Lenovo-T60-Laptopclients mittlerweile zu klein ist (1024x768) um die ganze Webseitenbreite anzuzeigen.

Hallo Hendrik,

-das schwarze brett (im folgenden sb abgekürzt) soll kein linbo
bekommen, deshalb „no-pxe“

nopxe kenne ich als „Schalter“ in der devices.csv nicht.

  • mac-adresse und vergebene ip mehrfach gecheckt.
  • in /srv/linbo finde ich für jeden pxe-client eine start-conf, also
    für das sb keine
  • in der devices.csv lautet der eintrag:
    aula;vertretungsplan-aula;nopxe;1C:5A:3E:EC:4C:47;10.0.251.1;;;;staffcomputer;;0;;;;;

Eine Zeile für einen „nur IP“ Client sieht bei mir so aus:

srv;bzups;lwl;00:C0:B7:7F:CF:CE;10.16.1.2;—;---;1;iponly;—;0;;;;MIGRATION;1

Dein Eintrag „nopxe“ ist im Feld der Hardwareklasse: deswegen wird auch
eine start.conf.nopxe erstellt.

  • wenn das sb bootet, meldet sich aber trotzdem linbo…?? muss man hier
    ins bios von der kiste und pxe abschalten?

… klar schaltet man PXE ab, wenn man es nicht braucht …
aula;vp-

könnte das der grund
sein? das ist leider eine riesenkiste an der wand, komme ich nicht
ran. könnte man irgend eine .conf von einem anderen pxe-client
kopieren, die änderung machen um dem sb unterjubeln?

normalerweise sagt die „0“ im zweiten Feld nach dem iponly (bei mir),
dass es ein „nichtPXE“ Client ist.

Ändere mal deine Zeile zu:

aula;vertretungspl;1C:5A:3E:EC:4C:47;10.0.251.1;;;;iponly;;0;;;;;

übrigens verzweifle ich am anderen schwarzen brett (wlan über fritzbox,
win7), das bekommt durch irgend ein skript oder einen geplanten dienst
alle 5min eine netzwerkeinstellung untergejubelt, so dass meine
händische konfig überschrieben wird. :-/

… ja, so ist das dsb: alles irgend wie vergossen.
Ich hab für die DSBs der Realschule, die die ohne meinen Rat angeschafft
haben, ein eigenes Netz mit eigenem DSL Anschluss (hab ja zwei T@SCHOOL,
weil wir zwei Schulen sind).
Denn die Dinger bestehen auf 192.168.1.x (so in etwa): was anderes
können die nicht (sind halt echte Profis…).

LG

Holger