Linbo bootet nicht lokal / uefi

Hallo!

Ich versuche gerade ein Lenovo Tablet der Serie X1 in unser System aufzunehmen.

Zunächst schien alles recht gut zu laufen:
Am Client SecureBoot deaktiviert,
Eine neue start.conf aus den examples generiert und entsprechend den Vorgaben für die Samsung nvme-Platte angepasst (nvme0n1p1, usw.):

Rechner startet via EthernetUSB-Adapter aus dem Netz, lädt Linbo, lässt sich einwandfrei partitionieren.

Bevor ich nun mit der Windows-Installation loslegen wollte, teste ich, ob der Rechner linbo auch lokal bootet: Fehlanzeige!

Die Platte ist im BIOS auf bootable gesetzt. Leider finde ich sonst keine Einstellungen dort, die mir hilfreiche scheinen.

Eine Fehlermeldung gibt’s beim Linbo-Start per PXE:

ACPI Exception: AE_BAD_PARAMETER, Could not install PciConfig handler fro Root Bridge PCI0 (20170728/evrgnini-245)

aber der scheint wohl gar nicht gravierend zu sein??
https://ask.linuxmuster.net/t/linbo-acpi-exception/4246

Ich nehme ja auch schwer an, dass es irgendwas damit zu tun hat :slight_smile:
https://ask.linuxmuster.net/t/warnung-vor-lenovo/3597
Aber mir ist nach Lesen des Artikels trotzdem nicht ganz klar, ob und wie mir das hilft.

Hat jemand Ideen? Will ungern einen Haufen Installationsarbeit investieren, wenn ich die Geräte nachher nicht einsetzen kann und bei dem Problem, ob ich hier überhaupt imagen kann (siehe Lenovo MIIX) bin ich noch gar nicht

Gruß
Martin

Hallo Martin,

bis das erste Image auf dem PC installiert ist, muss Linbo immer über Netzwerk gestartet werden. Erst mit einer Synchronisation wird Linbo auf dem Client eingebaut.

Nimm am besten die Doku zur Hand : https://docs.linuxmuster.net/de/latest/clients/windows10clients/index.html
Die ist LMN7 sollte aber aber auch für LMN6 gehen :

  1. Weiter um die Installation abzuschließen.
  2. Windows startet automatisch neu. Um jedoch das installierte Windows nun wieder über LINBO zu starten, sollte gegebenenfalls der Bootorder so umgestellt sein, dass als erstes vom Netzwerk (PXE) gebootet wird und nicht über ein anderes Medium gebootet wird.
  3. Im LINBO-Menü nun Windows unsynchronisiert über den GRÜNEN Startknopf starten (nicht rot oder orange):

Viele Grüße,
Helge

Hallo Helge,

Danke für die Nachhilfe :flushed: :slightly_smiling_face:

Wieder was gelernt. Immerhin bin ich nun sehr hoffnungsvoll, dass
das jetzt reibungslos klappt!

Ich bericht nächste Woche, obs auch klappt, das Image auch wieder zurückzuspielen.

Grüße
Martin

Kleine Anmerkung an Rande:

Es gibt aber auch eine Alternative wenn es so absolut nicht will. Das Tool der Wahl ist dann die Linbo-CD.

Beste Grüße

Thorsten

So nun bin ich weiter oder auch irgendwie nicht.

Habe versucht ein neues Windows zu installieren. Soweit so gut.
Richtige Partition ausgewählt, Installation von Stick begonnen, bis zum ersten Neustart gewartet.

Leider startet das Windows nun aber nicht über Linbo. Linbo versucht zwar, das Betriebssystem zu laden, scheitert aber.

Dann habe ich mich daran erinnert, dass wir aus älteren Versuchen noch ein Uefi-Windows auf dem Server liegen haben. Das in die start.conf eingefügt und versucht es auf den Rechner zu bügeln.
Hier gelingt es grub nun das Image zu starten. Leider zunächst Bluescreen. Windows startet nicht.
Reparatur funktioniert nicht auch nach mehrmaligem Versuch.

Linbo startet auch jetzt nicht lokal, obwohl das ja eigentlich jetzt klappten sollte.

Zufällig kam es dann dazu, dass der Rechner startete ohne, dass ich den Bootstick und das Netzwerkkabel eingesteckt war. Nun startete das Windows!
Mein zwei Jahre altes Image war da.

Meine Frage: Könnte der Trick, den Holger hier beschrieben hat mein Problem lösen,
oder ist es doch eher was anderes.

https://ask.linuxmuster.net/t/warnung-vor-lenovo/3597

Zweite Frage:
Könnte mir das Problem auch einfach egal sein, ich pflege mein Image, lade es auf den Server und ignoriere, dass linbo nicht lokal bootet. Die Rechner starten einfach immer das Windows und nur zur Wartung hänge ich sie ans Netzwerk. Oder handele ich mir da weitere Probleme ein?

Danke fürs Mitdenken!

Gruß
Martin

Hallo Martin,

Meine Frage: Könnte der Trick, den Holger hier beschrieben hat mein
Problem lösen,
oder ist es doch eher was anderes.

Warnung vor Lenovo

nein, das klingt sehr nach genau jenem Problem.

Zweite Frage:
Könnte mir das Problem auch einfach egal sein, ich pflege mein Image,
lade es auf den Server und ignoriere, dass linbo nicht lokal bootet. Die
Rechner starten einfach immer das Windows und nur zur Wartung hänge ich
sie ans Netzwerk. Oder handele ich mir da weitere Probleme ein?

ich sehe da keine Probleme auf die zukommen.
Du kannst die Clients halt nicht „offline“ zurücksetzen.

Aber: untersuch das mal genauer.

  1. welche Verzeichnisse gibt es in der FAT32 formatierten efi Partition
    unterhalb des Ordners EFI ?
  2. was steht den in der Bootreihenfolge im BIOS?
  3. welche Einträge tauchen dort noch aus?

normalerweise steht da „Windows bootmanager“, sobald Windows installiert
ist (also das EFI/microsoft/ Verzeichnis vorhanden ist) aber nachdem
linbo drauf ist, sollte dort auch „grub“ auftauchen, weil es dann das
Verzeichnis EFI/grub/ in der Fat32 Partition geben sollte.

Du kannst ja auch mal meien Tricks aus dem anderen Tread probieren:
umbennenen von grub zu redhat

LG

Holger

Hallo Holger,

Dort findet sich folgendes:

/Boot/bootx64.efi

/Microsoft/ … /bootmgr.efi

/grub/grubx64.efi

Im BIOS habe ich die Bootreihenfolge angepasst (Netzwerkboot, Festplatte, …, USB-Optionen)
und die Option BootorderLock eingeschaltet.

Es gibt dort auch den Eintrag Windows Bootmanager, diese Option kann man zwar explizit auf „Off“ stellen, das führt aber nicht dazu, dass der Eintrag aus der Bootreihenfolge verschwinden würde.

Außerdem gibt es noch einen Schalter „Delete Windows BootOption“. Der ändert aber auch nichts am
Bootverhalten von Linbo. Der Windows BootManager verschwindet dann lediglich aus der BootOrder.

Ich habe dann deine Trick ausprobiert mit der Umbenennung. Leider hat das keinen Effekt. Es taucht auch kein neuer Eintrag im BIOS auf.

Irgendwie denke ich, es muss auch an was anderem liegen. Denn das Image wird ja nun via Linbo gestartet, nur dass via Linbo das Windows eben nicht startet.

Ich werde jetzt mein Image mal aktualisieren und auf den Server laden. Wenn das funktioniert
werde wir einfach erstmal ohne lokalen Boot und Offline-Zurücksetzen leben.

LG
Martin