Lenovo T430 in LMN7

Hallo,

hat jemand Lenovo T430 Laptops im der LMN7 eingebunden?

Ich habe Probleme, dass die Hardware von LINBO nicht richtig erkannt wird und der Prozess endet immer mit:
[1] Reboot oder [2] Shutdown

Die Geräte laufen mit SATA-SSD und BIOS.
Meine Startparameter von LMN6.1 bringen leider auch nichts.

Für eine funktionierende Konfiguration wäre ich dankbar!

Mit besten Wünschen
Stefan

Hallo Stefan,

Ich habe Probleme, dass die Hardware von LINBO nicht richtig erkannt
wird und der Prozess endet immer mit:
[1] Reboot oder [2] Shutdown

Das ist bisher immer ein Netzwerkproblem gewesen.
Nimm mal
dhcpretry=9

ich hab T420 am laufen.

LG

Holger

Das Problem hängt in der Regel damit zusammen, dass der Rechner Linbo gestartet hat aber die GUI nicht nachladen konnte.
Die neue Linbo Gui wird separat nachgeladen. Einfach mal einen Ping auf die IP des entsprechenden Clients machen, wahrscheinlich wirst du hier sehen, dass nach dem Download des Linbo Images und starten von Linbo kein Ping mehr möglich ist.

Holger liefert hier die passende Lösung. Alternativ könnte auch ein Netzwerktreiber fehlen - bei einem so alten Gerät aber sehr sehr unwahrscheinlich :slight_smile:

Danke für die Tipps, die das Problem gleich richtig verorten.

Tatsächlich wird die LINBO-GUI nicht auf den Client geladen, die letzten Meldungen vor der Reboot-Aufforderung sind (nur im abgefilmten Video erkennbar):

Succesfully mounted Cache partition
Fatal: Cannot read network infos. Continuing offline.
Failed to install linbo-gui from cache

Das System ist noch ganz frisch - mein Server ist bei netzint - und die Übergabe noch nicht erfolgt. Ich kann z. Zt. aber schon erste Tests mit einigen Testclients über die Schulkonsole machen.
Daher habe ich von einem Client das T430 gepingt während es startete. Der Ping kommt direkt nach dem Erhalten der ersten IP 2x durch (das Gerät ist schon in workstations aufgenommen) und sonst nie.

dhcprety stand auf 30 - jetzt auf 90 - hilft leider nix.
Andere Geräte konnte ich mit LINBO bespielen z.B. HP dc7700, HP Elite 8300)
Fehlt doch der Treiber?

Für weitere Tipps dankbar - oder hat jemand sogar eigene T430 am laufen?

Gruß
Stefan

Hallo Stefan,

Das System ist noch ganz frisch - mein Server ist bei netzint - und die
Übergabe noch nicht erfolgt. Ich kann z. Zt. aber schon erste Tests mit
einigen Testclients über die Schulkonsole machen.

… des hab i jetzt net gerafft …
Der Server steht noch bei Netzint aber du machst schon mal tests? …

Daher habe ich von einem Client das T430 gepingt während es startete.
Der Ping kommt direkt nach dem Erhalten der ersten IP 2x durch (das
Gerät ist schon in workstations aufgenommen) und sonst nie.

dhcprety stand auf 30 - jetzt auf 90 - hilft leider nix.

30 ? … so eine hohe Zahl hab ich noch nie gesehen: das würde den boot
ja um 30 Sekunden verlängern.
Nee: 8 ist normal und 12 nimmt man mal für ein initiales Testen.

Poste doch mal die
start.conf.t430
und die /srv/linbo/boot/grub/t430.cfg

Ist der Server migriert?
Was steht den nahc einem Durchlauf von linuxmuster-import-devices in der
Zeile der Hardwareklasse?
keeping cfg oder renewed (oder so).

verschieb mal die start.conf.t430
und setz eine frische aus /srv/linbo/examples/ hin
und dann import
und dann Client mit F12 booten

Und wenn das alles nicht hilft, dann mach danach noch die Platte platt:
bisweilen kam es vor, dass sich linbo an einer noch vorhandenen
start.conf auf dem Client verschluckt.

LG

Holger

Danke für die Tipps,

die ich bald probieren und dann hier berichten werde!

Meine Info war wohl zu verkürzt.
Mein LMN7-Server steht nicht bei mir in der Schule, sondern ist ausgelagert. Das hat netzint gemacht und wird auch von netzint betreut :smiley:
Momentan kann ich schon auf die Schulkonsole online zugreifen und erste Client-Tests bei mir im Hause machen, mehr geht dann in Kürze…

Gruß
Stefan

P.S: Heißt dhcpretry=30 wirklich, dass die ganze Zeit verwendet wird,
oder nur dass maximal 30 Sek. Zeit für DHCP eingeräumt wird, aber sobald die IP bezogen sofort weiter gemacht wird?

Hallo Stefan,

P.S: Heißt dhcpretry=30 wirklich, dass die ganze Zeit verwendet wird,
oder nur dass maximal 30 Sek. Zeit für DHCP eingeräumt wird, aber sobald
die IP bezogen sofort weiter gemacht wird?

meinem Gefühl nach: der wartet das ab: die ganzen angegebene Zeit.

LG

Holger

Nein das ist falsch, sobald der Client eine IP hat, startet er durch. Wichtig ist das ganze für Notebooks welche ohne Netzwerkkabel starten sollen. Diese warten 30 Sekunden ab bis es offline weiter geht.

Hallo zusammen,

Wichtig ist das ganze für Notebooks welche ohne Netzwerkkabel starten sollen. Diese warten 30 Sekunden ab bis es offline weiter geht.

So ist das in der Tat. Aber warum eigentlich? Ohne Kabel (und das wissen die Computer ja heutzutage) ist es doch kompletter Blödsinn, überhaupt DHCP zu versuchen. Weiß jemand, warum das so ist?

Beste Grüße

Jörg

Wahrscheinlich, weil es so programmiert wurde :thinking:

Wieso? Kabel können kaputt gehen oder irrtümlich an falsche Dosen/Ports gesteckt werden. Das macht das Softwareverhalten ja nicht gleich zu Blödsinn.

Hallo Buster,

der Parameter an sich ist schon sinnvoll. Wenn ein Kabel steckt, dann kann es immer noch lange dauern.

Was ich meine: Wenn kein Kabel steckt, dann wird DHCP garantiert nicht klappen. Das sollte der DHCP-Client merken und sofort aufgeben. Zumindest wäre das ein sinnvolles Standardverhalten.

Nun habe ich aber ein wenig recherchiert: Offenbar ist das Konzept, dass andere Komponenten dafür zuständig sind zu erkennen, ob überhaupt eine physikalische Verbindung besteht Die starten dann den dhclient oder eben nicht.

Unter Linbo könnte man z. B. unter /sys/class/net die vorhandenen Interfaces suchen und dann z. B. mit cat /sys/class/net/eth0/carrier feststellen, ob ein Kabel steckt. Wäre vielleicht mal ein FR.

Beste Grüße

Jörg

Moin,

Meine Erfahrung mit Linbo ist ja schon ein paar Jahre alt … Damals haben die Kolleg:innen sich auch bei den Rechnern am LAN am zweimaligen Start von Linbo gestört. Die Lösung war GRUB so einzustellen, dass gleich das OS gestartet wurde. Eine Synchronisation konnte so nur der Benutzer erzwingen, wenn er Probleme hat. Die hätte den Kolleg:innen -mit konventionellen HDDs- erst recht zu lange gedauert. Wenn ich ein neues Image verteilen wollte, hab ich temporär wieder eingestellt, dass Linbo gestartet wird. Dieses Vorgehen war besonders für die Notebooks im WLAN hilfreich.
Heute mache ich erst mit OPSI bei denen auch so, dass Updates nicht automatisch zugewiesen werden. OPSI funktioniert zwar via WLAN, aber in Praxis fehlt dann -verstandlicherweise- die Bereitschaft die Installation beim Herunterfahren abzuwarten. So kommt dieser Vorteil von OPSI bei Notebooks leider nicht zum Tragen. Ich bau die Notebooks für Updates also außerhalb der Unterrichtszeit raumweise auf und lass sie updaten. Wenigstens muss ich sie dazu nur an Strom anschließen und einschalten.

Gruß Jürgen

Hallo zusammen und Danke für die Tipps!!!

Ich habe die T430 bis jetzt immer noch nicht ans Laufen bekommen. Ich könnte nochmal Hilfe benötigen, was ich nun am besten noch probieren kann.

Ich habe daher alles zusammengefasst.

Fehler:
Die LINBO-GUI startet nicht und es gibt weiterhin die letzten Meldungen vor der Reboot-Aufforderung sind (nur im abgefilmten Video erkennbar):

Succesfully mounted Cache partition
Fatal: Cannot read network infos. Continuing offline.
Failed to install linbo-gui from cache
und danach
[Press [1] to reboot oder [2] to shutdown bei Offline Boot
so wie auch in dem anderen Thema, was zur Zeit läuft:

Fakten zum T430-Client:
Ca. 4 verschiedene T430 getestet, die in der LMN6 problemlos laufen, außerdem: „…habe ich von einem Client das T430 gepingt während es startete. Der Ping kommt direkt nach dem Erhalten der ersten IP 2x durch (das Gerät ist schon in workstations aufgenommen) und sonst nie.“
=> defekte Netzwerkkarte ist wohl auszuschließen
Festplatten vorher mit gparted komplett gelöscht um LMN6-Reste auszuschließen
=> kein Problem mit LMN6-Resten
Hier die Ausgabe von lspci auf einem T430:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 7 Series/C210 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
02:00.0 System peripheral: Ricoh Co Ltd PCIe SDXC/MMC Host Controller (rev 07)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

=> „Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 04)“
und
„Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)“
finde ich da.
Hat jemand eine Ahnung, ob der Controller der LAN-Buchse in LINBO unterstützt wird?
Mittlerweile habe ich wirklich den Netzwerktreiber in Verdacht, der bei LINBO fehlen könnte.
Wie könnte man das am besten herausfinden?

Fakten zum Anschluss der T430:
Alle anderen Clients mit unterschiedlicher Hardware (HP dc7700, HP Elte 8300, FuSI Celsius W360, Lenovo T60 etc.) funktionieren in der selben Hardwareklasse, am selben Netzwerkkabel angeschlossen wie die T430 problemlos.
Habe auch mal eine neue Hardwaregruppe für die T430 angelegt und (nach Geräteimport) weiter probiert, aber mit selben Erfolg
=> keine defekte start.conf

Aber zur Vollständikkeit hier mal die start.conf:

[LINBO]
Server = 10.1.0.1
Group = mgb_mint-una_bios_sata
Cache = /dev/sda2
RootTimeout = 600
AutoPartition = no
AutoFormat = no
AutoInitCache = no
DownloadType = rsync
GuiDisabled = no
UseMinimalLayout = no
Locale = de-DE
BackgroundColor = 394f5e
BackgroundFontColor = white
ConsoleFontColorStdout = lightgreen
ConsoleFontColorStderr = orange
SystemType = bios64
KernelOptions = dhcpretry=30 server=10.1.0.1
clientDetailsVisibleByDefault = yes

[Partition]
Dev = /dev/sda1
Label = ubuntu
Size = 30G
Id = 83
FSType = ext4
Bootable = yes

[Partition]
Dev = /dev/sda2
Label = cache
Size = 
Id = 83
FSType = ext4
Bootable = yes

[OS]
Name = Linux Mint Una XFCE
Version = 
Description = Ubuntu 18.04
IconName = mint.svg
Image = 
BaseImage = mgb_mint-una_bios_sata.cloop
Boot = /dev/sda1
Root = /dev/sda1
Kernel = boot/vmlinuz
Initrd = boot/initrd.img
Append = ro splash
StartEnabled = yes
SyncEnabled = yes
NewEnabled = yes
Autostart = no
AutostartTimeout = 5
DefaultAction = start
RestoreOpsiState = no
ForceOpsiSetup = 
Hidden = yes

und hier noch die cfgDatei unter /srv/linbo/boot/grub

# global part of group specific grub.cfg template for linbo net boot
# thomas@linuxmuster.net
# 20210202
#

# if you don't want this file being overwritten by import_workstations remove the following line:
# ### managed by linuxmuster.net ###

# edit to your needs
set default=0
set timeout=0
set fallback=1

set gfxmode=auto
set gfxpayload=keep

insmod all_video
insmod png
insmod gfxterm
insmod gfxmenu
insmod minicmd
insmod progress

terminal_output gfxterm

background_color 42,68,87

# 32bit pae, non pae or 64bit kernel
if cpuid -l; then
 set linbo_kernel=/linbo64
 set linbo_initrd=/linbofs64.lz
elif cpuid -p; then
 set linbo_kernel=/linbo
 set linbo_initrd=/linbofs.lz
else
 set linbo_kernel=/linbo-np
 set linbo_initrd=/linbofs-np.lz
fi

# theme settings (modify for custom theme)
set theme=/boot/grub/themes/linbo/theme.txt
export theme

clear

# find linbo cache partition
set cachelabel="cache"
if [ -n "$cachelabel" ]; then
  search --label "$cachelabel" --set cacheroot
fi
if [ -z "$cacheroot" ]; then
  search --file /start.conf --set cacheroot
fi
if [ -z "$cacheroot" ]; then
  search --file "$linbo_initrd" --set cacheroot
fi
if [ -n "$cacheroot" ]; then
  set root="$cacheroot"
else
  set root="(hd0,2)"
fi

# linbo part, boot local or net (default #0)
menuentry 'LINBO' --class linbo {

 echo LINBO $bootflag for group mgb_mint-una_bios_sata
 echo

 if [ -e "$linbo_kernel" -a -e "$linbo_initrd" ]; then
  set bootflag=localboot
 elif [ -n "$pxe_default_server" ]; then
  set root="(tftp)"
  set bootflag=netboot
 fi

 if [ -n "$bootflag" ]; then
  echo -n "Loading $linbo_kernel ..."
  linux $linbo_kernel dhcpretry=30 server=10.1.0.1 $bootflag
  echo
  echo -n "Loading $linbo_initrd ..."
  initrd $linbo_initrd
  boot
 else
  if [ "$grub_platform" = "pc" ]; then
   set ipxe="/ipxe.lkrn"
  fi
  if [ -e "$ipxe" ]; then
   echo -n "Initiating pxe boot ..."
   linux16 $ipxe dhcp
   boot
  fi
 fi

}
# group specific grub.cfg template for linbo net boot, should work with linux and windows operating systems
# thomas@linuxmuster.net
# 20201126
#

# start "Linux Mint Una XFCE" directly
menuentry 'Linux Mint Una XFCE (Start)' --class linuxmint_start {

 set oslabel="ubuntu"
 if [ -n "$oslabel" ]; then
  search --label "$oslabel" --set osroot
 fi
 if [ -n "$osroot" ]; then
  set root="$osroot"
 else
  set root="(hd0,1)"
 fi
 set win_efiloader="/EFI/Microsoft/Boot/bootmgfw.efi"

 terminal_output console
 if [ -e /boot/vmlinuz -a -e /boot/initrd.img ]; then
  linux /boot/vmlinuz ro splash root=/dev/sda1
  initrd /boot/initrd.img
 elif [ -e /vmlinuz -a -e /initrd.img ]; then
  linux /vmlinuz ro splash root=/dev/sda1
  initrd /initrd.img
 elif [ -e /boot/vmlinuz -a -e /boot/initrd ]; then
  linux /boot/vmlinuz ro splash root=/dev/sda1
  initrd /boot/initrd
 elif [ -e /vmlinuz -a -e /initrd ]; then
  linux /vmlinuz ro splash root=/dev/sda1
  initrd /initrd
 elif [ -e /boot/vmlinuz -a -e /boot/initrd.img ]; then
  linux /boot/vmlinuz ro splash root=/dev/sda1
  initrd /boot/initrd.img
 elif [ -e /boot/vmlinuz ]; then
  linux /boot/vmlinuz ro splash root=/dev/sda1
 elif [ -s /boot/grub/grub.cfg ] ; then
  configfile /boot/grub/grub.cfg
 elif [ "$grub_platform" = "pc" ]; then
  if [ -s /bootmgr ] ; then
   ntldr /bootmgr
  elif [ -s /ntldr ] ; then
   ntldr /ntldr
  elif [ -s /grldr ] ; then
   ntldr /grldr
  else
   chainloader +1
  fi
 elif [ -e "$win_efiloader" ]; then
  chainloader $win_efiloader
  boot
 fi
 terminal_output gfxterm

}

# boot LINBO and start "Linux Mint Una XFCE"
menuentry 'Linux Mint Una XFCE (Linbo-Start)' --class linuxmint_start {

 if [ -e "$linbo_kernel" -a -e "$linbo_initrd" ]; then
  set bootflag=localboot
 elif [ -n "$pxe_default_server" ]; then
  set root="(tftp)"
  set bootflag=netboot
 fi

 if [ -n "$bootflag" ]; then
  echo LINBO $bootflag for group mgb_mint-una_bios_sata
  echo
  echo -n "Loading $linbo_kernel ..."
  linux $linbo_kernel dhcpretry=30 server=10.1.0.1 linbocmd=start:1 $bootflag
  echo
  echo -n "Loading $linbo_initrd ..."
  initrd $linbo_initrd
  boot
 fi

}

# boot LINBO, sync and start "Linux Mint Una XFCE"
menuentry 'Linux Mint Una XFCE (Sync+Start)' --class linuxmint_syncstart {

 if [ -e "$linbo_kernel" -a -e "$linbo_initrd" ]; then
  set bootflag=localboot
 elif [ -n "$pxe_default_server" ]; then
  set root="(tftp)"
  set bootflag=netboot
 fi

 if [ -n "$bootflag" ]; then
  echo LINBO $bootflag for group mgb_mint-una_bios_sata
  echo
  echo -n "Loading $linbo_kernel ..."
  linux $linbo_kernel dhcpretry=30 server=10.1.0.1 linbocmd=sync:1,start:1 $bootflag
  echo
  echo -n "Loading $linbo_initrd ..."
  initrd $linbo_initrd
  boot
 fi

}

# boot LINBO, format os partition, sync and start "Linux Mint Una XFCE"
menuentry 'Linux Mint Una XFCE (Neu+Start)' --class linuxmint_newstart {

 if [ -e "$linbo_kernel" -a -e "$linbo_initrd" ]; then
  set bootflag=localboot
 elif [ -n "$pxe_default_server" ]; then
  set root="(tftp)"
  set bootflag=netboot
 fi

 if [ -n "$bootflag" ]; then
  echo LINBO $bootflag for group mgb_mint-una_bios_sata
  echo
  echo -n "Loading $linbo_kernel ..."
  linux $linbo_kernel dhcpretry=30 server=10.1.0.1 linbocmd=format:1,sync:1,start:1 $bootflag
  echo
  echo -n "Loading $linbo_initrd ..."
  initrd $linbo_initrd
  boot
 fi

}

Fakten zu Kernelparametern:
Alle mir einfallenden Parameter getestet von dhcpretry bis nolapic, In der LMN6 liefen die T430 unter LINBO 2.2.16-0

Fakten zur Umgebung:

root@server:~# dpkg -l | grep linuxmuster
ii  linuxmuster-base7                      9.1.2-0                                         all          linuxmuster.net configuration scripts
ii  linuxmuster-linbo-common7              9.4.8-0                                         all          linuxmuster-linbo common files: kernel, initrd and pxe boot configuration
ii  linuxmuster-linbo-gui7                 9.0.2                                           all          Linuxmuster Linbo GUI
ii  linuxmuster-linbo7                     9.4.8-0                                         all          linuxmuster-linbo scripts
ii  linuxmuster-prepare                    0.7.4-0ubuntu0                                  all          linuxmuster.net pre setup configuration scripts
ii  linuxmuster-webui7                     1.0.169rc6                                      all          next generation web-based management tool for linuxmuster.net v7.x

Mit bestem Dank für die Hilfe.
Da wir in Kürze die LMN7 produktiv einsetzen wollen und ich auf die T430 nicht verzichten kann, eilt es mittlerweile.

Mit besten Wünschen
Stefan

Und noch diese Info:

#### Working on linbo/grub configuration for groups:                      ####
####                   | linbo start.conf     | grub cfg                  ####
####   ----------------+----------------------+---------------------      ####
####   mgb_mint-una_bios_sata | present              | replaced             ####

Hallo Stefan,

Alle mir einfallenden Parameter getestet von dhcpretry bis nolapic, In
der LMN6 liefen die T430 unter LINBO 2.2.16-0

schau mal hier:

das hab ich gefunden, nachdem ich im Forum nach 82579LM gesucht habe:
könnte dir auch helfen …

warum hast du den server=10.1.0.1 in der Appen Zeile?
Wenn es nicht geholfen hat, dann lass das mal raus.

Mach auch mal tests mit anderen (vor allem weniger) Switches (oder hast
du das schon?)

LG

Holger

Hallo Holger.

Danke für die schnelle Rückmeldung!

Ganz zu Anfang getestet - an 2 versch. Switchen, einer davon der Switch, der auch direkt an der Internetleitung zum ausgelagerten Server hängt.

Das ist der lokale Cache-Server für Images. Rausgelassen habe ich es aber trotzdem auch schon.

Lösungsansatz BIOS-Downgrade:

Ja - habe ich auch gesehen, aber am Bios habe ich ja nix gemacht, in der LMN6.1 laufen die NICs ja und PXE klappt ja wohl auch, nur eben die GUI nicht. Werde es trotzdem mal testen…

Lösungsansatz andere Netzwerkkarte
Wäre es evtl. hilfreich mal eine USB-Netzwerkkarte ins T430 zu stecken und damit mal LINBO zu testen - nur um zu sehen, ob es wirklich an der Netzwerkkarte liegt?
Wenn ja, hat jemand einen Tipp, welche USB-Netzwerkkarte mit LINBO in der LMN7.1 funktioniert.

Weiterer Ansatz Offload-Probleme und Sophos ?
Es gibt auch noch Berichte über Probleme mit „Offload“ der Netzwerkkarte 82579LM, die ich allerdings nicht verstehe:

Sogar Probleme mit Sophos und der Netzwerkkarte 82579LM - und ich habe eine Sophos!

Aber die Berichte kann ich leider nicht in Versuche der Fehlerbehebung umsetzen - das übersteigt meinen Erfahrungsbereich.

Für Tipps dankbar…

Gruß
Stefan

Hallo Stefan,

hier ist das Problem beschrieben:

https://sourceforge.net/p/e1000/bugs/407/#4d6f

Letzter Satz ist wichtig: „You’ve encountered a hardware bug, please
work with TSO disabled.“

… und das geht möglicherweise nicht per kernelparameter: da mußt du mal
eine intensive ecosiasuche nach machen.

Du kannst aber trotzdem mal
pcie_aspm=off
versuchen … vielleicht klappt das ja inzwischen (der Post ist von 2014).

Dass es mit dem alten linbo ging und mit dem neuen nicht liegt wohl am
neueren e1000 Treiber der die Hardware besser ausnutzt und deswegen den
HardwareBUG findet :frowning:

Was du versuchen kannst: Windows auf der Kiste installieren und neusten
intel Treiber von deren Webseite installieren (auch ein Win10 update
könnte unter „Treiber“ einen Treiber mitbringen, der die Firmware der
Karte erneuert).
Ich kann dir nciht sagen, dass das geht, aber ich hatte schon ähnliche
Fehler bei Netzwerkkarten.
Damals hatte ein installiertes Windows den Stromsparmodus der NW Karte
aktiviert: schon lief linux nicht mehr drauf …
Damals mußte ich Windows aufspielen und in den Treibersettings den
Stromsparmodus ausschalten, dann ging es wieder unter linux … ist aber
lange her.

Alle Tests sollten mit dem aktuellsten linbo 4 stattfinden.

Eine suche nach „linbokernel (mit uname -a am Client ermitteln)
NETZWERKKARTENNAME“ könnte auch was hervorbringen

LG

Holger

Hallo Holger,

Danke für die tolle Hintergrundrecherche!
Und Danke auch für die Schilderung Deiner Erfahrungen - das hilft mir sehr ein Bild der Situation zu bekommen.

Klappt leider nicht. Habe nach Recherchen zu pcie_aspm=off auch gleich mal alle in dem Zusammenhang genannten Parameter ausprobiert:
pcie_aspm=off
acpi=off
noapic

und aus Verzweiflung auch noch - obwohl es sich auf die Grafikkarte bezieht
nomodeset

Das Bios ist von 2012. Da versuche ich doch mal ein Bios-Upgrade. Bei Lenovo gibt’s ein Upgrade von 2019. In der „README for BIOS Update Utility“ gibt’s zumindest mal einen Hinweis auf Probleme beim PXE-Boot mit dem Intel Boot Agent.

<2.63>
 UEFI: 2.63 / ECP: 1.12
- (Fix) Fixed an issue where the system might fail to remote boot.
        Note: From Intel Boot Agent 1.5.50, it doesn't support PXE option 61.

Und auf der Intel-Seite dazu sind viele Netzwerkkarten gelistet - meine 82579LM ist auch dabei.

Gruß
Stefan