IPFire neu aufsetzen - Teil2

Hallo!

Wie unter


beschrieben, habe ich eine IPFire neu eingerichtet.
und insbesondere
ssh -p 222 ipfire und
import_workstations
erfolgreich ausgeführt.

Wenn ich nun
linuxmuster-ipfire --restore
ausführe, dann gibt es diesen Fehler
* Repairing permissions ... ERROR!

und einen weiteren Fehler bei
import_workstations mit
Reloading external firewall ... failed!

Gruß
Gerhard

Hallo,

wurde den ein linuxmuster-ipfire --setup --first gemacht?

LG

Holger

Ja.

Das habe ich in dem verlinkten Beitrag beschrieben.

Gruß
Gerhard

Hallo Gerhard,

Ja.

Das habe ich in dem verlinkten Beitrag beschrieben.

ja: sorry, hab ich danach auch gesehen…

Ich erinnere mich dunkel, dass da mal so einen Fehler gab wie du ihn
beschreibst: damals fehlte ein Verzeichnis auf dem IPFire…

Kannst du mal in den Logdateien zum IPFire auf dem Server suchen, ob es
da was aussagekräftiges gibt?

LG

Holger

Hallo Holger,

ich hatte jetzt am Wochenende beim Neueinrichten eines zweiten IPFire, der unabhängig von einem Linuxmusterserver eingesetzt wird, ein vergleichbares Problem. Ich habe über den alten IPFire (Core 109) eine Datensicherung als ipf-Datei gemacht und mir diese heruntergeladen. Dann habe ich ein Core 120 ISO-Image auf einer neuen Festplatte installiert. Das hat problemlos funktioniert. Danach habe ich die Core 109 Einstellungen aus der ipf-Datei über die Datensicherung wieder eingespielt. Im Ergebnis hat der IPFire nicht mehr funktioniert. Ich erinnere mich noch an Konfigurationspronbleme beim Apache. Versuche diese zu beheben, sind misslungen. Die Probleme führten dazu, dass Apache nicht gestartet werden konnte und somit das Webinterface nicht aufgerufen werden konnte. Darüber hinaus muss es weitere Probleme gegeben haben, weil der Zugang zum Internet nicht funktionierte.

Ich denke, dass
linuxmuster-ipfire --restore
das gleiche Problem hat, wenn man ein restore auf eine neuere Core-Version macht.

In beiden Fällen habe ich dann notgedrungen in das per ISO-Image erstellte neue IPFire die Firewallregeln und sonstigen Einstellungen per Hand eingetragen. Jetzt funktionieren beide IPFire wieder.

Auf die log-Dateien habe ich jetzt keinen Zugriff mehr.

Gruß
Gerhard

Hallo Gerhard,

ich hatte jetzt am Wochenende beim Neueinrichten eines zweiten IPFire,
der unabhängig von einem Linuxmusterserver eingesetzt wird, ein
vergleichbares Problem. Ich habe über den alten IPFire (Core 109) eine
Datensicherung als ipf-Datei gemacht und mir diese heruntergeladen. Dann
habe ich ein Core 120 ISO-Image auf einer neuen Festplatte installiert.
Das hat problemlos funktioniert. Danach habe ich die Core 109
Einstellungen aus der ipf-Datei über die Datensicherung wieder
eingespielt. Im Ergebnis hat der IPFire nicht mehr funktioniert. Ich
erinnere mich noch an Konfigurationspronbleme beim Apache. Versuche
diese zu beheben, sind misslungen. Die Probleme führten dazu, dass
Apache nicht gestartet werden konnte und somit das Webinterface nicht
aufgerufen werden konnte. Darüber hinaus muss es weitere Probleme
gegeben haben, weil der Zugang zum Internet nicht funktionierte.

Ich denke, dass

linuxmuster-ipfire --restore|
das gleiche Problem hat, wenn man ein restore auf eine neuere
Core-Version macht.

das klingt plausibel: danke für den Hinweis.

Wenn jetzt ein “von Hand” wieder Eintragen keine Option wäre, würde ich
an deiner Stelle einen Core 109 installieren, Config zurückspielen und
dann erst updaten.

Wäre ein Versuch Wert.

LG

Holger

Hi,

ich habe das bei der Neu-Installation einer “frischen” IP-Fire anders gelöst. Das beschriebene Problem mit dem nicht mehr lauffähigen Apache hatte ich aber auch.

Ich habe die Konfig-Dateien von der Ursprungs-IP-Fire nach der Neuinstallation gesichert (einfach in ein SAVE-Dir auf der IP-Fire kopiert), dann den Restore über den LMN-Server durchgeführt und anschließend die Konfig-Dateien des Apache zurück gesichert. Danach hatte ich alle Regeln, die in der Restore-Datei auf dem LMN-Server waren UND einen lauffähigen Apache.

Ich hoffe, meine Beschreibung ist jetzt nicht zu diffus und ihr wisst, was ich meine …

Viele Grüße aus HAMM / NRW :wink:

Thomas