Import_workstations liefert Fehlermeldung

Hallo zusammen!

Ich musste den IPFire (110) durch neue Hardware ersetzen, weil der alte PC mehrmals nacheinander ausfiel.
Den neuen PC habe ich mit dem ISO-Image des alten IPFire aufgesetzt. Nun funktioniert import_workstations nicht mehr. Die Fehlermeldung ist "Reloading external firewall… failed!

Hinweisen im Forum folgend habe ich restart-fw – ext probiert, was die Fehlermeldung “Reloading of firewall proxy failed” liefert. Diese Fehlermeldung wird vom Skript /usr/share/linuxmuster/scripts/internet_on_off.sh ausgegeben:
exec_ipcop /var/linuxmuster/reload_proxy.sh || cancel “Reloading of firewall proxy failed!”

Weder auf dem IPFire noch auf dem Server (6.2) gibt es einen Ordner /var/linuxmuster mit dem Skript reload_proxy.sh. Das scheint die Ursache der Fehlermeldung zu sein, sicher bin ich mir aber nicht.
Auch habe ich keine Idee, wie ich das Problem beheben kann.

Gerhard

Hallo Gerhard,

Ich musste den IPFire (110) durch neue Hardware ersetzen, weil der alte
PC mehrmals nacheinander ausfiel.
Den neuen PC habe ich mit dem ISO-Image des alten IPFire aufgesetzt. Nun
funktioniert import_workstations nicht mehr. Die Fehlermeldung ist
"Reloading external firewall… failed!

hast du, nach Neuinstallation des IPFire, diesen wieder mit dem Server
verheiratet?
Das geht am einfachsten so:

auf dem lmn Server folgenden Befehl ausführen und die INstruktionen
befolgen:

linuxmuster-ipfire --setup --first

Dabei werden alle Einstellungen der Firewall gelöscht!
Wenn du also schon viel Zeit investiert hast, um den IPFire ein zu
stellen, dann schreib mir: es geht auch “einfühlsamer” aber aufwändiger.

Nach dem Befehl oben, sollte der IPFire neu gestartet werden.
Dann testest du ie “ehe” durch

ssh -p 222 ipfire

vom Server aus.
Es darf beim ersten mal eine Nachfrage kommen: aber keien nach dem Passwort.
Wenn du auf dem IPFire bist, tipp ein
exit
und mach nochmal:
ssh -p 222 ipfire

jetzt muß es ganz ohne Nachfragen gehen.
Wenn das nicht klappt, schreib nochmal genau, was wann wo nicht geklappt
hat.

LG

Holger

Hallo Holger,

den Befehl
linuxmuster-ipfire --setup --first
kannte ich nicht. Mit der Einrichtung des neuen IPFire über das ISO-Image des alten und der Neueinrichtung der Netzwerkkartenkonfiguration funktionierte auch das Meiste. Den passwortlosen Zugang zum IPFire habe ich gemäß Anleitung im Forum hergestellt.

Beim IPFire kann man außer einem ISO-Image auch eine Sicherung der Einstellungen vornehmen. (ipf-Datei) Kann man nach dem linuxmuster-ipfire --setup --first
über diese Sicherung die Firewall-Regeln einspielen?

Gruß
Gerhard

Hallo Gerhard,

19:51/0 aserver ~ # linuxmuster-ipfire --help

#################################

linuxmuster.net: IPFire usage

#################################

linuxmuster-ipfire --backup
–restore
–setup [–first] [–password=]
–upgrade
–help

backup: Backs up IPFire settings to /var/backup/linuxmuster/ipfire.
Keeps the last three backups.
restore: Restores IPFire settings using the latest backup.
setup: Starts linuxmuster.net specific IPFire setup.
Together with --first param it does an initial setup
of passwordless ssh connection to IPFire first.
If password is not given it will be asked.
upgrade: Upgrades IPFire to latest supported core level.
help: Shows this help

Gruß

Alois

gelöscht, weil doppelt

Hallo,

ich habe heute

  1. mit linuxmuster-ipfire --backup ein Backup der Firewall gemacht
  2. mit linuxmuster-ipfire --setup --first lmn-Server und IPFire verheiratet
  3. mit ssh -p 222 ipfire und anschließendem reboot den IPFire neu gestartet
  4. mit linuxmuster-ipfire --restore die bisherigen Einstellungen in die Firewall eingespielt.

Jetzt funktioniert import_workstations wieder.

Danke!
Gerhard