Fehlermeldung bei Anmeldung in der Schulkonsole

#1

Hallo,

Nach der Installation habe ich einen Lehrer-Account angelegt und die schueler.txt meiner Schule importiert. Hat alles super geklappt :grinning:

Jetzt wollte ich mich als Lehrer anmelden und dann kam das:

Der drehende Kreis (links im Bild) hört nicht mehr auf.

Auswählen kann ich das:
SErr02

Liegt das an den fehlenden Rechten, oder kann die Beta-Version noch nicht mehr?

Für Tips und Hinweise wäre ich dankbar.
Gruß,
Mathias

#2

Hallo Mathias,

Jetzt wollte ich mich als Lehrer anmelden und dann kam das:

SErr01
https://ask.linuxmuster.net/uploads/default/original/2X/d/d6c0ce29e811a3d944096abcc55650c1856f4b30.png

Der drehende Kreis (links im Bild) hört nicht mehr auf.

Auswählen kann ich das:
SErr02

Liegt das an den fehlenden Rechten, oder kann die Beta-Version noch
nicht mehr?

das klappt bei mir ohne Probleme (siehe Bild).
Wo hast du den deine Umgebung her?
Hast du die mit den ovas hergestellt?
Oder vanilly Install?
Wie hast du virtualisiert?

Irgendwie wirkt die doch nciht wirklich glatt…

LG

Holger

#3

Hallo Holger,

Virtualisiert habe ich mit VM-Ware.
Die Installation habe ich, wie hier beschrieben durchgeführt.
Gruß,
Mathias

#4

Hi,

welche URL rufst du auf? Ich vermute es ist die, zur Verwaltung der Lehrkräfte. Die darf man als Lehrkraft nicht bearbeiten, deshalb der Fehler (meine Vermutung).

vG Stephan

#5

Hallo Stefan,

https://server.linuxmuster.lan:8000/view/lmn/landingpage

Gruß,
Mathias

#6

Hallo Holger,

(wie) kann man die Ansicht auf Deutsch umstellen?

Viele Grüße,
Jochen

#7

Ich habe mal ein Bugreport erstellt, da das Problem bei mir auch auftritt.

vG

PS: Scheint aber nur beim allerersten Login aufzutreten!? Tritt nur auf, wenn man vorher als Admin angemeldet war und z.B. Benutzer bearbeitet hat, sich abmeldet und als Lehrer anmeldet. Wenn man die Anmeldeseite neu lädt und sich dann er anmeldet, tritt das Problem nicht auf (@rettich)

#8

@jochen: Als root anmelden und dann unter Settings (Ajenti) die Sprache auf Deutsch stellen. Vieles ist aber aktuell nur in Englisch verfügbar, da noch Übersetzungen fehlen.

#9

Hallo Stefan,
das war’s bei mir auch :slight_smile:
Gruß,
Mathias

#10

Hallo Stephan,

danke Dir!
War aber schon fast alles übersetzt. Hab mich jetzt am Rest mal versucht. Muss noch approved werden.

Viele Grüße,
Jochen

#11

Hallo Stefan,
ich muss meine letzte Antwort etwas genauer fassen:
Bei einem System, das von den OVAs erstellt wurde, erscheint die Fehlermeldung nur dann, wenn ich vorher als global-admin angemeldet war.

Bei einem selbst aufgesetztem System bleibt die Fehlermeldung. Allerdings läuft das System an anderen Stellen besser.

Da scheinen in die OVAs Anpassungen eingeflossen zu sein, die so in den Paketquellen nicht aufgenommen wurden. Insofern werde ich mit dem selbstaufgesetzten System arbeiten.

Bitte gebt mir Bescheid, ob ich die Sachen, die nicht laufen oder die Fragen aufwerfen in Weiterentwicklung->Feature-Requests stellen soll.

Gruß,

Mathias

#12

Hi,

Die gleiche Fehlermeldung wie oben? Wie genau sie die URL vom Anmeldebildschirm aus? Ajenti merkt sich i.d.R. die letzte Seite, die man vorher benutzt hat (evtl. auch mit einem anderen Benutzer).

Wenn du einen Github Account hast, kannst du sie auch dort melden (https://github.com/linuxmuster/linuxmuster-webui7/issues) mit möglichst genauen Angaben (Fehlermeldungen, Screenshots, …), damit man es schneller nachvollziehen und reproduzieren kann.

vG Stephan

#13

Hallo Stefan,

Das spielt leider keine Rolle. Hier ein Screenshot:

Gruß,
Mathias

#14

Ich denke, dass @Arnaud oder @Till dir am ehesten weiterhelfen können.

#15

Sieht auf den ersten Blick mal so aus als würde es sich bei result[‘HARD_LIMIT_MiB’] und result[‘USED_MiB’] um einen String statt einem Integer (?) handeln.

Schau mal was dir:

sophomorix-query --sam hulk --user-full --quota-usage -j

im Block QUOTA_USAGE_BY_SHARE ausgibt. (hulk zu ersetzen durch deinen entsprechenden Nuternamen)

"QUOTA_USAGE_BY_SHARE" : {
            "default-school" : {
               "HARD_LIMIT_MiB" : "NO LIMIT",
               "USED_MiB" : 0,
               "FULL_USER" : "LINUXMUSTER\\hulk              ",
               "HARD_LIMIT" : "NO LIMIT",
               "SOFT_LIMIT" : "NO LIMIT",
               "USED" : "8192",
               "SOFT_LIMIT_MiB" : "NO LIMIT"
            },
            "linuxmuster-global" : {
               "SOFT_LIMIT_MiB" : "NO LIMIT",
               "USED" : "0",
               "HARD_LIMIT" : "NO LIMIT",
               "SOFT_LIMIT" : "NO LIMIT",
               "USED_MiB" : 0,
               "FULL_USER" : "LINUXMUSTER\\hulk              ",
               "HARD_LIMIT_MiB" : "NO LIMIT"
            }
         },

Entweder hast du noch eine alte Version welche NO LIMIT noch nicht kennt, oder hier steht etwas ganz merkwürdiges drin.