Dokumentation Linux-Client

#1

Hallo Zusammen
wir möchten bei uns auf Linuxmuster umsteigen (haben bisher logodidact, und die wollen keine Ubuntu-Clienten mehr). Wir haben nun einen Testaufbau.
Das Herunterladen
http://docs.linuxmuster.net/de/latest/getting-started/linuxclients/cloudclient.html
schlägt leider fehl. Es werden bei
linuxmuster-client -a list-available
keine Clients angezeigt.

Ein manuelles Installieren mit der Anleitung
https://www.linuxmuster.net/wiki/anwenderwiki:linuxclient:manual:start
funktioniert nicht.
der Eintrag
deb http://pkg.linuxmuster.net/ xenial/
tut nicht, da auf pkg.linuxmuster.net/ es keinen Ordner xenial/ gibt. Auch der Key heisst jetzt
archive.linuxmuster.net.key

Wurden da Sachen verschoben? Ist die Anleitung aktuell?

Viele Grüße
Johannes Thäter
heimschule Lender Sasbach

#2

Hallo Johannes,

siehe hier: Infrastrukturanpassungen - neuer Paketserver und mögliche Folgen

Dauert wohl noch etwas, bis alles wieder geht.

vG

#3

Hallo Johannes,

alternativ schicke ich Dir einen Download-Link wenn Du magst.

Gruß

Alois

#4

Hallo Alois,
das wäre prima.
Imaging mit linbo geht schon, die Authentifizierung wäre jetzt der nächste Schritt.

Viele Grüße
Johannes

#5

Hallo Alois,
vielen Dank für den Download-Link
Ich habe die Dateien nach /var/linbo gelegt und in meiner start.conf das Image eingetragen. Es hat auch die gleichen Rechte wie mein erzeugtes cloop.
Leider lädt der Client das Image nicht.
grafik

Muss ich noch etwas tun?
Viele Grüße
Johannes

PS
Gibt es die 3 Pakete vielleicht auch als Download ?

#6

Hallo Johannes,

Ich hatte Dir zwei Links geschickt. Du hast nur das Cloop herunter geladen. Mit dem zweiten Link kommen die restlichen Dateien in gepackter Form.

Gruß Alois

#7

Hallo Johannes,

offenbar hast Du alle Dateien herunter geladen. Die gezippte Datei muss noch ausgepackt werden, dann solltest Du alle Dateien haben.

Gruß

Alois

#8

Hallo Johannes,

starte mal

service linbo-bittorrent restart

auf der Konsole, dann sollte es funktionieren.

Gruß

Alois

#9

Hallo,

service linbo-bittorrent restart

genau: die torrent Datei muss neu erschaffen werden.
Ich mache das cloop speziefisch mittels

/etc/init.d/linbo-bittorrent restart .cloop force

Und noch was: die Dateien in /var/linbo/, die du von Alois erhalten
hast, sollten die richtigen Rechte haben: 644

LG

Holger

#11

Hallo zusammen,
habe /etc/init.d/linbo-bittorrent restart xenial.cloop force gemacht und siehe da, der Client startet. Prima, wieder ein Schritt weiter, vielen Dank Holger.
Welches Passwort hat denn der linuxadmin im Standardclient?

Zusätzlich würde ich aber gerne auch die Pakete linuxmuster-… bei Gelegenheit bekommen,
da ich unser momentanes System (Mate 16.04 mit allerlei Anpassungen für unsere Schule)
mal in Linuxmuster ausprobieren möchte, damit es für die Kollegen und Schüler möglichst wenig Änderungen bei einer Systemumstellung gibt.

Viele Grüße
Johannes Thäter

#12

Hallo Johannes,

das Passwort sollte muster2016 sein.

Siehe auch

Gruß Alois

#13

Hallole,

das Passwort des linuxclient-admin, also dem linuxadmin, kann man so setzen:
Auf dem Server auszuführen:

/usr/sbin/linuxmuster-client -a set-postsync-pass -l [geheim] -p [mypatchclass]

Patchklasse=/var/linbo/linuxmuster/[patchklasse],
“geheim” = Pseudopasswort,
anscheinend sollte man die Rechnernamen in der /etc/workstations nach dem Muster Raumbez.-Rechnerbez. gestalten, also so:
A001-PC1.

L.G.
Christoph Gü

#14

Hallo zusammen,

der Standardclient funktioniert jetzt, ich kann mich anmelden, prima.
Wie sieht es denn aber mit den 3 Paketen linuxmuster-auth usw. aus.
Unser altes System (was nicht alt ist) habe ich auch schon auf linbo übertragen und würde gerne die Anmeldung der Nutzer mit reinbringen. Gibt es die auch als Download, bis die Paketquellen richtig eingetragen sind?

Viele Grüße
Johannes Thäter

#15

Hallo Johannes,

ich verstehe Dich offenbar nicht. Bei mir kann man sich als im System angemeldeter Benutzer am Linux-Client anmelden. Es braucht keine weiteren Pakete.

Gruß

Alois

#16

Hallo Alois,

ich habe xenial.cloop als ein mögliches Image und alles läuft, keine Frage.
Ich möchte aber unser Mate16.04, was wir momentan benutzen, am Linuxmuster-Server mal testen, also die Anmeldung über linuxmuster-auth. Es sind halt viele Anpassungen für unsere Schule drin und ich möchte bei einer Umstellung auf Linuxmuster erst mal so wenig wie möglich Änderungen für die Lehrer und Schüler am Clienten haben. Deshalb wollte ich die Anleitung
https://www.linuxmuster.net/wiki/anwenderwiki:linuxclient:manual:start (wie im Beginn erwähnt) ausführen.
Viele Grüße
Johannes Thäter

#17

Hallo Johannes,

Ich meine hier

https://archive.linuxmuster.net/

sollten die Pakete liegen.

Vielleicht kannst Du auch die Pakete aus dem Xenial-Client holen?

Gruß

Alois

#18

Hallo Alois,

dort gibt es leider keine xenial-Pakete
linuxmuster-client-auth
linuxmuster-client-profile
linuxmuster-client-shares
Unter Bionic liegt etwas, was nach so etwas aussieht:
linuxmuster-client-adsso_0.5.1-0ubuntu0_all.deb
Ich bin ja ganz neu hier und habe die Diskussionen zu V7 und Bionic-Client nur überflogen.
Wenn ich es richtig verstanden habe, ist das alles noch im Fluss?
Deswegen wollte ich erst mal V6.2 mit einem 16.04 Ubuntu-Client erstellen.
Ist das richtig so? Oder sollten wir hier gleich auf V7 gehen?

Viele Grüße
Johannes Thäter

#19

Hallo Johannes,

kann sein, dass die Pakete darin enthalten sind. Kopiere das Paket in den entsprechenden Ordner Deines Mint-Client und versuche dann die 3 Pakete zu installieren. Da Dein Mint auch die Version 16.04 ist sollten die Pakete passen.

Das Paket findest Du auch hier:

https://archive.linuxmuster.net/bionic/

“Ist das richtig so? Oder sollten wir hier gleich auf V7 gehen?”

Ich rate dazu Holgers Meinung abzuwarten. Wenn Du erst mal eine Testumgebung haben möchtest, dann sage ich ja.

Gruß

Alois

#20

Hallo Johannes,

hier

habe ich etwas zu linuxmuster-client-auth

gefunden.

Gruß

Alois

#21

Hallo,

das Paket linuxmuster-client-adsso ist für die Anbindung an v7 gedacht, nicht an v6.2.

Ich habe ehrlich gesagt Schwierigkeiten zu verstehen, warum das alte Repo so schnell abgeschaltet wurde, ohne zu warten bis das neue entsprechend läuft. Denn dadurch sind jetzt einige Dinge kaputt:

  • Neuinstallation von 6.2 (manuell), da die v6.2 Pakete noch das alte Repo versuchen einzubinden
  • Xenial Cloop kann nicht mehr heruntergeladen werden
  • Xenial linuxmuster Pakete fehlen

Ich denke, es gab sicher Gründe, warum es so gemacht wurde, wie es jetzt ist, aber toll wäre es schon, wenn man noch alle Pakete findet, die man aktuell noch gebrauchen könnte, so lange die v7 nicht final ist und es noch keinen neuen 18.04 default cloop gibt.

vG Stephan