DHCP im WLAN - Internet sperren

Hallo,
bezugnehmend auf eine alte Frage (Laptops im 172.16.*.* Netz. Wie in workstations eintragen) muss ich nochmal bzgl. der WLAN und DHCP-Konfiguration nachfragen.

Wir haben ein VLAN für die Geräte die via WLAN im Netzwerk hängen. Das Netz hat den IP-Adressbereich 172.16... Ich möchte erreichen, dass die Laptops und Tablets immer die gleiche IP-Adresse bekommen, um z. B. gezielt den WLan-Zugang zu sperren oder damit veyon zuverlässig funktioniert, usw.

Aktuell übernimmt unsere WLan-Controller (von netgear) das DHCP, hier habe ich keine Möglichkeit IP-Adressen an bestimmte MAC-Adressen zu binden.
Alternativ habe ich gelesen kann IPFire im blauen Netz DHCP übernehmen und kann auch mit fixen Adressen umgehen. Gibt es die Möglichkeit, die IP-Adressen aus der /etc/linuxmuster/workstations nach IPFire zu importieren.

Als dritte Möglichkeit kann man die lmn-Server als DHCP-Helper eintragen und dort ein entsprechendes Subnet eintragen.

Was ist den der beste Weg?

Besten Gruß, Martin

Hallo Martin,

So sieht die Konfiguration einer fixen Adresse im IPFIRE aus

host fix0 # LOL-01
{
hardware ethernet 0A:1a:13:6f:91:b6;
fixed-address 172.16.99.22;
}

und so die Konfiguration auf dem Server:

host 10.16.1.99 {
hardware ethernet 00:A6:0C:7E:09:E4;
fixed-address 10.16.1.99;
option host-name “rxxx-pc05”;
}

Es sollte also möglich sein die Konfiguration per Script umzuschreiben.

Gruß

Alois

Hallo und danke,

nach einigen Versuchen hab ich’s nun. Die Datei /etc/dhcp/dhcpd.conf auf ipfire sollte man nicht ändern, da die aus der settings-Datei von ipfire überschrieben wird. Es wird aber die Datei /var/ipfire/dhcp/dhcpd.conf.local eingebunden, in die man seine Änderungen schreiben kann.

Der folgende Code erzeugt aus der /etc/dhcp/dhcpd.conf.linuxmuster auf dem Server die entsprechende Datei auf ipfire. Subnet ggf. anpassen

awk '/^host +172\.16\./ {p=1} p && $0 !~ /option +extensions-path/ {print} /^}/ {p=0}' /etc/dhcp/dhcpd.conf.linuxmuster | ssh -p 222 root@ipfire "cat > /var/ipfire/dhcp/dhcpd.conf.local"

und noch den DHCP-Server neu starten:

ssh -p 222 root@ipfire "/etc/init.d/dhcp restart"

Besten Gruß, Martin