Client fährt nicht runter

Hallo,

ich habe das jetzt mehrfach beobachtet, dass manchmal ein Client nicht herunterfährt, wenn man auf der Anmeldemaske “Herunterfahren” auslöst.

Es bleibt einfach nur eine llere Fläche (mit Bildschirmhintergrundfarbe), die Maus lässt sich bewegen, mit Strg+Alt+F1 bekomme ich ein Terminal (und kann mit sudo poweroff dann auch Herunterfahren), mit Strg+Alt+F7 bekomme ich folgendes:

apache2: Could not determine the server’s fully qualified domain name,
using 127.0.0.1 for ServerName…

Da ich selbst Linux Mint 17 Xfce (basierend auf Ubuntu 14.04) als Clientimage hergestellt habe und noch nicht so erfahren bin mit Linux, befürchte ich bei solchen Problemen immer, dass der Mint-Client noch irgendeine grundsätzliche Fehlkonfiguration irgendwo haben könnte. kann mir jemand dazu was mitteilen?
Ist das noemal, dass auf dem Client ein web server apache2 läuft etc…

Gruß
Stefan

Hallo Steffen,

[…]

Gruß Jürgen

[S.Senft] S.Senft https://ask.linuxmuster.net/u/s.senft
15. Juni

Hallo,

ich habe das jetzt mehrfach beobachtet, dass manchmal ein Client nicht
herunterfährt, wenn man auf der Anmeldemaske “Herunterfahren” auslöst.

Es bleibt einfach nur eine llere Fläche (mit
Bildschirmhintergrundfarbe), die Maus lässt sich bewegen, mit
Strg+Alt+F1 bekomme ich ein Terminal (und kann mit sudo poweroff dann
auch Herunterfahren),

Das Phänomen habe ich mit HULC sehr selten auch.
Manchmal klappt auch der Aufbau des Desktop nicht, wenn ich vorher lokal
angemeldet war.

Ich vermute irgendwelche Probleme mit den Skripten in
/etc/linuxmuster-client - die eventuell damit zusammenhängen, dass in
KDE (oder bei Dir in XFCE) irgendwas fehlt oder anders ist als in Unity,
womit die Skripte entwickelt wurden.

mit Strg+Alt+F7 bekomme ich folgendes:

apache2: Could not determine the server’s fully qualified domain name,
using 127.0.0.1 for ServerName…

Diese Meldung bekomme ich auch. Hat aber mit ziemlicher Sicherheit
nichts mit dem An- und Abmelden zu tun.

Da ich selbst Linux Mint 17 Xfce (basierend auf Ubuntu 14.04) als
Clientimage hergestellt habe und noch nicht so erfahren bin mit Linux,
befürchte ich bei solchen Problemen immer, dass der Mint-Client noch
irgendeine grundsätzliche Fehlkonfiguration irgendwo haben könnte.
kann mir jemand dazu was mitteilen?

Schon möglich. Auch HULC hat in der zum Download bereitgestellten
Konfiguration einige Mängel, die wir auch nach zwei Jahren Erfahrung
längst nicht alle beseitigt haben. Dies dürfte auf den trusty- und den
xenial-Client ebenso zutreffen - und erst recht auf jeden Windows-Client!
Da hilft nur alle paar Jahre das immer noch nicht ganz perfekte System
durch ein neues, bunteres, ressourcenhungrigeres mit unbekannten
"Features" zu ersetzen … Sonst würde die IT-Industrie ja verhungern :wink:

Ist das normal, dass auf dem Client ein web server apache2 läuft

Bei uns möchte ich dies, weil wir im Unterricht Datenbankanwendungen mit
php, mysql und phpmyadmin erstellen.

Hallo Stefan,

apache2: Could not determine the server’s fully qualified domain name,
using 127.0.0.1 for ServerName…

sieht für mich wieder nach einem hosts Problem aus.

Bitte poste mal den Inhalt der /etc/hosts von einem laufenden Client.

LG

Holger

Hallo,

hier die /etc/hosts von einem Client:

127.0.0.1	localhost
127.0.1.1	Client002-base

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Hoffentlich hilft’s…
Gruß
Stefan

P.S: die hässlichen Formatdarstellungen von Dateiinhalten ( z.B. durch # am Zeilenanfang) hier in Discourse kann man vermeiden, wenn man den Text als Zitat oder Vorformatierten Text formatiert:

Hallo,

bzgl. /etc/hosts
schlage ich vor, dass wir es an nur einer Stelle diskutieren - und zwar diese:

Gruß
Stefan

4 Beiträge wurden in ein neues Thema verschoben: Code/Scripts/Log im Forum posten und dabei die Lesbarkeit nicht verlieren