BigBlueButton Endpunkt und Sicherheitsschlüssel ungültig

Hallo eben so ein Fehler bekomme ich wenn ich mich an BBB anmelde. Ich kann Verwlten user /berechtigung etc. aber bei Aufriufen der Startseite kommt zu diesem Fehler.
BBB ist local installiert ohne zugang zum Internet (vorerst).
root@meet:~/greenlight# docker run --rm --env-file .env bigbluebutton/greenlight:v2 bundle exec rake conf:check

Checking environment: Passed
Checking Connection: Failed
Error connecting to BigBlueButton server - Failed to open TCP connection to meet.mydomain.de:443 (getaddrinfo: Try again)

hat jemand Ideen zu diesem Fehler? ich komme halt nicht weiter. Ach so die Demo funktioniert ohne Fehler mit audio und video.
Danke für Hilfe!

Hallo,

läuft BBB auf dem gleichen Server wie greenlight?
Ich würde bbb mal neu starten mittels
bbb-conf --restart

LG

Holger

Hallo
ja das tut das. ich kann mich an …/b registrieren, anmelden, Benutzerverwalten bis auf die Startseite und Auzeichnungen sowie ich kann auch nicht die Serverräume starten oder ansehen denn dann kommt eben dieser Fehler.
Der Server ist Virtuell und ich möchte nur in Intranet verwenden und bis auf dieser Fehler tuts alles. Demo läuft auch ohne Fehler.

Was ist gemeint mit „Endpunkt Schlüssel“ und " Sicherheitsschlüssel " ?
Das habe ich auch gemacht und entsprechend plaziert.
bbb-conf --secret

und trotzdem kommt dieser Fehler. Wo mache ich falsch?

Gruß
Peter

Hallo Steffen,

läuft BBB per https-Zertifikat? Habe in Erinnerung BBB funktioniert nur mit https, bin aber nicht sicher.

Was sagt denn:

  • bbb-conf --check
    bzw.
    bbb-conf --secret

Eventuell hilft Dir:

  • bbb-conf --watch [Scan the log files for error messages every 2 seconds]

Alle Dienste neu starten:

systemctl restart bbb-web
systemctl restart bbb-webrtc-sfu
systemctl restart freeswitch
systemctl restart docker

Gruß Andre

certifikat ist auch da und ja https: funktioniert alles bis auf die ervernte Sachen.
die Ausgabe von bbb-conf --check kann nicht Einfügen da die Eintrege als Links interpretiert werden und das ist auf 2 begrenzt :frowning:

Hallo Peter,

schau Dir doch einmal folgenden Link an, eventuell hilft es Dir weiter.

VG Andre

Hallo,

certifikat ist auch da und ja https: funktioniert alles bis auf die
ervernte Sachen.
die Ausgabe von bbb-conf --check kann nicht Einfügen da die Eintrege als
Links interpretiert werden und das ist auf 2 begrenzt :frowning:

kopier die Ausgabe in code Tags.

[code]
...
Text
...
[/code]

LG

Holger

root@meet:~/greenlight# bbb-conf --check

BigBlueButton Server 2.2.28 (2210)
                    Kernel version: 4.15.0-122-generic
                      Distribution: Ubuntu 16.04.7 LTS (64-bit)
                            Memory: 8168 MB
                         CPU cores: 4

/usr/share/bbb-web/WEB-INF/classes/bigbluebutton.properties (bbb-web)
       bigbluebutton.web.serverURL: https://meet.mydomain.de
                defaultGuestPolicy: ALWAYS_ACCEPT
                 svgImagesRequired: true

/etc/nginx/sites-available/bigbluebutton (nginx)
                       server name: meet.mydomain.de
                              port: 80
                              port: 443 ssl
                    bbb-client dir: /var/www/bigbluebutton

/var/www/bigbluebutton/client/conf/config.xml (bbb-client)
                Port test (tunnel): rtmp://meet.mydomain.de
                              red5: meet.mydomain.de
              useWebrtcIfAvailable: true

/opt/freeswitch/etc/freeswitch/vars.xml (FreeSWITCH)
                       local_ip_v4: 10.11.2.30
                   external_rtp_ip: stun:stun.freeswitch.org
                   external_sip_ip: stun:stun.freeswitch.org

/opt/freeswitch/etc/freeswitch/sip_profiles/external.xml (FreeSWITCH)
                        ext-rtp-ip: $${local_ip_v4}
                        ext-sip-ip: $${local_ip_v4}
                        ws-binding: :5066
                       wss-binding: :7443

/usr/local/bigbluebutton/core/scripts/bigbluebutton.yml (record and playback)
                     playback_host: meet.mydomain.de
                 playback_protocol: https
                            ffmpeg: 4.2.4-1ubuntu0.1bbb1~16.04.1

/etc/bigbluebutton/nginx/sip.nginx (sip.nginx)
                        proxy_pass: 10.11.2.30

/usr/local/bigbluebutton/bbb-webrtc-sfu/config/default.yml (Kurento SFU)
                        kurento.ip: 10.11.2.30
                       kurento.url: ws://127.0.0.1:8888/kurento
                    kurento.sip_ip: 10.11.2.30
                    localIpAddress: 10.11.2.30
               recordScreenSharing: true
                     recordWebcams: true
                  codec_video_main: VP8
               codec_video_content: VP8

/usr/share/meteor/bundle/programs/server/assets/app/config/settings.yml (HTML5 client)
                             build: 1058
                        kurentoUrl: wss://meet.mydomain.de/bbb-webrtc-sfu
                  enableListenOnly: true


# Potential problems described below
# Warning: API URL IPs do not match host:
#
#                                IP from ifconfig: 10.11.2.30
#  /var/lib/tomcat7/demo/bbb_api_conf.jsp: meet.mydomain.de

................................................................................
# Error: Could not connect to the configured hostname/IP address
#
#    https://meet.mydomain.de/
#
# If your BigBlueButton server is behind a firewall, see FAQ.

# Warning: The API demos are installed and accessible from:
#
#    https://meet.mydomain.de
#
# and
#
#    https://meet.mydomain.de/demo/demo1.jsp
#
# These API demos allow anyone to access your server without authentication
# to create/manage meetings and recordings. They are for testing purposes only.
# If you are running a production system, remove them by running:
#
#    apt-get purge bbb-demo

# Error: Unable to reach default URL for presentation:
#
#    https://meet.mydomain.de/default.pdf
#
# Check value for beans.presentationService.defaultUploadedPresentation in
#   /usr/share/bbb-web/WEB-INF/classes/bigbluebutton.properties
root@meet:~/greenlight#

...
root@meet:~/greenlight# curl https://meet.mydomain.de/bigbluebutton/api
<response>
<returncode>SUCCESS</returncode>
<version>2.0</version>
</response>root@meet:~/greenlight#

Hallo,

wurde den die URL nach dem Update gesetzt, wie es in der Anleitung steht?
Man sollte https nehmen und das sollte man nicht mit der IP machen,
sondern mit dem FQDN

LG

Holger

Hello Centi,

Hier

und hier

steht es doch. Der Hostname, der gesetzt wurde (meet.mydomain.de) ist für BBB nicht erreichbar.
Funktioniert ein ping meet.mydomain.de bzw, ein nslookup meet.mydomain.de vom bbb-Server aus? Und ist das überhaupt richtig so? Ich kann da jedenfalls nichts anpingen. :wink:

Die Idee, mit bbb-conf --setip meet.mydomain.de (bzw. dem richtigen FQDN) den Hostnamen zu setzen, sollte das korrekt einrichten - aber offenbar stimmt da ja irgendwas mit der Erreichbarkeit nicht.

Was ist für den BBB-Server denn der zuständige DNS-Server? Gibt es da einen korrekten Eintrag für den BBB-Server (es geht z.B. bei Firewalls oft nicht, dass sie „intern“ über die „externe IP“ erreichar sind. Bei uns ist das z.B. so:

Internes Netz: DNS verweist auf 172.16.17.1 — Webserver in Orange (172.16.17.1) — Firewall mit entsprechenden Porweiterleitungen — Externes Netz: DNS verweist auf die jeweilige DSL-IP (z.B. 80.181.27.11)

So erreicht man vom internen und externen Netz den Webserver jeweils unter der richtigen IP.

Aber ist natürlich nur eine weitere Vermutung…

Viele Grüße
Thomas

Hallo Thomas,
ich möchte dan BBB nur Intern nutzen ohne dass es vom Internet erreichtbar ist. Das funktioniert auch bis auf ein paar Fehler wie Startseite, Räume kann man nicht starten.
MUSS der BBB Server von Internet erreichtbar sein um zu funktionieren? wenn ja wie kann man das ändern?
Gruß
Peter

Hallo Peter,

ich glaube nicht, dass er von außen erreichbar sein muss - aber intern muss die Namensauflösung funktionieren. Und das tut sie offenbar nicht.

Was erzeugt denn ein nslookup meet.mydomain.de vom BBB-Server aus?

Viele Grüße
Thomas

Hallo Thomas,

ich glaube so ist richtig
ich habe noch auch einem Windows DNS intern und in diesem ist aiuch so eingetragen

administrator@meet:~$ nslookup meet.mydomain.de
Server: 127.0.1.1
Address: 127.0.1.1#53
Name: meet.mydomain.de
Address: 10.11.2.30
administrator@meet:~$

Gruß
Peter

Hallo an Alle,
ich habe keine Lösung gefunden :frowning:
kann mir jemand helfen? Ideen?
Gruß
Peter

Hallo Peter,

das hatte ich gestern auch.

Geholfen hat:

service docker restart
bbb-conf restart

VG Andre

Hallo.
Unser BBB-Server hat nun eine Weile ein Schattendasein gefristet … gerade wollte ich mich mal wieder unter Greenlight anmelden, als ich auch die o.g. Fehlermeldung erhalten habe:
Serverfehler
BigBlueButton Endpunkt und Sicherheitsschlüssel ungültig

Ein Neustart hat nichts gebracht aber nach etwas Stöbern fand ich:

cd ~/greenlight 
docker run --rm --env-file .env bigbluebutton/greenlight:v2 bundle exec rake conf:check

Checking environment: Passed
Checking Connection: Failed
Error connecting to BigBlueButton server - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (certificate has expired)

Also: offenbar ist da ein Zertifikat abgelaufen…

Wenn ich apt update verwende, erhalte ich ähnliches:

  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Hit:18 https://ubuntu.bigbluebutton.org/xenial-22 bigbluebutton-xenial InRelease
Reading package lists... Done 

Mit anderen Worten: Da ist wohl ein größeres Update (z.B. auf Ubuntu Version 18.04) fällig, damit das wieder rund läuft??
Anscheinend ist nur Greenlight betroffen, denn von moodle aus kann man die Videokonferenzen wie gewohnt starten…

… und so sieht in meinem Fall die Lösung aus:

    cd ~/greenlight 
    docker-compose down
    docker pull bigbluebutton/greenlight:v2
    docker-compose up -d
3 „Gefällt mir“

yeah, danke. Das hat bei mir auch Abhilfe geschaffen.
Wenn ich im Nachgang allerdings die Standardpräsentationen austausche, werden diese nicht angezeigt.
(So gemacht, wie hier eschrieben: BigBlueButton grundlegend anpassen | andersGOOD Blog)
Any Ideas?

Servus Michael,
Sapralott! Hier gibts echt auf alles eine Antwort! Vielen Dank! Muss da jedes mal wieder mein Glas heben!
Vom Verständnis her: Greenlight hat so eine neue Version verpasst bekommen?
Beste Grüße
Andreas