Zugriff von Untagged auf Tagged VLAN


#1

Hallo!

Wir haben einen neuen Ubiquiti Edge Switch, der das Zentralorgan unseres Netzwerkes werden soll. Nun wollte ich etwas damit rumspielen und mal einen Access-Point ansteuern (Endziel).

Der Switch hängt (an Port 14) an einem ganz “normalen” Switch-Port eines HP (Ohne Tag, Ohne VLAN etc) unseres alten Netzes.

Ich hätte gerne, dass er folgendes Tut:
Vom alten Netz (Grün) aus, soll er die angeschlossenen Switches mit den VLANs 10 (Grün, Tagged) und 20 (Blau, tagged) versorgen, die senden dann an die APs Grün untagged und blau Tagged.

So weit komme ich gar nicht. Wenn ich den Edge Switch so ansteuere

verliere ich die Verbindung. Was muss ich tun? Ich will ja, dass er von Grün aus erreichbar bleibt fürs Web-Interface, in ihm Grün aber VLAN 10 ist. Warum ist die Verbindung weg?
Ich kann es ja nicht auf “default” lassen, da grün ja vlan 10 werden soll…

So ganz hab ich da was noch nicht verstanden, vielleicht hat jemand kurz einen Tipp.

Danke und lieben Gruß
Max


#2

Hallo Max!

Wir haben den Switch bei uns ein Einsatz - noch ohne VLANs, das kommt im nächsten Schuljahr.

Wenn der Switch aus dem VLAN 10 nicht erreichbar ist (aber noch aus dem Default-VLAN an Port 16) muss dem Switch noch mitgeteilt werden, aus welchem VLAN das Management möglich sein soll. Diese Einstellung sollte in der erweiterten Konfiguration bei den VLANs möglich sein.

Viel Erfolg und sonnige Grüße aus Berlin!
Roland


#3

Hallo,

Wenn der Switch aus dem VLAN 10 nicht erreichbar ist (aber noch aus dem
Default-VLAN an Port 16) muss dem Switch noch mitgeteilt werden, aus
welchem VLAN das Management möglich sein soll. Diese Einstellung sollte
in der erweiterten Konfiguration bei den VLANs möglich sein.

in aller Regel macht man das so, dass man ihm im VLAN einfach eine IP
zuweist.
Ältere Switches konnten das nicht: die waren nur aus einem VLAN heraus
erreichbar.
Ich kenne den Switch nicht, aber es sollte möglich sein.

LG

Holger


#4

Hallo!

Ich konnte die Management-VLAN-ID auf 10 ändern (Danke Roland!) und hänge jetzt aber bei der Aufnahme neuer Switches, die ja wohl als Management VLAN-ID defaultmäßig 1 haben und da auch ihren DHCP suchen.

Ich habe folgende Einstellung am Backbone:

VLANs

Auf Port 16 steckt jetzt das alte Grüne Netz, in dem sich alle Rechner und auch der UNIFI-Controller befinden und wird somit zum VLAN10 im neuen Switch.
Die Management-VLAN-ID ist auf 10 eingestellt und ich kann immer noch managen.

Wenn ich nun Grün auch noch auf Port 14 einstecke (Grün ist dann auch noch auf VLAN 1 erreichbar) ist das Management-Interface nicht mehr erreichbar, ziehe ich den Stecker wieder, dann gehts wieder.

Frage: warum? Wo ist da ein Loop (oder ist es etwas anderes)? Klar gehen 2 Kabel ins alte grüne ungetaqggte Netz, aber die “Berühren” sich doch im Switch nicht, oder?

Danke fürs Denken (an dem heißen Tag)
Max


#5

Hallo Max,

würde sagen, das ist eine Spanning-Tree Problematik. Port 16 wird geblockt, damit es nicht zu Loops kommt.

Grüße


#6

Hallo Morpweb,

danke, aber was kann ich denn nun tun? Gibt es eine Möglichkeit VLAN 1 und VLAN 10 beide im gleichen Netz zu haben? Ich weiß, der Sinn von VLAN ist ja, dass das gerade nicht so ist, aber wenn ich es möchte?

Danke und Grüße
Max


#7

Hallo Max,

aus meiner Sicht gibt es da zwei Möglichkeiten:

  • mit einer Verbindung: Das grüne Netz kommt Untagged vom HP-Switch (VLAN 1 Untagged) und wird zu VLAN10 (VLAN 10 Untagged am neuen Switch). Alle anderen VLANs müssen getagged werden.

  • mit mehreren Verbindungen. Ports müssen “aggregiert” werden. Aufteilung der VLANs wie oben.

Alle anderen Lösungen setzen voraus, dass es eine Spanning-Tree Instanz pro VLAN gibt.

Grüße