Xenserver IPFire mit Modem VLAN


#1

Hallo,
ich habe alles mit Xenserver 7.1 virtualisiert und Habe ein Problem mit dem Internetzugang.
Die rote Netzwerkkarte ist direkt am Modem angeschlossen. Für den Aufbau der Internetverbindung benötige ich wegen der Telekom ( bng und Annex J) Vlan 7. IPfire kann aber keine Verbindung aufbauen. Muss ich am Xenserver noch etwas verändern für die rote Netzwerkkarte?
Als einzelner Server lief das alles problemlos.

Viele Grüße

Steffen


#2

Hallo Steffen,

warum benötigst Du ein VLAN, wenn Du die rote Netzwerkkarte direkt an das Modem
anschließt ? Üblicherweise ist hier keines erforderlich, da Du ja eine Direktverbindung zum Modem hast.

VG
Chris


#3

Hallo Steffen,

ich würde versuchen auf dem Xenserver eine virtuelle Netzwerkkarte mit VLAN 7( gebunden an das physische Interface zum Modem) zu erstellen und diese an das rote Interface auf der Firewall zu binden. Das VLAN Tagging muss dann natürlich nicht mehr von der Firewall übernommen werden.

Grüße


#4

Hallo Chris!

Darum braucht er es:

Zitat aus www.telekom.de/hilfe/downloads/octopus-f50-bng-adsl.pdf

Nach der Umstellung auf BNG erwartet die “Telekom”, ebenso wie schon bei der Einwahl mit VDSL, für den
Internetverkehr auch via ADSL ein Tagging mit VLAN ID 7.

Zitat-Ende

Beste Grüße

Thorsten


#5

Hi Thorsten,
OK, ich kenne jetzt leider nicht die gesamte Verkabelung etc., aber in der Telekom-Anleitung zur Anlage ist die Rede davon, dass der Wan-Port in VLAN 7 konfiguriert wird. Dieser Port wird mit der Dose der Telekom verkabelt. Hat die Anlage interne Switch-Ports? Dann würde die rote Schnittstelle des IPFire hier angeschlossen werden. Erst der WAN-Port der Anlage schickt dann die Pakete getaggt mit VLAN 7 raus.
VG
Chris


#6

Hi!

Alles richtig und passt wenn es den ein Router ist. Hast du ein Modem, ja dann. Und Steff66 sprach vom letzteren. :frowning: Mit einem Router bräuchte er sich damit nicht abmühen.

Beste Grüße

Thorsten


#7

Vielen dank für eure Unterstützung. Ich habe eine Lösung gefunden:
Auf dem Xenserver habe ich PCI Pass-Through genutzt und damit die Netzwerkkarte direkt im virtualisierten IPfire eingebunden. Wenn es interessiert kann ich ja ein kleine HowTo verfassen.

Viele Grüße

Steffen


#8

Hallo Steffen!

Glückwunsch für die Selbsthilfe, wenn wir schon nicht für die Lösung sorgen konnten.

Das wäre natürlich schön und würde vielleicht jemanden irgendwann helfen. :+1:
Gerade von der gegenseitigen Hilfe lebt unserer Projekt. :grinning:

Beste Grüße

Thorsten


#9

Hallo Zusammen,

würde bei der Lösung noch den Hinweis ergänzen, dass PCI-Pass-Through meines Wissens nur für GPUs getestet und offiziell unterstützt wird.

Des Weiteren würde ich darüber nachdenken, die Firewall nicht direkt ans Internet zu hängen, sondern einen DSL-Router zu verwenden. Dies erhöht die Sicherheit der Firewall, da sie nicht direkt am Internet hängt. Auch hat man so auch ein zweistufiges Firewallkonstrukt unterschiedlicher Hersteller … :wink:

Grüße