Xen Supplemental Pack


#21

Hallo Felix,

verstehe ich den Installationsleitfaden richtig, dass ich nur die
XenServer-CD brauche und nicht den linuxmuster-supplemental-pack? Ich
will ja (momentan) nur migrieren…der supplemental-pack scheint mir
eine Sammlung Linuxmuster-VMs zu sein - oder ist es mehr?

das wäre doch garnicht so ungeschickt es so zu machen:
0) linuxmuster-ipfire --backup

  1. linuxmuster-migration --backup in der alten Installation auf eine USB
    Platte (Vorsicht: Dateisystem muss Linuxdateirechte UNterstützen: also
    kein FAT/NTFS)
  2. neuen Server aufsetzten: VMs mitinstallieren lassen
  3. Backupplatte an Server VM durchreichen und linuxmuster-migration
    –restore laufen lassen.
  4. ipFire vom Server aus auf das letzte Backup zurücksetzen.

Viele Grüße
Holger


#22

+1 So würde ich es vermutlich auch machen.


#23

Guten Tag,

ich bin dabei Linuxmuster zu installieren.
Mit Xen 7.2 habe ich es nicht hingekriegt.
Mit Xen 7.0 habe ich die VMs (lmn62.ipfire, lmn62.server, lmn62.XOA) auf die DVD gefunden hatte aber immer die Meldung: “Error : No SR specified and Pool default SR is null”.

Hat bei mir auch geholfen. Nachdem ich die Option “Enable thin provisioning” abgewählt habe, hat er tatsächlich die VMs installiert.

Jean-Francois


#24

Guten Tag Gemeinde. Ich versuche gerade auch seit 1 Tag nach der Anleitung zum 7.0.0 Packet eine Musterlösung zu installiere. Es ist sehr schade dass das Ganze sich sehr schwer tut. NIC werden nicht immer gesehen, Sup Packet wird nicht gesehen, mal so mal so. xs:main benötigt 7.0.0 Fehler??? Mein Hintergrund ist, das ich für Schulen in meinem Bundesland eine Lösung suche :slight_smile: Aber was mir hier vorliegt, lässt mich eher von der Lösung hier absehen. Schade, denn die Arbeit als solches, was die Gruppe hier geleistet hat ist ja wirklich sehr überzeugend. Jedenfalls was ich bis jetzt gelesen habe. Wie ist der aktuelle Stand?? Danke für die Info und Happy weekend, Daniel

Nachtrag Sup Pack 042 “original” hier runtergeladen ebenso das 7.0.0 xen Packet


#25

Hallo Daniel,

Guten Tag Gemeinde. Ich versuche gerade auch seit 1 Tag nach der
Anleitung zum 7.0.0 Packet eine Musterlösung zu installiere. Es ist sehr
schade dass das Ganze sich sehr schwer tut. NIC werden nicht immer
gesehen, Sup Packet wird nicht gesehen, mal so mal so. xs:main benötigt
7.0.0 Fehler??? Mein Hintergrund ist, das ich für Schulen in meinem
Bundesland eine Lösung suche :slight_smile: Aber was mir hier vorliegt,
lässt mich eher von der Lösung hier absehen.

schön ist es, wenn die INstallation in einem Rutsch geht: wichtiger ist
es aber, wie die Lösung sich im Betrieb schlägt: und darauf legen wir am
meisten Gewicht.

Die XEN Umgebung wird von der Firma NetzInt gestellt und die betreuen
die Pakete auch.
Ich selbst verwende nicht XEN sondern KVM in allen meinen Installationen.
Generell kann man die XEN Pakete nehmen: man muß aber nicht.
Man kann unsere Lösung auch “von Hand” installieren, was auch nicht der
Riesen Aufwand ist:

  1. IPFire installieren (mit 3 Netzwerkkarten) 10.16.1.254 und ssh ZUgang
    ermöglichen
  2. ubuntu server 12.04 installieren, lmn Repo einbinden,
    linuxmuster-base installieren und dann linuxmuster-setup --first
    aufrufen: absolut machbar.
    Da gibt es auch noch DoKu zu, die ich dir gerne verlinke, wenn du magst.

Wenn es dir aber erstmal um ein “hineinfühlen” in die Lösung geht, dann
stelle ich dir gerne eine .ova zur Verfügung mit
ipfire
server
Client1 (win10 und ubuntu 16.04)
Client2 (win10 und ubuntu 16.04)
Coovachilli (WLAN Zugangsserver)
WLAN Client

Das ganze kann man mit einem Doppelklick auf jedem Rechner mit min. 4 GB
Hauptspeicher und virtualbox laufen lassen. (6 oder mehr GB
Hauptspeicher sind besser: dann kann man mehr Maschinen gleichzeitig
laufen lassen).

LG

Holger


#26

Hallo Daniel,

hast du diese ANleitung verwendet?

http://docs.linuxmuster.net/de/latest/getting-started/install-on-xen/

Hast du Xen 7.0 oder 7.1 (oder 7.2) verwendet?
Hst du den Tread gelesen (warten und Thin Provisioning abwählen)?

Hast du es mal mit den xvas von hier versucht?

http://www.netzint.de/education/linuxmuster-net/xenserver-appliance-6-2

(ganz runter scrollen)

LG

Holger


#27

Hallo

vor so 3 Wochen habe ich auch mal eine Installation versucht.
Irgendeine alte Kiste die rumstand und mit wenig Aufwand den
Empfehlungen an Hardware entsprach.

http://docs.linuxmuster.net/de/latest/getting-started/install-on-xen/

Das habe ich benutzt.
Ganz beim ersten Versuch hat das auch nicht geklappt :wink:
Und in einer Stunde schon gleich garnicht :)))
Mal hat er die Netzwerkkarten nicht gefunden, mal konnte man sich als
Admin nicht anmelden, dann mal wieder die Netzwerkkarten…
Und irgendwann hat es dann doch funktioniert.
Warum? Keine Ahnung. Ich habe es einfach mal auf meine alte Hardware
geschoben.
Jetzt scheint das Ding normal zu laufen.
Demnaechst wird dann weiter probiert.

Gruesse Joachim


#28

Aus Deiner und der Sicht aller Vereinsmitglieder, die lmn 6.2 bereits haben, verständlich … Daniel hat jedoch absolut recht, wenn er zurzeit vor der Installation von der ausschließlich virtuell angebotenen lmn 7.0 zurückschreckt, selbst wenn er das Potential der hier eingeflossenen Kenntnisse und Erfahrungen durchaus zu schätzen weiß. Für ihn und alle anderen Einsteiger ist die problemlose fehlerfreie Installation keine Schönheitsfrage, sondern ein Kill-Kriterium! Wer traut sich denn heute noch mit Ubuntu 12.04 anfangen?! Dafür muss man schon ganz schön viel Vertrauen haben, wenn man beobachtet hat, wie lange die 7.0 bereits im Beta-Stadium verharrt. Für die Verbreitung von linuxmuster wäre es m. E. essentiell, dass man lmn 7.0 genauso wie lmn 6.2 auf Ubuntu Server 18.04 und auch die Firewall auf echter Hardware installieren kann - aber das schreibe ich nicht zum ersten Mal …


#29

Hallo Jürgen,

ich verstehe deine Argumente.
Man kann das so interpretieren.
Zu Sicherheit der 12.04 Installation: ja, wäre echt super, wenn wir
wenigstens auf 14.04 wären, aber der Verein hat sich entschlossen deie
Arbeit nicht in den Umstieg auf 14.04 zu stecken sondern gleich in die
7.0 und statt dessen die Sicherheit von 12.04 so zu gewährleisten dass
wir einen Entwickler damit beauftragt haben die wichtigsten Pakete, wenn
es Sicherheitsupdates gibt, für uns zu backporten.
Das funktioniert seit einem Jahr richtig gut.

Und zur langen Betaphase… da hast du wohl nicht mitbekommen, dass die
lmn 7.0 noch gar nicht in der Betaphase ist: das war sie auch noch nie.
Sie wird seit 2 Jahren entwickelt.
Wir stehen kurz vor der Alphaphase.
Jetzt gerade sind wir “Featurekomplete”: jetzt geht es ans Testen (bin
schon dabei).
Wir machen das halt anders als andere Softwarefirmen: wir produzieren
keine Bananensoftware die beim Kunden reift: wir wollen unseren guten
Ruf, eine grundsolide Lösung zu liefern, nicht auf das Spiel setzen.

Das ist nämlich einer unserer Standbeine, welche (meiner Meinung nach sind)

  • grundsolide: funktioniert einfach sehr zuverlässig
  • kann genau das, was eine Schule braucht (“von Lehrern, für Lehrer”)
  • Gute, umfangreiche Doku
  • sehr guter Support durch große Community, wiki und Telefon
  • riesige Erweiterbarkeit für den der es will (nextcloud, wiki,
    portfolio, Raumbuchung, UNTI Anbindung, moodle Anbindung usw.)

Was wir vielleicht nicht so gut können:

  • schick aussehen (die SchuKo ist altbacken)
    Das wird aber bei der lmn 7 anders werden. Und auch die Homepage wurde
    ja deutlich modernisiert
  • ja vielleicht könnte die Installation einfacher sein. Das war sie,
    aber die Entwicklung geht weiter und dann kommt eben ein neues XEn und
    dann merkt man es und dann muss da jemand nachbessern: und die die das
    machen würden, die stecken ihre Energie gerade in die lmn 7: ich kann
    damit leben.
    Wer sich gegen uns entscheidet, weil die Installation nicht auf Anhieb
    klappt … naja: wir haben ja nichts zu verkaufen, deswegen brauchen wir
    auch niemand zu uns locken.

Ach ja, und was wir gar nicht machen: mit Hochglanzprospekten und
Buzzwordsalat bei Schulleitungen und Trägern auftauchen und alle
vollabern mit Versprechungen die wir nicht halten können: das machen
andere, das bekomme ich immer wieder mit.

Also: es ist vielleicht nicht alles 5 Sterne, aber die uns wichtigen
Dinge sind so, wie sie sein sollen.

Ich bin zufrieden, auch wenn die Installation gerade etwas hakelig ist.
Ich meine in diesem Tread hier wurden viele Hinweise gegeben, wie es
doch klappt.

LG

Holger


#30

Ohne es zu wissen: wäre XCP-NG hier u.U. die bessere Alternative? Hat das schon mal jemand versucht?

Viele Grüße,
Jochen


#31

Hallo Jochen,

ich habe meine bisherige lmn.62 Umgebung von XenServer 7.1 auf XCP-ng 7.4.1 als ausfallsicheren Cluster migriert. Zudem habe ich XOA als virtuelle Maschine (XVA) zur web-basierten Verwaltung der Umgebung für Testzwecke erstellt (noch für lmn 6.2) und im Forum bereitgestellt.

Das läuft sehr stabil und es gibt keinerlei Feature-Begrenzungen wie in XenServer. In der Doku haben wir ja bereits mehrere Virtualisierungslösungen dokumentiert, da wir mit der lmn7 nicht nur eine einzige Virtualisierungslösung unterstützen wollen. Unsere Lösung funktioniert auf allen.

Mit der Version 7 der lmn werden wir aus meiner Sicht wohl eher auf XCP-ng setzen und hierfür ein Supplemental Pack erstellen, um erneut ein Angbeot für eine einfache Installation out-of-the-box verfügbar zu haben.

Dazu muss aber der Alpha-Test der lmn 7 abgeschlossen sein, dann werde ich das angehen.

VG
Christian


#32

Guten Abend Holger,
erst mal herzlichen Dank für das Feedback. Ich habe die beiden Pakete wie in der Doku geschrieben
http://docs.linuxmuster.net/de/latest/getting-started/install-on-xen/index.html verwendet.
Ich muss volgendes anmerken: Bin seit 30 Jahren in der IT und habe in Firmen immer ESX verwendet auf HP Rechner, weil einfach optimierte Packete vorhanden waren, was 100% Sicherheit und abgestimmte Installationen bedeutete. Als “Debianer” werde ich jetzt natürlich einfach eine QEMU KVM virt-manager Installation nutzen. Da ich in Schulen IPFIRE auf eigenständigen PCs einsetze ist mir das Ganze klar und benötige ich nicht.

  • Das wichtigste wäre aber nun der Schulserver zum testen, klar.

Das wir uns richtig verstehen, ich kenne die Problematik im OpenSource sehr gut und weis es zu schätzen das Leute mit viel, sehr viel Zeit und Engagement einsetzen, für die Sache arbeiten. Danke

Anmerkung: Ich habe ebenfalls einfach mal ein XEN Install original 7.5 gemacht, mit dem gleichen Effekt das Zeitweise die NIC nicht gesehen hat. Zugegeben, ich verwende hier einen alten ESPRIMO Fujitsu Desktop mit Intel NICś 3 an der Zahl und 8GB RAM mit einer 1 TB Harddisk, also kein RAID!!!


#33

Hi. Wenn du Debianer bist: warum nicht Proxmox und KVM darin nutzen?
Schönen Gruß,
Michael


#34

Danke für die Info, Michael. Viele Wege führen nach Rom.


#35

Wir sind mit der V7 durch das Prepare unabhängig von Hypervisor und Hardware. XenServer ist hier kein muss. Wir entwickeln im moment auf XCP-NG und Proxmox haben aber auch Installationen auf ESXi, VMWare Workstation, Virtualbox erfolgreich und problemlos getestet.


#36

Hallo Maurice,
ich habe es bislang so verstanden, dass irgendein Hypervisor verwendet
werdn kann und MUSS, der die VM(s) importieren kann, eine Installation
direkt auf echte Hardware jedoch nicht möglich ist. Vielleicht ist das
die Zukunft, aber noch wird das nicht jeder so sehen …

Gruß Jürgen


#37

Hallo Jürgen,

wir haben die Anforderung die Installation auf Hardware vornehmen zu können aufgenommen und bei der Entwicklung berücksichtigt. Es ist also möglich auch auf Hardware die V7 direkt zu installieren. Das ist jedoch nicht “Best-Pratice”.

Ich habe hierzu eine Matrix erstellt und @MachtDochNix hat diese Aufbereitet. Diese sollte in die Doku von V7 aufgenommen und hier verlinkt werden.

VG, Maurice


#38

Guten Abend Gemeinde…
Erst einmal danke für die guten Infos. Meine Absicht war nicht, hier eine große Diskussion anzustoßen. Jedoch zeigt sich, das der “Test” tatsächlich ein erster Eindruck hinterlässt. Mich schreckt es nicht ab, kann aber schon bei Einigen so “rüber” kommen.
Im Moment habe ich Proxmox mir mal angesehen und bei der 1. Installation gleich 100% Erfolg erlebt. Dabei habe ich erst mal, aus eigenem Interesse hier in meinem “Labor” IPFire als VM genutzt um die Stabilität in Echtzeit zu testen, also als Internetgateway mit PPPoE über mein Vigor130. Werde jetzt mal versuchen die linuxmuster.net Server Lösung zu testen/installieren. Darum geht es mir ja am Ende :slight_smile: Es ist aber schon so, dass es maßgebend ist auf einem aktuellen Stand zu sein und zu arbeiten. Die Firewall gehört meiner Meinung nach auch auf eine “echte” Maschine um möglichst störungsfrei/unabhängig und Sicher zu arbeiten.
Ich bin gespannt, was mich erwartet und würde mich evt. gerne auch in das Projekt einbringen.
In diesem Sinne “Eine gute Nacht”… Ich trinke jetzt auf unseren Nationalfeiertag noch ein Glas Wein.
CUL Daniel


#39

Hallo Zusammen,

wer ein bisschen mehr Zeit hat, der kann die Installation (mit Ergänzungen) “von Hand” im KVM - Kapitel an Hand von Screencasts verfolgen. Die Installation des Servers selbst ist ja nicht abhängig vom Virtualisierer … :wink:

http://docs.linuxmuster.net/de/latest/systemadministration/install-on-kvm/install.html#server-installation-des-servers

Grüße