Wie mit coova verfahren ?


#1

Hallo zusammen,

gibt es einen (offiziellen) Tipp, wie man mit dem Coova-Chilli verfahren sollte? Dist-Upgrade? oder lieber nicht?

Gibt es evtl eine VM mit einem neuen 64bit coova?

Grüße Rainer


#2

#3

Hallo Rainer,

wie ich hier Fehlersuche CoovaChilli

geschrieben habe, kann man ein do-release-upgrade wahrscheinlich machen, man muss nur die neuen config-Dateien installieren, und nicht seine eigenen übernehmen. Nach den Tests, die ich von zu Hause aus machen kann, müsste das funktionieren, ich kann aber erst nächste Woche in der Schule testen, ob ich ins WLAN komme (d.h. ob der Coova meine Benutzerdaten ordentlich überprüfen kann). Ich werde das dann hier posten.

LG Alex


#4

Hallo,

wie ich hier Fehlersuche CoovaChilli

geschrieben habe, kann man ein do-release-upgrade wahrscheinlich machen,
man muss nur die neuen config-Dateien installieren, und nicht seine
eigenen übernehmen. Nach den Tests, die ich von zu Hause aus machen
kann, müsste das funktionieren, ich kann aber erst nächste Woche in der
Schule testen, ob ich ins WLAN komme (d.h. ob der Coova meine
Benutzerdaten ordentlich überprüfen kann). Ich werde das dann hier posten.

Dominik und ich empfehlen:
14.04 32bit frisch installieren, dann die configs rüberkopieren.
Das ist nicht wirklich mehr Arbeit als ein do-release-upgrade und dann
die configs prüfen.
Einziger Pferdefuß: man muss die Rechte und Besitzverhältnisse der
Dateien danach wieder anpassen, weil die uids nicht mit denen der enuen
Installation übereinstimmen müssen.

LG

Holger


#5

Hallo zusammen,

ich habe einfach mal ein do-release-upgrade durchgeführt und dabei bei
jeder Frage die Vorgabe gewählt.
Das scheint geklappt zu haben … also mit einem Client konnte ich mich
einloggen. Am Mo kommt dann der Belastungstest.

@Holger&Dominik Warum neu aufsetzen? Also was könnte der Vorteil sein?
Und warum nicht 16.04 ?

GRüße RAiner


#6

Hallo Rainer,

@Holger&Dominik Warum neu aufsetzen? Also was könnte der Vorteil sein?

weil wir es unproblematischer fanden und es schneller geht: ein
neuaufsetzen, als das upgrade

Und warum nicht 16.04 ?

weil ich damit rechne vor 2019 auf lmn7 um zu steigen …

LG

Holger


#7

Ich habe den coova jetzt auf dem aktuellen source basierend auf einem ubuntu 16.04 64bit kompiliert. Ich werde das jetzt in eine neue virtuelle Machine einbauen und dann mal sehen ob es funktioniert.
Das Packet hat nur knapp ein halbes MB und kann gerne hier:
https://www.lehrerwerkzeuge.de/owncloud/index.php/s/6VY84hxq47L16zg
heruntergeladen werden.


CoovaChilli 16.04
#8

Ich habe heute mein Upgrade auf 14.04 testen können: Es funktioniert! Wie gesagt: Ich musste explizit die neuen config-Dateien der Paketersteller von freeradius übernehmen, damit es ging. Habe ich meine config-Dateien behalten (was die Standardeinstellung ist), so konnte sich im Anschluss kein Benutzer mehr anmelden (Passwort angeblich falsch…).

LG Alex


#9

Dieses Thema lief auch schon vor einiger Zeit … und auch hier mal nochmal kurz die Rückfrage:
Einige Schüler berichteten neulich, dass die Verbindung über coova (12.04) sehr langsam (geworden?) sei. Das war vor einiger Zeit aber noch nicht der Fall. Bringt hier eine Neuinstallation auf eine aktuelle Version etwas? Ich meine im Hinterkopf zu haben, dass einige auch deshalb von 12.04 auf 14.04/16.04 gewechselt haben, oder?


#10

Hallo Michael,

das war auch genau meine Beobachtung: Die Verbindung über den Coova (12.04) ist sehr langsam geworden. Daran hat aber auch eine Installation unter 14.04 nichts geändert. Ich habe den Coova jetzt rausgeschmissen, und mache es direkt über den unifi-Controller, seitdem ist die Verbindung einwandfrei.

LG Alex


Probleme mit w-LAN (coovachilli)
Probleme mit w-LAN (coovachilli)
#11

Hi.
Hm … es muss doch eine Ursache dafür geben, dass der coova “plötzlich” langsamer wird??? Hatten nicht andere berichtet, dass die Verbindung unter 14.04 (wieder) flott läuft??

Ich hatte von der netzint-Lösung gehört und weiß nicht, was du “direkt mit den Unifi-Controllern” meinst?
Bei uns ist es so, dass ein paar Scripte im coova laufen, die z.B. automatisch die Verbindung trennen, wenn Schüler in die große Pause gehen. Auf diese Funktionalität würde ich nur sehr ungerne verzichten…


Probleme mit w-LAN (coovachilli)
#12

Hallo Michael,

Bei GBit-Netzwerkkarten scheint diese Problem aufzutauchen.

mit

ethtool -K eth0 gro off
ethtool -K eth1 gro off

sind der Upload und der Download wieder annehmbar schnell. Ich habe die beiden Befehle in /etc/network/if-up.d/ethtool am Ende eingefügt:

$ETHTOOL -K eth0 gro off
$ETHTOOL -K eth1 gro off

allerdings ist das schon eine Weile her. Probiert’s einfach mal aus…

Und hier noch der Link zum nachlesen: https://github.com/coova/coova-chilli/issues/32

Gruß,

Mathias


Aussetzer beim Coova-Chilli
#13

Hi. Ich habe die Befehle abgesetzt – frage mich aber dennoch, ob hier auch virtuelle coova-Instanzen betroffen sind / sein können?? Wir haben alles unter Proxmox virtualisiert …


#14

Hallo Michael,

Wir auch :wink:


#15

Hallo Holger,

nachtrag: genau wie Rainer und Alex: ich habe ein do-release-upgrade gemacht und immer auf “I” getippt, also die Version des Paketbetreuers übernehmen.
Ohne weiteres zutun funktioniert nun auch coovachilli auf einem 14.04.
Ich finde das einfacher als eure Empfehlung, denn ich wüsste nichtmal welche Configdateien ich kopieren sollte.

VG, Tobias


#16

Ein herzliches Hallo an alle,

ich habe heute versucht den coova nach Tobias Methode auf 14.04 upzugraden:

Dabei ist mir wohl ein Fehler passiert, da ich am Schluss kein Netzwerk mehr hatte.

Ich dachte mir: Gott sei dank hab ich noch einen Backup-Clone des Coova erstellt. Da etwas schiefgelaufen ist, hab ich die alte Coova-VM gelöscht und die neue in Coova umbenannt und gestartet.

Nun hab ich folgendes Problem: Ubuntu zeigt mir auf dieser Maschine ein neues Release an. So weit so gut. Wenn ich jedoch ein do-release-upgrade machen möchte, dann sagt er mir, dass kein neues release da ist.

Nun habe ich folgendes versucht: ping gesetzt auf https://www.google.com brachte mir ein

ping: unknown host https://google.com

Es scheint also, dass die neue Virtuelle Maschine vom IPFire geblockt wird.
Muss ich die neu zugewiesenen MAC-IDs im IPFire eintragen? Und wenn ja, wie mach ich das?

Grüße
Marcus


#17

Und was macht ein ping www.google.com (ohne https://)?

Andreas


#18

Hallo Andreas,

das gleiche. Ich habe nochmals auf docs.linuxmuster.net nachgeschaut, wie man den ipfire einrichtet. Und hier sind die Netzwerkkarten definitv über MAC-ID am IPFire angemeldet. So wie es ausschaut, kann ich auf den IPFire aber nur mit Browserzugriff kommen. D.h. dass ich mich hier erst am Montag in der Schule drum kümmern kann. Was nicht so in meinem Sinne war.

Oder weißt du noch eine andere Möglichkeit?

Grüße

Marcus


#19

Hallo Marcus,

du kannst (wenn du per ssh auf den Server kommst) mit der Option -L von ssh einen Tunnel bauen und dann per Browser auf den ipfire zugreifen:

ssh -p2222 -L 8801:10.16.1.254:444 xxx@eure-schule.xx

Im Browser dann die Adresse https://127.0.0.1:8801 aufrufen.

Viele Grüße

Andreas


#20

Hallo Marcus,

Du könntest der neuen VM dieselbe MAC-Adresse geben wie der alten, dann merkt der IPFire keinen Unterschied.

Viele Grüße

Jörg