/var und /srv/linbo fast voll LMNv7

Hallo zusammen,

ich habe ein Problem und zwar ist auf einmal diese meldung aufgetaucht:

/var ist using 94,7% of 9,78 GB
/srv/linbo is using 93,9% of 39,12 GB
grafik

der update prozess funktioniert auch nicht mehr wie kann ich die partition /var vergrößern

ich habe im ubuntu 2 festplatten einmal die systemplatte 250 gb
und eine 1,5 TB Festplatte ich kann natürlich mehr speicher dazupacken aber könnte ich dann zumbeispiel einfach einen gparted live usbstick nehmen und die partition vergrößern?

Lg Pascal

Im Log verzeichnis liegt sehr viel rum was kann davon weg?

Außerdem liegt sehr viel im /var/cache/ von linbo gibt es einen befehl diesen cache mal zu leeren?

3604    /var/cache/linuxmuster/linbo/iso/boot/grub/i386-pc
3628    /var/cache/linuxmuster/linbo/linbofs64/bin
3728    /var/cache/linuxmuster/linbo/linbofs/bin
3728    /var/cache/linuxmuster/linbo/linbofs-np/bin
4796    /var/cache/linuxmuster/linbo/iso/boot/grub/x86_64-efi
4852    /var/cache/debconf
5884    /var/cache/linuxmuster/linbo/linbofs/usr/lib/grub
6040    /var/cache/linuxmuster/linbo/linbofs/lib/udev/hwdb.d
6040    /var/cache/linuxmuster/linbo/linbofs-np/lib/udev/hwdb.d
6500    /var/cache/linuxmuster/linbo/linbofs64/lib/udev/hwdb.d
6528    /var/cache/linuxmuster/linbo/linbofs64/usr/lib/grub
6568    /var/cache/linuxmuster/linbo/linbofs/lib/udev
6568    /var/cache/linuxmuster/linbo/linbofs-np/lib/udev
7248    /var/cache/linuxmuster/linbo/linbofs-np/usr/lib
8004    /var/cache/linuxmuster/linbo/linbofs-np/lib/modules/4.14.88/kernel/drivers/net/ethernet
8032    /var/cache/linuxmuster/linbo/linbofs/lib/modules/4.14.88/kernel/drivers/net/ethernet
8924    /var/cache/linuxmuster/linbo/linbofs-np/lib/modules/4.14.88/kernel/drivers/net
8952    /var/cache/linuxmuster/linbo/linbofs/lib/modules/4.14.88/kernel/drivers/net
9652    /var/cache/linuxmuster/linbo/linbofs/usr/lib
11120   /var/cache/linuxmuster/linbo/linbofs64/usr/lib
11912   /var/cache/linuxmuster/linbo/linbofs64/lib/modules/4.14.88/kernel/drivers/gpu/drm
11916   /var/cache/linuxmuster/linbo/linbofs64/lib/modules/4.14.88/kernel/drivers/gpu
12852   /var/cache/linuxmuster/linbo/linbofs-np/lib/modules/4.14.88/kernel/drivers
12888   /var/cache/linuxmuster/linbo/linbofs/lib/modules/4.14.88/kernel/drivers
12964   /var/cache/linuxmuster/linbo/linbofs-np/lib/modules/4.14.88/kernel
13000   /var/cache/linuxmuster/linbo/linbofs/lib/modules/4.14.88/kernel
13160   /var/cache/linuxmuster/linbo/linbofs64/usr/bin
13556   /var/cache/linuxmuster/linbo/linbofs-np/lib/modules/4.14.88
13560   /var/cache/linuxmuster/linbo/linbofs-np/lib/modules
13592   /var/cache/linuxmuster/linbo/linbofs/lib/modules/4.14.88
13596   /var/cache/linuxmuster/linbo/linbofs64/lib/modules/4.14.88/kernel/drivers/net/ethernet
13596   /var/cache/linuxmuster/linbo/linbofs/lib/modules
15020   /var/cache/linuxmuster/linbo/linbofs64/lib/modules/4.14.88/kernel/drivers/net
15324   /var/cache/linuxmuster/linbo/linbofs-np/usr/bin
15324   /var/cache/linuxmuster/linbo/linbofs/usr/bin
16804   /var/cache/linuxmuster/linbo/linbofs64/lib/udev
18520   /var/cache/linuxmuster/linbo/iso/boot/grub
18524   /var/cache/linuxmuster/linbo/iso/boot
24092   /var/cache/samba
26944   /var/cache/linuxmuster/linbo/linbofs-np/usr
27468   /var/cache/linuxmuster/linbo/linbofs64/usr
29348   /var/cache/linuxmuster/linbo/linbofs/usr
30808   /var/cache/linuxmuster/linbo/linbofs-np/lib
30844   /var/cache/linuxmuster/linbo/linbofs/lib
35864   /var/cache/linuxmuster/linbo/linbofs64/lib/modules/4.14.88/kernel/drivers
36044   /var/cache/linuxmuster/linbo/linbofs64/lib/modules/4.14.88/kernel
36904   /var/cache/linuxmuster/linbo/linbofs64/lib/modules/4.14.88
36908   /var/cache/linuxmuster/linbo/linbofs64/lib/modules
62768   /var/cache/linuxmuster/linbo/linbofs-np
62932   /var/cache/linuxmuster/linbo/linbofs64/lib
65208   /var/cache/linuxmuster/linbo/linbofs
77884   /var/cache/apt
97600   /var/cache/linuxmuster/linbo/linbofs64
178236  /var/cache/linuxmuster/linbo/iso
403816  /var/cache/linuxmuster/linbo
403912  /var/cache/linuxmuster

Hallo,

die roten .gz-Dateien kannst Du löschen.

Liegen unter /var/ auch die cloops? Wenn ja, lösch ein paar Sicherungen.

Gruß

Alois

Hallo Alois,

die habe ich gelöscht hat aber nur 17 MB gebracht die cloops liegen
unter /srv/linbo/. Eine sicherung habe ich gelöscht von cloop das hat 9 gb bebracht also in /srv/linbo ist wieder platz für ein image.

aber in /var ist immer nur noch 17 mb frei

Hallo,

wie groß ist denn /var überhaupt? Schau mal mit ncdu nach was wieviel Platz auf Deinem Server verbraucht?

Hast Du LVM eingerichtet? Damit sollte das Erweitern der Partition möglich sein.

Viele Grüße

Alois

Unter /var/cache/apt/archives/ sammeln sich bei jedem Update-Prozess die *.deb Pakete. Die kann man auch alle hin und wieder löschen.

Ansonsten kannst du mit dem du-Befehl auf die Suche gehen. Zum Beispiel:

du -sh /var/cache/apt/

In /srv/linbo/ liegen auch noch die cloops, die viel Platz benötigen. Brauchst du wirklich alle? Gibt es Sicherheitskopien (zu erkennen am Datum im Dateinamen). Die können auch weg…

Wenn das nicht reicht bleibt nur die Option die Volumes zu vergrößern. Anleitungen dazu gibt es hier im Forum…
Gruß
Ralf

Hallo Pascal,

an deiner Stelle würde ich deine 1,5TB Partition verkleinern und den freigewordenen Platz für /var und /srv/linbo nehmen. Such mal nach „lvm verkleinern“ bzw. vergrößern. Da solltest du Tutorials finden, die erklären, wie das geht. Vorher Backup machen :slight_smile:

Für /srv/linbo sind 40GB etwas klein, v.a. wenn du noch Windows-Cloops haben solltest.

vG Stephan

Verwendest du zufällig ein linux-cloop aus den client-servertools??? Die werden nämlich auch in /var/ gespeichert und hauen direkt die Partition voll? Siehe hier:

Hier ist die übersicht sehe ich hier auch ob lvm eingerichtet wurde ?
Ich habe damals einfach eine normale ubuntu installation gemacht

root@server:/var/log# df -lh
Filesystem                          Size  Used Avail Use% Mounted on
udev                                3,9G     0  3,9G   0% /dev
tmpfs                               794M  2,3M  791M   1% /run
/dev/sda2                           245G  5,4G  227G   3% /
tmpfs                               3,9G     0  3,9G   0% /dev/shm
tmpfs                               5,0M     0  5,0M   0% /run/lock
tmpfs                               3,9G     0  3,9G   0% /sys/fs/cgroup
/dev/sda1                           511M  6,1M  505M   2% /boot/efi
/dev/mapper/vg_srv-linbo             40G   29G  9,1G  76% /srv/linbo
/dev/mapper/vg_srv-global           9,8G  1,2G  8,2G  13% /srv/samba/global
/dev/mapper/vg_srv-default--school  1,5T   76G  1,3T   6% /srv/samba/schools/default-school
/dev/mapper/vg_srv-var              9,8G  9,3G   17M 100% /var
tmpfs                               794M     0  794M   0% /run/user/1000

habe den gerade mal ausgeführt verbraucht nur 77M

nein ich habe direkt frisch installiert mit den linuxmuster-prepare script

wie sehe ich den ob lvm installiert ist kann ich auch da ich nicht so gut auf der konsole bin einfach einen gparted live usb/cd nehemen und damit die partionen ändern ?
Backup ist erstellt.

Lg Pascal

Hallo Pascal,

Hier ist die übersicht sehe ich hier auch ob lvm eingerichtet wurde ?

ja du hast lvm.

Ich habe damals einfach eine normale ubuntu installation gemacht

… aber dem installscript nicht gesagt, dass du gerne größere /srv/linbo
und /var Partitionen haben würdest…
Das ist auch (noch?) etwas versteckt.

Damit ist dein weg nun folgender:
lv von samba verkleinern (vg_srv-default–school)
Dann lv von linbo um einen Teil dessen vergrößern
Dann lv von var um den Rest vergrößern.

Ich hab sowas ein paar mal gemacht: immer nach spontan gesuchten
Anleitungen im Netz (ecosia ist dein Freund).

lG

Holger

Alle Dateien mit der Endung .gz

VG Andre

Hallo Holger,

damit ich doch die partition bearbeiten kann muss ich

/srv/linbo
/var
/srv/samba/schools/default-school
unmounten

dies möchte ich mit dem befehl umount /srv/linbo tun

aber als fehler kommt immer target is busy.

bei /var das gleiche

Muss ich das vieleicht mit einer live cd machen oder geht das direkt im laufenden betrieb?

LG Pascal

Du musst die Partitionen dafür nicht aushängen.

Du vergrößerst die Festplatte im Hypervisor. Dann scannst du die Phsyical Volumes. Anschließend kannst du den logischen Volumes mehr Speicher zuteilen. Abschließend vergrößerst du das Dateisystem mittels resize2fs.

also ist das der einfachere weg ohne das ich die /srv/samba/schools/default-scholl verkleinern muss? von meinen 1,5 TB

und ist es normal das ich jetzt beim runterfahren immer den fehler erhalte
failed to unmount /var
&
failed to unmount /srv/linbo

Hallo Pascal,

Muss ich das vieleicht mit einer live cd machen oder geht das direkt im
laufenden betrieb?

live CD: schau dir Anleitungen im Netz an.

LG

Holger

habe eine gefunden die es erklärt
https://wiki.linuxmuster.net/archiv/dokumentation:handbuch51:wartung:lvm:groesse_lvm_aendern

und das hier war auch sehr hilfreich
https://wiki.ubuntuusers.de/Logical_Volume_Manager/

Für alle die die befehle benötigen hier:

lvreduce --resizefs -L -100G /dev/vg_srv/default-school

lvextend --resizefs -L +50G /dev/vg_srv/var

lvextend --resizefs -l +100%FREE /dev/vg_srv/linbo

e2fsck -f /dev/vg_srv/var

e2fsck -f /dev/vg_srv/linbo

e2fsck -f /dev/vf_srv/default-school

und siehe da es funktioniert

Ich bedanke mich für die Hilfe

LG Pascal

1 Like

jetzt wirft mir der lmn server diese fehlermeldung

grafik

wie überprüfe ich die festplatte auf fehler und repariere sie unter ubuntu?

p.s. scheint wohl falscher alarm zu sein ich habe gar keine dev/sdc
grafik

Lg Pascal