Schulkonsole nur über IP ereichbar


#1

Hallo zusammen,

ich habe das Problem, dass meine neu installierten Win10 Rechner die Schulkonsole nur über die IP-Adresse erreichen. Also:
https://IP-Adresse:242 statt über https://Server:242
Ebenso klappt das Drucken nicht mit http://Server:631/printers/
http://IP-Adresse:631/printers/… habe ich dann eingerichtet, konnte ich aber noch nicht testen, da der Kollege in den Raum musste.
Als DNS ist der Schülerserver eingerichtet, aber irgendwie klappt es mit der Namensauflösung nicht.

Danke für Eure Hilfe und Tipps
Oliver


#2

Hallo HAL,

ich habe das Problem, dass meine neu installierten Win10 Rechner die
Schulkonsole nur über die IP-Adresse erreichen. Also:
https://IP-Adresse:242 statt über https://Server:242
Ebenso klappt das Drucken nicht mit http://Server:631/printers/
http://IP-Adresse:631/printers/… habe ich dann eingerichtet, konnte
ich aber noch nicht testen, da der Kollege in den Raum musste.
Als DNS ist der Schülerserver eingerichtet, aber irgendwie klappt es mit
der Namensauflösung nicht.

ist das ein Win10 1607?
Ich hatte vorgestern an der Hotline einen Fall, wo das frisch
installierte Win10, SOBALD es in der DOmäne ist, keine Namensauflösung
mehr macht.
Das ist ein schöner Mist, weil auch das netlogon Verzeichnis nicht mehr
zugreifbar ist: also die scripte nicht mehr ausgeführt werden.
Ich vermute, dass win 10 1607 da was am netlogon und am DNS umgestellt hat.
Vielelicht ist dem, wenn es in der Domäne ist, der DNS des Servers zu
"unsicher" …

Hat jemand eine Idee?

LG

Holger


#3

Hallo Holger und alle anderen Mitstreiter,

es ist ein Win10 1511. Jetzt erinnere ich mich wieder: vor der Domänenaufnahme ging es mit dem DNS, nach der Aufnahme nicht mehr. (War mir nicht mehr ganz sicher ob ich das korrekt in Erinnerung hatte, deshalb habe ich es nicht erwähnt.)

LG
Oliver


#4

Hallo Holger und alle Mitstreiter,

ich wollte am Freitag schon jubeln, dass die Schulkonsole über https://servername:242 erreichbar und habe es heute mit den Schüler mit folgenden Ergebnis ausgetestet:

  • Zuerst kamen die Schüler nicht mit https://servername:242 hinein. Es klappte nur https://10.16.1.1:242
  • Dann habe ich mit https://10.16.1.1:242 die Schulkonsole aufgerufen und den Unterricht gestartet.
  • Die Schüler haben wieder mit https://servername:242 die Schulkonsole aufgerufen und die Fehlermeldung “Zeitüberschreitung” erhalten. Ein Klick auf “nochmal versuchen” öffnete dann die Seite
  • Dann habe ich es wieder auf meinem Rechner ohne Ergebnis probiert. Ein Eintrag in der Hostsdatei “10.16.1.1 Servername” Löste dann das Problem.

Mein Frage wäre nun: Kann man auf die Schulkonsole als Schüler nur zugreifen, wenn der Lehrer den Unterricht gestartet hat?

Viele Grüße
HAL


#5

Hallo HAL,

die Schüler müssen auch ohne das der Unterricht gestartet ist in die Schulkonsole kommen.

Gruß
Manfred


#6

Hallo Oliver,

Mein Frage wäre nun: Kann man auf die Schulkonsole als Schüler nur
zugreifen, wenn der Lehrer den Unterricht gestartet hat?

nein: das geht natürlich auch so.
Du hast offensichtlich ein Namensauflösungsproblem in dienem Netz.
Läuft bind auf dem Server?

Viele Grüße

Holger


#7

Hallo HAL,

in einem anderen Tread hast du geschrieben, dass es Win10 ist.

Ich habe gerade angefangen aufgrund der Beobachtungen einer Firma, das
Verhalten von Win10 1607 zu untersuchen.
Symptom: Nach Domänenaufnahme geht DNS nicht mehr udn auch das netlogon
Verzeichnis ist nicht mehr erreichbar.
Das sind beides Dinge, die MS in Win10 extra “abgeschlatet” hat: unser
Regpatch sollte sie verfügbar halten.
Möglicherweise wirkt der Regpatch aber seit 1607 nicht mehr richtig.

Also: hast du 1607?
Hast du 1607 direkt installiert?
Hast du 1511 installiert und dann auf 1607 upgedatet? Vor oder nach
EInspielen des Regpatches?
Vor oder nach Aufnahme in die Domäne?

Viele Grüße

Holger


#8

Hallo Holger,

ein ps -aux grep bind liefert folgende Programme/Skripte die laufen:

  • rpcbind -w
  • /usr/sbin/atftpd --deamon --bind-address 10.16.1.1 --tftpd-timeout 300 --retry-timeout 5 --maxthread 100 --verbose=5 /var/linbo
  • /usr/sbin/named -u bind

Es ist Win10 1511 installiert und noch nicht upgedatet.

ich habe heute noch ein wenig herumprobiert. Der DNS scheint doch korrekt zu laufen, denn ein ping www.heise.de liefert eine IP, die zum Heise-Verlag gehört. Ein Ping auf meinen Schülerserver liefert die IP-Adresse eines Hosters HEG Managed, der anscheinend eine Niederlassung in Köln hat. Ich habe dann das Ganze mit nslookup verfolgt. Ein

#> nslookup schuelerserver.schuelernetz.local
#> Server: schuelerserver.schuelernetz.local
#> Address: 10.16.1.1
#>
#> Nicht autorisierende Antwort:
#> Name: schuelerserver.schuelernetz.local.SCHUELERNETZ
#> Addresses: 62.138.238.45
#> 62.138.239.45

Im Vergleich dazu liefert

#> nslookup SCHUELERSERVER.SCHUELERNETZ.LOCAL
#> Server: schuelerserver.schuelernetz.locaL
#> Address: 10.16.1.1
#>
#> Name: SCHUELERSERVER.SCHUELERNETZ.LOCAL
#> Address: 10.16.1.1

Nachdem die Großschreibung geklappt hat, bin ich mir nicht mehr sicher, was ich vor einem 3/4 Jahr eingegeben habe (groß oder klein). Kann das eine Rolle spielen?

Viele Grüße
HAL


#9

Hallo Oliver,

#> nslookup SCHUELERSERVER.SCHUELERNETZ.LOCAL
#> Server: schuelerserver.schuelernetz.locaL
#> Address: 10.16.1.1

sag mal: wie heoßt den dein server
server?
oder
schuelerserver?

Was steht den auf dem Server in /etc/hosts

LG

Holger


#10

Hallo Holger,

der Server heißt: schuelerserver im Netz schuelernetz.local

Was ich noch festgestellt habe ist, dass, wenn ich die Win10 (1511) Rechner aus der Domäne heraus nehme, dann bringt der Aufruf:
#> nslookup schuelerserver
#> Server: schuelerserver
#> Address: 10.16.1.1
#>
#> Name: schuelerserver
#> Address: 10.16.1.1

das korrekte Ergebnis. Sobald der Rechner wieder in der Domäne ist, bekomme ich den Link nach Köln (s.o.).

LG
Oliver


#11

Hallo Oliver,

versuch doch mal folgendes:

Wenn der Rechner in der Domäne ist, es also gerade nicht funktioniert, mit:

ipconfig /all

die gesamte Netzkonfiguration anzeigen lassen (und am besten posten).

Da sollte für die Ethernetverbindung (LAN) zunächst die IP des Clients
stehen, also 10.X.X.X

In demselben Abschnitt sollte auch ein DNS-Server aufgeführt sein. Wenn
dies nicht der LML-Server ist (10.16.1.1), dann ist das schon mal das
Problem. In diesem Fall würde ich als Workaround den DNS-Server fest
eintragen (nur den DNS-Server vorgeben, die IP-Adresse trotzdem
automatisch beziehen).

Wenn da allerdings die 10.16.1.1 aufgeführt ist, dann poste doch bitte
mal die Ausgabe von:

nslookup

Viele Grüße

Jörg Richter


#12

Hallo Jörg,

der DNS ist in beiden Fällen (mit/ohne Domäne) der 10.16.1.1
Das ist das was ich nicht verstehe. Die Ausgaben vom nslookup stehe weiter oben, kann sie aber am Mittwoch noch als Bild hinzufügen.

Danke derweil für Deine Hilfe!
Schöne Osterfeiertage

Oliver


#13

Hallo Oliver,

Weiter oben ist eine Ausgabe von nslookup, aus der hervorgeht, dass da noch ein weiteres “schuelernetz” angehängt wird. Das führt dann zu der falschen IP.

Dabei ist mir aufgefallen, dass Du “local” als TLD verwendest. Das ist keine gute Idee, denn diese TLD wird für Multicast-Dienste verwendet, und das führt auch noch an anderer Stelle zu Problemen. Wenn man keine echte Domäne verwendet, dann sollte man einen kompletten Phantasienamen nehmen (z. B. “lokal”). Ob Dein Problem aber damit zusammenhängt, das weiß ich nicht.

Viele Grüße

Jörg


#14

Ok, noch ein wenig weitergedacht.

Ich vermute, dass Deine Windows-Domäne SCHUELERNETZ heißt. Windows hängt das als Suffix an den Rechnernamen dran.

Bei den Einstellungen zur IP-Adresse gibt es erweiterte DNS-Einstellungen. Dort gibt es eine Option, die ungefähr “Primäre DNS- Suffixe anhängen” heißt - ich weiß es gerade nicht auswendig. Die kannst Du ja mal testweise deaktivieren. Dann wird zwar eventuell auch z. B. server nicht mehr aufgelöst, sondern nur noch server.schuelernetz.local aufgelöst, aber dann wüssten wir, dass wir auf der richtigen Spur sind.

VieleGrüße

Jörg


#15

Hallo miteinander,

bei meinem Versuch, einen Windows 10 cloop (nur?) für mich zu basteln, bin ich jetzt auch auf das DNS-Problem gestoßen. Ich bin jetzt so weit, dass externe IP-Adressen richtig aufgelöst werden, man also “surfen” kann. Für interne Adressen - und dazu gehört neben “server” und “ipfire” auch “wpad” für die automatische Proxyerkennung! - wird jedoch für wpad.SCHULE gesucht und eine völlig blödsinnige IP 164.x.y.z und für server.SCHULE 162.x.y.z oder umgekehrt gefunden.
Ich habe Windows 1607 installiert und mittlerweile hat sich das System selbstständig auf 1709 aktualisiert. Ob der Fehler mit einem der Windows Updates oder mit derjenigen für ipfire zusammenhängt kann ich nicht mehr reproduzieren.
Der xenial-Client mit dem aufgepropften KDE Neon löst alle internen Namen richtig aus und wertet wpad.dat nach wie vor zu meiner vollen Zufriedenheit aus.
Mit Android, iOS und Mac OS X muss ich noch weiter testen - wobei zumindest Android mit wpad nichts anfangen kann, nur mit einer explizit angegebenen Adresse für proxy.pac.

Was könnte ich auf dem Windows Client machen?

Könnte ich etwas am DNS von linuxmuster oder der wpad.dat bzw, proxy.pac machen?

Gruß Jürgen


#16

Hallo Jürgen,

hast du die Regpatches nach dem UPdate nochmal eingespielt?
Vielleicht ist das der Fehlende Schritt …

Meine Win10 Installationen lösen korrekt auf.

LG

Holger


#17

Hallo Holger,

der regpatch ändert nichts.

Es klappt jedoch, wenn ich in Windows bei den Netzwerkadapter
Eigenschaften für DNS eintrage, dass “linuxmuster-net.lokal” angehängt
werden soll.
Was sorgt dafür, dass dort SCHULE eingetragen wird und wieso bekomme ich
dann eine Phantasie-IP statt keiner Antwort zurück?
smb.conf?
dhcpd.conf?

Eine wenn auch hölzerne Lösung wäre der harte Eintrag oben für mich -
möglicherweise jedoch nicht für jemanden, der einen echten Domain-Namen
verwendet.

Gruß Jürgen