OpenVPN-Probleme Windows 10-Clients

Hallo Liste!

In unserem Kollegium gibt es einige Kollegen, die Probleme haben, über OpenVPN von zuhause aus auf Ressourcen im Schulnetz zuzugreifen (darunter ist dummerweise auch meine Frau, die mir da ganz schön Druck macht). Betroffen sind ausschließlich Windows 10-Systeme, bei meinem eigenen Windows 10-Rechner funktioniert der Zugang allerdings problemlos.
Das Fehlerbild:
Die OpenVPN-Verbindung lässt sich problemlos aufbauen, der Verbindungsmonitor wird grün, allerdings lassen sich keine Websiten aufrufen oder anpingen.
Wo könnte ich da ansetzen?

Vielen Dank

Thomas

Hallo Thomas,

OpenVpn muss zwingend als Administrator ausgeführt werden. Ansonsten
passiert das was Du beschreibst.

Gruß

Alois

Hallo Alois,

danke für Deine Hilfe. An das habe ich auch schon gedacht. OpenVPN wird aber definitiv als Administrator ausgeführt.

Liebe Grüße

Thomas

Hallo,

OpenVpn muss zwingend als Administrator ausgeführt werden. Ansonsten
passiert das was Du beschreibst.

genau: dann wird nämlich die Route wegen mangelnder Rechte nicht
gesetzt: schwupps kommt man nirgend wo hin: schade, dass es keine
Fehlermeldung gibt.

Das Problem besteht seit Vista

Also: OVPN nicht in den Autostart oder so, sondern immer mit rechter
Maustaste -> “Ausführen als Administrator” starten.

Viele Grüße

Holger

Hallo Thomas,

man muss mit rechtem Mausklick auf das OpenVpn-Icon klicken und dort “als
Administrator ausführen” auswählen. Administrator sein reicht nicht.

Möglicherweise musst Du eine andere Version von OpenVpn installieren.

Gruß

Alois

Hallo Alois,

hab ich auch beides schon versucht, also rechter Mausklick “als Administrator ausführen” und eine neuere Version von OpenVPN installiert. Es ist wirklich ein merkwürdiges Problem.

Viele Grüße

Thomas

Hallo Thomas,

vielleicht eine Dumme Frage. Ist das Zertifikat im Ipfire frei geschaltet?

Gruß

Alois

Hallo Alois,

ja, das Zetifikat ist freigeschaltet.

Ich habe mir jetzt mal die Logdatei von OpenVPN angeschaut. Es sieht alles gut aus, auch die ROUTE-Befehle laufen alle durch, so dass wohl auch die Administrator-Rechte vorhanden sind. Dann kommt eine Fehlermeldung:

read from TUN/TAP : Es sind mehr Daten verfügbar. (code=234)

Ich habe diese Meldung schon gegoogelt. Dabei wird empfohlen, die MTU-Werte zu ändern (z.B. tun-mtu 1500

und tun-mtu-extra 32 ?) und zwar sowohl auf Client-, als auch auf Server-(also IPFire-)Seite. Kann ich das gefahrlos tun oder handele ich mir damit nur neue Probleme ein?

Viele Grüße

Thomas

Hallo Thomas,

da würde ich zunächst - wie hier beschrieben

http://www.it-fehler.de/mtu-size-ermitteln/

die richtige mtu ermitteln.

Gruß

Alois

Hallo Alois,

danke für die Info. Ich komme bei diesem Testverfahren auf eine MTU von 1492, also den Standardwert. Soll ich diesen dann beim IPCop und in den *.ovpn-Dateien eintragen?

Viele Grüße

Thomas

Hallo Thomas,

Du musst im Ipfire in der Konfiguration von OpenVPN die MTU eintragen
(zuvor OpenVPN stoppen). Nach dem Start von OpenVPN ist die MTU auf dem
tun-Device 1500 (as zeigt ifconfig auf dem IPFIRE an).

Jetzt kannst Du die Konfigurationsdatei für OpenVPN auf dem lokalen Rechner
auf 1500 ändern.

Bei mir ist es im Übrigen egal ob 1500 oder 1400 eingestellt ist. OpenVPN
funktioniert.

Prinzipiell sollte man, wenn die Änderung erfolgreich ist, allen die
bereits ein Zertifikat haben dazu raten ein neues Zertifikat zu erstellen
(dazu muss das vorhandene Zertifikat gelöscht werden).

Gruß

Alois

Hallo Alois,

jetzt bin ich endlich dazugekommen, an diesem leidigen Problem weiterzuarbeiten.
ich habe auf dem IPFite die MTU auf 1500 gesetzt und auf dem betroffenen Client im OpenVPN-Profil ebenfalls 1500 eingestellt, aber das Problem bleibt weiter bestehen.
Ich glaube auch, dass es bei funktionierendem OpenVPN Wurst ist, ob 1400 oder 1500.
Vielleicht hat noch jemand eine Idee, wo man da noch was drehen könnte?

Gruß

Thomas

Ich habe die Erfahrung gemacht, dass es manchmal besser ist statt einen
festen Wert zu vergeben die Option “MTU-Discovery” zu benutzen. Dann
handeln Server und Client bei jeder Verbindung die optimale Enstellung aus.
Vielleicht kannst Du ja auch das mal probieren.

Gruß

Michael

Hallo Michael,

danke für den Tipp: Ich habe da mehrere Optionen. Soll ich “Forciert” oder “optional” nehmen?

Gruß

Thomas

Hallo Thomas,
hast du damit Erfolg gehabt? Oder hast du da Problem anders gelöst?
Viele Grüße ,
Helge

Hallo Helge,

scheinbar habe ich damit Erfolg gehabt. Zumindest habe ich jetzt zum Schuljahresbeginn bei einigen Kollegen den openVPN-Zugang eingerichtet und es hat bei allen funktioniert. Nur beim Rechner meiner Frau besteht das Problem nach wie vor noch, obwohl ich alles Menschenmögliche versucht habe.

Viele Grüße

Thomas

Hallo Thomas,

kannst du bitte deine red.ovpn posten? Irgendwie kriege ich es noch nicht hin mit Windows10. Mit Ubuntu ist es gar kein Problem, läuft wie am Schnürchen. Nur dieser Win10-PC vom Kollegen …

Danke schonmal,
Helge

Hallo Helge,

hast Du mal testweise die Firewall auf dem Rechner Deiner Frau ausgeschaltet?

Gruß

Alois

Hallo Alois,
ich bin nicht der, dessen Frau Probleme hat, sondern dessen Kollege - ist aber wohl egal :wink:

Ich habe es auf einem PC mit Win10- Home probiert und gesehen, dass es geht. Es ist auch nicht nötig, das Programm als Administrator zu starten - kann das an der Home-Version liegen? Das einzige ist, dass der Nameserver nicht gesetzt wird. D.h. alle Eingaben mit IP-Adresse.

Viele Grüße,
Helge

Hallo Helge und Alois,

ja ich habe testweise die Firewall ausgeschaltet. Wie geschildert, das Problem ist, dass sich die openVPN-Verbindung problemlos aufbaut, dann aber keine Netzwerkadresse im Schulnetz erreicht wird.
Hier meine red.ovpn:

#OpenVPN Server conf
tls-client
client
dev tun
proto udp
tun-mtu 1400
remote fassoldshof.dd-dns.de 1194
pkcs12 tbordfeldt.p12
cipher BF-CBC
comp-lzo
verb 3
ns-cert-type server

Viele Grüße

Thomas