Nextcloud 14 upgrade tut


#1

Hi,

ich habe nextcloud 13.0.6 auf nextcloud 14.0.1 /manuell/ ge-up’ed.
Allerdings hatte mir das webinterface diese Möglichkeit noch nicht angezeigt.
Dennoch: es tut so weit wie bisher. Ein paar Änderung weden teilweise angemahnt:

grafik

  1. occ db:add-missing-indices: Hat tatsächlich auch mit dem angegebenen Kommando ersten Punkt bereinigt. Geht im laufenden Betrieb.
  2. Zweiten Punkt “no-referrer” müsste meiner Meinung nach eigentlich von der nextcloud-installation in der .htaccess-Datei selbst behoben werden. Um die Fehlermeldung eben weg zu haben, habe ich es (sieh weiter unten im Thread) in der Datei:/etc/apache2/sites-enabled/default-ssl.conf gemacht: dort die letzte Zeile von
        RequestHeader set X_FORWARDED_PROTO 'https'
        Header always set Strict-Transport-Security "max-age=31536000; includeSubDomains"
        Header always set Referrer-Policy "no-referrer"

eingefügt. Die ersteren Zeilen sind schon vorher (von mir) drin gewesen und aktiveren HSTS, oder so ähnlich.

  1. noch dazu:
    nextcloud wirbt jetzt offensiv für ein Abonnement…

  2. well-known/caldav-Problem:

Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/caldav” aufzulösen. Weitere Informationen findest Du in der Dokumentation

In dem Server, der kein unterverzeichnis hat, habe ich die Warnung gar nicht. In dem anderen habe ich das Problem gelöst, in dem in der selben Datei /etc/apache2/sites-enabled/default-ssl.conf

                Redirect 301 /.well-known/carddav /subdir/remote.php/dav
                Redirect 301 /.well-known/caldav /subdir/remote.php/dav

hinzugefügt wurde. Das doppelt sich dann mit den Einträgen in der .htaccess. Evtl. muss man den Eintrag in der .htaccess auskommentieren, aber dann schreit wiederum die Dateisignatur von NC.

Hoffe das hilft jemandem.
Tobias


Update NextCloud 13.05 --> 14.0 macht Probleme
#2

p.s. gemischt mit upgrade von 16.04 auf 18.04:

es gab ein paar Dinge, die nicht vollst’ndig installiert oder uninstalliert worden warten:

php-intl und php-curl waren bei mir nachzuinstallieren.

ersteres viel mir grade erst auf, weil Fehlermeldungen wie
Error PHP You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /opt/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18

sich bei mir zu hauf einliefen.


Update NextCloud 13.05 --> 14.0 macht Probleme
#3

Hi Tobias
Danke, die Hints haben mir ein Haufen Zeit gespart.
Bin jetzt mit web-updater und dann occ manuell auch auf 14.01, jedoch noch mit 16.04 drunter.
LG
Max


#4

Hallo,

ich habe eine Kopie der .htaccess gesichert, da sie beim nächsten Update überschrieben wird und die editierten Einträge dann fehlen.

Viele Grüße

Wilfried


#5

Hallo,

nachdem ich heute auf 14.02 upgedatet habe waren die Fehlermeldungen wieder alle da und noch 2 neue.
Nach dem Zurückkopieren der gesicherten .htaccess bleiben dann nur noch die neuen:

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/caldav” aufzulösen. Weitere Informationen findest Du in der Dokumentation.
  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/carddav” aufzulösen. Weitere Informationen findest Du in der Dokumentation.

Weitere Hinweise finden sich noch hier:

Habe es aber noch nicht hinbekommen, da mir nicht klar ist, wo das Rootverzeichnis des Webservers apache ist. Vielleicht weiß jemand mehr.

Viele Grüße

Wilfried

PS: So langsam werden die Updates wieder nervig …


#6

Hallo Wilfried,

habe Roland gestern über die Schulter geschaut beim upgrade auf 14.0.3 (!) und dort hat er auch das .well-known/caldav etc eingetragen und zwar: weil er seine cloud im unterverzeichnis domäne.de/nextcloud hat, hat er die Zeile Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav wie sie in der von dir erwähnten Doku steht in die conf.d/sites-enabled/default document root Datei geschrieben.
Bei mir heißt sie: /etc/apache2/conf.d/sites-enabled/ssl-default.conf und dort wird das eingetragen, auf der Ebene, wo auch “DocumentRoot …” oder "ServerName … " steht.

Bei mir hab ichs noch nicht gebraucht. ABer ich bin noch bei 14.0.1

Grüße, Tobias


#7

Update zu 14.0.3:

  • nettes feature: nextcloud überprüft die Signaturen aller installierten Dateien.

– wenn ich jetzt also .htaccess und noch ein paar Sprachdateien anpasse (z.B. dass bei mir nicht “Benutzername oder E-Mail” sondern “Schulkonto (klein)”

grafik

steht, dann kommt bei mir im Admin-interface jetzt ne Warnung, dass .htaccess di integritätsprüfung nicht bestanden hätte… stimmt ja auch … :frowning:

Für das htacces-Problem hab ich die andere Variante gewählt und es in /etc/apache2/conf.d/sites-enabled/…default gesteckt, siehe hier:

Für meine Kosmetik habe ich keine andere Lösung :sob:


#8

Hallo Tobias,

das hat bei mir nichts gebracht, zumal /sites-enabled nur symbolische Links auf /sites-available enthält.
Habe jetzt aber eine Lösung gefunden, die zumindest bei mir (Server 16.04, php 7) die Fehlermeldungen verschwinden lässt:

In der Datei /etc/apache2/apache2.conf habe ich ganz am Ende unter der vorhandenen letzen Zeile
</Directory …

die beiden Redirect-Anweisungen ergänzt:

Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

Bei mir steht statt ‘nextcloud’ noch ‘owncloud’, weil ich die nextcloud beim Umstieg im Verzeichnis owncloud installiert habe.
Noch ein apache-Neustart mit systemctl restart apache2 und gut ist.

Viele Grüße

Wilfried


#9

Hallo Wilfried,

das kannst du schon machen, so lange du nur einen Webserver dort laufen lässt und keine VirtualHosts verwendest.
Die Links auf sites-available sind übrigens so gewollt: “enable” geschieht dadurch, dass der Link gesetzt wird, “disable” bedeutet dass der link gelöscht wird. Es gibt sogar kommando-zeilen befehle dafür: “a2dissite” und “a2ensite”.

Du hast also recht: ich hätte also tatsächlich die Datei /etc/apache2/sites-available/default-ssl.conf editiert und dort innerhalb des “VirtualHosts” - Abschnitts die Zeilen wie du eingefügt, wenn das bei mir nötig gewesen wäre.

VG, Tobias