Neue E-Mail Adressen (bei 6.2) in LDAP eintragen: wie?

Hallo!
Wir werden demnächst für alle Lehrer Mailadressen bei BelWü haben. Diese möchte ich nun in den LDAP eingetragen haben.

ich habe das mal getestet:

00:03/0 server /etc/sophomorix/user  # smbldap-usermod -M fuehringer@eichendorff-gymnasium.de fue
00:05/0 server /etc/sophomorix/user # smbldap-usershow  -h fue
dn: uid=fue,ou=accounts,dc=paedml-linux,dc=lokal
objectClass: ,,,,,
sambaSID: 
cn: 
sambaLMPassword: 
sambaNTPassword: 
sambaPwdLastSet: 2012/8/28
sambaLogonTime: 
sambaLogoffTime: 2038/1/19
sambaKickoffTime: 2038/1/19
sambaPwdCanChange: 1970/1/1
sambaPwdMustChange: 2038/1/19
sambaAcctFlags: 
displayName: 
sambaHomePath: 
sambaHomeDrive: 
description: ,
sambaPrimaryGroupSID: 
uidNumber: 
uid: 
gidNumber: 
givenName: 
sn: 
homeDirectory: 
gecos: 
loginShell: 
userPassword: 
sophomorixstatus: 
mail: 

Warum ist „mail:“ noch leer?
Ich möchte dann da Adressen der Form nachname@eichendorff-gymnasium.de drinnenstehen haben.
Ich habe also in der lehrer.txt in Feld 6 da die „—“ durch Namen ersetzt, wo notwendig (Umlaute, doppelte Namen, lange Doppel-Namen…)
Dann würde ich das Script, das ich hier im Forum (von Jörg und Tobias) gefunden und abgeändert habe mal „loslassen“.
Darin wird

ldapsearch -x „(&(objectClass=posixAccount)(uid=$username))“ mail -LLL

verwendet.
Das liefert bei mir dann doch:

00:16/0 server /etc/sophomorix/user # ldapsearch -x "(&(objectClass=posixAccount)(uid=fue))" mail -LLL 
dn: uid=fue,ou=accounts,dc=paedml-linux,dc=lokal
mail: fuehringer@eichendorff-gymnasium.de

Reicht das oder muss das bei smbldap-usershow auch angezeigt werden, wenn ich die Mailadressen in Moodle und in der NC haben möchte? Liest die NC das überhaupt aus?

LG
Max

Lass mal die Option -h bei smbldap-usershow weg.

Andreas

Danke!
Jetzt sind da (endlich) ganz viele Sachen eingetragen, Hurra!
LG
Max

Wo ist dieses Script? Kannst du es verlinken?
Danke

Letzter Post hier:


ich habe es eben dann so modifiziert, dass ich nur „nachname“ @ „meinedomain“ als Mail habe, wenn in der lehrer.txt - - - steht.
Beinhaltet der Nachname Umlaute, habe ich sicherheitshalber den Namen nochmals ohne ins 6. Feld eingetragen.
Auf Klein / Großschreibung habe ich nicht geachtet, aber grade sehe ich, dass die Großbuchstaben mit „tr“ in Kleinbuchstaben umgewandelt werden :slight_smile:
LG
Max

danke … das andere Problem (Installation des docker Containers) bleibt leider. Ich pushe das nochmal nach oben…
Michael