Mehrfachanmeldung eines Users unterbinden

Hallo miteinander,

zum genannten Thema gibt es eine Anleitung, die ich gerade auf IServ anzuwenden versuche.
https://www.linuxmuster.net/wiki/anwenderwiki:samba:samba_anpassungen

Da es smb.conf.shares dort nicht gibt und der Eintrag in smb.conf.local wenigstens so wie beschrieben nicht funktionierte, habe ich “max connections =1” direkt in smb.conf eingetragen.
“CALL \iserv\netlogon\usermessage.vbs & shutdown -l” habe ich ebenfalls direkt in login.bat (und nicht in local.bat) eingetragen nach der Stelle, wo sowieso geprüft wird, ob H:\ vorhanden ist.

Im Test mit Windows Remote Desktop funktionierte es genau wie gewünscht, bei der lokalen Anmeldung fliegt jedoch bereits der erste Benutzer raus, der sich anzumelden versucht.

Ob ich domain admin bin und die beiden Kollegen, die es lokal versucht haben nicht, sollte doch keine Rolle spielen, oder?

Wir benutzen “Roaming Profiles” und es gibt noch ein weiteres individuelles Share, welches als I:\ eingehängt wird und ein GruppenShare, welches als G:\ eingehängt wird
Der Pfad für H: ist %H/Files
Der Pfad für I: ist %H/Windows
Der Pfad für G:\ ist %H/Groups
Könnte es sein, dass der Zähler für max connections bereits während der ersten Anmeldung >1 wird?

Die Anleitung bezieht sich ja auf lmn 6.x und damit auf Samba 3.x. IServ benutzt wie lmn 7 Samba 4. Passt die Anleitung noch?

Hat jemand eine für Windows7/10 funktionierende Lösung oder eine Idee, was bei mir noch falsch laufen könnte?

Gruß Jürgen

P.S.:
Es gibt einen zwei Jahre alten Thread zum gleichen Thema bezüglich des Linuxclient, den ich losgetreten hatte, der aber mit diesem nicht viel gemeinsam hat (außer dass es dort am Ende für mich auch nicht zufriedenstellend gelöst wurde …).

Hallo Jürgen,

keine Lösung, aber ein Ansatz zum Nachverfolgen:

Im Home-Share (smb.conf oder amb.conf.*) kann am mit preexec ein Skript
angeben, dass beim Verbinden auf dem Server ausgeführt wird. Damit
könntest Du jeden Verbindungsversuch loggen. Client-Rechner und
Usernamen erhält das Skript als Parameter, die Syntax müsste ich
nachschauen.

Beste Grüße

Jörg

Hallo Jürgen,

mach mal die Überprüfung nicht auf das Verzeichnis/Laufwerk sondern auf eine Datei im Selbigen.

Beste Grüße

Thorsten