M.2 nvm SSD: Linbo kommt nicht bis zum Bootbildschirm


#1

Hallo,
ich habe einen Lenovo Client mit einer M.2 NVMe SSD.
Es soll der linuxmuster Linux Client gestartet werden.
Egal, welche BIOS-Einstellungen ich ausprobiere (legacy, UEFI) und welchen SystemType ich in der start.conf angebe bleibt linbo bereits vor Anzeige der Startbildschirms hängen.
Welche Stellschrauben sollte ich mir genauer ansehen ?
Danke!
VG
Chris


#2

Hallo Chris,

ich habe einen Lenovo Client mit einer M.2 NVMe SSD.

ich habe einen von HP. (Desktoprechner)

Es soll der linuxmuster Linux Client gestartet werden.
Egal, welche BIOS-Einstellungen ich ausprobiere (legacy, UEFI) und
welchen SystemType ich in der start.conf angebe bleibt linbo bereits vor
Anzeige der Startbildschirms hängen.
Welche Stellschrauben sollte ich mir genauer ansehen ?

ich habe ihn zuerst aufgenommen und dann diese start.conf verwendet

# LINBO start.conf Beispiel mit Windows XP und Kubuntu # Windows XP System auf Partition 1 (FAT32) # Kubuntu Gutsy 7.10 auf Partition 2 # Swap auf Partition 3 # Erweiterte Partition auf Partition 4 # Daten auf Partition 5 # Cache auf Partition 6 # Festplatte 60G (IDE)

[LINBO] # globale Konfiguration
SystemType = bios
#KernelOptions = autostart=1
KernelOptions =
ConsoleFontColorStderr = red
ConsoleFontColorStdout = white
BackgroundFontColor = white
Cache = /dev/nvme0n1p5 # lokale Cache Partition
Server = 10.16.1.1 # IP des TFTP-Servers, der Images vorhaelt
Group = semwin10-nvme
RootTimeout = 600 # automatischer Rootlogout nach 600 Sek.
AutoPartition = no # keine automatische Partitionsreparatur beim
LINBO-Start
AutoFormat = no # kein automatisches Formatieren aller
Partitionen beim LINBO-Start
AutoInitCache = no # kein automatisches Bef�llen des Caches beim
LINBO-Start
DownloadType = torrent # Image-Download per
torrent>multicast>rsync, default ist rsync

[Partition] # Start einer Partitionsdefinition, Windows XP
mit FAT32
Dev = /dev/nvme0n1p1 # Device-Name der Partition (sda1 = 1.
Partition auf erster IDE-Platte)
#Size = 30876936 # Partitionsgroesse in kB (Bsp.: 5G)
#Size = 40960000 # Partitionsgroesse in kB (Bsp.: 5G)
Size = 51200000 # Partitionsgroesse in kB (Bsp.: 5G)
#Size = 131072000 # Partitionsgroesse in kB (Bsp.: 5G)
#Size = 130874368 # Partitionsgroesse in kB (Bsp.: 5G)
Id = 7 # Partitionstyp (83 = Linux, 82 = swap, c =
FAT32, 7 = NTFS, …)
FSType = ntfs # Dateisystem auf der Partition (FAT32)
Bootable = no # Bootable-Flag

[Partition] # Start einer Partitionsdefinition, Kubuntu
Dev = /dev/nvme0n1p2 # Device-Name der Partition (sda2 = 2.
Partition auf erster IDE-Platte)
#Size = 8400000 # Partitionsgroesse in kB (Bsp.: 6G)
#Size = 16384000
Size = 26214400
#Size = 12005760 # Partitionsgroesse in kB (Bsp.: 6G)
Id = 83 # Partitionstyp (83 = Linux, 82 = swap, c =
FAT32, 7 = NTFS, …)
FSType = ext4 # Dateisystem auf der Partition (ext3)
Bootable = no # Bootable-Flag

[Partition] # Definition der Swappartition
Dev = /dev/nvme0n1p3 # Device-Name der Partition (sda3 = 3.
Partition auf erster IDE-Platte)
Size = 4096000 # Partitionsgroesse in kB (Bsp.: 1G)
#Size = 2048576 # Partitionsgroesse in kB (Bsp.: 1G)
Id = 82 # Partitionstyp (83 = Linux, 82 = swap, c =
FAT32, …)
FSType = swap # Dateisystem auf der Partition (swap)

[Partition] # Erweiterte Partition
Dev = /dev/nvme0n1p4 # Device-Name der Partition (sda4 = 4.
Partition auf erster IDE-Platte)
Size = # Partitionsgroesse in kB (leer bei erweiterter
Partition)
Id = 5 # Partitionstyp (5 = erweiterte Partition)
FSType = # Dateisystem auf der Partition (leer bei
erweiterter Partition)
Bootable = no # Bootable-Flag

[Partition] # Start einer Partitionsdefinition,
Datenpartition mit FAT32
Dev = /dev/nvme0n1p5 # Device-Name der Partition (sda5 = 5.
Partition auf erster IDE-Platte)
#Size = 29982720 # Partitionsgroesse in kB (Bsp.: 30G)
Size = 109445120
# bei den 60GB SSDs darf diese Partition nur unter 500MB gross sein
#Size = 12457280 # Partitionsgroesse in kB (Bsp.: 30G)
Id = 83 # Partitionstyp (83 = Linux, 82 = swap, c =
FAT32, 7 = NTFS, …)
FSType = ext4 # Dateisystem auf der Partition
Bootable = no # Bootable-Flag

[Partition] # Definition der Cache-Partition
Dev = /dev/nvme0n1p6 # Device-Name der Partition (sda6 = 6.
Partition auf erster IDE-Platte)
Size = # Partitionsgroesse in kB (Bsp.: keine Angabe =
Rest der Platte, ca. 18G)
Id = 83 # Partitionstyp (83 = Linux, 82 = swap, c =
FAT32, …)
FSType = ext4 # Dateisystem fuer Cache-Partition (reiserfs empf.)
Bootable = yes # Bootable-Flag

[OS] # Beginn einer Betriebssystemdefinition
IconName = winxp.png
Name = Windows 10 # Name des Betriebssystems
Version = # Version (optional, frei waehlbar)
Description = Windows 10 EDU n 64bit ohne SLIC # Beschreibung
Image = # erst eintragen, wenn es erzeugt
werden soll
#BaseImage = semwin10-800.cloop # Dateiname des Basisimages
(Erweiterung .cloop)
BaseImage = semwin10-nvme.cloop # Dateiname des Basisimages
(Erweiterung .cloop)
Boot = /dev/nvme0n1p1 # Partition, die Kernel &
Initrd enthaelt
Root = /dev/nvme0n1p1 # Rootpartition, in die das BS
installiert ist
# # bei Windows ist Boot und Root immer dieselbe Partition
Kernel = reboot # Relativer Pfad zum Kernel, bei
Windows immer grub.exe
Initrd = # Relativer Pfad zur Initrd, bei
Windows immer leer
# Kernel-Parameter fuer
Windows-Boot aus 1. Partition der 1. IDE-Festplatte
# bei SATA-Platten statt /dev/sda
/dev/sda eintragen
Append = # bleibt bei Windows leer
StartEnabled = yes # “Start”-Button anzeigen
SyncEnabled = yes # “Sync+Start”-Button anzeigen
NewEnabled = yes # “Neu+Start”-Button anzeigen
Hidden = yes # verstecke OS-Reiter
Autostart = no # automatischer synchronisierter
Start des Betriebssystems
AutostartTimeout = 5
DefaultAction = sync

[OS]
AutostartTimeout = 5
DefaultAction = start
IconName = ubuntu.png
Name = ubuntu 14.04 # Name des Betriebssystems
Version = # Version (optional)
Description = ubuntu 14.04 Trusty # Beschreibung
#Image = karmic.rsync # Dateiname des differentiellen
Images (Erweiterung .rsync)
Image = # erst eintragen, wenn es erzeugt
werden soll
#BaseImage = lucid-nwt-lap-lmg.cloop # Dateiname des
Basisimages (Erweiterung .cloop)
BaseImage = trusty-ssdl4.cloop # Dateiname des Basisimages
(Erweiterung .cloop)
Boot = /dev/nvme0n1p2 # Partition, die Kernel &
Initrd enthaelt
Root = /dev/nvme0n1p2 # Rootpartition, in die das BS
installiert ist
Kernel = vmlinuz # Relativer Pfad zum Kernel
Initrd = initrd.img # Relativer Pfad zur Initrd
#Append = ro splash # Kernel-Append-Parameter, ggf.
anpassen
Append = ro splash # bei Gutsy muss evtl. root=/dev/sda2 angehaengt
werden, da bei manchen
# IDE-Kontrollern der Gutsy-Kernel
die neuen PATA-Treiber verwendet, die
# IDE-Platten mit /dev/sd* ansprechen
# ansonsten wird automatisch das
verwendet, was unter “Root =” angegeben ist.
StartEnabled = yes # “Start”-Button anzeigen
SyncEnabled = yes # “Sync+Start”-Button anzeigen
NewEnabled = yes # “Neu+Start”-Button anzeigen
Hidden = yes # verstecke OS-Reiter
Autostart = no # automatischer synchronisierter
Start des Betriebssystems

LG

HOlger


#3

Hi Holger,
danke für die start.conf. Meine sah ähnlich aus.
Ich habe Deine nun mal eingetragen angepasst, den Client im BIOS auf CSM enabled und auf Boot AUTO und legacy first gestellt.
Ich sehe dann den ersten linbo Bildschirm mit den Hinweisen:

no such device: cache
no such device: start.conf
no such device: linbofs64.lz

Danach kein Bild mehr.
LG
Chris


#4

Hallo Chris,

danke für die start.conf. Meine sah ähnlich aus.
Ich habe Deine nun mal eingetragen angepasst, den Client im BIOS auf CSM
enabled und auf Boot AUTO und legacy first gestellt.
Ich sehe dann den ersten linbo Bildschirm mit den Hinweisen:

no such device: cache
no such device: start.conf
no such device: linbofs64.lz

hast du nach Änderung der start.conf einen import gemacht?

LG

Holger


#5

Hi Holger,
ja ich habe einen import nach den Änderungen ausgeführt.
Nach Anpassungen verschwindet zumindest die Meldung, dass kein cache gefunden wurde. Mehr aber auch nicht.
VG
Christian
P.S. Ich habe jetzt mal eine “vereinfachte” start.conf verwendet, aber leider auch mit gleichen Fehlermeldungen.
start.conf.xenial.zip (1,6 KB)


#6

Hallo Chris,

ja ich habe einen import nach den Änderungen ausgeführt.
Nach Anpassungen verschwindet zumindest die Meldung, dass kein cache
gefunden wurde. Mehr aber auch nicht.

welche Anpassungen haben das bewirkt?

kannst du mir mal die logdatei des Clients schicken?
Oder sind da keine?
Oder ein Photo vom Bootbildschirm von linbo.

LG

Holger


#7

Hallo Holger,

es waren nur syntaktische Anpassungen (LF ohne weitere Kommentarzeichen).
Für die ersten Versuche wurde ein log geschrieben, da hatte ich noch die falschen Angaben für die Festplatte drin. Log anbei.
Für die letzten Versuche wurde kein neueres Log mehr erstellt.
Photo kann ich Dir gerade nicht schicken, da ich nicht in der Schule bin.
VG
Chris
h10207_linbo.log.zip (6,9 KB)


#8

Hallo Chris,

es waren nur syntaktische Anpassungen (LF ohne weitere Kommentarzeichen).
Für die ersten Versuche wurde ein log geschrieben, da hatte ich noch die
falschen Angaben für die Festplatte drin.

… so falsch sind die nicht, würde ich sagen.
Die Platte (Samsung Pro 850) wird als sda erkannt:


sd 0:0:0:0: [sda] 500118192 512-byte logical blocks: (256 GB/238 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t
support DPO or FUA
sda: sda1 sda2 sda3 < sda5 sda6 >
sd 0:0:0:0: [sda] Attached SCSI disk


Das sieht nicht nach NVMe aus…

Weswegen meinst du den es seien NVMe eingebaut?
Nur wegen der Bauform?
M2 Slots können per SATA oder dierekt per PCIe angeschlossen sein…

In meinem Rechner auf dem ich gerade schreibe stecken zwei M2 SSDs: eine
ist eine Samsung Pro (SATA) und die andere ist eine Trancend NVMe.

Gib mal genauere Angaben zum System:
Laptop oder Desktop?
Schreib mal, was genau auf der SSD drauf steht.

Jetzt gerade würde ich sagen: nimm eine sda start.conf und probier es
nochmal.

LG

Holger


#9

Hallo Holger,

das ist ein Lenovo Thin Centre M715q Modell 10M3 (Tiny). Ich das jetzt mal aus auseinandergebaut, um die M2 SSD zu prüfen. Auf dem Etikett steht: Samsung Model MZ - VLW2560, PCIe NVMe, 256 GB.

Also ist es eine NVMe SSD für den M2 Anschluss.

Mmh, ich habe gerade die Vermutung, dass der Log noch von dem vorher eingetragenen Modell ist, das auch eine SSD hat, aber eine normale, die ich zuvor angeschlsosen hatte. Danach habe ich das neue Model eingetragen und dann wurde kein Log mehr erzeugt.

Sorry.

Warum wird denn gar kein Log erstellt.
VG
Chris


#10

Hallo Holger,
ich habe nun mal einen screenshot des ersten Bildschirms nach dem Bootvorgang erstellt. Danach bleibt der Bildschirm schwarz. Ein
Log-File wird für den Client nicht angelegt.
Hast Du eine Idee?
VG
Christian
linbo-ssd-evme-fehler


#11

Hallo Chris,

… sorry: ich stand auf der Leitung.
Jetzt bin ich endlich mal hergegangen und hab nach dem Ding im Netz
gesucht und die Details gefunden:

https://www.thinclient24.de/lenovo-thinkcentre-m715q-10m3.html

… du hast eine Radeon GPU (Ein APU von AMD).
Da mußt du bei linbo ab 2.3.31 folgenden Eintrag in der start.conf machen:

KernelOptions = nomodeset
Einfach zu den vorhandenen Einträgen dazu schreiben.
(da steht schon splash usw…)

Dann import_workstations
und dann Client booten

TaDa :slight_smile:

LG

Holger


#12

Hi Holger,
you saved my day :sunglasses:

Ich habe den Eintrag KernelOptions = nomodeset bei der Rubrik [Linbo]
eingetragen und ich habe bei [OS] unter Append nomodeset ebenfalls hinzugefügt.

Die Fehler zu Beginn bleiben erhalten - wie auf dem Screenshot -, aber danach startet er dann und ich sehe das Linbo-Menü. Jetzt lasse ich den mal formatieren und spiele das Linux-Image auf. Mal sehen, ob er dann schon so läuft.
Im Bios habe ich Security Chip deaktiviert, CSM aktiviert und Legacy first eingestellt.

Stelle ich im BIOS auf UEFI First und lege ich in der start.conf eine EFI Partition an, dann bootet er auch mit UEFI.
Danke !
VG
Chris


#13

Hi Holger,
nachdem der Linbo-Bootbildschirm erscheint, bleiben aber noch weitere Probleme.
Egal ob ich UEFI only, CSR mit Auto und UEFI oder nur Legacy only im BIOS einstelle und die start.conf entsprechend anpasse (Reihenfolge der Paritionen etc. angepasst), ich habe immer das Problem, dass Grub nicht in den Cache geschrieben werden kann.

Schaue ich mir den Log-File an, dann finden sich folgende Auszüge:

nvme nvme0: pci function 0000:01:00.0
grub-install: warning: cannot open directory `/usr/share/locale’: No such file or directory.

Moeglicher Fehler erkannt: linbo_cmd laeuft bereits.
1525 root 0:00 {linbo_cmd} /bin/sh /usr/bin/linbo_cmd ip
1528 root 0:00 {linbo_cmd} /bin/sh /usr/bin/linbo_cmd ip
1529 root 0:00 {linbo_cmd} /bin/sh /usr/bin/linbo_cmd ip
mount: special device /dev/nvmenp does not exist
Installing for i386-pc platform.
grub-install: warning: cannot open directory `/usr/share/locale’: No such file or directory.
Installation finished. No error reported.

Hättest Du sonst noch Ideen ?

VG
Chris


#14

Hallo Chris,

mount: special device /dev/nvmenp does not exist

das ist falsch: nvmep gibt es nicht: auf das e folgt eine Zahl (0).

Hättest Du sonst noch Ideen ?

jup.
Durchsuch mal die dmesg auf dem Cleint nach dem booten (in linbo) damit
du heraus bekommst, wie das Device genau heißt:
Bei mir ZUhause heoßt die erste Partition:
/dev/nvme0n1p1
usw…

Schick auch mal die start.conf

LG

Holger


#15

Hallo Holger,
also in der start.conf habe ich auch eine andere Bezeichnung für die Partitionen eingetragen - wie bei Dir auch:
/dev/nvme0n1p1

start.conf anbei.

Wie gesagt, ich habe das in verschiedenen Varianten mit UEFI, nur Legacy, unterschiedlicher Reihenfolge der Partitionen, dann Cache Partition nicht als letzte Partition.

Als ich mich mit linbo-remote auf den Client geschaltet hatte, konnte ich zumindest in das Verzeichnis /cache wechseln.

dmesg auf dem Client kann ich erst am Mo prüfen.

Danke !
VG
Chris
start.conf.xenial.zip (1,5 KB)


#16

Bringt vermutlich wenig, aber ich hab aehnliche Probleme mit nvme0n1p1, Linbo bootet, grub kriegt aber beim Einspielen des cloops den MBR auch nicht geschrieben und meckert rum. Ich such Montag mal die genaue Fehlermeldung raus.


#17

So, gleiches Problem wie oben, M2-SSD mit /dev/nvme0n1p1…3 und mit linbo 2.3.26 ging das einwandfrei, ich vermute das Problem kam mit 2.3.31-0 und es ist wohl ein Problem mit dem grub.

/cache # grub-install /dev/ncme0n1
Installing for i386-pc platform.
grub-install: warning: cannot open directory /usr/share/locale': No such file or directory. grub-install: error: failed to get canonical path ofrootfs’

Kann man Linbo downgraden und wenn ja, wie?

Edith, so geht’s, altes Linbo von dort holen http://pkg.linuxmuster.net/babo62/

oder halt:
wget http://pkg.linuxmuster.net/babo62/linuxmuster-linbo-common_2.3.26-0_all.deb
wget http://pkg.linuxmuster.net/babo62/linuxmuster-linbo_2.3.26-0_all.deb

dpkg -i *.deb

Dann haengt beim einen Rechner das total kaputte “alte” neue Linbo 2.3.31 noch wie Blei auf der Client-Platte, booten per USB-Stick und dd if=/dev/zero of=/dev/nvme0n1 count=10 loescht das dann weg.

Ein anderer Rechner war einwandfrei mit dem neuen zu booten, weiss der Teufel.

Reboot und alles tut wieder soweit, war wohl irgendwas bei 2.3.31 kaputt.


#18

Hallo Irrlicht,

/cache # grub-install /dev/ncme0n1
Installing for i386-pc platform.
grub-install: warning: cannot open directory |/usr/share/locale': No
such file or directory. grub-install: error: failed to get canonical
path of|rootfs’

das sieht mir doch sehr nach einem Tippfehler aus: ncme0n1
sollte eher nvmep0n1 heißen, oder?

Kann man Linbo downgraden und wenn ja, wie?

ich kann es nicht versprechen, aber so könnte es gehen:
cd /var/cache/apt/archive/
ls linuxmuster-linbo*
dpkg -i linuxmuster-linbo-restvompaketnamen.deb

LG

Holger


#19

Ja stimmt, aber wenn man das richtige eingibt, erscheint die gleiche Fehlermeldung, das war nur nochmal auf der Konsole fuer copy&pasta.

Downgrade habe ich (s.o.) hinbekommen, tut auch alles wieder - in /var/cache/apt/archive war kein altes Paket mehr.
Im Repository liegt wohl unter testing noch 2.3.34, aber laut changelog hat sich da nicht viel geaendert. Ich geh davon aus, dass 2.3.31 irgendeinen bug hat bzgl. M.2, hat mich bestimmt 5h gekostet.

Gruss Harry not irrlicht :slight_smile:


#20

Hallo Harry,

sollte eher nvmep0n1 heißen, oder?

Ja stimmt, aber wenn man das richtige eingibt, erscheint die gleiche
Fehlermeldung, das war nur nochmal auf der Konsole fuer copy&pasta.

kannst du das ein wenig ausführen?
Du hattest also in der start.conf das falsche, und nachdem du das
richtige eingetragen hattest, kam noch immer genau die Fehlermeldung?

Downgrade habe ich (s.o.) hinbekommen,

OK.

tut auch alles wieder

??? funktioniert es jetzt?

Kann es sein, dass du nach dem Berichtigen der EInträge in der
start.conf schlicht das import_workstations vergessen hattest?

LG

Holger