LMN7 Linbo immer OFFLINE

Hallo zusammen,
ich versuche das neue LMN7 in meiner Schule ans Laufen zu bringen. Ich habe die Appliances für Proxmox von www.netzint.de verwendet und soweit klappt alles ohne Probleme. Server und Firewall laufen, Lehrer, SuS etc. lassen sich anlegen und für den Computerraum habe ich eine Gruppe (bionic) und die ersten Geräte angelegt.
Da die Sache mit den linuxmuster-client-servertools noch nicht in den Repos verfügbar ist, habe ich mich der Anleitung und der cloops von User @baumhof bedient:

Linux Client - Client Server Tool - lmn7

Nun ergibt sich leider folgendes Problem:

Die Clients starte erwartungsgemäß über PXE und präsentieren die Linbo-Konsole. Dort werden allerdings die Client-IP und die MAC beide als OFFLINE gekennzeichnet und ich kann nix machen.

Nach einiger Recherche habe ich in der Gruppe linbo auf dem Server den Kernel-Parameter „dhcpretry=10“ hinzu genommen, was aber leider auch nichts gebraucht hat.

Mir ist noch folgendes aufgefallen. Kurz nach dem PXE-boot erscheint die Meldung:

[Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x52 (or later)

Dann kommt die Linbo-Konsole.
Das passiert auf beiden Rechnertypen (Terra 1009492 und HP ProDesk 400 C1).

Hat der Firmware Bug etwas mit meinem Problem zu tun oder mache ich einen anderen Fehler?

Danke vorab und Gruß
Ralf

Hallo Ralf,

wenn Linbo im Offline ist läuft oft der tftp nicht.

Schau mal nach ob er läuft

ps -A|grep tftp

sollte mindestens einen Prozess anzeigen.

Hier:

scheint das gleiche Problem zu bestehen.

Gruß

Alois

Hallo Ralf,

und herzlich willkommen :slight_smile:

Die Clients starte erwartungsgemäß über PXE und präsentieren die
Linbo-Konsole. Dort werden allerdings die Client-IP und die MAC beide
als OFFLINE gekennzeichnet und ich kann nix machen.

Nach einiger Recherche habe ich in der Gruppe linbo auf dem Server den
Kernel-Parameter „dhcpretry=10“ hinzu genommen, was aber leider auch
nichts gebraucht hat.

hast du danach ein
linuxmuster-import-devices
gemacht?
Sonst wirkt der Eintrag in der start.conf. nicht.

Mir ist noch folgendes aufgefallen. Kurz nach dem PXE-boot erscheint die
Meldung:

[Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update
microcode to version: 0x52 (or later)

Dann kommt die Linbo-Konsole.
Das passiert auf beiden Rechnertypen (Terra 1009492 und HP ProDesk 400 C1).

Hat der Firmware Bug etwas mit meinem Problem zu tun oder mache ich
einen anderen Fehler?

normalerweise würde ich sagen: das könnte schon sein: aber nicht bei
zwei unterschiedlichen Rechnern.

Also: falls linuxmuster-import-devices nicht gemacht wurde: mach das mal
und teste nochmal.

Wenn es nciht hilft, dann boote mal ein beliebiges linux auf einem der
Clents und schau, ob es die IP vom server bekommt, und ob es die
richtige ist.

LG

Holger

Ja, der tftpd läuft. Das scheint nicht das Problem zu sein.

Hallo Holger,
ja, das mache ich nach jeder Änderung. Hier mal der Output:

/usr/sbin/sophomorix-device terminated regularly                     
Calling console printout
LOG       : Reading /etc/linuxmuster/sophomorix/default-school/devices.csv    
LOG       : All *.devices.csv files without syntax error                      
LOG       : /usr/sbin/sophomorix-device terminated regularly                  
------------------------------------------------------------------------------
Working on dhcp configuration for devices                 
* in subnet 172.16.1.0/24:                                              
server          | 172.16.1.1      | server          | 0 |          
firewall        | 172.16.1.253    | server          | 0 |          
PC09            | 172.16.1.199    | classroom-stude | 1 | bios64   
PC12            | 172.16.1.198    | classroom-stude | 1 | bios64   
PC02            | 172.16.1.197    | classroom-stude | 1 | bios64   
------------------------------------------------------------------------------
 Working on linbo/grub configuration for devices:                     
   PC09            | bionic                                           
   PC12            | bionic                                           
   PC02            | bionic                                           
------------------------------------------------------------------------------
 Working on linbo/grub configuration for groups:                      
                   | linbo start.conf     | grub cfg                 
   ----------------+----------------------+---------------------    
   bionic          | present              | replaced               
------------------------------------------------------------------------------
 Restarting services:                                                 
 * isc-dhcp-server .............................................. OK! 
 * linbo-bittorrent ............................................. OK! 
 * linbo-multicast .............................................. OK! 
------------------------------------------------------------------------------
 linuxmuster-import-devices finished at 2020-04-28 13:17:54           

Wenn ich einen Standard-Linux-Client boote (habe nur Linux im Computerraum) dann kriegt er offenbar eine DHCP-Adresse vom linuxmuster-server.

Da fällt mir allerdings ein, dass die Firewall auch den DHCP im LAN aktiv hat (schäm). Das könnte wohl auch Probleme machen… zwei DHCP-Server in einem Netz…

Ich deaktivere den mal und teste nochmals.

Am doppelten DHCP-Server scheint es auch nicht zu liegen. Nun läuft nur noch der DHCP auf dem LMN-Server und das Problem besteht nach wie vor.

Die DHCP-lease-list zeigt auch nur den Standard-Linux-Client an:

1c:6f:65:cf:9c:fc  172.16.1.211    PC05           2020-04-28 13:33:28 -NA-                

Was mir noch aufgefallen ist… Auf der Linbo-Konsole wird folgendes angezeigt:

LINBO 2.3.59-0 auf Server 10.16.1.1

Müsste da in meinem Fall nicht 172.16.1.1 als Serveradresse stehen?

Hallo Ralf!

Herzlich willkommen bei uns!

@thomas kannst du hier bitte mal schauen.Sieht mir nach der Ursache aus:

Beste Grüße

Thorsten

HAllo,

Die DHCP-lease-list zeigt auch nur den Standard-Linux-Client an:

1c:6f:65:cf:9c:fc 172.16.1.211 PC05 2020-04-28 13:33:28 -NA-

Was mir noch aufgefallen ist… Auf der Linbo-Konsole wird folgendes
angezeigt:

LINBO 2.3.59-0 auf Server 10.16.1.1

Müsste da in meinem Fall nicht 172.16.1.1 als Serveradresse stehen?

auf jeden Fall.

Bitte schau mal in die /srv/linbo/start.conf
steht da deine Serveradresse drin oder die 10.16.1.1?

Hast du beim Installieren den Adressbereich 172.16.1.0/24 angegeben?
Wurde das auch vorher mit einem linuxmuster-prepair in den VMs so umgesetzt?

Bitte schreib mal genauer was du da beim Aufsetzen gemacht hast und in
welcher Reihenfolge.
Wie hast du installiert?
Welche ovas?

LG

Holger

Das hatte ich schon überprüft. In der start.conf.bionic steht:

Server = 172.16.1.1
Group = bionic

Also… Ich habe die Proxmox-Appliance 7.0
(Server-VM Release 20200417) von

https://www.netzint.de/education/downloads/proxmox-appliance-7-0

heruntergeladen und den Adressbereich mittels linuxmuster-prepair Script angepasst (172.16.1.0/24).

Dann habe ich mich als Lehrer und zwei Testschüler angelegt. Alles wunderbar.
Dann habe ich dein Zip-Archiv mit den bionic-cloop heruntergeladen und gemäß deiner Anleitung alles an die richtigen Stellen kopiert und angepasst. Im Web-Interface wird das Image korrekt angezeigt.
Leider hänge ich dann bei Punkt 9 - „am Client als Linuxadmin anmelden…“ weil die Linbo-Konsole offline ist.

Mehr habe ich nicht gemacht.
Habe ich etwas vergessen?

Hallo Ralf,

Das hatte ich schon überprüft. In der start.conf.bionic steht:

Server = 172.16.1.1
Group = bionic

Also… Ich habe die Proxmox-Appliance 7.0
(Server-VM Release 20200417) von

https://www.netzint.de/education/downloads/proxmox-appliance-7-0

heruntergeladen und den Adressbereich mittels linuxmuster-prepair Script
angepasst (172.16.1.0/24).

Dann habe ich mich als Lehrer und zwei Testschüler angelegt. Alles
wunderbar.
Dann habe ich dein Zip-Archiv mit den bionic-cloop heruntergeladen und
gemäß deiner Anleitung alles an die richtigen Stellen kopiert und
angepasst. Im Web-Interface wird das Image korrekt angezeigt.
Leider hänge ich dann bei Punkt 9 - „am Client als Linuxadmin anmelden…“
weil die Linbo-Konsole offline ist.

Mehr habe ich nicht gemacht.
Habe ich etwas vergessen?

… ich finde nichts: sieh gut aus, was du da gemacht hast.

Sag mal: war auf dem Client schon mal ein linbo drauf?

LG

Holger

Nein, in Bezug auf Linbo ist alles jungfräulich.
Gibt es eigentlich eine Möglichkeit den Linbo-Bootvorgang auf dem Client zu loggen oder zumindest anzuhalten. Ich habe die Kernel-Option „quiet“ schon gelöscht, um die Kernel-Meldungen sehen zu können aber die laufen zu schnell durch und lassen sich mit nicht anhalten. Wenn dann die grafische Linbo-Konsole kommt sind die Meldungen weg…

Ich poste bei Gelegenheit mal die komplette Linbo-Config. Irgendwo muss der Fehler ja stecken…

Hallo Ralf,

… ich glaub ich hab einen Fehler gefunden: ist eine blöde Falle.

Du hast den Clients die IPs 172.16.1.199 198 197
gegeben: das liegt im Aufnahmebereich von linbo: da dürfen sie nicht sein.

Bitte ändere die IPs der Clients auf
172.16.1.20 21 22

in der Datei /etc/linuxmuster/sophomorix/default-school/devices.csv

und lass danach

linuxmuster-import-devices
laufen.

Dann nochmal einen Client booten

LG

Holger

1 Like

OK, das ist ein guter Tipp. Ich hatte schon eine ähnliche Theorie. Mir ist aufgefallen, dass der DHCP die range 172.16.1.200-250 eingestellt hat, meine Adressen jedoch außerhalb liegen.
Ich versuche es aber erst einmal mit den von dir vorgeschlagen Adressen.
Leider bin ich erst am Do. wieder in der Schule. Ich gebe aber auf jeden Fall ein Feedback ob das der Fehler war.

Ansonsten bin ich schwer begeistert von LMN7/Linbo. So ein System habe ich mir gewünscht, seit ich vor 10 Jahren mit Rembo gearbeitet hatte.

Auch ein Kompliment an das Forum bzw. an euch für die schnelle und kompetente Hilfe! :+1:

LG
Ralf

Das war wirklich eine blöde Falle…
IP geändert und schon ist Linbo online. Sehr schön!
Jetzt klappere ich deine Anleitung zur „Installation“ des ersten default.cloop für LMN7 weiter ab…
LG
Ralf