Lmlcc unter v7 -- Fehlermeldungen

Hallo.
Ich habe versucht, diese Version von lmlcc unter v7 zu verwenden: 18.04 bionic: lmlcc-0.31-tar-Paket

Beim Starten erhalte ich allerdings:
lmlcc_Fehler
lmlcc_2

Ich meine, dass hier schon davon berichtet wurde, dass man lmlcc auch unter v7 benutzen kann/soll … ist es eine andere Version oder wie habt ihr das gemacht?

Schöne Grüße,
Michael

Hallo Michael,

Ich habe versucht, diese Version von lmlcc unter v7 zu verwenden: 18.04
bionic:
lmlcc-0.31-tar-Paket
http://www.linuxmuster.net/wiki/_media/anwenderwiki:linuxclient:lmlcc-0.31.tar.bz2

Beim Starten erhalte ich allerdings:
lmlcc_Fehler
lmlcc_2

lmlcc_3
https://ask.linuxmuster.net/uploads/default/original/2X/e/e7a77e24ccdc44760555668c7aa76466e8e804a3.png

Ich meine, dass hier schon davon berichtet wurde, dass man lmlcc auch
unter v7 benutzen kann/soll … ist es eine andere Version oder wie habt
ihr das gemacht?

ich hab es im default.cloop installiert: das funtktioniert dort.
Hast du das als linuxadmin gestartet?
Oder als ein anderer Nutzer?
Ist der Client in einer lmn7 Domäne integriert?

LG

Holger

Hallo Holger,
ich habe dein bionic-11-19 genommen und die o.g. lmlcc-Version (die aber bisher nur für v6.2 angegeben ist). Der Client ist in der Domäne – aber angemeldet war ich nur als linuxadmin (also nur lokal). Gestartet habe ich das Tool auf zwei Arten: beim ersten Mal über die Dash --> lmlcc und danach in einem Terminal mit „sudo su“ vorher … es lieferte beides die gleichen, abgebildeten Fehler .

Es ist doch verdächtig, dass die angegebene Datei profile.conf fehlen soll (tut sie auch!) – ist sie denn bei dir vorhanden? Was steht da drin? Vielleicht kann man das ja einfach kopieren??
Schöne Grüße,
Michael

Hallo Michael,

irgendwie hab ich das Gefühl, dass du die lmn6.2 Version installiert
hast, nicht die lmn7 Version.

LG

Holger

Kann sein… Woher hast du denn die passende lmlcc-Version für die v7?
Oder ist die etwa jetzt via apt installierbar??

Hallo Michael,

Kann sein… Woher hast du denn die passende lmlcc-Version für die v7?

https://wiki.linuxmuster.net/community/anwenderwiki:linuxclient:lmlcc7?s[]=lmlcc

Oder ist die etwa jetzt via apt installierbar??

nope

LG

Holger

Hallo Holger,
hast Recht – diese Version hatte ich nicht. Aber sie läuft. Top! Danke!
Michael

Hallo Michael,

hast Recht – diese Version hatte ich nicht. Aber sie läuft. Top! Danke!

Dank Martin: der macht das Ding :slight_smile:

LG

Holger

Ok, danke Martin! :slight_smile:

Zwei Dinge sind weiterhin unklar: ich erhalte beim Aufruf des Tools diese Meldungen:


Screenshot_20191210_160535
Normal? Was gehört da richtigerweise hin?

Eigentlich wollte ich damit den leoclient2 verwenden. Der lässt sich aber nicht ohne weiteres installieren. Die Meldung im lmlcc ist natürlich nachvollziehbar:
Screenshot_20191210_160552

Aber das Tool kann nicht problemlos unter bionic installiert werden. Zunächst: es liegt unter http://pkg.linuxmuster.net – da gibt es aber den Key nicht, den man laut Doku hinzufügen soll:
http://docs.linuxmuster.net/de/v7/clients/leoclient2/leo2-installation.html

Das Paket selbst liegt dann noch unter xenial – gehört aber eigentlich nach bionic, oder?
Wie geht’s weiter? Ich frage mich, ob ich die beiden .deb-Pakete nicht besser per Hand installieren sollte, um keine alte Paketquelle unter bionic einbinden zu müssen?

Schöne Grüße,
Michael

Hallo Michael,

unter Timeserver sollte die IP deiner Firewall stehen, wie ist denn die IP deiner Firewall?
Welche IP zeigt denn der lmlcc für deine Firewall auf dem Startfenster an?
Poste doch bitte einen Screenshot des Startfensters.

Die CUPS-Option stammt noch aus dem cloop 16.04. Damit übernimmt der Client automatisch
die Drucker-Liste vom Server.
Wenn drucken funktioniert, dann kannst du die Meldung ignorieren.

Da der leoclient noch nicht für bionic/v7 angepasst wurde, kann der lmlcc dazu auch noch nicht verwendet werden.

Grüße
Martin

Hallo Martin.

Hier kommt es:

Die Timeserver-Adresse (10.16.1.254) zeigt auf die OPNSense – soweit alles richtig. Ich hatte mich nur über das Fragezeichen dort gewundert. Offenbar wird die FW-IP nicht richtig ermittelt, oder? Oben steht 10.16.1.253 – das stimmt aber nicht, da das der L3-Router ist. Die FW hat 10.16.1.254 und stimmt mit dem Timeserver überein.

Um das Drucken muss ich mich noch kümmern. … hatte gehofft, dass die Einstellungen mit lmlcc möglich seien.

Ok, den leoclient2 kann ich dann noch nicht verwenden. Schade.
Allerdings: Dann muss das ja ein Fehler sein, dass es bereits in der v7-Doku auftaucht?? @Tobias? Wie siehst du das?

Schöne Grüße,
Michael

Hallo Michael,
ja, der lmlcc nimmt die IP der default-route als firewall IP.
Kannst du bitte die Ausgabe des Befehls „route -n“ eines Clients von dir hier posten - ggf. kann ich dann den lmlcc so anpassen, dass er einen L3-Router erkennt.
Inwieweit der leoclient2 mit der lmn7 schon funktioniert habe ich noch nicht getestet,
man müsste m.E. die Startscripte anpassen.
Grüße
Martin

… kein Problem. Hier ist es:

root@vm-client:~# route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.16.1.253     0.0.0.0         UG    100    0        0 ens18
10.16.1.0       0.0.0.0         255.255.255.0   U     100    0        0 ens18
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 ens18

… wobei mir die letzte Zeile gerade selbst komisch vorkommt?!? Gibt’s die bei euch auch?

Hallo Michael,
ja bei mir in meinem VM-Übungssystem gibts die Zeile auch:

Kernel-IP-Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
0.0.0.0 10.16.1.254 0.0.0.0 UG 100 0 0 enp0s3
10.16.0.0 0.0.0.0 255.240.0.0 U 100 0 0 enp0s3
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 enp0s3

Schade, damit kann ich also die Firewall nicht von einem L3 Router unterscheiden.
Hast du einen Konsolenbefehl, wo die Firewall auftaucht?

Grüße
Martin

Hi Martin.
Wie wäre es mit ping -c 1 -w 1 -n firewall?

Hallo Michael,

ping -c 1 -w 1 -n firewall

der Befehl setzt aber eine funktionierende DNS-Namensauflösung voraus,
bzw. ruft den DNS-Server Eintrag ab.

Danke für die Idee.

Heißt die Firewall immer „firewall“ in der lmn7?

Grüße
Martin

Hallo Martin,

Heißt die Firewall immer „firewall“ in der lmn7?

tja … gute Frage.

Es ist so in den ovas eingestellt und beim vanilla Setup wird die
Firewall automatisch so genannt (und unter der richtigen IP so auch
erwartet).

Damit müßten also in 100% der INstallationen die Firewalls firewall
heißen…

Aber irgendeiner hat immer einen Grund das zu ändern oder wenigstens zu
versuchen es zu ändern.

Ich denke den Fall mußt du nicht beachten.

LG

Holger

Hallo Michael,
neue Version lmlcc 0.7e , die die Firewall korrekt erkennen sollte:
https://wiki.linuxmuster.net/community/anwenderwiki:linuxclient:lmlcc7

Grüße
Martin

1 Like

Super – Version 0.7e funkioniert! Danke.
Warum ist denn die Subnetzmaske bei mir weiterhin rot? Was steckt dahinter?
255.255.255.0 sollte bei Subnetting und /24er Netzen doch passen…??

Hallo Michael,
eben - der lmlcc kann flaches Netz nicht von Subnetting unterscheiden.
Werde wohl noch einen Hinweis einbauen.
Grüße
Martin