Linuxmuster-import-devices fasst Benutzer(gruppen) an

Hallo miteinander,
auch wenn dieses Problem mir aufgefallen ist, weil ich eine Windows 10 1903 workstation mangels Vertrauensstellung zur Domäne nach linuxmuster-setup mit den Bordwerkzeugen rauswerfen und anschließend wieder neu aufnehmen wollte, mache ich dafür mal einen neuen Thread auf:

Weshalb werden laut durchlaufendem Protokoll alle möglichen Benutzergruppen angefasst, wobei doch eigenlich nur ein Computerkonto erzeugt oder gelöscht werden soll?
Der Prozess wird hierdurch quälend langsam und aus meiner Sicht auch noch unzuverlässig.

Gruß Jürgen

Hallo Jürgen,

das ist kein Problem von der WebUI (Titel geändert). Es wird hier lediglich linuxmuster-import-devices aufgerufen bzw. sophomorix. Warum die ganzen Objekte durch iteriert werden kann @jeffbeck sicher beantworten.

Grüße Maurice

Hallo Jürgen, was meinst du mir angefasst?
Bitte schreib mal, was du gemacht hast?

LG, Rüdiger

Hallo Rüdiger,

ich habe eine workstation in d’SELMA erfasst und “Speichern und
Importieren” angeklickt. Dann habe ich einige Minuten gewartet, während
linuxmuster-import-devices Objekte wie Benutzer und Gruppen bearbeitet
hat, wie Du im Protokoll


siehst, die aus meiner Sicht nichts mit workstations zu tun haben.

Falls dies bei Dir so nicht passiert: Dieses Verhalten könnte sich
verändert haben, weil ich linuxmuster-setup mit in den IP-Adressen
veränderter setup.ini ausgeführt habe. Allerdings meine ich es von
Anfang an beobachtet zu haben.

Gruß Jürgen

Die hier gezeigten Ausgaben sind im Moment noch normal:

Bei anlegen einer einzelnen Workstation (und auch Benutzer, Gruppe, …) wird sichergestellt, dass auch die entsprechende Schule vollständig mit allen Gruppen existiert.

Das sollte allerdings alle sehr schnell gehen.