Linuxmuster 7 Neuinstallation

Hallo zusammen,

ich bin neu hier, im Forum sowie auch in der Nutzergemeinschaft der linuxmuster.net.
Toll, was hier für open source geleistet wird. Vielen Dank.

An der Grundschule meiner Frau (Bayreuth, BY) kümmere ich mich um die Systemadmin. Als Serverlösung habe ich mich nach einiger Recherche für linuxmuster entschieden.

Nachdem es eine kplt. Neuinstallation wird, fiel die Wahl gleich auf die 7er Version.

Mittlerweile hat sich doch ein großer Fragenberg aufgetan, auch und vor allem weil wir auch in Bayreuth (Gruß nach Hamburg :wink: ) an eine TimeForKids-Vorgabe gebunden sind.

Mein anfängliches Vorhaben, die vorgegebenen IP-Bereiche an unsere bisherige Installation anzupassen, habe ich schon wieder etwas aufgegeben. Mal sehen, ob’s mir noch gelingt.

Im Moment muss/soll erstmal die Standardversion laufen. Allerdings bereitet mir hier die opnsense große Probleme.
Das Setup sieht folgendermaßen aus (Netz steht alles auf Standard):
Virtualisierer XCP-ng Version 8.0 (Verwaltungs-IP 192.168.1.201)
Als *.xva importiert:
lmn7-server
lmn7-opnsense
lmn7-opsi
lmn7-docker

Pings und Zugriff soweit über Konsole etc. alles möglich.
Allerdings startet/bootet mir die opnsense völlig unreproduzierbar ständig neu - mal unmittelbar, nachdem sie gebootet hat, mal nach 2 Minuten, mal nach 15 Minuten.
Ich kriege somit nichtmal die Updates der anderen VMs durch.

Was liegt da im argen? Wer würde bzw. könnte mir mit einem Lösungsansatz weiterhelfen.
Oder ist die gepackte xva fehlerhaft?
Ich habe die VM schon mehrmals gelöscht und wieder importiert, die Reboots sind auch völlig unabhängig von jeglichem Konfigurationszustand.

Freue mich auf Antwort und mögliche Hilfe.
Eigentlich kann ich erst weitermachen, wenn ich opnsense stabil bekommen habe.

Viele Grüße aus Bayreuth
und schonmal tausend Dank vorab,

Andreas (Dietel)

Hallo Andreas,

hier ist Hamburg :wink:

Wenn Ihr wie wir die Tfk-Box verwenden müsst, heißt das ja nicht, dass
man Euch wie uns auch noch vorschreibt, welche(s) IP-Segment(e) die
Schnittstelle GRUEN bekommt. !92.168.1.x deutet darauf hin, dass Du
GRUEN auf 10.0.0.254 ändern dürftest. Danach müsstest Du natürlich alle
Firewallregeln prüfen.
Wenn Du keinen Zugriff auf die Box haben solltest, macht die Umstellung
eventuell der Time for Kids Support für Euch?

OpenSense musst Du nicht unbedingt mit installieren. Bei
linuxmuster-setup kannst Du angeben, ob die Firewall mit konfiguriert
werden soll oder nicht. Was nicht oder nicht gut funktioniert: Die
TfK-Box und OpenSense kaskadieren. Du verlierst natürlich einige
Features der lmn, wie z. B. die Internetfreigabe, wenn kein
administrativer Durchgriff auf die Firewall besteht.

Falls Du weiterhin den Adressbereich 192.168.1.0/24 verwenden willst
oder musst, schicke ich Dir gern per PN meine Mitschrift, was ich in
lmn6.x alles ändern musste. Daran hat sich mit lmn7 (leider) kaum etwas
geändert. Testen konnte ich das bislang allerdings nur zu Hause mit
meinem „TfK-Box-Nachbau“ ipfire …

Gruß Jürgen

Hallo a_dietel,

Grüße in den Süden! :slight_smile:

Mit dem Befehl shasum -c lmn7-opnsense-*.ova.sha kannst du schauen, ob das xva korrekt ist.

Wenn die VMs unmotiviert rebooten (apropos: welche Virtualisierung nutzt du?), würde ich mal schaun, was die log-files so sagen. In /var/log/system.log auf der opnsense sollte ein wenig darüber stehen, warum die herunterfahren. Bei mir steht bei einem ordentlichen reboot:

Dec 20 09:39:55 firewall shutdown: reboot by root:  
Dec 20 09:39:56 firewall syslogd: exiting on signal 15
...

Das Booten beginnt mit ein paar Copyright-Meldungen:

Dec 20 10:45:56 firewall kernel: Copyright (c) 2013-2018 The HardenedBSD Project
.
Dec 20 10:45:56 firewall kernel: Copyright (c) 1992-2018 The FreeBSD Project.
Dec 20 10:45:56 firewall kernel: Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
...

Sollten die auftauchen, ohne dass irgendwie ein ordentliches shutdown gelogged wurde, wurde die VM wohl von aussen ausgeschaltet oder resettet. Dann kannst du im Host-System schauen, ob da Hinweise in /var/log/syslog oder (für die KVM Virtualisierung) in /var/log/libvirtlibvirtd.log zu finden sind.