Linbo + Zeitsync

Hallo zusammen

Linbo (2.3.56-0) übernimmt doch die Zeitsync. mit der Hardware-Uhr der Clients ?

Zumindest ist beim Start von Linbo eine solche Meldung zu sehen.
Ich habe darauf hin die Zeitsync. im Postsyncscript herausgenommen. Dann hatten die Clients aber wieder die falsche Zeit von Linbo.

Aktueller Stand meiner Uhren ist nun:

  • Virtualisierer: UTC (also -1)
  • Server, Firewall: ± 0
  • Client-Linbo-Zeit: +2
  • Client mit aktiviertem Postsync-Timesync: ±0 ohne Postsync: +2

Wie ist nun das korrekte Verfahren damit Server, FW und Client die gleiche Zeit haben?
Das ist ja für die Anmeldung am Samba4 erforderlich !
Grüße Rainer

2 Like

Hallo Rainer

bei mir funktioniert der Zeitsync auch nicht wenn ich einen PC habe der abweicht dann stellt Linbo ihn auf 0 uhr und in windows kommt 22 Uhr raus egal zu welcher Uhrzeit
Wie kann ich den Zeitsync richtig konfigurieren damit auch die Richtige Zeit ankommt.

Gruß Pascal

Mit welchem Server Synct Linbo den die Zeit weil bei mir ändert sich jetzt überhaupt keine Zeit mehr wo kann ich den Server mit dem Linbo Synct einstellen?

Lg Pascal

Hi!

In v7 ist der Server der Zeitserver für die Clients und die Firewall der Zeitserver für den Server. Sollte zumindest so vorkonfiguriert sein.
Läuft der ntp service auf dem Server?
systemctl status ntp.service
In /etc/ntp.conf muss die Firewall als primary ntp server eingetragen sein.

VG, Thomas

Hallo Thomas,

ja der NTP lief nicht auf dem Server ich habe ihn gestartet und einen Client Zeit Syncen lassen jetzt hat er die Zeit gesynct aber eine Stunde zu früh also die Reale Zeit ist 18 Uhr und in Linbo kommt aber 17 Uhr an wo muss ich die Zeit noch ändern damit linbo die richtige Zeit bekommt ?

Lg Pascal

Liegt es vielleicht daran die OPNsense meldet diese Fehler:

als Zeitserver ist de.pool.ntp.org eingetragen.


LG Pascal

Hallo Pascal,

welche Zeitzone zeigen Server und Linbo-Client mit date an? Muss
eigentlich gleich sein. update-linbofs packt /etc/localtime des Servers
in linbofs ein, von dem her …

VG, Thomas

root@server:/# date
Sa 15. Feb 18:43:42 CET 2020
root@server:/# linbo-ssh 10.16.4.5
~ # date
Sat Feb 15 17:43:52 UTC 2020
~ #

also soll ich auf dem server update-linbofs laufen lassen und dann den rechner neustarten.
Muss ich dann mit einem Stick die Rechner neu mit linbo versorgen?

Lg Pascal

Habe update-linbofs ausgeführt dann einen Rechner neu gestartet er hat auch 2 mal neugestartet aber keine veränderung der Zeit
Lg Pascal

Hallo Thomas,

ich habe noch ein anderes Problem entdeckt ich glaube die der Server bekommt nicht die richtige Zeit wenn ich mit ntpd -nq -p 10.16.1.1 die zeit vom Linbo synce kommt diese ausgabe + CET und UTC sind falsch die aktuelle Uhreit ist 22:17 Uhr

~ # ntpd -nq -p 10.16.1.1
ntpd: reply from 10.16.1.1: peer is unsynced
ntpd: reply from 10.16.1.1: peer is unsynced
ntpd: reply from 10.16.1.1: peer is unsynced
ntpd: reply from 10.16.1.1: peer is unsynced
ntpd: reply from 10.16.1.1: peer is unsynced
ntpd: reply from 10.16.1.1: peer is unsynced
Alarm clock
~ # date
Sat Feb 15 21:17:40 UTC 2020
~ # TZ=CET date
Sat Feb 15 21:17:57 CET 2020
~ #

oder was bedeutet peer ist unsynced?

Lg Pascal

Hallo Pascal,

die Zeitzone auf Server und Linbo-Client sollte identisch sein. Keine
Ahnung, warum das bei dir nicht so ist.
Überprüf mal folgendes auf dem Server:

❯ ls -l /etc/localtime
lrwxrwxrwx 1 root root 33 Okt 4 06:14 /etc/localtime ->
/usr/share/zoneinfo/Europe/Berlin

Dann lass dir mal die md5-Summe von /usr/share/zoneinfo/Europe/Berlin
ausgeben:
md5sum /usr/share/zoneinfo/Europe/Berlin
2d53644b5272b0826ad62a3317a66bb9 /usr/share/zoneinfo/Europe/Berlin

Auf dem Linbo-Client dasselbe mit /etc/localtime:
md5sum /etc/localtime
2d53644b5272b0826ad62a3317a66bb9 /etc/localtime

Die Summen sollten übereinstimmen.
Falls nicht, kannst du auf dem Server mit update-linbofs neue
Linbo-Bootfiles erzeugen und danach den Linbo-Client neu starten.

Aber eigentlich wird das ja bei der Paketinstallation gemacht.

Bzgl. peer unsynced, checke mal ob der Server die Zeit erfolgreich von
der Firewall beziehen kann.

VG, Thomas

1 Like

Hallo Thomas,

root@server:~# ls -l /etc/localtime
lrwxrwxrwx 1 root root 33 Feb 15 22:03 /etc/localtime -> /usr/share/zoneinfo/Europe/Berlin
root@server:~# md5sum /usr/share/zoneinfo/Europe/Berlin
2d53644b5272b0826ad62a3317a66bb9  /usr/share/zoneinfo/Europe/Berlin
root@server:~# linbo-ssh 10.16.4.7
~ # ls -l /etc/localtime
ls: /etc/localtime: No such file or directory
~ # md5sum /etc/localtime
md5sum: can't open '/etc/localtime': No such file or directory
~ #

Den Pfad gibt es auf dem linbo Client nicht ?

Ich habe mal den Server die Zeit mit der FW neu syncen lassen und im der Firewall den Zeitserver auf LAN und auf WAN gestellt der war vorher nur auf LAN das ist die Ausgabe:

root@server:~# ntpd -nq 10.16.1.254
16 Feb 12:28:45 ntpd[18340]: ntpd 4.2.8p10@1.3728-o (1): Starting
16 Feb 12:28:45 ntpd[18340]: Command line: ntpd -nq 10.16.1.254
16 Feb 12:28:45 ntpd[18340]: proto: precision = 0.100 usec (-23)
16 Feb 12:28:45 ntpd[18340]: Listen and drop on 0 v6wildcard [::]:123
16 Feb 12:28:45 ntpd[18340]: Listen and drop on 1 v4wildcard 0.0.0.0:123
16 Feb 12:28:45 ntpd[18340]: Listen normally on 2 lo 127.0.0.1:123
16 Feb 12:28:45 ntpd[18340]: Listen normally on 3 eth0 10.16.1.1:123
16 Feb 12:28:45 ntpd[18340]: Listen normally on 4 lo [::1]:123
16 Feb 12:28:45 ntpd[18340]: Listen normally on 5 eth0 [fe80::215:5dff:feb2:191e%2]:123
16 Feb 12:28:45 ntpd[18340]: Listening on routing socket on fd #22 for interface updates
16 Feb 12:28:48 ntpd[18340]: Soliciting pool server 194.102.255.19
16 Feb 12:28:49 ntpd[18340]: Soliciting pool server 162.159.200.1
16 Feb 12:28:50 ntpd[18340]: Soliciting pool server 78.96.7.25
16 Feb 12:28:51 ntpd[18340]: Soliciting pool server 162.159.200.123
16 Feb 12:28:52 ntpd[18340]: ntpd: time slew +0.000261 s
ntpd: time slew +0.000261s
root@server:~# date
So 16. Feb 12:28:57 CET 2020
root@server:~# TZ=UTC date
So 16. Feb 11:29:12 UTC 2020
root@server:~#

Dann habe ich nochmal update-linbofs ausgeführt und einen linbo client neu gestartet und siehe da:

root@server:~# linbo-ssh 10.16.4.5
~ # date
Sun Feb 16 11:44:23 UTC 2020
~ # reboot
Connection to 10.16.4.5 closed by remote host.
Connection to 10.16.4.5 closed.
root@server:~# linbo-ssh 10.16.4.5
~ # date
Sun Feb 16 12:46:53 CET 2020
~ # 

aufeinmal geht es jetzt gibt es auch den Pfad /etc/localtime und die checksumme stimmt auch komisch warum ich zwei mal update-linbofs laufen lassen musste.

Lg Pascal

Hier stimmt die Zeit von LINBO und Server überein – dennoch stelle ich fest, dass der LINBO-Start lange dauert. Hier zwei Screenshots, die die Stellen zeigen, wo es lange dauert, bis es weitergeht:

Screenshot_20200216_195337
Da dauert es sicher 20 Sekunden. Und anschließend bei der Meldung: Syncinc time ... dauert es auch nochmal ein paar Sekunden, bis es weitergeht. Ist das bei euch auch so?
Screenshot_20200216_195411

Hallo Michael :smile:

ja bei mir dauert es auch sehr lange.

Lg Pascal

Hallo Pascal,

die Frage „ist das bei Euch aus so“ kam von Michael.

Gruß

Alois

Hallo,

das habe ich auch gemacht: die md5summen stimmen überein.
Trotzdem steht der letzte Mist am Client als Zeit im BIOS.
z.B. Heute Morgen um 7:30 Uhr sagte linbo es sei 14:46
Ich hab das nun genauer untersucht:
der Server hat 10.16.1.254 als ntp eingetragen und holt auch brav die
Zeit von der OPNsense.
Der Client hingegen beendet ein:
ntpd -nq -p 10.16.1.1
nur mit der Meldung
Alarm Clock
sonst nichts: Zeit bleibt auch grottenfalsch.
Wenn ich am Client aber
ntpd -nq -p 10.16.1.254
mache, dann kommt neben
Alarm Clock
noch die Meldung, dass die Zeit gesetzt wurde: was auch stimmt.

Deswegen meine Frage: wie kann ich dem Server sagen, dass er bitte ntp
Anfragen aus Grün beantwortet?

LG

Holger

Hallo Holger,

musst da da nicht einfach den Port 123 für ntp freigeben?

Gruß

Alois

ja so musste ich das auch einstellen damit der Zeit-Sync vom Server auf die Firewall klappt.

ich habe das deswegen für das gesamte lan eingetragen weil ich die FW in Windows auch nochmal als Zeitserver drinne habe.

Lg Pascal

… nur als Tipp: Unter OPNSense gibt es unter Firewall --> Regeln --> Fließend (floating rules) auch die Möglichkeit, so einen Port gleich für alle Schnittstellen (und nicht nur für grün/LAN) freizugeben.

Läuft der ntp service? Wenn er läuft, beantwortet er auch Anfragen.

VG, Thomas