Linbo Sync - jedesmal nach Neustart wird das gesamt Image erneut geladen

Hallo zusammen,
ich habe als Linux-Client ein Ubuntu 18 auf Fujitsu Esprimo P758 HW laufen. Da ich Probleme mit den getroffenen postsync - Einstellungen hatte, habe ich den postsync derzeit komplett rausgenommen.

Ich habe die Client auf sync + start gestellt. Alle neu partitioniert, Image heruntergeladen, synchronisiert und gestartet. Danach booteten die Clients mit Ubu18, ich konnte mich an der Domäne anmelden und wie gewohnt alle Dienste nutzen.

Starte ich den PC neu, tritt das Problem auf, dass Linbo jedesmal das gesamt Image erneut herunterlädt, synchronisiert und danach startet Ubu18 normal, so dass ich es dann wieder nutzen kann.

Es gibt aber keine Änderungen am Image, so dass dieses auch nicht neu heruntergeladen werden dürfte.

In dem Linbo-Log eines Clients habe ich folgende Auffälligkeiten festgestellt:

Installing for x86_64-efi platform.
grub-install: warning: cannot open directory `/usr/share/locale’: No such file or directory.
Installation finished. No error reported.

NTFS signature is missing.
Failed to mount ‘/dev/sda’: Invalid argument
The device ‘/dev/sda’ doesn’t seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

sda2 kein Label MSR gesetzt

Installing for x86_64-efi platform.
grub-install: warning: cannot open directory `/usr/share/locale’: No such file or directory.
GPT:disk_guids don’t match.
GPT: Use GNU Parted to correct GPT errors.
GPT:disk_guids don’t match.
GPT: Use GNU Parted to correct GPT errors.
GPT:disk_guids don’t match.
GPT: Use GNU Parted to correct GPT errors.
Installation finished. No error reported.
Stelle EFI-Standardboot wieder her.
Setze EFI BootNext: 0002.
BootNext: 0002

grub-install: warning: cannot open directory `/usr/share/locale’: No such file or directory.
Installation finished. No error reported.
OK!

Der Rechner verfügt nur über UEFI 64, eine SSD mit 256 GiB, wovon ca. 125GiB für Partitionen + der Rest für den Cache vergeben sind. Alle Partitionen verwenden Labels.

Ideen?

Danke!

VG
Chris

Hallo Chris,

ist in der start.conf vielleicht Auto-Partition eingeschaltet.

Gruß

Alois

Was sagt die start.conf? Ist da evtl als default "new’ eingestellt??
Alois, zwei Doofe, ein Gedanke?? :slight_smile:

Hallo Alois, Hallo Michael,

nein, Auto-Partition habe ich nicht eingestellt.

SystemType = efi64 # bios,bios64,efi32,efi64
RootTimeout = 600 # automatischer Rootlogout nach 600 Sek.
AutoPartition = no # automatische Partitionsreparatur beim LINBO-Start
AutoFormat = no # kein automatisches Formatieren aller Partitionen beim LINBO-Start
AutoInitCache = no # kein

und bei Ubuntu habe ich angegeben

StartEnabled = yes # “Start”-Button anzeigen
SyncEnabled = yes # “Sync+Start”-Button anzeigen
NewEnabled = yes # “Neu+Start”-Button anzeigen
Autostart = yes # automatischer Start des Betriebssystems (yes|no)
AutostartTimeout = 5 # Timeout in Sekunden fuer Benutzerabbruch bei Autostart
DefaultAction = sync # Standardaktion bei Autostart: start|sync|new
Hidden = yes # verstecke OS-Reiter (unbenutzte Option, auf “yes” lassen)

VG
Chris

Hallo Chris,

ich empfehle folgendes:

  1. Client gesynct booten und einen Terminal öffnen + sudo su
  2. touch /forcefsck
    eintippen
  3. ungesynct rebooten
  4. reboot und Image erstellen + hochladen
  5. testen

LG

Holger

Hallo Chris,

handelt es sich um ein reines Linux-System beim Client? Ich hatte da kürzlich auch ein Problem welches sich dadurch lösen lies dass ich die start.conf Vorlage aus /var/linbo/examples verwendete. Mit einer start.conf die ich aus einem Dual-Boot gewonnen hatte wollte der Client nicht funktionieren.

Was war der Unterschied?

In der Vorlage aus /var/linbo/examples war der Cache die zweite Partition und swap die Dritte. Bei meiner ursprünglichen start.conf war der Cache die letzte Partition.

Vielleicht ist so etwas auch der Grund bei Deinem Problem!?

Gruß

Alois

Hallo Holger,

ja danke das wars.
Das Image war scheinbar nicht in Ordnung habe den forcefsck laufen lassen, das System aktualisiert, neu gestartet, bereinigt, neu gestartat (ungesynct) und habe danach ein neues Images erstellt, dieses verteilt und danach die Clients neu gestartet. Nachdem das neue Image alle Clients hatten, erfolgt danach der synchronisierte Start von Ubuntu direkt aus dem cache ohne weiteres Nachlagen vom Server.

@Alois: Ich habe die start.conf nicht geändert und bei mir ist die Cache Partition die letzte Partition. Ich habe zudem eine Partition für Win10.
Den Hinweis hatte ich im Forum schon mal gelesen, wobei mir nicht klar ist, warum dies zu Problemen führen sollte. Da fehlte mir bislang die technische Begründung.

Danke an Euch !

VG
Chris

Mir fehlt auch die Begründung. Es ist aber definitiv so. Ich hab’s jetzt zum zweiten Mal bei reinen Linux-Clients gehabt.

Gruß Alois

Hallo,

Den Hinweis hatte ich im Forum schon mal gelesen, wobei mir nicht
klar ist, warum dies zu Problemen führen sollte. Da fehlte mir
bislang die technische Begründung

Mir fehlt auch die Begründung. Es ist aber definitiv so. Ich hab’s jetzt
zum zweiten Mal bei reinen Linux-Clients gehabt.

der Hinweis kam auf mit linbo 2.3 bei der Verwendung von UEFI.
Da beobachtete ich das erst mal, dass “cache am Ende” Probleme machen
konnte…

Inzwischen hat Alois das auch auf anderen Plattformen gesehen.
Es sit aber nicht generell: ich habe sehr viele “linux only” Cleints und
bei mir ist historisch schon immer der Cache die letzte Partition.
Also: es kann das Problem sein, muß aber nicht.

LG

Holger