Linbo-remote läuft gegen die Wand !

linbo-remote

#1

Hallo,

ein altes Problem möchte ich hier nochmal aufwärmen:
(Lml 6.2, linbo 2.3.26)
Wenn ich meine Rechner mit linbo-remote aufwecke, bleiben sie NICHT stehen, sondern laufen munter weiter - und zwar immer so, wie es in der Datei:
/var/linbo/boot/grub/[xyz].cfg
steht.
Daher bin ich gezwungen, bei automatisierten Prozessen (Rechner aufwecken, synchronisieren, schlafenlegen) IMMER auch diese Datei zu manipulieren, bevor ich linbo-remote ausführe.

Hat dafür jemand eine Erklärung ?
(Natürlich habe ich das:
### managed by linuxmuster.net
abgewandelt, damit meine Eintragungen in dieser Grub-Datei nicht bei jedem import_workstations manipuliert werden. Ferner starten bei mir die Rechner OHNE Neustart direkt in den Sync-Modus, die Linbo-Maske erscheint also gar nicht, sondern nur Mister Grub.

Gruß
Christoph Gü


#2

Hallo Christoph,

um aus zu schließen, dass da in der grub.cfg irgend was falsch ist, mach
mal bitte folgendes:

  1. sichere deine /var/linbo/boot/grub/.cgf
  2. kontrollier ob in der start.conf. kein autostart in den
    KernelOptions steht
  3. mach ein import_workstations
  4. lass einen Rechner booten, sync ein BS und fahr ihn runter.
    Nun schau nach, ob dieser Rechner mit linbo-remote normal zusammen arbeitet.

Zu Beachten: linbo-remote arbeitet nicht mit ungesynctem Start zusammen,
da der ungesyncte start von grub2 ausgeführt wird, und nicht von linbo:
also darfst du bei Default nicht 1 oder 4 stehen haben.

LG

Holger


#3

Hi Christoph,
nochmal die Nachfrage: wenn du linbo-remote -i host -p sync:1 startest, hängst du dann ein -n mit an?

VG, Tobias


#4

Hallo Christoph,

soweit ich weiß, ist das normal bzw. soll so sein.
Wenn du die zugehörige grub.cfg angefasst hast, also z.B. auf set default=1 für direkten Betriebssystem-Boot auf der 1. Partition umgestellt hast, sodass nun das Linbo in dieser Hardwaregruppe ‘deaktiviert’ ist, dann greift GRUB ja vorher ein mit dem Befehl ‘Boot von Partition 1’ anstatt ‘boote Linbo’ und somit können die Rechner ja auch keine linbo-remote-Befehle entgegen nehmen.
So ist es jedenfalls bei uns und so haben wir das auch immer verstanden.
Du musst dann quasi jedes Mal, wenn du mit linbo-remote arbeiten willst, vorher wieder auf set default=0 umstellen.
Wir haben uns dafür zwei kleine Aliase geschrieben, die die Einträge abändern.
Einmal linbo-act <Hardwaregruppe> für das schreiben von set-default=1 in die jeweilige grub.cfg und linbo-deact <Hardwaregruppe> für den Direktstart in Windows bzw. Ubuntu.
Aber vielleicht soll das gar nicht so sein und wir haben das falsch verstanden und es handelt sich um einen Bug?!

Grüße
Valentin


#5

Hallo Valentin,

Einmal |linbo-act | für das schreiben von

set-default=1| in die jeweilige grub.cfg und |linbo-deact
| für den Direktstart in Windows bzw. Ubuntu.
Aber vielleicht soll das gar nicht so sein und wir haben das falsch
verstanden und es handelt sich um einen Bug?!

das Problem ist, dass wenn du einmal set default = 1 drin hast, dann
startet grub2 am Client immer direkt das BS1 ohne dass grub erneuert
wird oder dass linbo bootet.
Deswegen reagiert der Client nicht mehr auf linbo-remote Befehle.

LG

Holger


#6

Hallo, Ihr Lieben,

war gerade etwas “abgetaucht” und konnte daher noch nicht reagieren. Aber ich habe alle Hinweise verstanden - vielen Dank !

Für mich ist das Problem damit gelöst - ich kann gut damit umgehen.

Gruß Christoph Günschmann


#7

Hallo, Tobias,

nein, die Option -n kenne ich gar nicht !
Gruß,
Christoph Gü.


#8

Die verhindert, dass ein Autostart ausgeführt wird, wenn du mit linbo_remote -p das eigentlich gar nicht willst, z.B…

linbo-remote -i host -p initcache:torrent,sync:1

und er startet nach dem sync trotzdem? Dann liegt es an einem AutoStart=yes.
Dann hilft “-n” beim Absetzen des linbo-remote Befehls.

Mit der grub.cfg und deinem Problem hat das aber nichts zu tun.

VG, Tobias


#9

Ok, Tobias,

danke - ich probiere jetzt Eure / Deine Vorschläge aus.

L.G.
Christoph Gü.