Linbo.iso missing

Hello Linuxmuster!

I am testing LMN on my proxmox VE and have installed it manually (ubuntu server12)

Everything appears to be running ok but…
I want to use the linbo iso to create a bootable USB stick to test with however it is not in /var/linbo directory and is not found under http://10.16.1.1/linbo.iso either

I can see various files named linbo and also linbo fs but i cant (or dont know how to) use them to create a bootable USB

I have searched for *.iso and did get results but no linbo.iso

I tried PXE boot with a client machine and although it found the server and got an ip address it still would not boot (error ‘operating system not found’)

Please can you help!

Many thanks!

Lloyd

Hi Lloyd,

I am testing LMN on my proxmox VE and have installed it manually (ubuntu
server12)

thats the lmn 6.2 on ubuntu server 12.04 not the lmn 7 on ubuntu server
18.04 right?

Everything appears to be running ok but…
I want to use the linbo iso to create a bootable USB stick to test with
however it is not in /var/linbo directory and is not found under
http://10.16.1.1/linbo.iso either

the linbo.iso should be available from the server by accessing the
netwokshare \server\linbo-repo

But i guess it will be created after you run
import_workstations
on the server for the first time or maybe only after you have registered
the first client.

I can see various files named linbo and also linbo fs but i cant (or
dont know how to) use them to create a bootable USB

you need the .iso for that.

I have searched for *.iso and did get results but no linbo.iso

not yet … i guess.

I tried PXE boot with a client machine and although it found the server
and got an ip address it still would not boot (error ‘operating system
not found’)

proxmox has problems fetching the linbo.fs over tftp via pxe.
I dont know the setting you need for a virtual proxmox CLient to
sucsessfully make a PXE boot: maybe some else here knows that.

I would advice you to boot a real Client.

Yours

Holger

Hi Lloyd,

you could try (as root):

/usr/share/linuxmuster-linbo/make-linbo-iso.sh

This should create the linbo.iso image and place it in /var/linbo.

We are using Proxmox, and I remember I had to play around with the
network cards. Right now we have virtio for both server and client,
virtio for the server and e1000 for the client works, too. However
virtio might show a different behaviour depending on your actual hardware.

Best regards

Jörg

Thanks Holger and Jorg!

The shell script worked Jorg and I now have a working bootable USB :slight_smile:

Holger

Yes it is 6.2 on server 12. However I used the pkg.linuxmuster repo not the archive. (after finding the renamed key). Will it still work ok or should I do a fresh install using the new repo?

I am using real client machine to test (but will set up a VM client, thanks for the tips on networking Jorg)

I still have to resolve PXE boot not working. Even when booting Linbo from USB it does not connect to the server (DHCP is working fine)

One question: I cannot access the imaging section of the Linbo interface - it does not accept the password LINBO. Is this because it has no connection to the server? or is the password different? (I have tried upper and lower case)

I also have the LDAP issue when trying to register workstations and not resolved it yet so i have not been able to test setting up a client machine this way yet

Thanks again for your help

Hy Lloyd,

Yes it is 6.2 on server 12. However I used the pkg.linuxmuster repo not
the archive. (after finding the renamed key). Will it still work ok or
should I do a fresh install using the new repo?

normaly you dont need a fresh install: change the lines in
/etc/apt/sources.list.d/linuxmuster.list
from
http://pkg
to
http://archive
import the archive.linuxmuster.net.key
and upgrade the system.

I am using real client machine to test (but will set up a VM client,
thanks for the tips on networking Jorg)

I still have to resolve PXE boot not working. Even when booting Linbo
from USB it does not connect to the server (DHCP is working fine)

i guess there is something wrong with the Bridge from Server to real Client.

One question: I cannot access the imaging section of the Linbo interface

  • it does not accept the password LINBO. Is this because it has no
    connection to the server? or is the password different? (I have tried
    upper and lower case)

does the GUI show an IP Adress?
The linbo Password was set in the setupprocess: did you state “LINBO” there?

Please look in the File:
/etc/rsync.secret
the linbo Passwort is stated there.

I also have the LDAP issue when trying to register workstations and not
resolved it yet so i have not been able to test setting up a client
machine this way yet

please send us the contents of the File:

/etc/linuxmuster/workstations

Yours

Holger

Hi Lloyd,

regarding the PXE problem - which step exactly is going wrong:

  1. Bios PXE - does the client get an IP address?

  2. Linbo boot - does Linbo boot into the Linbo GUI?

  3. Does Linbo show an IP address or “Offline”

For problem 1+2, you could try a different network driver for the serer VM. For Problem 3, you need to encrease the “dhcp retry” parameter in your start.conf.

Cheers

Jörg

Hi Lloyd,

For problem 1+2, you could try a different network driver for the serer
VM. For Problem 3, you need to encrease the “dhcp retry” parameter in
your start.conf.

… and run
import_workstations
after the alteration of the
/var/linbo/start.conf.

The import_workstations script will transport the
dhcpretry statement from the start.conf.
to the relevant
/var/linbo/boot/grub/.cfg
which is used by the local grub on the Client.

The dhcpretry statement needs to be in the line of
KernelOptions =

an Example would be:

KernelOptions = quiet splash modprobe.blacklist=radeon dhcpretry=5

(in one line)

The modprobe is needed for my clients with Radeon GPU: otherwise the
linbo GUI will not appear on the Cleint.
If you do not have Radeon GPUs, then you only need:

KernelOptions = quiet splash dhcpretry=5

yours

Holger

Thank you both!

I did a fresh install to be sure (but without installing the firewall)

linbo.iso is still not in var/linbo so i assume it must be generated

I successfully ran import_workstations and then used the shell script to generate the iso

I checked rsyncd.secrets and it shows the entry LINBO:password
However I still cannot access the imagaing tab of linbo GUI with this password, or the default password LINBO

How does linbo authenticate? Is the password written to the iso locally when generating or does it require a connection to the server?
If locally then where can i edit it?

When i boot from the iso the linbo GUI shows offline and no IP address which would explain why the password fails if it authenticates with the server
But this does not make sense to me because there would be instances where you need imaging tools when offline after building a PC, whether booting into linbo from local hard disk or USB

PXE boot does get an ip address but the linbo gui does not load. The error message reads: operating system not found. I will work on resolving this, thanks for the advice :slight_smile:

Where can i learn more about Linbo please? I would like to understand how it works better.
I have researched tools for image deployment/creation/management and Linbo appears to be the one that fits my needs really well (FOG is the only other one, however in the long run I would like to implement the entire network management system)

I have read the documentation on the start.conf and am reading the wiki on github

Thank you again!

Lloyd

Hi Lloyd,

linbo.iso is still not in var/linbo so i assume it must be generated

I successfully ran import_workstations and then used the shell script to
generate the iso

was there a line in your /etc/linuxmuster/workstations
bevore you ran import_workstations
?

I asked for the contents of that file in one of my last mails.
Could you please send them.

I checked rsyncd.secrets and it shows the entry LINBO:password
However I still cannot access the imagaing tab of linbo GUI with this
password, or the default password LINBO

in the linbo GUI, when you press the imaging Tab, ther appear no Dots
when you type in the password: thats normal.
So type it in “blind” and press Return.

How does linbo authenticate? Is the password written to the iso locally
when generating or does it require a connection to the server?

usually it is stored withn the Client so linbo can work offline.
But i dont know if it is stored in the iso too.
I guess so, but i dont know.
The iso does need connection to the server to fetch its start.conf.

If locally then where can i edit it?

i dont know that.

When i boot from the iso the linbo GUI shows offline and no IP address
which would explain why the password fails if it authenticates with the
server
But this does not make sense to me because there would be instances
where you need imaging tools when offline after building a PC, whether
booting into linbo from local hard disk or USB

if you boot from harddisk you can login offline: i do that very often.
All imaging features are there when you boot offlien except “upload to
the server”
You can create images and sync the Cleint (if there is an image in the
cache).

PXE boot does get an ip address but the linbo gui does not load.

which IP Adress?
It might be that you have another DHCP in your net: and thats why there
is “no operatingsystem fount”.

Where can i learn more about Linbo please? I would like to understand
how it works better.

there is a technical documentation, but i fear its written in German.

I will try to resolve your bootingproblems.

Please tell us about your setup.
Do you have virtualization?
Which?
Are you trying to boot an virtual Client or a real one?
Tell us about the connection between the Client and the server, if you
boot a real Client.

Would you like to have a working virtual environment with
IPFire
Server
Client1
Client2
WLAN server
WLAN Client
?
I can provide that (its aroung 13GB in Size)

Yours

Holger

Good morning Holger! Thank you for quick replying!

Yes: it is:
r100;lt-nb-53;xenial;00:24:54:CC9:27:7D;10.16.100.1;;;;;;1;

Yes I understand and it was accepting my input - it gave me error messages after pressing return (in German about authentication failure). I also booted into console to check my keyboard was working correctly. I am sure this step is ok

10.16.100.1
I do not have another DHCP server running on my host, and i connected my real client machine directly by cat5 network cable to the host
However I do need to reconfigure the bridge for this to be sure this is working properly, sometimes I do not get an ip address at all

This would still be helpful please! Google translate works fairly well and most of the scripts in Linbo have English comments already. If you have any links or docs I would most appreciate it

Thank you this would be really helpful to try a working setup already virtualised
Is this separate VMs for firewall and server yes?
Do i need the WLAN server and client at this stage?
13 GB is ok!

My setup is

Proxmox 5.3
I believe it can import ova VMs with some work. and virtual box images
Booting a real client via cat5 ethernet cable direct to the host server, via proxmox bridge

Thank you again Holger!

Lloyd

This is wrong, it should be 10.16.1.100 I have a screenshot!

Hi Lloyd,

Where can i learn more about Linbo please? I would like to understand
how it works better.

linbo is opensource.
You can even build your own linbo.
Information can be found here:

Yours

Holger

Hi Lloyd,

This is wrong, it should be 10.16.1.100 I have a screenshot!

an this is a wrong IP Number for a known host!

You said the workstations line would be:

r100;lt-nb-53;xenial;00:24:54:CC9:27:7D;10.16.100.1;;;;;;1;

There it is 10.16.100.1 which would be OK.

Background:
there is a DHCP Lease which is for getting unknown Clients into linbo.
That Lease is from
10.16.1.100
to
10.16.1.200

Dont use those IPs for a known host (so they are not supposed to be in
the workstations File).

Please check again which IP you get on the Client and what IP you have
in the /etc/linuxmuster/workstations
an tell us.

Anyway: the linbo password should work anyway.

At this point i blame the proxmox bridge.

Yould please someone with proxmox post theyr bridge config?

I knkow there are quite some people here using proxmox.

Yours

Holger