Laptop ohne Dockingstation bootet nicht(s)

Hi.
Ich habe einen Laptop (HP Elitebook 8440p) mit LINBO + Ubuntu 16.04 bestückt. Das lief alles ganz normal.
Anschließend wollte ich das Gerät mal ohne PXE booten …einfach lokal (genauergesagt: ohne sich in der Dockingstation zu befinden). Ich hatte erwartet, dass dann LINBO lokal startet und dann im OFFLINE-Mode durchstartet. Leider geschah aber weder das eine noch das andere: Ich erhalte sinngemäß ein “Missing OS – Press Ctrl + Alt + Del”. Es wird also offenbar kein Bootloader gefunden. Ich frage mich natürlich, was da schief gelaufen ist und warum? Auf anderen Clients klappt das auch … über Linbo-Local.
Wer hat eine gute idee?

Linbo 2.2.16 mit V.6.1

Hallo Michael,

Ich habe einen Laptop (HP Elitebook 8440p) mit LINBO + Ubuntu 16.04
bestückt. Das lief alles ganz normal.
Anschließend wollte ich das Gerät mal ohne PXE booten …einfach lokal
(genauergesagt: ohne sich in der Dockingstation zu befinden). Ich hatte
erwartet, dass dann LINBO lokal startet und dann im OFFLINE-Mode
durchstartet. Leider geschah aber weder das eine noch das andere: Ich
erhalte sinngemäß ein “Missing OS – Press Ctrl + Alt + Del”. Es wird
also offenbar kein Bootloader gefunden. Ich frage mich natürlich, was da
schief gelaufen ist und warum? Auf anderen Clients klappt das auch …
über Linbo-Local.
Wer hat eine gute idee?

… ob sie gut ist, wird sich zeigen …

Steht den in der Bootreihenfolge im BIOS auch die Festplatte drin?

LG

Holger

Ich habe extra beim Start “ESC --> F12 --> Boot from Disk” gewählt … kein Erfolg.

Aber auch die Default-Einstellung via PXE sollte ja eigentlich als zweites Device (nach geescheitertem PXE-Boot) dann via HDD booten … auch das tut sie aber nicht.

Hallo Michael,

Ich habe extra beim Start “ESC --> F12 --> Boot from Disk” gewählt …
kein Erfolg.

Aber auch die Default-Einstellung via PXE sollte ja eigentlich als
zweites Device (nach geescheitertem PXE-Boot) dann via HDD booten …
auch das tut sie aber nicht.

der lokale boot geht erst, wenn wenigstens ein Betriebsystem wenigstens
ein mal gebootet wurde.
Außerdem sollte nur der Cache auf bootable gesetzt sein (in der start.conf).

Du kannst aber auch folgendes machen:
Leg mal diese Datei an
/var/linbo/menu.lst.

mit diesem Inhalt:

default	2	
#default	saved	

# (normally the first entry defined).
timeout		3

# Pretty colours
color cyan/blue white/blue

## ## End Default Options ##

title		LINBO
root		(hd0,5)
kernel		/linbo vga=788 quiet
initrd		/linbofs.lz

title		Windows
root		(hd0,0)
makeactive
chainloader	+1
boot

title		ubuntu 14.04
root		(hd0,1)
kernel		/vmlinuz vga=788 splash root=/dev/sda2 quiet
initrd		/initrd.img

Und gib ihr diese Rechte:

-rw-r--r-- 1 root root 439 Jun  5  2015 menu.lst.dc7900

Nach dem Sync eines Betriebsystems am Cleint wird die menu.lst
übertragen und installiert: dann sollte die Auswahl Offline erscheinen.

LG

Holger

Das war natürlich der Fall … der Laptop startet ja völlig normal, wenn er an der Dockingstation hängt.

Meinst du damit die Option
Bootable = no im Abschnitt [Partition] des Caches? Hat sich da seit 2.2 etwas geändert? An dem Schalter habe ich seit Jahren nichts gedreht

Ist das auch schon 2.2-tauglich? Sieht mir nach grub2 aus, was doch erst mit Version 6.2 läuft, oder?
(Produktiv setzen wir weiterhin 6.1 ein).

Hallo Michael,

Außerdem sollte nur der Cache auf bootable gesetzt sein (in der
start.conf).

Meinst du damit die Option
Bootable = no im Abschnitt [Partition] des Caches? Hat sich da seit
2.2 etwas geändert? An dem Schalter habe ich seit Jahren nichts gedreht

ja: bootable = yes
muss beim cache stehen.
Und nein; da hat sich mit 2.2 nichts geändert: das ist auch bei 2.3 noch
so (es sei den man nimmt EFI, dann muss die EFI Partition bootable sein,
nicht der cache).
“Seit Jahren nichts gedreht” ist irrelevant, da vieel Geräte auch
booten, wenn die falsche Partition bootable ist: aber nicht alle.
Also: änder das mal in der start.conf, dann partitioniere den Cleint udn
synce ihn und dann nimm ihn vom Netz.

baumhof:

Du kannst aber auch folgendes machen:
Leg mal diese Datei an
/var/linbo/menu.lst.

Ist das auch schon 2.2-tauglich? Sieht mir nach grub2 aus, was doch erst
mit Version 6.2 läuft, oder?
(Produktiv setzen wir weiterhin 6.1 ein).

andersrum wird ein Schuh draus: das ist die Lösung bis einschließlich
2.2, welche ab 2.3 nicht mehr funktioniert.
Ich hab da schon dran gedacht bei dir: außerdem hattest du deine linbo
version ja dazu geschrieben (das ist immer sehr Praktisch :slight_smile: ).

Viele Grüße

Holger

Alles klar – hat genauso wie von dir beschrieben geklappt. Alles bestens.
Danke!