Klasse erscheint nicht in der Klassenauswahl

Hallo zusammen,

ich kann die Klasse (08d) in der Schulkonsole nicht auswählen, weil sie dort nicht erscheint. Die Schüler der Klasse sind aber in der schueler.txt mit Klassenangabe angelegt. Alle anderen Klassen erscheinen korrekt. Sophomorix-check findet keine Unstimmigkeit. Gibt es einen sophomorix-Befehl, mit dem ich das fixen kann?

Viele Grüße,
Andreas

Hallo Andreas,

ich kann die Klasse (08d) in der Schulkonsole nicht auswählen, weil sie
dort nicht erscheint. Die Schüler der Klasse sind aber in der
schueler.txt mit Klassenangabe angelegt. Alle anderen Klassen erscheinen
korrekt. Sophomorix-check findet keine Unstimmigkeit. Gibt es einen
sophomorix-Befehl, mit dem ich das fixen kann?

geh mal als administrator in die Schulkonsole und dann auf den Reiter
“einstellungen” UNterpunkt “Klassen”
Steht die Klasse dort?
Ist sie auf “sichtbar” gesetzt?

Haben alle eure “einstelligen” Klassen eine 0 am Anfang?
Gibt es also auch 07a und 08b usw. ?

LG

Holger

Hallo Holger,
deine Vorschläge hatte ich schon vorher probiert und habe es erneut überprüft. Die Klasse 08d ist in der Schulkonsole > Einstellungen > Klassen als sichtbar eingestellt. Ich habe sogar das Häkchen mal entfernt, gespeichert, dann das Häkchen wieder gesetzt und gespeichert.
Alle einstelligen Klassen haben die Null am Anfang. Außer der 08d werden alle angezeigt…
VG, Andreas

Hallo Andreas!

Lass dir mal an der Server-Konsole die Ausgabe von folgendem Befehl anzeigen.

sophomorix-class -i

Wenn dort unter dem H eine 1 steht bei der Klasse, dann probiere

sophomorix-class --nohide --class 08d

Beste Grüße

Thorsten

Hallo Thorsten,

hier die Ausgabe der Server-Konsole - demnach sollte die Klasse sichtbar
sein…:

AdminClass |H| Quota | MQ |A|L| SchoolType | Department

Hallo Thorsten,

jetzt nochmal…:

hier die Ausgabe der Server-Konsole - demnach sollte die Klasse sichtbar
sein…:

AdminClass     |H|    Quota |  MQ |A|L| SchoolType         | Department
------------------+-+------------+------+-+-+----------------------+--------------------
05a               |0|            |      |0|0|                      |
05b               |0|            |      |0|0|                      |
05c               |0|            |      |0|0|                      |
05d               |0|            |      |0|0|                      |
05e               |0|            |      |0|0|                      |
06a               |0|            |      |0|0|                      |
06b               |0|            |      |0|0|                      |
06c               |0|            |      |0|0|                      |
06d               |0|            |      |0|0|                      |
06e               |0|            |      |0|0|                      |
07a               |0|            |      |0|0|                      |
07b               |0|            |      |0|0|                      |
07c               |0|            |      |0|0|                      |
07d               |0|            |      |0|0|                      |
08a               |0|            |      |0|0|                      |
08b               |0|            |      |0|0|                      |
08c               |0|            |      |0|0|                      |
08d               |0|            |      |0|0|                      |
09a               |0|            |      |0|0|                      |
09b               |0|            |      |0|0|                      |
09c               |0|            |      |0|0|                      |
09d               |0|            |      |0|0|                      |
10a               |0|            |      |0|0|                      |
10b               |0|            |      |0|0|                      |
10c               |0|            |      |0|0|                      |
11k               |0|            |      |0|0|                      |
12k               |0|            |      |0|0|                      |
la                |0|            |      |0|0|                      |
teachers          | |            |      |1|0|                      |
vhs-kurs          |0|            |      |0|0|                      |

Viele Grüße,
Andreas

Hallo Andreas!

Eigentlich schon! :dizzy_face:

Hast Du den anderen Befehl trotzdem mal ausprobiert? Kann eigentlich nicht schaden.

Kleiner Tipp am Rande, wenn die die Code-Tags verwendest, dann wird dein Konsolenausdruck nicht verunstaltet. Habe ich ob mal für dich gemacht. Anzuschauen mittels Bearbeiten unter den drei Punkten …

Beste Grüße

Thorsten

Hallo Thorsten,

ich hab den Befehl ausgeführt, leider hat es nichts geholfen:

 # sophomorix-class --nohide --class 08d
#### /usr/sbin/sophomorix-class started ...                               ####
Unhiding class 08d
#### NOT setting quota (nothing quota related changed)                    ####
#### NOT creating mailaliases/lists (nothing mail related changed)        ####
#### /usr/sbin/sophomorix-class terminated regularly                      ####

Die Klasse erscheint einfach nicht in der Schulkonsole. :confused:
grafik

grafik

Viele Grüße,
Andreas

Hallo Andreas!

Ich hatte Kontakt mit jeffbeck aufgenommen. Auf Seiten des Servers haben wir alles geprüft was geht. Der Fehler muss in der Schulkonsole stecken und da gibt es ein großes Problem. Der Quellcode wird nur von wenigen geblickt und die sind nicht mehr unter uns. Darum wird es auch in der lmn7 eine neues WEBUI geben.

Wir können nun nur etwas brachial vorgehen.

a.) Was passiert wenn du einen Fantasie-User in eine neue Klasse z.b. 08z in die schueler.txt einfügst? Taucht dann die Klasse in der Schulkonsole auf?

b.) Wenn ja, verschiebe alle deine User aus der 08d in die 008d. Taucht die dann auf?

Könntest Du damit bis zum Ende des Schuljahres leben, ist ja bald? Bei uns nächste Woche! :slight_smile:

c.) Dann die Bereinigung zum Schuljahreswechsel machen, eventuell klappt es dann wieder.

Das ist momentan, alles was mir noch einfällt.

Beste Grüße

Thorsten

Hallo Andreas,

könntest Du nochmal genau mailen, wo Du versuchst, die Klasse
auszuwählen? Ist als als Lehrer im Menü “Klassen”?

Und nur zur Sicherheit: Man kann sich nur in Klassen eintragen, in denen
man nicht schon ist - die kann man dann oben auswählen.

Hilfreich wäre auch die Ausgabe von "groups " auf der
Serverkonsole.

Beste Grüße

Jörg

Hallo Andreas,

hast du schon folgendes probiert:

  1. alle Schüler der 8d aus der schueler.txt entfernen
  2. auf der Serverkonsole: sophomorix-check, sophomorix-move (–>
    Schüler werden in attic verschoben
    3.Schüler wieder in die schueler.txt eintragen
  3. auf der Serverkonsole: sophomorix-check, sophomorix-move

…das hat bei mir in einem ähnlichen Fall geholfen.

Ansonsten die Radikallösung: mit sophomorix-kill alle user der 8d final
löschen (Achtung ggf. vorher Daten der Schüler weg kopieren) und dann
komplett neu anlegen…

Gruß

Dominik

Hallo Thorsten, Jörg und Dominik,

danke für Eure Antworten.

@ Thorsten: Ich habe einen Schüler mit der neuen Klasse 08Z angelegt. Die Klasse 08Z taucht nicht in der Schulkonsole auf. (Ich habe mich nach dem Anlegen als Lehrer neu angemeldet.). Schöne Ferien! :sunglasses:

@Jörg: Die zwei Screenshots in meinem letzten Beitrag zeigen die Schulkonsolenansichten als Lehrer (Als Administrator gibt es m.W. die Klassenauswahl so gar nicht). Das eine Foto zeigt die Auswahl der schon von mir als Lehrer angelegten Klassen, das zweite die Auswahl der Klassen, die ich noch auswählen könnte. Somit wollte ich zeigen, dass ich die Klasse nicht irgenwie vergessen habe.

Welchen Befehl meinst du genau mit “groups”? Einfach das Wort eingegeben zeigt mir halt sudo, lpadmin, sambashare usw. an. Das wirst du wohl eher nicht meinen?

@Dominik: Deinen Vorschlag habe ich aus Zeitgründen noch nicht probiert. Kommt noch.
Bei der von dir vorgeschlagenen Radikallösung hätte ich die Sorge, dass die User-IDs der weg- und wieder zurückkopierten Dateien nicht mehr zu den User-IDs der neu angelegten User passen.
Ich würde dann eher den Schülern sagen, dass sie Ihre Daten auf USB-Stick sichern.

Viele Grüße,
Andreas

Hallo,

eine Idee hab ich noch.
Hast du eine Hardwareklasse / Gruppenkonfiguration / User, der/die 08d heißt?
Das kann auch dumme Nebenwirkungen haben.

LG Jesko

Hallo Andreas!

Doch und das wird es wohl gewesen sein!

Bestimmt ist da der Haken nicht gesetzt.

Beste Grüße

Thorsten

Hallo Thorsten,

deine Vermutung mit dem nicht gesetzten Häkchen hatte Holger auch schon geäußert (s.o.). Das ist es aber nicht. Hier noch einmal die Screenshots. Zunächst die Administratoransicht:

Auffällig daran ist, dass beim Administrator die (fiktive) Klasse 08Z, die ich testhalber heute Mittag erstellt habe, erscheint. Nicht jedoch in der Lehrer-Schulkonsole: (Der Screenshot ist von meiner Linux-VM zuhause, da habe ich die Spracheinstellungen noch nicht gefixt, sollte aber keine Rolle spielen…)

Viele Grüße,
Andreas

Hallo Andreas,

im Bild “Schulkonsole_Lehrer” (also nicht auf dem Bild, sondern dort in
der Schulkonsole, was das Bild zeigt) ist unterhalb des gezeigten
Bereiches die Möglichkeit, sich in die Klassen einzutragen. Steht dort
die Klasse auch nicht?

Mit dem Befehl meine ich sowas wie:

groups fischer

(wenn fischer Dein Benutzername ist). Eventuell muss man ein sudo
davorschreiben.

Beste Grüße

Jörg

Das Problem scheint zu sein, dass die schulkonsole irgendwie die Klasse nicht richtig anzuzeigen scheint.
Sie holt die Daten aus postgres.

Könntest du mal in der postgres-Datenbank anzeigen lassen, wie die Klasse aussieht?

# psql -U ldap ldap
> SELECT * from classdata WHERE gid='08d';
> SELECT * from classdata WHERE gid='08c';

Die 08d wird nicht angezeigt, die 08c wird angezeigt, richtig?

Gibt es im output Unterschiede in diesen Klassen?

Hallo Jörg,

sorry, jetzt hat es etwas gedauert mit der Antwort. Du schriebst:

im Bild “Schulkonsole_Lehrer” (also nicht auf dem Bild, sondern dort in
der Schulkonsole, was das Bild zeigt) ist unterhalb des gezeigten
Bereiches die Möglichkeit, sich in die Klassen einzutragen. Steht dort
die Klasse auch nicht?

Nun, es ist mir ja ganz peinlich, aber du hast mir die Antwort auf mein Problem geliefert. Ich war einfach zu doof, um auf der Seite hinunterzuscrollen und habe die Auswahl immer übersehen :flushed: - betriebsblind.
Nun ist sie da, die 08d…
Entschuldigt bitte, dass ich so viel Wind erzeugt habe.

Viele Grüße,
Andreas

Hallo Andreas,

Nun, es ist mir ja ganz peinlich, aber du hast mir die Antwort auf mein
Problem geliefert. Ich war einfach zu doof, um auf der Seite
hinunterzuscrollen und habe die Auswahl immer übersehen :flushed: -
betriebsblind.
Nun ist sie da, die 08d…
Entschuldigt bitte, dass ich so viel Wind erzeugt habe.

… passiert jedem mal.

Hast du den Thread als gelöst markiert?

LG

Holger