Fragen zur Installation: VLANS/ Grün, Rot, Blau


#1

Hallo,

ich bin gerade bei der Erstinstallation. Unser Netz sind wie folgt aus:

  • 4 VLANS für WLan (Schüler, Lehrer, Geräte, Gäste): 172.11.. / 172.12.. / 172.13.. und 172.14..

  • Für das Lan 1 Vlan (10.16..) und ein Managmentnetz (10.10..). Nach außen ein WatchGuard, die uns der träger vorschreibt.

Es wird entsprechend geroutet.

Ich wollte nun einen VM Host aufsetzen. der den lm-Server sowie IP-Fire beinhaltet. IP-Fire dann nur für die Seiten-Sperrungen.

Wo gehört nun Grün, Rot und Blau hin:

  • Grün: in 10.16.. Netz ?
  • Rot: an die WatchGuard?
  • und Blau nirgends wo hin?

Wenn ich auf dem Server linuxmuster-hv-setup --first aufrufe wil er aber unbedingt eine Netzwerkkarte im blauen Netz haben.

Besten Dank, Martin


#2

Hallo Martin,

Wo gehört nun Grün, Rot und Blau hin:

  • Grün: in 10.16././ Netz ?

ja.

  • Rot: an die WatchGuard?

… an das LAN, das nach außen ins Internet geht.

  • und Blau nirgends wo hin?

in der lmn ist ein Netz für “Blau” also das WLAN vorgesehen.
Dieses muss an die Blaue Netzwerkkarte des IPFire.
“Mehr” Netzte benötigst du nicht.
Willst du unterschiedliche WLAN Netze aufspannen, so läßt du das z.B.
unifi machen. Dafür reichen aber Rot Grün und Blau als Netze in die
geroutet wird (aus dem WLAN).

Wenn ich auf dem Server /linuxmuster-hv-setup --first/ aufrufe wil er> aber unbedingt eine Netzwerkkarte im blauen Netz haben.

der Befehl heißt:
linuxmuster-setup --first
nicht linuxmuster-hv-setup --first

Die dritte Netzwerkkarte erwartet er am IPFire, nicht am Server.
Der Server hat nur eine Netzwerkkarte: eine Grüne.

Die Prozedur ist aber in der Doku sehr ausführlich beschrieben:

http://docs.linuxmuster.net/de/latest/getting-started/install-on-xen/configuration.html

LG

Holger


#3

Hallo Martin,

4 VLANS für WLan (Schüler, Lehrer, Geräte, Gäste): 172.11././ /
172.12././ / 172.13././ und 172.14././
Für das Lan 1 Vlan (10.16././) und ein Managmentnetz (10.10././).
Nach außen ein WatchGuard, die uns der träger vorschreibt.

das Vlan 1 (10.16.x.y) ist ein weiteres Vlan, nehme ich jetzt mal an…?

Ich wollte nun einen VM Host aufsetzen. der den lm-Server sowie IP-Fire
beinhaltet. IP-Fire dann nur für die Seiten-Sperrungen.

Was heißt nur für die Seitensperrungen?
Der IPFire ist für etliche Funktionen der LMN zuständig.

Wo gehört nun Grün, Rot und Blau hin:

  • Grün: in 10.16././ Netz ?

Ja.

  • Rot: an die WatchGuard?

Wenn das euer Internetanschluss/Router ist, ja.

  • und Blau nirgends wo hin?

Blau braucht man nur, wenn man dem WLAN Internet über den IPFire geben will.

Wenn eure WLANs und deren Internezgriff schon anders realisiert sind,
brauchst du blau eigentlich nicht.

Wenn ich auf dem Server /linuxmuster-hv-setup --first/ aufrufe wil er
aber unbedingt eine Netzwerkkarte im blauen Netz haben.

Versuchst du eine v6.2 oder v7 (alpha) zu installieren? Da das mit v7
noch nicht öffentlich ist, wohl eine 6.2 ?!?

Imho heißt der Befehl bei 6.2 linuxmuster-setup --first und erfordert,
dass der IPFire schon installiert ist und läuft. Die (virtuellen)
Netzwerkarten für rot und ggf. blau und orange werden ja auch nur am
IPFire konfiguriert. Der LMN-Server hat nur eine virtuelle NIC, und die
ist in grün.

Dein VM Host für LMN braucht also mindestens 2 virtuelle Switches:

Einen für grün. Mit dem werden dann die virtuelle NIC des LMN-Servers
und die NIC für grün des IPFire verbunden. Und natürlich die reale NIC
des Servers für das interne Netz (grün) zugeordnet.

Der zweite virtuelle Switch ist für rot und da wird nur die rote
virtuelle NIC des IPFire verbunden sowie die reale NIC ins Internet
zugeordnet.

Alles andere wie blau und orange ist optional.

Viele Grüße
Steffen


#4

Hallo Holger,

hei, wieso bist du eigentlich immer schneller… habe gerade auch eine
Antwort abgeschickt…

Viele Grüße
Steffen


#5

Hallo,

danke für die Antworten.

mein Post oben betrifft die “Installation mit XEN”

Also unser Netz steht schon und es geht jetzt nur um die Verkablung des Server der nach XEN und die zugehörigen VMs ausführt. Unser Netz sieht ziemlich genau so aus: http://docs.linuxmuster.net/de/latest/_images/vlan-infrastructure-virtual.png außer das der VM-Host kein eigenes VLAN hat und wir noch 3 weitere VLANs für das WLAN-Netz haben

ich habe den xen-Server installiert, wie in der Dokumentation beschrieben und bin an diesem Schritt: http://docs.linuxmuster.net/de/latest/_images/image28.png Der Befehl heißt dort linuxmuster-hv-setup --first
Der Befehl linuxmuster-setup --first scheint für die manuelle Installation zu sein.

Dann müsste bei uns blau an den WLAN-Controller von Netgear