Frage zu sophomorix-quota

Hallo,

eine Kollege xy konnte nicht mehr speichern, ich habe dann in der Schulkonsole sein Quota erhöht. Hat leider nichts gebracht.

In der Datei
/etc/sophomorix/user/lehrer.txt
steht

lehrer ;Nachname        ;Vorname       ;01.01.1970 ;xy      ;---     ;usertoken ;7000+200 ;mailquota` ;

d.h. die Angabe aus der schulkonsole wurde übernommen.
Der Befehl sophomorix-quota -i -u xy gibt folgendes aus:

    Reporting quota for some users:
                          Block   limits             File 
User       BF     used     soft     hard   grace    grace 
------------------------------------------------------------
xy         +-  3277.5M   156.2M   195.3M    none        0
           --        8  5468.7M  6835.9M       0        0

Was bedeuteten jetzt die beiden Zeilen? Ich würde die erste Zeile so interpretieren, dass der Kollege etwa 3,3GB gespeichert hat, aber nur 200MB darf.

Also scheint die Reihenfolge der beiden Quota in der Konfigurationsdatei falsch zu sein, allerdings habe ich als Nutzer das Problem nicht:

In der Datei
/etc/sophomorix/user/lehrer.txt
steht

lehrer ;Nachname        ;Vorname       ;01.01.1970 ;ich      ;---     ;usertoken ;50000+100 ;mailquota` ;

Der Befehl sophomorix-quota -i -u ich gibt folgendes aus:

Reporting quota for some users:
                          Block   limits             File 
User       BF     used     soft     hard   grace    grace 
------------------------------------------------------------
ich         -- 26796.2M 39062.5M 48828.1M       0        0
           --        0    78.1M    97.6M       0        0

Allerdings: Mein Quota habe ich vor langer Zeit eingestellt, das des Kollegen erst kürzlich.

Wer kann Licht ins Dunkle bringen?

Grüße,
Sven

Hallo Sven,

bitte setz erst mal das Quota des kollegen nach Anpassen in der
lehrer.txt mittels
sophomorix-quota --set -u

und schau dir dann das Quota noch mal an.

Viele Grüße

Holger

Hallo Holger,

nach Ausführen von

sophomorix-quota --set -u xy

erhalte ich jetzt

Reporting quota for some users:
                          Block   limits             File 
User       BF     used     soft     hard   grace    grace 
------------------------------------------------------------
xy         --  3277.5M  5468.7M  6835.9M       0        0
           --        8   156.2M   195.3M       0        0

ohne dass ich die lehrer.txt geändert hätte. Jetzt sieht es gut aus. Die Frage ist nur, was macht die Schulkonsol anders / falsch?
Das über die Schulkonsole Quota wurde korrekt in die lehrer.txt eingetragen und auch übernommen, nur eben in der falschen Reihenfolge. Die 6835.9M standen ja schon da, nur in der faslchen Zeile.

Verstehst du das?

Grüße und Dank fürdie Hilfe,
Sven

Hallo Sven,

Verstehst du das?

leider ist das eine Art “Known BUG”.
Das Problem ist, dass seit bei neueren ubuntu Versionen das booten
parallelisiert wurde (und dadurch deutlich beschleunigt) es so ist, dass
die Dateisysteme nicht mehr immer in der gleichen Reihenfolge gemountet
werden: und das scheint wiederrum für Quota wichtig zu sein.
Als du den Lehrer angelegt hattest, war die /var Partition vor der /home
gemountet worden: also wurden die Quotas verkehrt herum gesetzt.
Gerade sind sie richtig rum.
Ein blöder Fehler für den wir noch keien Lösung haben.

Ich würde dir emfehlen jetzt, wo sie gerade richtig rum sind, mal
sophmorix-quota -s -a
laufen zu lassen und so das Quota für alle nochmal setzten zu lassen
(dauert halt …)

LG

Holger

Hallo Holger,

ich erinnere mich dunkel. Ich habe jetzt alle Quotas neu gesetzt, für die Nachwelt, der Befehl dafür ist:

sophmorix-quota -s

die Option -a gibt es nicht.

Grüße,
Sven

Hallo Sven,
es gibt eine Lösung für dein Problem:
alle deine quotaangaben sind in folgendem Format weil du 2 quotierte Partitionen hast:

7000+200

Und in sophomorix.conf steht:

@quota_filesystems =("auto");

Das heisst sophomorix richtet sich nach der mount Reihenfolge, so wie von Holger beschrieben.
Was halt auf manchen systen schief läuft.

Also manuell einstellen:

sophomorix-quota -i

aufrufen. Dann siehst du die Filesysteme, die quotiert sind (Bei dir 2 Stück: /dev/sda7, /dev/sda4 zum Beispiel)

Dann änderst du obige Zeile z.B. zu:

@quota_filesystems =("/dev/sda4","/dev/sda7");

Oder andersrum, wenns für dich andersrum passt.

Testen mit einem user:

sophomorix-quota --set -u xy

wenns passt ausrollen (dauert)

sophomorix-quota --set

Hallo Rüdiger,

sophomorix-quota -i

aufrufen. Dann siehst du die Filesysteme, die quotiert sind (Bei dir 2
Stück: /dev/sda7, /dev/sda4 zum Beispiel)

Dann änderst du obige Zeile z.B. zu:

@quota_filesystems =("/dev/sda4","/dev/sda7");|

Cool!
Das wußte ich noch gar nicht :slight_smile:

Viele Grüße

Holger