FQDN als hostname in der DNS Auflösung?

Hi zusammen,

irgendwas hab ich verbockt: Bei mir meldet sich jeder Client und Server selbst unter dem kompletten hostnamen. Wenn ich z.B. in der Konsole hostname eingebe, dann erscheint, seltsamerweise auf jedem Rechner der FQDN.

# hostname
host.meine-schule.de

statt wie früher: host
Das steht auch genau so in /etc/hostname drin.

Ich denke, die Rechner kriegen alle (auch meine Server außer dem server) ihren hostnamen per DHCP oder LINBO setzt ihn eben beim start. Ich habe daher mal in /etc/dhcp/dhpcd.conf.linuxmuster geschaut: da stehen nur hostnamen ohne domäne drin.

Kann mir jemand helfen, wie ich wieder nur den hostname in $(hostname) oder $HOSTNAME bekomme?

Vielen Dank!
Tobias

Hi Tobias.
Hast du den “linuxmuster-setup --modify” Befehl laufen lassen?
Schönen Gruß,
Michael

Hallo Michael,

ja, vor ca. einem Jahr. Das kann schon damit zusammenhängen, dass mein server eine uptime von 230 Tagen hat und ich irgendeinen Dienst seither nicht neu gestartet habe, der gestern mit dem linbo-update gestartet wurde.
Ich habe bloß keinen Schimmer, wie es sein sollte.
Ich werde wohl eine 6.2 neu aufsetzen.
VG, Tobias

Hi Tobias

Ich habs grade ins Linbo-Update-Thema geschrieben: ist bei mir auch so (ich glaube, seit dem Linbo-Update). Aber nur bei Ubuntu, nicht im Linbo, da heißen die PCs noch korrekt, zumindest in der Linbo-GUI.

LG
Max

Ok, eine Änderung in LINBO ist also “schuld”. Danke für die Klärung. Ich lasse den Thread mal ungelöst bis klar ist, ob das in /etc/hostname so bleibt.
VG, Tobias

Hallo,

bei mir heißen nach dem Linbo-Update alle PCs .paedml-linux.lokal
Aber nicht im Linbo sondern erst im Ubuntu.
Ist mir vorher noch nicht aufgefallen gewesen. Woran kann das liegen?

LG
Max

Hallo Max,

das ist bei mir auch so, die PCs haben jetzt die vollständige Domäne anhängen.
Ich habe seitdem auch Probleme beim Starten der Linuxclients!

LG Alex

Hallo Max,

Linbo trägt jetzt den Fully Qualified Domain Name in /etc/hostname ein.
Das sollte kein Problem sein.
Ist eigentlich Standard.

VG, Thomas

Hallo Thomas,

kann man jetzt das aktuelle Linbo installieren?

Viele Grüße Alois

Hallo Thomas,

Das stimmt, aber ich denke, dass viele hier Sachen geskriptet haben und auch $HOSTNAME $(hostname) verwenden. Eine Info in den Release-Notes wäre dazu hilfreich gewesen.

vG Stephan

Hallo,

mir ist jetzt teilweise klar, warum das neue Linbo bei vielen Probleme macht. Mir ist aufgefallen, dass alles was ich hostspezifisch per linbo-postsync geregelt habe nicht mehr funktioniert…klar weil im universellen-postsync-script an vielen Stellen $HOSTNAME verwendet wird und daher nichts mehr klappt, weil die Hosts bis jetzt nicht nach FQDN benannt waren…das ist jetzt schon extrem ärgerlich, weil das an so vielen Stellen knallt.

Ich habe jetzt ganz am Anfang des Scripts eine Zeile, die den FQDN aus dem Hostnamen wieder entfernt…das ist natürlich nicht der Weisheit letzter Schluss funktioniert aber.

Die Startprobleme, die manche hier schildern habe ich auch an einigen wenigen Terra-Rechnern mit einem mittelalten Realtek-Netzwerkchip. Ich habe hier nach einigen Tests die Vermutung, dass der neue linbo-kernel den Netzwerkchip auf eine Art und Weise initialisiert, mit dem dann der Ubuntu - Kernel nicht klar kommt…vielleicht kann das wer genauer verifizieren?

Alles in allem ist das größte Problem der neue Eintrag in /etc/hostname, der sich mit dem Postsyncscript beißt.

Gruß

Dominik

1 Like

Hi!

Sorry, dass manche Skripte jetzt auf die Nase fallen. In den Release Notes stand

Immerhin ein Hinweis, dass in dem Bereich irgendwas passiert ist.

HInsichtlich von Postsync-Skripten kann ich das allerdings nicht nachvollziehen. Hier enthält die Umgebungsvariable HOSTNAME immer noch den Kurznamen, FQDN den Langnamen. Postsync-Skripte sollten also so weiterlaufen wie bisher.

VG, Thomas

Hi zusammen,

ich habe grade man -k hostname auf meinem 18.04 System gelesen (als einzige Quelle) und bin zwar der Meinung es wäre besser, in /etc/hostname würde nur der Name stehen und in /etc/domainname oder in /etc/hosts der FQDN, aber wenn du, Thomas, es so beibehalten willst, dann würde ich vorschlagen:

$(hostname) durch $(hostname -s) in den Skripten zu ersetzen

Und übrigens: $HOSTNAME ist bei mir der FQDN im Client (16.04) und $FQDN ist bei mir nicht gesetzt/leer. Wo das genau jetzt anders als bei Thomas gesetzt wird muss ich noch rausfinden.
EDIT: recherchiert /etc/init.d/hostname.sh sagt:

...
[ -f /etc/hostname ] && HOSTNAME="$(cat /etc/hostname)"
...
hostname "$HOSTNAME"

Ich vermute stark, dass neuere Systeme als mein 16.04 das via systemd machen (und da hab ich keine Lust zu recherchieren aus bekannten Abneigungen gegenüber systemd) und bermute daher kommt der Unterschied zu dir, Thomas.

VG, Tobias

P.S. Obwohl ich downgegraded habe auf 2.3.38 blieb bei mir das FQDN-Problem bestehen, downgraden muss auch nicht supportet werden :). Es hat mir bloß mal wieder einen Tag ohne Vertretungsplan in der Schule gekostet. @thoschi, es wird Zeit, dass ich dein “vplan” image/skript mal ersetze … since the running system changed anyway… VG, Tobias

Was die hostname-Änderung übrigens auch zur Folge hatte:

Mein privater Mailserver weigert sich seitdem die Mails vom Thunderbird vom Client anzunehmen. Ich vermute, weil er ein FQDN bekommt, den er gar nicht auflösen kann, weil er ja außerhalb der Schule steht.
Ich weiß, vermutlich ist mein Mailserver falsch konfiguriert, trotzdem sieht man auch hier was für massive Auswirkungen das hat.
(Diese Auswirkungen hat ja überhaupt nichts mit LINBO oder dem jeweiligen Ubuntu zu tun).

VG, Tobias

Das lese ich so auch in man hostname unter 16.04:

   THE FQDN

[...]

       The  recommended  method of setting the FQDN is to make the hostname be
       an alias for the fully qualified name using /etc/hosts,  DNS,  or  NIS.
       For  example,  if  the  hostname was "ursula", one might have a line in
       /etc/hosts which reads

              127.0.1.1    ursula.example.com ursula

Und etwas weiter:

FILES
       /etc/hostname  Historically  this file was supposed to only contain the
       hostname and not the full canonical FQDN.  Nowadays  most  software  is
       able  to  cope with a full FQDN here. This file is read at boot time by
       the system initialization scripts to set the hostname.

       /etc/hosts Usually, this is where one sets the domain name by  aliasing
       the host name to the FQDN.

Viele Grüße

Andreas

Hallo Tobias,

Ich mache das mittlerweile mit der Nextcloud. Wenn Du meinen 16.04 32bit-Client (wegen IBM T41) mit automatischem Firefox-Start einer Nextcloud-Synchronisierten Seite haben magst, schreib doch kurz.
Da muss nur der Vertretungsplaner das Info-Stundenplanmodul anklicken und den Rest erledigt die Cloud.

LG
Max