Einträge im Bootmenu UEFI

Liebe Kollegen,
einmal eine ganz allgemeine Frage zu Linbo.

Es wird in verschiedenen Beiträgen hier im Formu geschrieben, dass bei euch
In der Bootsequenz z.B. der windows-bootmanager auswählbar sei, angeblich auch ein
Punkt Linbo …
Bei mir gibt es nur den Eintrag PXE v4 und PXE v6 - ich seh also nichtmal die Platte …
Der Start durch Linbo klappt aber. Ist das normal? Kann man das ändern?
Eigentlich hätte ich nichts dagegen, für den „Normalbetrieb“ direkt zu booten und nur für
Renovierungsarbeiten auf Linbo zurückzugeifen. Das würde auch das Problem lösen, wenn
jemand den Rechner hart ausschaltet und Linbo dann nicht mehr starten kann.

Ich wäre um ein paar Hinweise dankbar :slight_smile:

VG
Wolfgang

Hallo Wolfgang,

Es wird in verschiedenen Beiträgen hier im Formu geschrieben, dass bei euch
In der Bootsequenz z.B. der windows-bootmanager auswählbar sei,
angeblich auch ein
Punkt Linbo …
Bei mir gibt es nur den Eintrag PXE v4 und PXE v6 - ich seh also
nichtmal die Platte …
Der Start durch Linbo klappt aber. Ist das normal? Kann man das ändern?
Eigentlich hätte ich nichts dagegen, für den „Normalbetrieb“ direkt zu
booten und nur für
Renovierungsarbeiten auf Linbo zurückzugeifen. Das würde auch das
Problem lösen, wenn
jemand den Rechner hart ausschaltet und Linbo dann nicht mehr starten kann.

windows sollte nie ungesynct gestartet werden.
Wenn es dir an der Stelle vielleicht Sinnvoll erscheint: an anderer
Stelle reitet es dich rein (viren/manipulationen/vollgelaufene
Partitionen: generell unzuverlässigkeit, die echt MIst ist in
Computerräumen).
Also: lieber etwas unbequem und dafür solide.

Das bootverhalten von linbo wird durch den Paramerter
KernelOptions =
gesteuert
Dort kannst du den Eintrag machen:
autostatrt=X

X steht für
0 -> linbo starten
1 -> erstes ungesynct starten
2 -> erstes gesynct starten
3 -> erstes neu+gesynct starten
4 -> zweites ungesynct starten

den Rest kannst du dir denken
:slight_smile:

Diese Einstellung wird durch den Aufruf von linuxmuster-import-devices
in die /srv/linbo/boot/grub/.cfg
geschrieben, solange dort die Zeile

# ### managed by linuxmuster.net

nicht beschädigt ist.

Schau mal in die Datei: direkt unter der genannten Zeile stehen die
Einträge.
Ich manipuliere sie immer von Hand (ich mag Handarbeit)

Die Einträge in der Datei wirken sofort.
Der importaufruf ist zum Transferieren in die Datei.

LG

Holger

Hallo Holger,

im Prinzip bin ich ganz auf deiner Seite … aber - wie du bereits gemerkt hast - hab ich anscheinend
lauter sehr eigenwillige Geräte :slight_smile: Meine Chefetage und die Oberstufenkoordinatoren verwenden alle eine
Doppel-Monitor Lösung … leider bleibt der Bildschirm schwarz, wenn beim Start von Windows BEIDE Bildschirme eingeschaltet sind - warum auch immer. Dann bleibt nur hartes Abschalten. Eine Syncen (im Sinne von New) dauert bei mir aktuell knappe 7 Minuten. Hier wäre es sehr angenehm, wenn man diese Zwangspause NICHT hätte. Meine Planung sieht vor, einen abendlichen reboot mit Putzen auszuführen, damit das System am nächsten Morgen dann wieder sauber ist.
Ja, es ist ein Spagat zwischen Sicherheit und Comfort - aber 7 Minuten ist schon lang, für einen Monitor zuviel …

Die sache mit dem Dirty-bit und Linbo wurde ja bereits an anderer Stelle diskutiert - mir würd es durchaus sinnvoll erscheinen, wenn man das per Flag oder so ein und ausschalten könnte, dass auch ein abgestürztes Windows nochmal durchstarten kann …

VG
Wolfgang

Hallo Wolfgang,

linbo ist flexibel.
Für dein Problem empfehle ich folgendes:
Grafischen grub einrichten mit autosync aber einem timeout von 5 Sekunden.
Ist das Kind in den Brunnen gefallen, kann der Kollege beim reboot
„ungesynct“ auswählen.

Wie das mit dem timeout über die start.conf geht, weiß ich nicht,
deswegen händisch in der /srv/linbo/boot/grub/.cfg
die Zeile managed by linuxmuster.net
ändern zu
NOT managed by linuxmuster.net
(mit allen # davor)
und dann folgendes eintragen:

set default=2
set timeout=5
set fallback=1

„Nach meiner Kenntnis ist das sofort, unverzüglich“ (Schabowski) :slight_smile:
du mußt also keinen import machen.

LG

Holger

Ok, danke.
Ich werd später in die Schule fahren - Wochenenden werden eh überbewertet - und das testen :slight_smile:

VG
Wolfgang

… ok, an die Wand gelaufen, da ich noch einen Eintrag für die grub.cfg bräuchte, die das Windows startet.
Laut diverser Quelle müsste ich dafür die bootmgfw.efi verwenden - die existiert bei mir aber nicht auf dem Client.
Ist das normal?
Wenn ja - über welchen Mechanismus bootet linbo das Windows dann?

VG
Wolfgang

Hallo Wolfgang,

… ok, an die Wand gelaufen, da ich noch einen Eintrag für die grub.cfg
bräuchte, die das Windows startet.

verstehe ich nicht.
Der Eintrag wird doch von linuxmuster-import-workstations erstellt?

stell mal die managed by linuxmuster.net Zeile wieder her und lass einen
import laufen:
danach hast du eine gruppe.cfg, in der 4 Einträge stehen:
0 -> linbo
1 -> windows ungesynct
2 -> windows gesynct
3 -> windows neu + start.

Laut diverser Quelle müsste ich dafür die bootmgfw.efi verwenden - die
existiert bei mir aber nicht auf dem Client.

… ah: du hast uefi Clients?

… da hab ich das auch schon gemacht … ist aber schon wieder aus meinem
Gehirn gerutscht…

Wenn ja - über welchen Mechanismus bootet linbo das Windows dann?

… da müßte ich mich nochmal reinlesen … und das kann ich gerade nicht.
Such mal in ask nach uefi: ich hab da vor 2 Monaten (oder drei?) mal
beschrieben wie ich uefi bei lenovo yogas eingerichtet habe … da
kannst du Hintergründe raus lesen.

Sorry …

LG

Holger

Kein Problem, hilfst ja eh immer weiter, wenn’s geht und manchmal geht’s halt net :slight_smile:

Ich recherchier halt mal weiter … im Prinzip geht es ja … ist eher die Optimierung.

danke :slight_smile: